19:02:36 <fungi> #startmeeting infra
19:02:37 <openstack> Meeting started Tue Sep 13 19:02:36 2016 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:40 <openstack> The meeting name has been set to 'infra'
19:02:46 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:49 <fungi> #topic Announcements
19:02:55 <fungi> #info pleia2 published a book along with mfisch!
19:02:57 <fungi> #link http://www.informit.com/store/common-openstack-deployments-real-world-examples-for-9780134086231 "Common OpenStack Deployments: Real-World Examples for Systems Administrators and Engineers"
19:03:06 <timrc> o/
19:03:07 <pleia2> :)
19:03:09 <fungi> this is awesome
19:03:21 <Zara> :D
19:03:25 <mordred> woot pleia2
19:03:29 <pleia2> very exciting, worked on it with mfisch and crinkle helped a bunch too
19:03:30 <fungi> any good quotes? are you going to be hosting a book signing anywhere?
19:03:44 <pleia2> I'll have copies at the openstack summit, signing TBD
19:03:52 <fungi> also a dramatic reading would be awesome
19:03:56 <pleia2> hehe
19:04:07 <pleia2> I do have an appendix about contributing, where infra is heavily featured
19:04:16 <pleia2> I even managed to remove jenkins from the diagrams before printing
19:04:18 <fungi> i could only have hoped ;)
19:04:19 <anteaya> yay book
19:04:41 <anteaya> yay crinkle
19:04:41 <fungi> #info Reminder: late-cycle joint Infra/QA get together to be held September 19-21 (CW38) in at SAP offices in Walldorf, DE
19:04:44 <fungi> #link https://wiki.openstack.org/wiki/Sprints/QAInfraNewtonSprint
19:04:44 <crinkle> \o/
19:04:50 <fungi> still 3 slots open before you have to get on the waiting list
19:05:28 <timrc> fungi should do the audio for audible
19:05:34 <fungi> looks like AJaeger says he's coming for a day too
19:05:34 <timrc> Because he's not busy enough.
19:05:37 <notmorgan> fungi: unfortunately I am going to pass. I really just don't have sitting on a plane that long in me.
19:05:44 <notmorgan> mordred: ^ cc
19:06:14 <jeblair> for anyone *not* going, knuth is giving a lecture on metafont at the sfpl
19:06:15 <fungi> notmorgan: yeah, i'm passing this time as well, but will keep the home fires burning with the release looming so everyone can focus on sprinting
19:06:25 <pleia2> thanks for holding down the fort, fungi
19:06:41 <clarkb> notmorgan: its direct from pdx!
19:06:45 <notmorgan> fungi: lmk if I can be of help on that front too.
19:06:52 <clarkb> that was a big part in me caving to go
19:06:57 <fungi> notmorgan: i will indeed!
19:07:04 <notmorgan> clarkb: that is part of the issue. I can't sit on the plane atm :(
19:07:27 <fungi> #topic Actions from last meeting
19:07:29 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-09-06-19.03.html
19:07:34 <fungi> fungi Test whether gerrit flush-caches significantly reduces memory utilization in Gerrit's JVM
19:07:41 <fungi> i guess i forgot, but will try to test later this week, sorry!
19:07:47 <fungi> #action fungi Test whether gerrit flush-caches significantly reduces memory utilization in Gerrit's JVM
19:07:54 <fungi> pleia2 set up sprint booking for infra bug day
19:07:56 <fungi> #link https://wiki.openstack.org/wiki/VirtualSprints#Infra_Bug_Day Infra Bug Day
19:08:00 <fungi> somebody's on the ball
19:08:12 <anteaya> yay
19:08:22 <anteaya> that's tomorrow yeah?
19:08:37 <pleia2> yep
19:08:44 <anteaya> okay great, thanks
19:08:58 <fungi> #info Infra Bug Day September 14, 2016 (tomorrow) at 16:00 UTC in #openstack-sprint
19:09:28 <pleia2> #link http://lists.openstack.org/pipermail/openstack-infra/2016-September/004722.html
19:09:34 <fungi> perfect
19:09:37 <fungi> thanks pleia2!
19:09:40 <Zara> \o/
19:10:03 <fungi> also a reminder, for those who can make it, the storyboard weekly meeting is the hour before the sprint starts
19:10:30 <Zara> yep!
19:10:41 <Zara> we can give you a heads up on any ui changes from last time...
19:10:59 <fungi> that's in #openstack-meeting
19:11:02 <pleia2> great
19:11:08 <fungi> #link http://eavesdrop.openstack.org/#StoryBoard_Meeting StoryBoard Meeting
19:12:02 <fungi> #topic Specs approval
19:12:09 <fungi> #info "Docs Publishing via AFS" added to Priority Efforts list/topics
19:12:12 <fungi> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/doc-publishing.html Docs Publishing via AFS
19:12:36 <fungi> just documenting that we're putting a bit of a rush on this one since we don't want to be evicted from cloudsites before we're done :/
19:12:46 <jeblair> i started working on that today, i may have some things to ask others to help with soon
19:13:02 <anteaya> jeblair: andreas offered to help you
19:13:09 <fungi> AJaeger also indicated he'd be interested in collaborating in person on this on tuesday of the sprint in walldorf
19:13:14 <fungi> yeah, that
19:13:37 <jeblair> cool; i'm hoping this won't take up too much sprint time
19:13:50 <mordred> jeblair: let me know if I can be helpful and stuff
19:13:51 <ianw> also happy to help, if i can
19:14:07 <jeblair> excellent!
19:14:18 <ianw> AJaeger and I have some cross-over time in my afternoon
19:14:18 <fungi> cool. and if you need continuation in american timezones after you all hit the biergarten, let me know
19:14:28 <fungi> i don't expect to run an infra team meeting that day anyway
19:14:44 <fungi> but have a few liters of hels for me
19:15:00 <pleia2> no problem :)
19:15:24 <fungi> #topic Priority Efforts
19:15:45 <fungi> other than the aforementioned addition here, nothing to report it seems from the agenda
19:16:01 <fungi> any last-minute additions for priority efforts updates?
19:16:08 <clarkb> xenialification continues
19:16:17 <fungi> resistance is futile?
19:16:30 <clarkb> pretty much. I am learning things that I hope will be good input for zuulv3 too
19:16:36 <fungi> #topic Priority Efforts: Newton testing on Xenial
19:24:10 <notmorgan> timrc: not buffalo chips though.
19:24:10 <fungi> openstack is back!
19:24:12 <fungi> but clarkb is not (yet)
19:24:14 <zigo> Let's move to OFTC... :P
19:24:15 <ianychoi> Wow openstack !
19:24:15 * zigo sets the topic to OFTC migration ... :P
19:24:17 <fungi> there's clarkb
19:24:19 <fungi> clarkb: care to repeat your comments about Newton testing on Xenial?
19:24:34 <anteaya> the bot missed everything after fungi set the topic
19:24:35 <fungi> zigo: if only we could... we discussed it more than once but i think freenode would have to be down for a week before the community would begrudgingly relocate
19:25:36 <clarkb> swift and nova are basically done at this point
19:25:48 <clarkb> I am learning things that will likely be good feedback for zuulv3
19:25:58 <clarkb> (basically we shouldn't ocnflate where jobs run with what jobs run)
19:26:14 <fungi> and what was with that broken xenialing patch from last night?
19:26:21 <fungi> or is that what you're talking about?
19:26:23 <clarkb> thank you for the reviews and feel free to push changes too
19:26:40 <clarkb> ya basically I got into this deep hole that kept getting deeper with the way we use jjb
19:26:57 <clarkb> I wanted to convert the identity-v3-only jobs all to xenial because they are already >= newton only and non voting
19:27:10 <fungi> okay, so basically just that heavy reliance on templates which are overly-parameterized can make this harder rather than easier?
19:27:10 <clarkb> but it turns out we share the definition with most of those with a ton of other jobs too
19:27:16 <clarkb> right
19:27:37 <fungi> and risk turning it into a big-bang migration?
19:27:57 <fungi> granted, the "old" way we did it for precise->trusty was all big-bang
19:28:00 <clarkb> right
19:28:35 <fungi> so using duplicate jobs with different names gives us the opportunity to migrate piecemeal, but maybe sometimes it's just the illusion of being able to do that
19:28:42 <clarkb> correct
19:28:54 <clarkb> and it worked well for the jobs that qa/infra curate more directly
19:29:12 <clarkb> we mostly seem to run into problems where projects have gone off and done their own thing (and cargo culted things between each other)
19:29:44 <fungi> oh, right there were also, e.g., neutron jobs with hacky kernel module and userspace updates that were working around too-old versions in trusty that complicated things
19:29:59 <clarkb> yes
19:30:09 <clarkb> though figuring that out is still ongoing so not sure what the end result will be there
19:30:35 <clarkb> but overall things are going well I think
19:30:39 <fungi> and there was also something to do with the loosely-devstack-based functional test jobs for the "lessons learned" pile?
19:31:14 <fungi> or was that the same as the hacky upgrade workarounds?
19:31:24 <clarkb> I think thats the same hacky upgrade workarounds
19:31:34 <fungi> okay, cool, so not as bad as i thought at least
19:31:38 <clarkb> basically what happens is we put a ton of effort into making sure things work and we deploy it to the "core" set of jobs
19:32:01 <clarkb> then later we find out that people have hacked around what is sane to do random things and it breaks the assumptions that our deployment just works everywhere because of devstack/d-g
19:32:23 <fungi> got it. anything else?
19:32:28 <clarkb> thats about it
19:32:35 * mordred hands clarkb a sandwich
19:32:36 <clarkb> found a bug in d-g reproduce.sh
19:32:48 <clarkb> my fix fails unittests so fixing is ongoing
19:32:55 <fungi> anybody else have questions/concerns about the xenial jobs transition?
19:33:25 <fungi> i guess my main concern is making sure we impress upon projects that the switch needs to happen _soon_
19:33:49 <fungi> releasing with half of openstack newton tested on xenial and half tested on trusty seems like it would be bad
19:34:18 <mordred> bah
19:34:22 <mordred> what could possibly go wrong?
19:34:31 <fungi> and then we'd have to decide whether we push to migrate remaining stable/newton jobs to xenial or support trusty for an additional cycle after mitaka is eol
19:34:49 <clarkb> I think I would push to migrate to xenial more
19:34:59 <clarkb> because really the only issues we have found are where we are actually broken
19:35:14 <clarkb> and not because xenial is broken (assuming the neutron tests turn out to be related to the custom compiles)
19:35:32 <fungi> i tend to agree, but if we end up in that situation we need to make sure we've got buy-off from the stable-maint team
19:36:06 <fungi> or at least they need to go into it being aware of the situation
19:36:31 <fungi> #topic Open discussion
19:36:41 <fungi> anybody have anything else while everyone's here?
19:37:14 <pleia2> any suggested prep for the sprint next week?
19:37:16 <anteaya> have fun in germany everyone
19:37:36 <fungi> pleia2: make sure your gertty's synced before you get on the plane? ;)
19:37:47 <pleia2> hehe
19:37:52 <pleia2> the usual ;)
19:37:57 <fungi> don't forget to bring a towel?
19:38:20 <jeblair> brush up on the zuulv3 spec :)
19:39:26 <fungi> if your gertty is in sync and you're subscribed to openstack-infra/infra-specs (i hope you all review infra-specs!) then you've got a copy of all the (proposed _and_ approved) specs already ;)
19:39:52 <mtreinish> pleia2: heh, memorize the mqtt protocol spec :)
19:40:17 <anteaya> ha ha ha
19:40:27 <anteaya> like reading just isn't enough
19:40:32 <fungi> looks like we can end this and give everyone a 20-minute break before the tc meeting
19:40:38 <anteaya> fungi: thank you
19:40:39 <ttx> boo
19:40:48 <anteaya> ttx: no?
19:40:59 <ttx> just kidding
19:41:05 <fungi> i took that as a surprise "boo" like a ghost
19:41:11 <anteaya> ah
19:41:17 <fungi> the tc is hiding in wait
19:41:18 <anteaya> I took it as negation
19:41:27 <anteaya> fungi: i like your interpretation better
19:41:44 <mtreinish> fungi: not boo as in boo-urns?
19:41:52 <fungi> i try to find the most amusing interpretation of any ambiguous statement. gives me more entertainment value
19:42:11 <anteaya> I should watch more cartoons
19:42:15 <jesusaur> ++
19:42:17 <fungi> mtreinish: that works for an entertaining interpretation
19:42:29 * fungi was _not_ saying boo-urns, unlike hans moleman
19:42:35 <fungi> thanks everyone!
19:42:55 <fungi> oh, wait, i should info the skipping of the meeting before i end this
19:43:11 <Zara> hehe
19:43:49 <fungi> #info The Infra team meeting for next week (September 20) will not be held, but we will resume our normal meeting schedule on Tuesday the 27th
19:44:12 <fungi> thanks everyone, and enjoy walldorf!
19:44:19 <fungi> #endmeeting