19:02:31 <fungi> #startmeeting infra
19:02:31 <openstack> Meeting started Tue Jun 13 19:02:31 2017 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:34 <openstack> The meeting name has been set to 'infra'
19:02:41 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:44 <fungi> #topic Announcements
19:02:49 <fungi> #info If you want to meet in person, registration for the PTG is now *OPEN*.
19:02:52 <fungi> #link https://www.openstack.org/ptg/ PTG September 11-15 in Denver, CO, USA
19:03:18 <fungi> as always, feel free to hit me up with announcements you want included in future meetings
19:03:28 <fungi> #topic Actions from last meeting
19:03:32 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2017/infra.2017-06-06-19.03.html
19:03:38 <fungi> fungi [lots of specs-related followup and cleanup]
19:03:40 <fungi> #link https://review.openstack.org/471948 Clean up implemented specs
19:03:41 <patchbot> patch 471948 - openstack-infra/infra-specs - Clean up implemented specs
19:05:34 <ianychoi> o/
19:05:42 <fungi> ianw abandon pholio spec and send announcement about discontinuing the (unused) service
19:05:46 <fungi> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118275.html shutting down pholio.openstack.org
19:06:01 <ianw> haven't shut it down yet, but will
19:06:07 <fungi> i don't see a spec change yet to move that one to abandoned either
19:06:24 <fungi> #action ianw abandon pholio spec and shut down pholio.openstack.org server
19:06:31 <fungi> thanks for writing that up!
19:06:37 <ianw> yep, will do
19:06:43 <fungi> clarkb finish writing up an upgrade doc for gerrit 2.11 to 2.13
19:06:46 <fungi> i think you said you were planning to dig into it later this week?
19:07:02 <clarkb> ya, I've run into the performance issues in the gate and have been trying totrack those down
19:07:10 <clarkb> so haven't had time to work through gerrit upgrade process yet
19:07:41 <clarkb> goal is to get the gerrit plan written down in the next couple days
19:07:42 <fungi> cool. they're both important
19:07:45 <fungi> #action clarkb finish writing up an upgrade doc for gerrit 2.11 to 2.13
19:08:05 <fungi> #topic Specs approval - PROPOSED: PTG Bot (fungi)
19:08:12 <fungi> #link https://review.openstack.org/473582 "PTG Bot" spec proposal
19:08:34 <fungi> fairly straightforward (i hope), presumably many of you saw the discussion on the ml about running this
19:08:41 <fungi> if not, it's linked in the spec
19:09:28 <fungi> if you voted on this earlier, i just pushed up a new patchset a few minutes ago to address some clarification jeblair requested
19:09:51 <fungi> if you haven't seen it yet, it's a quick read
19:11:23 <fungi> one thing maybe worth noting about the bot itself is that it's written for python 3, though looking through the puppet-statusbot module which i was intending to pattern it after, nothing really jumped out at me as being a challenge for installing/running it under python3
19:12:37 <fungi> its python deps are a subset of statusbot's, but we'll just end up with two copies of them (one in the python2.7 import path, and one in the python3.4 import path on the server)
19:13:23 <fungi> we already seem to be satisfying those from pypi, therefore i don't think we need to do anything different besides yse pip3 or python3 -m pip in place of the normal pip exec we have for statusbot
19:15:06 <fungi> anybody have any concerns before i set a deadline for council voting? since i only uploaded it this week, i was thinking of a week from thursday as the cutoff
19:16:12 * fungi takes your collective silence as a deafening tacit approval ;)
19:16:23 <fungi> #info Council voting is open for the "PTG Bot" spec proposal until 19:00 UTC on Thursday, June 22.
19:16:44 <fungi> any questions at all about this before we move on?
19:17:26 <fungi> #topic Priority Efforts
19:17:39 <fungi> nothing called out specifically here for this week
19:17:52 <fungi> #topic Open discussion
19:18:19 <fungi> i just refreshed the agenda and, still seeing no general topics proposed, it's open discussion
19:18:41 <cmurphy> i went through a bunch of the puppet modules and fixed the beaker jobs, would appreciate reviews https://review.openstack.org/#/q/project:%22%255Eopenstack-infra/.*%2524%22+topic:fix-beaker
19:18:55 <ianychoi> From I18n team, I would like to say
19:18:56 <ianychoi> - Please review a infra-spec modification: https://review.openstack.org/#/c/440825/
19:18:56 <ianychoi> - I am considering one more Zanata upgrade before Zanata uses Java 9 and/or Wildfly 11 :)
19:18:56 <ianychoi> - Can I ask the progress of the database modification for translate-dev.o.o to support openstackid-dev?
19:18:59 <cmurphy> if they're not all green and the end of the patch stack isn't green please don't merge broken things
19:19:52 <fungi> cmurphy: 61 changes! wow. and they're all passing
19:19:56 <cmurphy> clarkb: you might be interested in this one specifically https://review.openstack.org/#/c/461806/
19:20:10 <clarkb> ianychoi: for the auth I think we are still waiting on openstackid-dev updating how you change your password?
19:20:16 <cmurphy> fungi: they're not though, because the ubuntu beaker jobs are all nonvoting
19:20:18 <clarkb> ianychoi: I think last I heard it was still not quite useable?
19:20:26 <cmurphy> but, the end of each stack should be green
19:20:28 <fungi> cmurphy: oh, hah right :/
19:20:41 <fungi> cmurphy: that's awesome work, thanks!
19:20:44 <ianychoi> clarkb, the passwords were changed the time we discussed :)
19:20:58 <clarkb> ianychoi: yes, but users need to be able to change their own passwords too
19:21:06 <clarkb> ianychoi: and that piece is/was still missing I think
19:21:26 <clarkb> cmurphy: I've pulled it up and will review after lunch
19:21:34 <fungi> test again, i'm pretty sure smarcet said that was fixed (or nearly so) last week
19:22:04 <ianychoi> aha really yep the password link needed basic auth but now it does not require basic auth
19:22:27 <fungi> we merged a change to point the password reset at the dev site and he undid the basic auth blocking public access to that and, i think, also confirmed e-mail sending is working
19:23:52 <clarkb> cool
19:25:49 <ianychoi> For merging a spec: https://review.openstack.org/#/c/440825/ , which things might I do further?
19:27:07 <fungi> ianychoi: i've added it to my personal priority list to review that one. assuming nobody points out any substantial concerns in it i'll propose it for an official rollcall next week. how does that sound?
19:27:40 <ianychoi> fungi, sounds great! Thanks a lot
19:27:46 <ianw> cmurphy: the "Update beaker setup for xenial" is boilerplate?
19:28:34 <fungi> #link https://review.openstack.org/#/q/project:%22%255Eopenstack-infra/.*%2524%22+topic:fix-beaker cmurphy's changes to fix beaker jobs on our puppet modules
19:28:36 <fungi> #link https://review.openstack.org/440825 New spec for translation_check_site (Ansible AIO)
19:28:43 <ianw> so rather than port everything to 4, the approach is more to install puppetlabs v3?
19:29:09 <cmurphy> ianw: most of them are boilerplate...i just clicked on a random one and it has extra changes in it, so i'll double check
19:29:45 <cmurphy> ianw: i wanted to get everything working and voting on puppet 3 which we're still using before taking the next step to start testing on puppet 4
19:30:10 <cmurphy> so we can start from square 0
19:30:52 <fungi> seems like a reasonable approach
19:31:06 <ianw> sure, i'm just thinking if we broadly agree on that here we and it's mostly xenial only boilerplate we can get that in quickly
19:31:31 <ianw> and turn it to voting to stop regression?
19:31:53 <fungi> that's my hope
19:32:08 <cmurphy> yep
19:32:14 <fungi> i don't want these to linger or they'll bitrot quickly (between merge conflicts and new regressions)
19:32:19 <ianw> are you allowed/able to mirror puppetlabs repo?
19:33:01 <pabelanger> o/
19:33:10 <cmurphy> mirror the puppetlabs puppet modules from github?
19:33:15 <cmurphy> i don't see why not
19:33:31 <ianw> i meant the v3 packages more
19:33:36 <cmurphy> oh right
19:33:43 <cmurphy> again i don't see why not
19:34:09 <cmurphy> but they don't have puppet 3 packages for xenial
19:34:32 <cmurphy> so the current proposal is to get them from the distro repos which we do already mirror
19:34:51 <cmurphy> definitely worth talking about for puppet 4 though
19:35:27 <fungi> puppet 3.8.5-2ubuntu0.1 is currently in ubuntu xenial-updates
19:36:10 <fungi> doesn't look like puppet 4.x was introduced into an ubuntu release until yakkety (16.10)
19:36:46 <mordred> so in some ways we could choose to not worry about puppet 4 until we move servers to post-xenial
19:36:48 <ianw> cmurphy: oh, heh, yeah i was parsing your comment in the change backwards, makes sense
19:37:00 <mordred> I mean, we should fix stuff
19:37:06 <fungi> 18.04 will presumably have puppet >= 4.8.2 since that's what's presently slated for 17.10
19:37:33 <mordred> just saying - if we move our own deployments to use distro packages of puppet for puppet3, we can keep doing thatuntil we have an 18.04 server should we choose
19:37:50 <fungi> fixing sooner would be good, but we'll need to have stuff working on puppet 4 before we can move to the next lts for sure
19:37:52 <cmurphy> mordred: sure but there are other benefits to switching over
19:37:55 <mordred> cmurphy: cool
19:39:10 <fungi> oh, i missed this in the action items (and haven't done it yet!):
19:39:13 <fungi> #action fungi start an infra ml thread about puppet 4, beaker jobs and the future of infra configuration management
19:39:29 <ianw> so we should turn these jobs voting, and add 4 jobs even if failing?
19:39:39 <ianw> heh, or discuss in ^^
19:39:44 <fungi> definitely on #1, probably on #2
19:39:58 <cmurphy> i haven't gone through every module so not all of them will pass on puppet 3 yet
19:40:30 <cmurphy> if anyone wants to help that would be cool
19:40:46 <ianw> cmurphy: seems like you've done the hard work anyway :)  plenty of templates
19:41:12 <cmurphy> most of the hard stuff isn't the rspec stuff it's the random other xenial breakage
19:41:33 <cmurphy> or a lot of the modules probably never had working fixture manifests in the first place
19:43:48 <fungi> i would bet on the latter
19:44:34 <cmurphy> like accessbot https://review.openstack.org/#/c/461810/ there is no way that has ever worked
19:47:51 <fungi> hah
19:47:55 <fungi> accessbo
19:51:14 <fungi> open discussion seems to have petered out... thanks everyone!
19:51:24 <fungi> #endmeeting