19:03:00 <fungi> #startmeeting infra
19:03:01 <openstack> Meeting started Tue Jul 18 19:03:00 2017 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:07 <openstack> The meeting name has been set to 'infra'
19:03:13 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:03:21 <fungi> #topic Announcements
19:03:44 <fungi> #info Don't forget to register for the PTG if you're planning to attend
19:03:54 <fungi> #link https://www.openstack.org/ptg/ PTG September 11-15 in Denver, CO, USA
19:04:08 <fungi> #link https://etherpad.openstack.org/p/infra-ptg-queens Infra planning pad for Queens PTG in Denver
19:04:19 <fungi> as always, feel free to hit me up with announcements you want included in future meetings
19:04:35 <fungi> #topic Actions from last meeting
19:04:45 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2017/infra.2017-07-11-19.03.html Minutes from last meeting
19:04:57 <fungi> #action ianw abandon pholio spec
19:05:11 * fungi checked the open infra-specs changes just a moment ago
19:05:23 <fungi> #action fungi get switchport counts for infra-cloud
19:05:37 <fungi> still waiting for info back from hpe on the last round of requests
19:05:42 <ianw> i didn't do that, but can we go ahead with https://review.openstack.org/#/c/477386/ (remove from system-config?)
19:06:05 <fungi> ianw: oh, sure. i've already +2'd so just need one more
19:06:30 <fungi> #link https://review.openstack.org/477386 Remove pholio.openstack.org
19:06:44 <fungi> anyway, on the infra-cloud front, there's some possible good news
19:07:03 <pabelanger> Yay
19:07:11 <fungi> they're looking to see if they might be freeing up some unwanted mounting rails and whether they have similar switches to our original they may want to get rid of
19:07:41 <fungi> so it's _possible_ we may not have to ask for budget from the foundation to buy all that, but i'm not getting my hopes up just yet
19:08:03 <fungi> fungi start a ml thread about the infra-cloud rails and switching situation
19:08:04 <jeblair> oh that's really good -- because the 10 second prelim google search i did on the model numbers returned lots of "not in stock" and "discontinued"
19:08:23 <fungi> dropping this last action item since it makes no sense until we hear back
19:08:55 <fungi> #topic Specs approval
19:09:03 <fungi> #info APPROVED Ansible Puppet Apply is implemented
19:09:15 <fungi> #link http://specs.openstack.org/openstack-infra/infra-specs/#implemented-design-specifications Ansible Puppet Apply is implemented
19:09:26 <fungi> #info APPROVED Gerrit ContactStore Removal
19:09:42 <fungi> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/gerrit-contactstore-removal.html Gerrit ContactStore Removal
19:09:51 <fungi> #info APPROVED Make Gerrit contactstore removal a priority
19:10:04 <fungi> #link http://specs.openstack.org/openstack-infra/infra-specs/#priority-efforts Make Gerrit contactstore removal a priority
19:10:36 <fungi> i've also got a change proposed to get that moving...
19:10:51 <fungi> #link https://review.openstack.org/483974 Check change owners against OSF Individual Members
19:11:33 <fungi> also heads up about the related announcement in case you missed it on the ml(s)
19:11:47 <fungi> #link http://lists.openstack.org/pipermail/openstack-dev/2017-July/119786.html IMPORTANT upcoming change to technical elections
19:12:06 <fungi> #topic Priority Efforts
19:12:40 <fungi> we don't seem to have anything specific called out there for this week
19:12:58 <fungi> excepting my links above about the contact store removal
19:13:23 <fungi> clarkb's out this week so gerrit upgrade stuff is sort of on hold
19:13:36 <fungi> zuul v3 is moving at a rapid clip
19:13:58 <fungi> see weekly zuul meeting minutes for details there
19:14:19 <fungi> #link http://eavesdrop.openstack.org/meetings/zuul/ zuul meeting minutes
19:15:10 <jeblair> we have an item from there to make more detailed timing plans for the v3 cutover
19:15:19 <fungi> oh, right
19:15:28 <fungi> we wanted to bring that up in the infra meeting
19:15:33 <jeblair> mordred is coordinating that
19:15:50 <fungi> #topic Priority Efforts - Zuul v3
19:15:56 <jeblair> mostly we need to work out if we're going to try to do something the week/weekend before, or start monday morn
19:16:07 <jeblair> so that folks can plan travel, etc appropriately
19:16:49 <jeblair> the tc/uc/bod stuff on sunday may be a blocker for several folks
19:17:04 <fungi> it is for me anyway
19:17:34 <fungi> also i can't really fly in any earlier. promised to take christine to a concert right before i leave for denver, and have had tickets and hotel room booked for months
19:18:27 <pabelanger> I should be able to fly in early
19:18:36 <jeblair> ansiblefest is the week before.  i personally wouldn't mind a weekend between the two, but that's not a requirement.
19:18:45 <pabelanger> that is true
19:19:14 <jeblair> of course, that "weekend" is still only saturday anyway, so, meh.
19:19:51 <jeblair> fungi: i guess you're traveling on sat?
19:20:03 <fungi> yes, my flight gets in mid-afternoon saturday
19:20:34 <fungi> for some reason i can get direct flights from denver back to norfolk but they don't have any on the way out
19:20:44 <fungi> so getting there later than i would like
19:21:41 <jeblair> fungi: that's probably the info we need now, aside from the later ptg planning topic :)
19:22:06 <fungi> cool. that said, i'm going to reorder the general topics so we can do ptg planning at the end
19:22:17 <fungi> #topic Project update session at summit (fungi)
19:22:50 <fungi> all ptls, including me, were asked whether our teams wanted to give "project updates" as reserved conference talk slots
19:23:45 <fungi> we didn't do them previously since our activities generally aren't very outward-facing to th eusual openstack consumer audience, but i figured i'd get input from the team on whether we should consider doing them anyway
19:24:29 <jeblair> welp, we can certainly talk about zuulv3
19:24:41 <fungi> yeah, i thought that might be a possibilitu
19:24:45 <fungi> possibility
19:25:09 <pabelanger> I don't mind if we do them, -infra overview always seem to go over well
19:25:16 <fungi> also worth noting, there aren't as many available slots for project updates as there are projects, so if a lot of projects want to do one there's a chance ours could get bumped anyway
19:25:22 <pabelanger> and zuulv3 of course
19:26:01 <jeblair> zuulv3 is something that we can address for both an openstack developer and user audience.
19:26:20 <jeblair> we've been talking to other communities about zuul for years, and it tends to go over well.
19:26:29 <pabelanger> For sure
19:26:43 <fungi> if there are people who want to help put together a 20-minute talk (that's what these are booked as), i'm happy to tell anne we're on board
19:27:08 <pabelanger> infra-cloud is a good topic too, give the state of it
19:27:35 <fungi> even if we have to push zuul v3 go-live to after the ptg, odds are it will be solidly in production by the time we get to sydney
19:28:15 <pabelanger> I can volunteer for project update we need people
19:29:34 <fungi> #info Seeking volunteers to help write and/or present a 20-minute Infra team update at the Sydney, AU summit this November
19:29:40 <fungi> thanks pabelanger!
19:30:05 <fungi> #topic Cleaning up inactive meetbot channels (fungi)
19:30:31 <fungi> for those who missed the discussion last week-ish, we've reached 120 channels with the openstack meetbot instance
19:30:48 <fungi> and have at least one new channel that wants logging but can't be added until we cull the dead wood
19:31:26 <jeblair> this isn't going to keep scaling forever.  should we go ahead and setup openstack2?
19:32:16 <fungi> yeah, it should be sane to run more than one as long as people don't try to use them for the same meetings at the same time in two different channels or something
19:33:23 <fungi> in the interim, i ran some stats and there are a handful of non-new channels which have had nothing said this year so those are easy enough to probably get rid of
19:34:05 <fungi> there are also some several dozen which have only had bots speaking since april, depending on how aggressive we want to be about unused channels
19:34:10 <pabelanger> seems like a good first step
19:34:56 <fungi> er, i take that back, the several dozen were channels which had fewer than 10 lines spoken by non-bots since april
19:35:12 <fungi> we do have spammers popping into channels at random which skew the results a bit
19:35:54 <jeblair> fungi: ++
19:36:25 <fungi> anyway, granted we _do_ need to go ahead and get to work on scaling up our meetbot configuration to probably run an arbitrary (but for now sharded across two) number of bots
19:37:13 <fungi> but before starting a -dev ml thread i wanted to try and get some suggestions on what levels of activity make sense to consider channels "active"
19:37:49 <fungi> or should i just pick something arbitrary (like fewer than 10 non-bot lines spoken in the past three months) as a starting point and see who objects to removing logging for some specific channels?
19:38:21 <pabelanger> WFM
19:38:27 <jeblair> fungi: i think your thresholds are good
19:39:22 <fungi> #agreed We should improve puppet-meetbot to support sharding channels across multiple bots
19:39:50 <fungi> #action fungi start an ML thread on cleaning up logging for dead or mostly-dead channels
19:39:54 <fungi> thanks!
19:40:06 <fungi> #topic Retiring deprecated infra repos (fungi)
19:40:07 <ianw> seems sane, and maybe having a limit isn't such a bad thing after all ...
19:40:33 <fungi> continuing in the vein of cleanup
19:40:47 <jeblair> ianw: hah -- people have been trying to limit openstack's growth for years.  finally success was achieved when we hit the irc channel limit!
19:40:56 <fungi> nice!
19:41:01 <pabelanger> :)
19:41:39 <fungi> so anyway, this was an upshot from ttx's exploration of what is being hosted unofficially in our infrastructure and i got to thinking about some of our official infr arepos which are also basically defunct
19:42:36 <fungi> i put together an initial list which i think are unused and not maintained any longer: activity-board puppet-apparmor puppet-apps_site vinz vinz-webclient
19:43:43 <fungi> activity-board ended up going nowhere and we never did get one deployed before the foundation terminated the contract with bitgeria
19:44:07 <jeblair> those all seem reasonable
19:44:23 <mordred> ++
19:44:43 <fungi> though http://apps.openstack.org/ is still online, so maybe that's a separate discussion
19:45:56 <fungi> i was particularly curious about vinz and vinz-webclient
19:46:28 <fungi> does anybody know if the renewed interest in that last year ever went anywhere? there were only a few changes merged
19:47:02 <fungi> er, not even merged, just proposed
19:48:04 <jeblair> fungi: oh, maybe we should keep puppet-apps_site around still then.
19:48:22 <fungi> #link https://review.openstack.org/#/q/project:openstack-infra/vinz changes proposed for vinz
19:49:11 <fungi> yeah, i'm thinking i'll make a separate e-mail thread about teh apps site if it looks like it's no longer being updated
19:49:12 <pabelanger> I've never looked into vinz myself
19:49:42 <fungi> polygerrit probably makes vinz unnecessary anyway
19:50:29 <fungi> jeblair also mentioned a couple of zuul v3 role/playbook repos which might need to be retired as well, but we can address those once we get further along and are sure we don't need them
19:50:46 <pabelanger> ++
19:51:03 <fungi> #agreed we can retire: activity-board puppet-apparmor puppet-apps_site vinz vinz-webclient
19:51:12 <fungi> #undio
19:51:14 <fungi> #undo
19:51:15 <openstack> Removing item from minutes: #agreed we can retire: activity-board puppet-apparmor puppet-apps_site vinz vinz-webclient
19:51:28 <fungi> #agreed We can retire: activity-board puppet-apparmor vinz vinz-webclient
19:52:04 <fungi> #action fungi start a ML thread on continuing to operate http://apps.openstack.org/
19:52:15 <fungi> okay, i think that's good progress on this topic
19:52:18 <jeblair> fungi: yeah, let's aim for zuul repo cleanup post ptg
19:52:21 <jeblair> so we don't flap
19:52:27 <fungi> definitely
19:52:48 <fungi> and if anyone thinks of other repos we can/should retire, let me know or spin some changes to do that
19:53:08 <fungi> #topic PTG planning (fungi)
19:53:31 <fungi> #link https://etherpad.openstack.org/p/infra-ptg-queens Infra planning pad for Queens PTG in Denver
19:53:46 <fungi> looks like we got some additions since last week
19:54:34 <fungi> pabelanger: the trystack idea is interesting
19:54:49 <pabelanger> fungi: ya, I've been on some emails about it recently
19:54:57 <fungi> though i think they're still struggling with how to switch from facebook groups auth to general openid/oauth
19:55:13 <pabelanger> TL;DR the team that does it today might want to stop doing it
19:55:36 <fungi> and also struggling with spammers who seem to be the bulk of signups
19:55:46 <fungi> or so i heard anyway
19:56:03 <pabelanger> Ya, there is some OPs things that need to be dealt with too
19:56:47 <fungi> i expect if trystack were to become a community endeavor, it would need a fairly substantial redesign and would be higher-maintenance than infra-cloud so likely would need its own dedicated team of at least a few people
19:57:12 <pabelanger> exactly
19:57:46 <pabelanger> it could be a good use case for using a community project to run it too, eg: ansible-openstack, kolla, tripleo, etc
19:58:01 <pabelanger> and give people real world ops training
19:58:03 <fungi> i guess if we think we could get people who want to (and have the levity to) volunteer to run trystack v2, and could get them to come to the ptg, then maybe?
19:59:24 <jlvillal> Off topic :(  To fix the ironic-inspector gate we would like to get: https://review.openstack.org/483059  merged please
19:59:26 <fungi> i still anticipate zuul v3 related work will dominate much of the ptg for us this time
19:59:32 * jlvillal notices a few seconds left in the meeting
19:59:49 <pabelanger> fungi: maybe?
20:00:23 <fungi> between presenting a cross-project session or two, answering lots of questions and probably dealing with job rewrites
20:00:41 <fungi> anyway, we're out of time for this week. find us in #openstack-infra
20:00:46 <fungi> thanks everyone!
20:00:56 <fungi> #endmeeting