#opendev-meeting: infra

Meeting started by clarkb at 19:01:05 UTC (full logs).

Meeting summary

    1. http://lists.opendev.org/pipermail/service-discuss/2022-January/000316.html Our Agenda (clarkb, 19:02:15)

  1. Announcements (clarkb, 19:02:39)
  2. Actions from last meeting (clarkb, 19:04:52)
    1. http://eavesdrop.openstack.org/meetings/infra/2022/infra.2022-01-25-19.01.txt minutes from last meeting (clarkb, 19:05:04)

  3. Topics (clarkb, 19:05:25)
  4. Improving Opendev's CD throughput (clarkb, 19:05:35)
    1. https://review.opendev.org/c/opendev/infra-specs/+/821645 -- spec outlining some of the issues with secrets (clarkb, 19:05:41)
    2. https://review.opendev.org/c/opendev/system-config/+/821155 -- sample of secret writing; more info in changelog (clarkb, 19:05:47)
    3. ACTION: infra-root Review OpenDev CD throughput related spec for secrets management: https://review.opendev.org/c/opendev/infra-specs/+/821645 (clarkb, 19:06:49)

  5. Container Maintenance (clarkb, 19:08:12)
    1. https://etherpad.opendev.org/p/opendev-container-maintenance (clarkb, 19:08:17)

  6. Nodepool Image Cleanup (clarkb, 19:08:50)
    1. https://review.opendev.org/c/opendev/base-jobs/+/827181 (clarkb, 19:09:46)
    2. https://review.opendev.org/c/openstack/project-config/+/827184 (clarkb, 19:09:50)
    3. https://review.opendev.org/c/opendev/system-config/+/827186 (clarkb, 19:09:54)

  7. Cleaning up old reviews (clarkb, 19:25:01)
    1. ACTION: clarkb to produce a list of repos that can be retired. We can then retire the repos and abandon their open reviews as step 0 (clarkb, 19:25:08)

  8. Gerrit mergeability checking (clarkb, 19:26:10)
    1. ACTION: frickler propose patch to re-enable Gerrit mergeability checking (frickler, 19:32:17)

  9. Gerrit issues we are tracking (clarkb, 19:32:57)
    1. https://bugs.chromium.org/p/gerrit/issues/detail?id=15589 (clarkb, 19:34:30)
    2. https://bugs.chromium.org/p/gerrit/issues/detail?id=15649 (clarkb, 19:36:49)

  10. Open Discussion (clarkb, 19:38:10)


Meeting ended at 19:52:33 UTC (full logs).

Action items

  1. infra-root Review OpenDev CD throughput related spec for secrets management: https://review.opendev.org/c/opendev/infra-specs/+/821645
  2. clarkb to produce a list of repos that can be retired. We can then retire the repos and abandon their open reviews as step 0
  3. frickler propose patch to re-enable Gerrit mergeability checking


Action items, by person

  1. clarkb
    1. clarkb to produce a list of repos that can be retired. We can then retire the repos and abandon their open reviews as step 0
  2. frickler
    1. frickler propose patch to re-enable Gerrit mergeability checking


People present (lines said)

  1. clarkb (94)
  2. fungi (23)
  3. ianw (21)
  4. frickler (12)
  5. opendevmeet (3)


Generated by MeetBot 0.1.4.