14:00:02 <topol> #startmeeting interop_challenge
14:00:02 <openstack> Meeting started Wed Aug 17 14:00:02 2016 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'interop_challenge'
14:00:14 <catherine_d|1> o/
14:00:14 <markvoelker> o/
14:00:16 <gema> o/
14:00:16 <topol> Hi everyone, who is here for the interop challenge meeting today?
14:00:17 <rohit404> o/
14:00:19 <tongli> o/
14:00:51 <topol> The agenda for today can be found at:
14:01:05 <topol> #link https://wiki.openstack.org/wiki/Interop_Challenge#Meeting_Information
14:01:20 <topol> In case we need to take notes, the etherpad for this meeting can be found here
14:01:33 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-17
14:01:47 <topol> #topic review action items from previous meeting
14:02:01 <topol> #link
14:02:01 <topol> http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-08-10-14.00.html
14:03:01 <leong> o/
14:03:14 <topol> Have folks added which version of OpenStack they plan to interop?
14:03:14 <kei> o/
14:03:41 <topol> tongli, shamail, where folks supposed to put this?
14:03:43 <gema> where do we add that?
14:04:23 <tongli> @topol, I would say put in the etherpad, then put in the summary after.
14:05:01 <topol> tongli, that works.  for now folks can add it to the bottom of the etherpad for todays meeting
14:05:07 * markvoelker notes that in the 8/3 meeting some folks reported plans to use Mitaka and Kilo (see line 35 of https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-03#35 )
14:05:59 <topol> tongli can you gather all this up and then put somewhere?  Separate etherpad for it perhaps???
14:06:41 <tongli> @topol, let's just use this etherpad. too many links probably not good.
14:07:04 <topol> Also it looks like in last weeks meeting everyone agreed to start with LAMPStack
14:07:04 <tongli> @topol, I put it at the end of today's etherpad.
14:07:19 <tongli> @topol, we voted using ansible.
14:07:25 <topol> tongli, thats fine just gather up from last weeks etherpad so its all inone place
14:07:32 <tongli> the lampstack ansible has been merged.
14:07:59 <topol> tongli Yay!  That was my next item to review.
14:08:14 <tongli> can other folks put your preferred test OS release in the etherpad, please!
14:08:37 <topol> #action other folks put your preferred test OS release in the etherpad, please!
14:09:08 <tongli> @markvoelker, can you put your releases on the etherpad.
14:09:14 <topol> Thanks for the quick reviews and merge of LAMPStack
14:09:20 <markvoelker> tongli: already did
14:09:39 <tongli> @markvoelker, thanks.
14:09:53 <topol> Did everyone look at the results template?  Any concerns with that?
14:10:12 <topol> #link http://paste.openstack.org/show/553587/
14:10:19 <tongli> @topol, we had discussion, and generally agree with the content.
14:10:57 <topol> K cool.
14:10:58 <topol> #agree Folks like the results template
14:11:06 <tongli> I think that the question is how often we run the test against each cloud
14:11:14 <leong> Maybe add an affiliate/company?
14:11:37 <topol> leong good idea
14:11:39 <gema> yep and we'll need to agree on what running successfully means
14:11:45 <gema> other than that I am also good
14:11:48 <tongli> seems to me Mark wants to produce just one report per test per cloud, is that right? @markvoelker
14:12:13 <topol> #action shamail to add affiliate/company to the results template
14:12:26 <markvoelker> tongli: Well, Barcelona is about 69 days away.  I think a good start would be for vendors to show a result for their products that are on the market now and that consumers can actually get today
14:12:44 <topol> @markvoelker, that sounds good to me
14:12:48 <markvoelker> There's not likely to be tremendous churn in those products in the next 69 days, so I'm not sure multiple runs really tells us much.
14:13:01 <topol> @markvoelker +++
14:13:10 <tongli> @markvoelker, ok, fine.
14:13:31 <markvoelker> E.g. even if VendorX releases some maintenance patches for their Liberty distro, it seems relatively unlikely to break the workload.
14:13:46 <Rockyg> good point, markvoelker
14:13:54 <topol> #agree Folks should produce one report per cloud
14:13:56 <tongli> I would like to ask if it is all possible that vendors create a test account for me, and I can run against each cloud.
14:14:29 <gema> tongli: are you volunteering to run the workloads instead of us running them independently? :D
14:14:30 <catherine_d|1> The first test category is RefStack test ... At the minimum, all participants should collect RefStack test data now
14:14:31 <topol> yes, so tongli is available to anyone that needs help and he is eager to run tests
14:14:38 <tongli> @gema, yes. I am
14:14:42 <gema> tongli: you got it :D
14:14:50 <gema> tongli: thanks!
14:15:01 <topol> @gema we are here to serve :-)
14:15:09 <gema> topol:  :D
14:15:14 <tongli> if that is ok, please send me the credentials to my email , I put the email in the etherpad.
14:15:27 <gema> tongli: as soon as the cloud is up will do :D
14:15:36 <topol> #action if folks want tongli to help run tests on their cloud, get him an account
14:15:47 <catherine_d|1> gema: does it make sense for someone else to run the tests?  Some clouds maybe private..
14:16:06 <gema> catherine_d|1: our cloud is going to be public and a developer cloud, so I am happy for him to try
14:16:07 <topol> catherine_d,  either way, as long as test get run
14:16:17 <gema> catherine_d|1: I will also try and it will be interesting to compare
14:16:18 <topol> gema thats awesome
14:16:32 <topol> okay, new topic
14:16:48 <Rockyg> question -- creds and tongli doing tests will only work on public clouds... what about distros without a public cloud?
14:17:09 <gema> Rockyg: those may stand up a test cloud for this testing anyway
14:17:11 <gema> they can run it
14:17:26 <brunssen> o/
14:17:29 <topol> Rockyg I guess whoever has acces to the private cloud will have to run
14:17:34 <markvoelker> Rockyg: I'm reading it as "if you want tongli to run tests for you and it's feasible to get him access to your cloud/lab/whatever, he's available. Otherwise, you can do it."
14:17:47 <gema> yep
14:17:51 <topol> as usual markvoelker is spot on
14:18:05 <topol> #topic Test candidates review (refer to the current test candidates on the etherpad)
14:18:43 <catherine_d|1> generally tongli: won't have access to the cloud for debug ... it may make sense that he run the last test run once all are verified working
14:18:50 <Rockyg> Great.  I think w should write rules a little more formally as part of the "challenge rules"
14:18:52 <dcnatt_> Catching up. Has the team discussed a vnf test candidate yet?
14:19:08 <topol> So right now we have the docker terraform and LampStack with Ansible.  Do we need any more?
14:19:17 <markvoelker> dcnatt_: No, but test candidates is the current topic. =)
14:19:33 <topol> The foundation folks also would like an NFV app if possible
14:20:06 <topol> I believe AT&T is looking for one of these
14:20:07 <dcnatt_> Interested in throwing out nfv test candidate and containerized workloads for consideration
14:20:27 <topol> dcnatt_  Yes, you haveone of these??
14:20:41 <dcnatt_> I have inflight POCs for both
14:20:46 <dcnatt_> Can repurpose
14:20:55 <dcnatt_> If team sees value
14:20:55 <topol> dcnatt_ when can code be pushed to the repository?
14:21:18 <dcnatt_> lmc.. I wanted to propose here first then verify
14:21:25 <topol> dcnatt Definitely value.  I heard from the foundation folks they would like that included
14:21:51 <dcnatt_> I'll pursue asap. What about containerized multi-cloud interop
14:22:49 <tongli> @dncatt_, if you need any help with ansible, I like to lend a hand.
14:22:53 <topol> dcnatt_  There is certainly interest in NFV.  There maybe interest in containerized multi-cloud interop. My guess is folks will want to see the workload code
14:23:05 <dcnatt_> @tongli - thanks, always appreciated
14:23:24 <markvoelker> Hm.  We have a Swarm workload.  I was monkeying with a k8s workload (deployed atop OS with Ansible) the other day in the lab.  Might be able to tidy that up if we need it.
14:23:26 <markvoelker> Do we though?
14:23:56 <topol> So best thing is to get the workload pushed up to the repository as soon as possible.
14:24:13 <dcnatt_> We have semantic pipeline auth/auth at the CNI to support workloads across OS and AWS etc.
14:24:26 <topol> My hope is we get a few of these workloads runnning for everyone.  Then if time permits we can add others. Does that make sense?
14:24:28 <tongli> @markvoelker, do you mean the docker swarm test already in the contrib project, or you have a different one?
14:24:38 <markvoelker> tongli: the one already there
14:25:15 <topol> Did we decide what should be the second workload to try and run?
14:25:24 <dcnatt_> We are showing app decomp to component workloads, dynamic networking at the container level plumbed to virtual network across providers and managed by policy
14:25:28 <markvoelker> topol: Sure, time is of the essence (which is sort of why I was hesitating...we'd originally said we wanted workloads decided by Aug 8 =p)
14:25:30 <tongli> @markvoelker, ok. thanks for clarifying it.
14:26:09 <topol> markvoelker.  if we get them soon I think we are okay. We all just need near term deadlines to get the adrenaline going
14:26:41 <topol> markvoelker I'm also okay with some workloads being run ats
14:27:02 <markvoelker> topol: Ok.  So if time permits I'll see if I can get a k8s workload posted.  If not, no worries, we can always do more workloads post-Barcelona.
14:27:14 <markvoelker> Sound good?
14:27:21 <topol> markvoelker sounds good
14:27:36 <tongli> so work load tests as follows: 1. Ansible lampstack 2. Terraform docker swarm 3. ATT NFV?
14:27:45 * markvoelker sets himself a reminder
14:27:47 <dcnatt_> Agree
14:27:49 <topol> tongli YES!
14:27:59 <topol> tongli you type faster than me
14:28:04 <gema> will the NFV workload run on a normal neutron enabled cloud?
14:28:07 <tongli> so #3 is a try as much as possible?
14:28:21 <dcnatt_> It will "Run"...
14:28:24 <topol> #agree so work load tests as follows: 1. Ansible lampstack 2. Terraform docker swarm 3. ATT NFV
14:28:53 <topol> dcnatt_ please push the code up as soon as you can. tongli can help with wrapping ansible around it
14:29:02 <dcnatt_> Will do
14:29:43 <tongli> awesome.
14:30:02 <topol> one other question, did folks have issues with the Terraform?  If necessary tongli could rewrite as Ansible
14:30:10 <tongli> I will  send results to the owner of the cloud who sends me account info.
14:30:12 * topol topol ducks
14:30:41 <markvoelker> topol: no.  The more the merrier.
14:30:43 <topol> #action let tongli, topol know if any issues with Terraform
14:31:01 <gema> topol: no, we wanted to try different deployment methods for the different workloads
14:31:05 <gema> to increase the coverage
14:31:23 <topol> markvoelker okay tongli will be happy to hear that
14:31:27 <rohit404> topol i gave the terraform docker swarm a spin last nite, saw some ssh key issues, i'll follow up
14:31:28 <Rockyg> topol, good thing tongli has his hand full
14:31:37 <markvoelker> (e.g. if Terraform or some other orch tool is making assumptions about what everyone's OpenStack clouds can do and that makes stuff break, that will be useful data)
14:31:56 <topol> markvoelker ++ excellentpoint
14:32:27 <topol> #topic Test environment from different vendors. or should we just test stuff against our own environment?
14:32:33 <topol> i think we covered this.
14:32:52 <topol> Everyone runs themselves but if you can give tongli access he is willing to help
14:32:59 <markvoelker> topol: ++
14:33:04 <gema> topol: ++
14:33:33 <Rockyg> ==
14:33:36 <Rockyg> ++
14:33:41 <dcnatt_> ++
14:33:41 <topol> #agree Everyone runs tests themselves but if you can give tongli access he is willing to help
14:33:48 <topol> new topic
14:33:55 <tongli> only 5 company indicated OS releases on etherpad, should there be more?
14:34:16 <catherine_d|1> topol: ++
14:34:32 <topol> tongli lets you and I follow up on who may be missing
14:34:37 <Rockyg> sorry guys.  It's really early and I'v bee doing early for the week.  Burnout
14:35:05 <Rockyg> sounds like we need to....
14:35:10 <dhellmann> tongli : which etherpad?
14:35:19 <gema> https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-17
14:35:26 <topol> #action tongli and topol to follow up on who has declared  their release
14:35:29 <tongli> @gema, you beat me on that.
14:35:37 <gema> tongli: :D
14:36:55 <topol> #topic result repository
14:37:06 <topol> Send as emails? Or a better suggestion?
14:37:25 <topol> a new folder in the ops repository that holds the workloads?
14:37:30 <tongli> if we only produce one report per test per cloud, then email maybe just fine.
14:37:46 <dhellmann> email to the defcore mailing list?
14:38:01 <markvoelker> Or something like SurveyMonkey to make it a bit more structured, perhaps?
14:38:08 <Rockyg> dhellmann, sounds good...
14:38:46 <topol> dhellmann, so folks won't view that as spam?
14:39:00 <dhellmann> topol : I was asking if that's what you meant by "email"
14:39:01 <topol> as long as everyone is okay wiht the mailing list
14:39:08 * markvoelker puts on DefCore co-chair hat
14:39:13 <markvoelker> I won't consider it spam. =)
14:39:17 * markvoelker doffs hat
14:39:30 <Rockyg> markvoelker, ++
14:39:35 * topol topol kisses the ring of markvoelker
14:39:50 <tongli> @markvoelker, then defcore-committee mailing list.
14:40:57 <markvoelker> Ok, so how about I post the information that we expect people to send in via email in some location that's more permanent that paste.openstack.org? =)
14:41:15 <markvoelker> Do we have a wiki page for the interop challenge?  If not maybe I'll just go create one.
14:41:20 <markvoelker> topol: ^^
14:41:39 <tongli> @markvoelker, shamail already created one.
14:42:11 <topol> #agree folks can email their results to the defcore mailing list
14:42:13 <catherine_d|1> markvoelker: we do have wiki page for interop-challenge https://wiki.openstack.org/wiki/Interop_Challenge#Meeting_Information
14:42:33 <markvoelker> Ok, I'll put it there
14:43:08 <topol> got diconeected for a sec
14:43:26 <topol> so folks are to mail the list and markvoelker to record on the wiki page?
14:43:40 <markvoelker> topol: yep
14:44:01 <markvoelker> #action markvoelker update wiki page with how to submit test results
14:44:11 <topol> #action markvoelker to record results on the wiki page,  folks you email results to the defcore meeting list
14:44:29 <topol> excellent
14:45:07 <topol> #topic next weeks meeting, topo and shamail at OpenStack East next week
14:45:13 * markvoelker is too
14:45:20 <topol> So for next week should we cancel?
14:45:46 <topol> Or we could leave the hour as an open office hour if folks need help from tongli
14:45:46 <dcnatt_> is at containercon/cloud native day in Toronto
14:45:52 <markvoelker> I'd be fine with that.
14:46:30 <topol> K, so next weeks meeting is canceled but tongli available on IRC for help
14:47:19 <topol> #topic open discussion
14:48:18 <tongli> I added a little section at the end of the etherpad for summary. please update if miss something.
14:48:58 <topol> I think we got a lot covered in this meeting. Very productive
14:49:12 <topol> Any open issues or do folks want time back
14:49:25 <dcnatt_> Good here
14:49:28 <gema> all good
14:49:54 <tongli> @dncatt_, eager to see NFV stuff in , let me know if you need a hand. Thanks.
14:50:03 <topol> Awesome. Great meeting everyone.  And I look forward to seeing folks at OpenStack East!
14:50:08 <dcnatt_> will do, thanks for support offer
14:50:18 <tongli> thanks.
14:50:19 <gema> thank you all!
14:50:26 <rohit404> thanks folks !
14:52:16 <Rockyg> yhaks?
14:52:25 <Rockyg> thanks...
14:52:49 <topol> #endmeeting