14:02:58 <catherine_d|1> #startmeeting interop-challenge
14:02:59 <openstack> Meeting started Wed Aug 31 14:02:58 2016 UTC and is due to finish in 60 minutes.  The chair is catherine_d|1. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:03 <openstack> The meeting name has been set to 'interop_challenge'
14:03:22 <rohit404> o/
14:03:23 <hogepodge> o/
14:03:35 <shamail> hi
14:03:48 <gema> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-31
14:03:50 <tongli_> o/
14:03:59 <MarkBaker> hello interop folk
14:04:29 <catherine_d|1> o/
14:04:47 <topol> hi
14:04:56 <topol> hi
14:04:58 <tongli_> hi, brad.
14:04:59 <skazi> o/
14:05:00 <catherine_d|1> #chair topol
14:05:01 <openstack> Current chairs: catherine_d|1 topol
14:05:18 <dmellado> hi
14:05:22 <topol> sorry for being late. Had some wifi issues. running off my cellphone hotspot :-)
14:05:46 <openstack> topol: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
14:05:56 <topol> cool someone started the meeting
14:06:01 <dmellado> topol: it seems that it has already been started, yes
14:06:05 <topol> who is here today?
14:06:05 <luzC> o/
14:06:07 <tongli_> @topol, catherine alerady started on.
14:06:11 <rohit404> o/
14:06:13 <dmellado> o/
14:06:15 <gema> o/
14:06:16 <tongli_> o/
14:06:41 <skazi> o/
14:06:59 <catherine_d|1> o/
14:07:12 <MarkBaker> o/
14:07:39 <shamail> o/
14:08:14 <topol> The agenda for today can be found at:
14:08:15 <topol> #link https://wiki.openstack.org/wiki/Interop_Challenge#Meeting_Information
14:08:15 <topol> In case we need to take notes, the etherpad for this meeting can be found here
14:08:16 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-31
14:08:30 <topol> #topic review action items from previous meeting
14:08:30 <topol> #link
14:08:30 <topol> http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-08-17-14.00.html
14:08:56 <topol> markvoelker
14:08:56 <topol> markvoelker update wiki page with how to submit test results
14:08:56 <topol> markvoelker to record results on the wiki page, folks you email results to the defcore meeting list
14:09:21 <topol> is markvoelker here today?
14:09:40 <topol> I believe these action items have been copleted
14:09:59 <topol> tongli_ can you confirm?
14:10:15 <tongli_> @topol, he might be traveling, could not find him yesterday neither.
14:10:25 <tongli_> @topol, yes, that is all agreed on.
14:10:30 <topol> But these items have been done correct?
14:10:51 <rohit404> "Where/How to Share Test Results" section seems to be added on the wiki
14:10:58 <topol> great
14:11:19 <topol> tongli
14:11:19 <topol> if folks want tongli to help run tests on their cloud, get him an account
14:11:19 <topol> let tongli, topol know if any issues with Terraform
14:11:21 <topol> tongli and topol to follow up on who has declared their release
14:11:23 <topol> topol
14:11:41 <hogepodge> Can you add the link to the wiki?
14:12:08 <topol> #link https://wiki.openstack.org/wiki/Interop_Challenge#Meeting_Information
14:12:42 <topol> Does anyone need help from tongli_ to get the workloads running?
14:13:26 <topol> Let us know if anyone is struggling
14:13:28 <tongli_> or has anyone run these tests on their own?
14:13:39 <peterscraig_> since I've only recently engaged I may need your help tongli_
14:14:05 <tongli_> @peterscraig_, I am here to help.
14:14:18 <topol> OK, good. dont be shy
14:14:32 <tongli_> I have run these tests against IBM Bluebox and some of my private cloud, all working well.
14:14:40 <vkmc> I'm as well recently involved, got my environment ready, hopefully will try running workloads later today
14:14:51 <peterscraig_> I'll be working to setup the tests later this week
14:14:57 <vkmc> at least the three-tier webapp
14:14:59 <topol> vkmc Excellent
14:15:00 <tongli_> @vkmc, cool.
14:15:16 <topol> peterscraig Very good as well
14:15:28 <topol> tongli and topol to follow up on who has declared their release
14:15:28 <topol> UNASSIGNED
14:15:30 <topol> other folks put your preferred test OS release in the etherpad,
14:15:31 <rohit404> I did run the Terraform Swarm tests against Cisco cloud and with some fixes that are out for review it's running fine
14:15:32 <topol> please!
14:15:33 <tongli_> @vkmc, do not need any thing special, other than have two images,
14:15:34 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-17
14:15:36 <topol> 
14:15:38 <topol> shamail to add affiliate/company to the results template
14:15:42 <tongli_> coreos and a ubuntu image to run these tests.
14:15:51 <topol> rohit404 Great!
14:16:01 <shamail> sounds good.
14:16:11 <gema> rohit404: what kind of fixes, do you have a link to them?
14:16:36 <rohit404> gema: https://review.openstack.org/#/c/356586/
14:16:40 <gema> ta
14:16:56 <tongli_> @gema, there is a patch for the docker swarm , already there, just need someone to push the button to get it merged.
14:16:57 <gema> oh, I just reviewed it, sounded good
14:17:11 <gema> tongli_: yep, no idea who has the core commit rights on that branch
14:17:37 <topol> tongli_ do you know who the cores are?
14:17:52 <tongli_> catherine might know.
14:18:19 <topol> #action tongli_ to check with Catherine to identify the cores :-)
14:19:03 <topol> Last action item from last week: I believe everyone did  update last weeks etherpad with their company affiliation and what release version they are using
14:19:11 <catherine_d|1> one of the important thing is ... since we use this repository ... does it make sense to invite one of the core to join our project>
14:19:23 <topol> or at least lots of people did. Need to track down anyone that maybe missing
14:19:46 <topol> catherine_d|1 yes of course
14:20:15 <topol> ok to today's agenda
14:20:32 <topol> #topic Test Environments
14:20:39 <peterscraig_> I added Mirantis' version to the etherpad for today's meeting
14:21:03 <topol> Sounds like the first two workoads are getting tested. Any news on the ATT NFV workload?
14:23:29 <topol> peterscraig_ Thanks. I copied it to the etherpad where all the others are listed
14:24:07 <peterscraig_> @topol thanks
14:24:16 <topol> So is anyone from AT&T here?  eeiden?
14:24:46 <topol> I talked to eeiden yesterday and I believe At&T is still deciding which NFV workload to propose
14:25:23 <topol> #action tongli_ and topol to follow up with eeiden on which ATT NFV workload to use
14:25:51 <topol> #topic Results - Send as emails
14:26:12 <topol> tongli_  does eveyone know how to send results?
14:26:26 <gema> I am unclear on that
14:26:44 <topol> tongli_  do we have that documented on the wiki now?
14:27:05 <tongli_> @topol, @gema, I think we supposed to create a report (manually) and email to the defcore mailing list.
14:27:15 <gema> tongli_: yeah but there was a specific format
14:27:15 <tongli_> Mark will record the results.
14:27:29 <MarkBaker> topol, I believe Toby mentioned Clearwater IMS in the 1st call
14:27:34 <tongli_> correct, the format is at the bottom of the wiki page.
14:27:35 <topol> tongli_ we have a template to fill out. Where is that?
14:27:46 <gema> tongli_: where is that wiki?
14:27:50 <topol> tongli_ perfect!
14:28:04 <tongli_> https://wiki.openstack.org/wiki/Interop_Challenge, at the bottom of the page.
14:28:18 <topol> #link https://wiki.openstack.org/wiki/Interop_Challenge#Meeting_Information  has everything :-)
14:29:13 <luzC> lost connection for a sec. about the results it will be sending the email to the defcore mailing list right?
14:29:23 <topol> And the specific spot:
14:29:28 <topol> #linl https://wiki.openstack.org/wiki/Interop_Challenge#Where.2FHow_to_Share_Test_Results
14:29:28 <luzC> also it will be 1 email per cloud results (all workloads/executions)
14:29:28 <tongli_> @luzC, yes.
14:29:33 <topol> #link https://wiki.openstack.org/wiki/Interop_Challenge#Where.2FHow_to_Share_Test_Results
14:29:33 <gema> cool, thanks
14:29:57 <topol> #action all to become familair with the template and how to submit results :-)
14:30:05 <tongli_> @luzC, yes, one report per cloud with all three test results.
14:30:31 <catherine_d|1> RefStack test should be run also on the clouds
14:31:05 <catherine_d|1> I will add instructions about testing/sending results to the wiki afther this meeting
14:31:13 <hogepodge> catherine_d|1: can we also encourage participants to run more than just the defcore specified tests?
14:31:29 <catherine_d|1> hogepodge: absolutely
14:31:40 <topol> #action catherine_d|1 will add instructions about testing/sending results to the wiki after this meeting
14:31:55 <hogepodge> catherine_d|1: there's a habit amongst result submitters to only run defcore specific tests, and we want to capture as much of the available api as possible
14:32:06 <jkomg> +1
14:32:27 <catherine_d|1> hogepodge: +1
14:32:44 <topol> +1 Lets get all those results flowing in!
14:32:57 <rohit404> catherine_d|1: there was a recommendation documentation in progress for running the refstack tests, is that already available ? do you know by any chance ?
14:33:20 <tongli_> the results of refstack run and the work load results will be different location.
14:33:27 <tongli_> refstack recorded at a site.
14:33:31 <gema> rohit404: dmellado and I are going to be working on how to generate a proper tempest.conf for the run , we can share the list for testing
14:33:44 <tongli_> work load test results are supposed to send to the defcore mailing list.
14:33:46 <gema> dmellado: my cloud is almost ready for the testing, I hope I can try it soon
14:33:55 <dmellado> gema: ack, awesome ;)
14:34:23 <dmellado> gema: I'll put it on a git.openstack repo so we could track and collaborate on it
14:34:25 <tongli_> the work load test result only references the link to the refstack result.
14:34:33 <gema> dmellado: ack, thanks
14:34:38 <catherine_d|1> rohit404: we do ..  I will add that to the wiki ... For RefStack related questions, please ask on #refstack or #openstack-defcore
14:35:23 <topol> #action catherine_d|1 will add that to the wiki ... For RefStack related questions, please ask on #refstack or #openstack-defcore
14:35:34 <rohit404> sounds great ! thanks gema, catherine_d|1
14:35:49 <topol> Sounds like folks are making good progress!
14:36:11 <topol> #topic Open discussion
14:36:26 <topol> any other topics or issues?
14:36:39 <dcnatt_> Joined late, apologies. Quick update on VNF - hoping to have code first of next week
14:36:41 <tongli_> NFV work load
14:36:44 <dcnatt_> lol
14:36:48 <tongli_> a bit urgent now, I would think.
14:37:04 <gema> topol: how are we going to present this at ODS? do we need to give anything other than the results for that?
14:37:08 <dcnatt_> Challenging working through options
14:37:44 <dcnatt_> Do we have a format of exactly what we wish to report/present?
14:37:58 <topol> tongli_  gema  ODS?  You mean the OpenSTack SUmmit Barcelona?
14:38:04 <gema> topol: yep
14:39:31 <topol> gema,  We need to work with the foundation on the best way to present. One option may be having the workloads running in the exhibitor hall or as part of a presentation
14:40:00 <luzC> topol did we establish some dates to have the result reports from everyone?
14:40:14 <topol> So as more folks get the workloads running we will chekcpoint with the foundation
14:40:17 <gema> topol: ack
14:40:43 <topol> luzC the idea was to leave this as open as long as possible so that we could include as many folks as possible
14:41:11 <luzC> cool, makes sense
14:41:49 <topol> Okay  I see some Open Discussion items on the etherpad (Thanks Catherine)
14:41:53 <topol> nterop-Challenge related reviews
14:41:54 <topol> Added dir and heat files for interop challange (  https://review.openstack.org/#/c/351799/ )
14:41:54 <topol> swarm-manager.service does not support enable as a command ( https://review.openstack.org/#/c/356586/ )
14:41:55 <topol> Test version Mitaka (Mirantis) - sorry missed prior meetings
14:41:57 <topol> How do I propose Juju as a tool covered by this challenge? Is Juju OpenStack? No less so than Terraform or AnsibleGood point
14:42:37 <topol> So we have some patches that need to be reviewed
14:42:52 <catherine_d|1> topol: yea
14:44:00 <topol> So for Juju,  did you want to just use Juju with the existing workloads?
14:44:37 <gema> topol: who are you talking to?
14:44:41 <gema> I Am completely lost
14:45:07 <catherine_d|1> this is related to the discussion ealrlier that we should invite the core from the osops to the interop-challenge porject
14:45:07 <topol> gema, someone on the etherpad in open discussion asked bout Juju. Who was that?
14:45:19 <gema> topol: ah, ok
14:45:41 <gema> topol: juju is a deployment tool and we could use it for a workload indeed
14:46:00 <topol> gema yes, but don't we need Charms built?
14:46:20 <gema> topol: all we'd need is to decide to run it, the charms are already there
14:46:28 <gema> we may need to agree on some config options
14:46:44 <vkmc> is there a juju deployment available somewhere?
14:46:47 <gema> topol: that wasn't me comenting on the etherpad, but I have worked with juju before and I like it :D
14:47:09 <topol> gema so its always great to see all the deployment tools working
14:47:18 <gema> vkmc: you can deploy many services with juju, we just have to choose one
14:47:31 <gema> there are open source charms for them (the scripts that configure the services)
14:47:41 <vkmc> I'm aware yes, but I mean of a public cloud set up with MaaS + Juju
14:47:42 <topol> gema I thought with juju you had to purchase its runtime component. Is that not true?
14:48:00 <gema> vkmc: I believe so, but the right person for that question is MarkBaker
14:48:03 <vkmc> AFAIK there is not a community version
14:48:11 <vkmc> that we can use/deploy
14:48:14 <gema> topol: I don't think that's true
14:48:27 <gema> MarkBaker: can you comment on this?
14:48:33 <jkomg> I also thought there wasn't a community version, I'd love to be wrong
14:48:41 <topol> gema so my question is how could someone like tongli_ test the juju version?
14:48:48 <gema> I have always done a sudo apt-get install juju
14:48:50 <gema> and used it
14:48:52 <vkmc> jkomg++
14:49:08 <gema> you bootstrap your env and that's it
14:49:31 <tongli_> @gema, if there is a good instruction on how to use it, I do not mind to try it.
14:49:33 <topol> gema so we would need someone to add to the repository the Juju content and how to run it so we could all try it
14:49:35 <MarkBaker> sorry - was distracted
14:49:44 <topol> Yay MarkBaker :-)
14:49:49 * MarkBaker reads scrollback
14:49:51 <gema> MarkBaker: the floor is yours
14:50:11 <tongli_> but I think we have pretty much decided to use ansible and terraform. as the report format indicated.
14:50:27 <tongli_> should we alter the report to include juju?
14:50:38 <topol> I am okay with seeing if Juju can work for folks as well.
14:50:43 <MarkBaker> ok, there are no propreitary components to Juju, no purchase required
14:50:48 <gema> tongli_: I think if we were going to include juju we should choose a different workload
14:50:51 <gema> and add it to the list
14:50:56 <gema> the overhead would be minimal imo
14:50:58 <topol> gema that would be ideal
14:51:00 <luzC> tongli_ +1
14:51:14 <MarkBaker> the Juju OpenStack provider supports multiple versions of OpenStack - i.e you can deploy workloads to openstacks from different providers
14:51:23 <MarkBaker> providers in this conztext = distributions
14:51:31 <gema> MarkBaker: if you and james could choose an easy but not as easy as wordpress workflow to run
14:51:34 <gema> I can document it
14:51:43 <gema> and we'd be set to go next week with a juju workload as well
14:51:49 <MarkBaker> Juju has hundreds of charms including all the worklaods discussed here
14:51:56 <MarkBaker> many NFV workloads for example
14:52:03 <peterscraig_> Doesn't the different providers break the intent of the test in the same way Shade does?
14:52:11 <topol> MarkBaker, NFV would be really cool!!!
14:52:26 <tongli_> so gema, if we do this juju thing, there needs to be a workload test in the repository where lampstack is currently in?
14:52:47 <gema> tongli_: I don't think we'd need anything other than instructions
14:52:48 <MarkBaker> peterscraig_, no there is a single Juju OpenStack provider which works against many different openstack distributions
14:52:50 <gema> we won't need code
14:52:55 <gema> it's all in the charms already
14:53:12 <topol> gema can you get this into the repository so we can see what we have here?
14:53:29 <topol> Ideally Juju with NFV would be my preference
14:53:37 <MarkBaker> gema is correct - most of the work is already done, we just need to run the tests
14:53:56 <gema> topol: I have never deployed any NFV workload on my clouds so MarkBaker would have to help with that
14:54:06 <peterscraig_> Reading back to MarkBaker's comments about juju providers, I interpreted that as JuJu adapting to different distributions, which is the opposite of the goal. Or am I misinterpreting?
14:54:09 <gema> but I Can definitely add a few lines on how to install/use juju
14:54:12 <topol> MarkBaker do you think that is doable?
14:54:17 <MarkBaker> for many workloads the charms have tests (benchmarks etc..) built in as a way of validating the installation
14:54:59 <MarkBaker> peterscraig_, juju does not adapt to different distros, it uses base API calls. Admittedly it needs a lot more testing against other OpenStacks though
14:55:00 <gema> MarkBaker: I think the key here is for you to tell us: what version of juju / ubuntu we should use for this, and what service
14:55:04 <topol> Time is  of the esssence. gema, MarkBaker the key is to get something into the repository for folks to be able to try
14:55:25 <peterscraig_> ack
14:55:37 <MarkBaker> topol, I'll write up/point to some docs zinstructing people how to get going
14:55:44 <topol> Cool
14:55:45 <gema> MarkBaker: +1!
14:56:14 <topol> #action MarkBaker will write up/point to some docs instructing people how to get going
14:56:55 <topol> If all goes well we show 3 different workloads and 3 different deployment tools running on everyone's OpenStack clouds
14:57:31 <topol> the foundation asked for an NFV workload so if anyway to wing that would be cool
14:57:33 <tongli_> earlier, someone indicated to have deadline to report test results.
14:57:43 <tongli_> should we establish that?
14:57:45 <dcnatt_> Working on it and it looks plausible
14:57:53 <gema> the week before ODS barcelona sounds like a good deadline?
14:58:45 <dcnatt_> +1
14:58:45 <topol> tongli_ we will leave it open as long as possible to help get as many folks successful as we can.  Obviously the more folks that get it done early will allow me to lower my blood pressure medicine dosage
14:58:54 <tongli_> @gema, two weeks before, just make sure people have a sense of urgency.
14:58:56 <dcnatt_> me2
14:59:05 <topol> two weeks sounds good
14:59:12 <gema> topol, tongli_ ack
14:59:46 <topol> #agree final results deadline is two weeks before Barcelona summit
15:00:01 <topol> any other items for today? Pretty much out of time
15:00:02 <vkmc> +1 to deadline
15:00:36 <topol> OK great meeting everyone!!!
15:00:40 <tongli_> just run these tests and share the results. looking forward to the results.
15:00:47 <dcnatt_> Thx all
15:00:48 <topol> Thanks for participating!!!
15:00:56 <topol> #endmeeting