14:00:25 <topol> #startmeeting interop_challenge
14:00:31 <openstack> Meeting started Wed Sep  7 14:00:25 2016 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:35 <openstack> The meeting name has been set to 'interop_challenge'
14:00:49 <markvoelker> o/
14:00:52 <topol> Hi everyone, who is here for the interop challenge meeting today?
14:01:01 <catherine_d|1> o/
14:01:04 <kei> o/
14:01:08 <fredli> o/
14:01:33 <tongli> o/
14:01:45 <topol> #topic review action items from previous meeting
14:01:50 <skazi> o/
14:01:54 <rohit404> o/
14:01:54 <tongli> https://etherpad.openstack.org/p/interop-challenge-meeting-2016-09-07
14:02:15 <topol> #link
14:02:15 <topol> http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-08-31-14.02.html
14:03:17 <topol> the etherpad tongli posted has our agenda and is also where we can place notes if we need to
14:03:25 <hj-hpe> Greetings all
14:03:48 <topol> tongli_ to check with Catherine to identify the cores :-)
14:04:03 <topol> tongli this was done I believe
14:04:17 <Rockyg> o/
14:04:20 <tongli> @topol, yes.
14:04:22 <catherine_d|1> topol: I have also added the name to the etherpad
14:04:27 <tongli> the link is at the bottom of the etherpad.
14:04:32 <topol> perfect
14:04:40 <tongli> https://review.openstack.org/#/admin/groups/1076,members
14:04:49 <luzC> o/
14:04:51 <topol> 2. tongli_ and topol to follow up with eeiden on which ATT NFV workload to use
14:05:02 <topol> any news on an ATT NFV workload?
14:05:44 <Gaurav__> Hi
14:06:07 <topol> my guess is that is still missing.  tongli did you hear anything different?
14:06:26 <jkomg> o/
14:06:44 <tongli> you mean ATT NFV work load scripts?
14:06:57 <topol> tongli yes?
14:06:58 <tongli> no, I did not see any patch.
14:07:02 <topol> K
14:07:18 <topol> let's you and I follow up on that
14:07:53 <topol> #action tongli topol check on ATT NFV workload scripts.
14:07:53 <tongli> I think we were told last week that the patch should be submitted early this week.
14:08:11 <topol> K, need to see it soon. Time is getting short
14:08:27 <topol> 3. catherine_d|1 will add instructions about testing/sending results to the wiki after this meeting
14:08:39 <topol> This was done correct?
14:08:45 <catherine_d|1> topol: that is done
14:08:51 <topol> great!
14:09:28 <topol> 4. MarkBaker will write up/point to some docs instructing people how to get going (juju + NFV)
14:09:40 <topol> did we ever get anything in from MarkBaker
14:09:40 <catherine_d|1> #link     RefStack testing instructions: https://wiki.openstack.org/wiki/Interop_Challenge#RefStack_Testing_and_Results_Upload
14:11:17 <topol> Im guessing we didnt get anything yet
14:11:55 <topol> #action tongli and topol to check with MarkBaker on write up/point to some docs instructing people how to get going (juju + NFV)
14:12:24 <topol> Now to todays agenda topics :-)
14:12:41 <topol> #topic Update from meeting with OpenStack Foundation (Lauren, Jonathan, Mark, and hogepodge)
14:13:12 <topol> So I met with OpenStack Foundation (Lauren, Jonathan, Mark, and hogepodge) yesterday
14:13:33 <topol> Foundation is excited about our interop efforts. Jonathan wants an in depth demo. Scheduled for later this week.
14:13:54 <topol> Current target for showcasing this work would be 10 minutes of the Keynote on Day 2
14:14:32 <Gretchen> phone numbers did not work
14:14:33 <topol> Keynote session looking for couple more clouds to be used in the keynote session for live demo.
14:15:03 <topol> Gretchen we dont use phone numbers for this meeting anymore
14:15:05 <Gaurav__> do we have link to the demo
14:15:08 <vkmc> o/
14:15:54 <topol> demo for Jonathan will be tongli running both the dockerswarm and LAMPStack workloads on an OpenStack Cloud.
14:16:11 <topol> Jonathan wants to see really what we have so far
14:16:48 <fredli> so both the dockerswarm and LAMPStack  will be the choices, won't they?
14:17:03 <rohit404> topol: do you need others for the demo with Jonathan ?
14:17:28 <topol> fredli, yes we all agreed to get those worloads working first.
14:17:39 <tongli> @topol, it will be nice if there is another cloud that I can also use to show that the scripts produce same results against two clouds
14:18:24 <topol> rohit404,  for on stage MOST DEFINITELY :-). for jonathan we could get away with just running on one cloud but multiple clouds would be great
14:18:25 <tongli> @fredli, the docker swarm one takes less than 30 seconds to complete, for demo, it goes well, I would suggest we use that and the lampstack
14:18:37 <fredli> topol: thanks
14:19:00 <topol> so back to main stage thoughts...
14:19:15 <topol> Have different vendors talk about their interop challenge experience on stage
14:19:43 <topol> Foundation has asked more clarity on which vendors are testing on private clouds and which on public vlouds
14:20:01 <topol> #action need to update #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-17 with this information
14:20:32 <topol> please mention if you are testing on a public or private cloud (or both)
14:22:05 <topol> Foundation asked if we might be able to utilize the Deutsche Telekom cloud in Europe.  They thought Huawei was working on this cloud?
14:22:50 <topol> Foundation also asked/desired that our workloads be contributed to the app catalog
14:23:20 <topol> So things have started to get exciting!!!
14:23:36 <Rockyg> fredli, will take the action to find out about the DT cloud.
14:23:49 <peterscraig> Mirantis is planning to implement the tests as a Murano app you can just add from the Community App Catalog to any cloud running Murano and run
14:24:09 <topol> Rockyg, GREAT!
14:24:21 <topol> peterscraig, GREAT!
14:24:35 <topol> #action fredli, will take the action to find out about the DT cloud.
14:24:54 <fredli> yes, I will take it.
14:25:13 <topol> #action Mirantis is planning to implement the tests as a Murano app you can just add from the Community App Catalog to any cloud running Murano and run
14:26:02 <topol> okay so housekeeping options.   we demo to Jonathan tomorrow at 4pm EST.  If anyone wants invited to this meeting please email me
14:26:23 <topol> would any other teams be in a position to demo tomorrow as well?
14:26:36 <topol> If tongli has us all covered :-)
14:26:58 <topol> err If not tongli has us all covered :-)
14:27:22 <markvoelker> topol: Are you doing the demo tomorrow over WebEx or Hangouts or something?  I could possibly demo on one of our internal lab setups if so.
14:27:23 <topol> Any interest in attending? It will be a conf call and web conf meeting for Jonathan
14:27:24 <rohit404> topol: i have run one of the workloads so could show that
14:27:46 <topol> tongli you have a hangouts correct?
14:28:11 <jkomg> Would an IBM meeting be easier, screenshare-wise?
14:28:12 <tongli> hangouts have changed a lot. now it uses youtube stuff. I tried to do things yesterday,it did not work.
14:28:15 <jkomg> or whatever people use
14:28:22 <jkomg> We stopped using hangouts
14:28:45 <tongli> I think we have to fall back to our e-meeting.
14:28:53 <tongli> we just allow eternal access.
14:29:02 <jkomg> access forever!
14:29:03 <tongli> should work on linux, mac and windows browsers.
14:29:17 <jkomg> linux can't screenshare, mind, but they can view.
14:29:25 <Jason____> where is the access information ?
14:29:28 <tongli> right.
14:29:45 <tongli> I will drive, you guys can see the screen.
14:29:46 <topol> yeah but what it markvoelker and others want to demo too
14:29:58 * Rockyg hands jkomg a flower and a torch
14:30:00 <tongli> I know.
14:30:02 <topol> err what if
14:30:16 <jkomg> heh
14:30:37 <tongli> I do not know, google hangout now is hard to use. I could not get it going after 15 minutes trying.
14:30:44 <tongli> so I give it up.
14:31:02 <topol> markvoelker do you have a better webconf tool you recommend?
14:31:05 <markvoelker> I can donate a WebEx if that helps
14:31:14 <jkomg> webex would be much better
14:31:19 <Rockyg> webex could work
14:31:29 <topol> Let's try that.
14:31:37 <tongli> that is fine. I have webex plugins already.
14:32:06 <topol> tongli can you connect with markvoelker and Rockyg and do a test to make sure webex works for all of you?
14:32:31 <topol> ideally all plugins uopdated/installed before the meeting with Jonathan
14:32:41 <tongli> yes, mark and Rockyg, please send me the info and I want to try to share my screen before the meeting.
14:32:47 <tongli> can we do it later today?
14:33:01 <tongli> or after this meeting.
14:33:04 <topol> markvoelker can you send me the webex details and I will put them in the meeting notice?
14:33:13 <markvoelker> tongli: Ok, I'll send something out in a bit.  The meeting is 4pm EDT tomorrow, correct?
14:33:22 <tongli> yes
14:33:26 <topol> markvoelker correct!
14:33:41 * Rockyg backs slowly out of the room and points to markvoelker waving his webex flag....
14:34:08 <tongli> @markvoelker, I have also submitted a patch to address the issues that you reported. https://review.openstack.org/#/c/366784/
14:34:10 <luzC> markvoelker +1
14:34:13 <topol> #action tongli Rockyg markvoelker to do webex demo dry run
14:34:46 <topol> #action all email topol (btopol@us.ibm.com) if you want invited to the demo session
14:34:49 <tongli> @markvoelker, please review. if I can get the cores to review faster,
14:34:52 <Rockyg> ok. i can be a thirdparty for the experiment
14:35:16 <topol> that brings us to our next and very critical topic:
14:35:29 <topol> #topic Tong needs to test on other folks public clouds ASAP.
14:36:06 <topol> The foundation is excited about our work. We need to deliver. And we need to show the workloads targeting multiple public OpenStack clouds
14:36:19 <tongli> @topol, I have talked to shihao (Jason) from Huawei, to get them going.
14:36:45 <tongli> @topol, we will have a call soon.
14:36:45 <Jason____> @tong , thanks , i hope have to talk with you later about the issues
14:36:46 <topol> who has these?  Can we get a free access trial account?
14:37:07 <topol> topol ready to bust out his credit card if need be
14:38:12 <topol> #action all we need to identify which public clouds we can target for both testing and on stage demo
14:38:31 <topol> so please everyone find us some clouds and report back
14:38:36 <Rockyg> Do we have anyone from OVH here?  They provides some of the nodepool...
14:39:14 <markvoelker> OVH has been offering free time on their public cloud to openstack committers, so no need for credit cards. =)
14:39:36 <topol> tongli ^^^
14:39:59 <topol> markvoelker please help to connect tongli to this :-)
14:40:06 <markvoelker> tongli: https://thanks.ovh/weareopenstack/
14:40:08 <tongli> what is OVH?
14:40:53 <tongli> not working any more.
14:41:01 <tongli> no more voucher available.
14:41:32 <topol> what about OSIC?
14:42:15 <tongli> @topol, I will try that.
14:42:19 <hogepodge> I can ask about osic
14:42:26 <topol> tongli I'll bust out the credit card for RAX for you later today
14:42:39 <luzC> we are going to test on OSIC
14:42:44 <topol> hogepodge thanks! appreciate the help
14:42:54 <luzC> it is private
14:42:58 <luzC> not public
14:43:01 <catherine_d|1> I will connect with Jean-Daniel Bonnetot from OVH and inviting them to join Inetop-Challenge
14:43:14 <topol> luzC thats ok.
14:44:08 <topol> The sooner we can show the workloads running on mutliple clouds the better
14:44:20 <luzC> if you want a new project on osic to test further https://osic.org/clusters
14:45:33 <topol> So given we will get some keynote stage presence please everyone focus on getting the first two workloads running.  Let's get everyone to that point
14:45:45 <topol> Does that make sense to everyone?
14:46:25 <topol> that brings us to our next topic.
14:46:33 <Jason____> what's the two workloads ?
14:46:47 <topol> dockerswarm and LampStack
14:47:08 <Jason____> ok
14:47:09 <topol> Jason___ you know where to find the workloads yes?
14:47:27 <Jason____> not yet , but i will talk with tongli later
14:47:31 <markvoelker> Jason___: see git repo links in https://wiki.openstack.org/wiki/Interop_Challenge#Where.2FHow_to_Share_Test_Results if not.
14:47:33 <luzC> Jason___  https://github.com/openstack/osops-tools-contrib/
14:47:42 <Jason____> done
14:47:45 <topol> #topic test runs and results
14:48:06 <Jason____> ok
14:48:14 <topol> So I know tongli has sent his results in.  Has anyone else?  Anyone close? Anyone stuck?
14:49:04 <topol> markvoelker you are close, yes?
14:49:09 <markvoelker> topol: tongli and I have discussed VMware's results (and he has some patches up to fix some portability issues)
14:49:19 <topol> markvoelker excellent
14:49:29 * topol I count that as close!
14:49:30 <rohit404> topol: i have run one of the workloads and we fixed an issue with that as well
14:49:33 <markvoelker> Basically the workloads assume a certain block storage device name and NIC name that aren't portable as they depend on the hypervisor and guest os
14:49:44 <rohit404> will be running the second workload soon
14:49:53 <tongli> @markvoelker, the patch is there, just need someone to review, you can extract it to test if you like to
14:49:57 <topol> markvoelker, yep tongli told me
14:50:16 <topol> rohit404 Excellent
14:50:39 <markvoelker> #link https://review.openstack.org/#/c/366784/ patches to fix device naming assumptions
14:50:51 <topol> So everyone please keep going.  Let's get everyone to the two workload milestone
14:50:57 <pilgrimstack1> Hi from OVH
14:51:23 <pilgrimstack1> How can I help?
14:51:36 <catherine_d|1> topol:eralier we talk about public cloud ..
14:51:37 <topol> hi pilgrimstack1. how much do you know about our interop challenge for the Barcelona Summit?
14:52:09 <pilgrimstack1> hmmm almost nothing
14:52:19 <catherine_d|1> pilgrimstack1: is from OVH public cloud
14:52:42 <topol> Our plan (as part of the keynote on day 2) will show that OpenStack provides interoperability by showing that workloads are portable to different clouds
14:53:11 <topol> We have two workloads already available. A docker swarm workload and a LAMPStack workload.
14:53:32 <pilgrimstack1> catherine_d|1: I'm checking the wiki
14:53:34 <topol> Foundation has asked us to show them working on lots of public clouds.
14:54:15 <topol> Can we get access to yours to test now and demo later in Barcelona?
14:55:40 <topol> pilgrimstack1 while you ponder lets goto open discussion
14:55:46 <topol> #topic open discussion
14:56:07 <Rockyg> Could probably get more cloud volunteers by posting to openstack-ops ML
14:56:25 <topol> Rockyg that's  a great idea
14:56:35 <topol> could you reach out?
14:56:40 <catherine_d|1> Rockyg: openstack ops ML is a private ML ... not everyone can post
14:57:18 <catherine_d|1> need someone from that ML to post ..
14:57:23 <Rockyg> not private, you just hav to be a member
14:57:36 <Rockyg> I can post.
14:57:41 <pilgrimstack1> topol: yes, of course
14:57:46 <catherine_d|1> Rockyg:  asked but no reply yet
14:57:52 <topol> Rockyg THANKS!
14:58:02 <catherine_d|1> Rockyg: +1
14:58:10 <pilgrimstack1> can I run it too?
14:58:15 <topol> pilgrimstack1 Excellent! Can you get tongli access
14:58:20 <Rockyg> I can point them to wiki if you put up a section on how to volunteer a cloud acct/who to contact
14:58:21 <topol> pilgrimstack1 yes please
14:58:33 <topol> tongli can show you how to run it as well
14:59:04 <tongli> @pilgrimstack1, yeah, totally,
14:59:09 <topol> #action Rockyg to post request for clouds to openstack-ops ML
14:59:57 <topol> #action catherine_d|1 to provide new wiki section for  volunteer a cloud acct/who to contact
15:00:51 <topol> #action pilgrimstack1 to run workload and also get tongli acess
15:01:07 <topol> this is excellent progress!
15:01:43 <topol> anything else for today?  and please email me btopol@us.ibm.com if you want invited to demo tomorrow
15:02:31 <topol> K, great meeting everyone! Thanks!
15:02:40 <Rockyg> thanks!
15:02:43 <topol> #endmeeting