14:01:23 <topol> #startmeeting interop_challenge
14:01:26 <openstack> Meeting started Wed Oct  5 14:01:23 2016 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:29 <Jason____> engineers is on testing
14:01:30 <openstack> The meeting name has been set to 'interop_challenge'
14:01:46 <topol> Hi everyone, who is here for the interop challenge meeting today?
14:01:46 <rohit404> 0/
14:01:52 <GheRivero> o/
14:01:52 <skazi> o/
14:01:53 <eeiden> o/
14:01:57 <Jason____> the account could be used in keynote
14:01:57 <Rockyg> o/
14:01:58 <oshykhkerimov> o/
14:02:03 <tongli> o/
14:02:25 <topol> The agenda for todays meeting can be found at
14:02:31 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-10-05
14:02:40 <topol> And its a very exciting one!!!
14:02:58 <topol> We can use this same etherpad to take notes
14:02:58 <topol> #topic review action items from previous meeting
14:03:14 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-09-28-14.00.html )
14:03:18 <Jason____> @ topol , yes. Huawei private cloud passed the test
14:03:28 <gema> o/
14:03:37 <vkmc> o/
14:03:42 * topol will try and rush thru previous action items to get to the agenda!!!
14:03:48 <catherine_d|1> o/
14:04:01 <topol> action items from last meeting:
14:04:10 <topol> tongli to work with JASON__ on Huawei cloud issues
14:04:19 <luzC> o/
14:04:23 <shamail> o/
14:04:29 <topol> This works now for the LAMPStack workload correct
14:04:46 <Jason____> thanks tongli , the issues have been solved .
14:04:52 <tongli> @topol, we did. and Huawei has no issues. their private cloud successfully run, just talked about before the meeting.
14:05:13 <Jason____> yes, I have send the results to tongli by email
14:05:28 <Jason____> we will update the wiki by tomorrow
14:05:28 <topol> OUTSTANDING! Here's a hint... someone from just earned a trip on stage for the 2nd day Keynote
14:05:32 <Rockyg> YES!
14:05:45 <gema> :D
14:05:49 <eeiden> nice!!!
14:05:49 <topol> JASON__ to hear back regarding DT cloud today
14:05:57 <topol> any idea on the DT cloud
14:06:13 <dmellado> topol: we passed the 2 ansible workloads + the refstack cert from the Red Hat side
14:06:20 <dmellado> will be sending the results to both you and tongli
14:06:34 <topol> dmellado on which cloud?
14:06:41 <topol> DT?
14:06:42 <gema> I thought the results were going to be sent to the defcore list
14:06:43 <dmellado> I've also submitted a patch to allow virtualenvs on the ansible workloads, in any case ,)
14:06:47 <dmellado> topol: Red Hat one,
14:06:59 <dmellado> gema: I'll cc results
14:07:05 <tongli> @dmellado, please send to the list. I think Mark will record.
14:07:10 <gema> dmellado: was checking to figure out where to send mine :D
14:07:11 <dmellado> tongli: ack
14:07:19 <topol> OUTSTANDING.  someone from RedHat just earned a trip on stage for the 2nd day Keynote
14:07:20 <luzC> gema yes, I sent OSIC results to the defcore list
14:07:27 <gema> luzC: I saw those, thanks :D
14:07:28 <tongli> and also update the wiki page. @dmellado.
14:07:32 <dmellado> tongli: will do
14:07:38 <gema> tongli: which wiki?
14:07:39 <topol> gema is correct please mail int he results and update wikipage
14:07:43 <tongli> @dmellado, thanks a lot.
14:07:55 <tongli> @gema, https://wiki.openstack.org/wiki/Interop_Challenge
14:07:57 <topol> next action item
14:08:01 <gema> tongli: thanks!
14:08:10 <topol> topol to follow up with Jonathan.
14:08:34 <topol> I like this one because it enables me to jump to the main topic for todays meeting
14:08:51 <vkmc> dmellado++
14:08:55 <vkmc> :)
14:08:55 <dmellado> \o/
14:08:59 <topol> So Here is what Jonathan Bryce told us
14:09:20 <topol> Right now, the Interop Challenge Showcase is 10 minutes, starting around 22 minutes into the show on Wednesday morning.
14:09:45 <topol> For the presentation we’re thinking something that’s fun, high-energy and gets as many of the participants on stage at once as possible. The idea is that we bring out everyone who’s capable of running the app line them all up and tell them to get started
14:10:08 <topol> since it takes a few minutes for things to start firing off in the clouds
14:10:39 <Jason____> @topol , how many cloud you will start at presenstation
14:10:40 <topol> While they are getting started, Brad and jonathan will run through a few minutes of slide content to explain the importance of interop and portability,
14:11:01 <topol> the way the challenge came together, what the app is (with an old-school enterprise architecture diagram of if).
14:11:13 <tongli> each tester will hold their own laptop and firing off the tests?
14:11:26 <topol> tongli YES
14:11:29 <topol> By that point, some servers and networks are probably being created in some of the clouds and we’d start to bounce from participant to participant and see the progress they’re all making separately
14:11:42 <tongli> very nice!
14:11:47 <gema> very nice indeed
14:11:50 <rohit404> that's cool
14:12:00 <topol> we’d go through and give everyone a chance to show off if they’ve got it working or not and do kind of an iron chef round robin verifying that they’re all deploying from the same ansible script
14:12:10 <topol> and getting working results
14:12:13 <tongli> that means our laptops will have to have access to the cloud we are testing.
14:12:29 * dmellado hopes that the network would be stable or will bring a video xD
14:12:35 <topol> tongli yes
14:12:36 <tongli> could be a bit of a challenge to the private cloud, but I think tester to the private cloud should have access.
14:12:44 <topol> dmellado they usually have aprivate network for demos
14:12:50 <topol> at keynote
14:13:13 * rohit404 externally accessible private cloud to avoid VPNs please
14:13:27 <topol> This would mean that each participating org would need a representative to come on stage with a laptop that would be able to show off in some way the resources being provisioned (e.g. browser dashboard views, browser load of the finished WP install).
14:13:45 <tongli> @topol, so each test's screen will show on big screen or not?
14:14:14 <topol> tongli, not sure yet
14:14:15 <topol> On the production side, we need to put a cap pretty quickly on who’s going to be in so we can make sure we have the ability to show that many different outputs. I’d like to put a deadline of this Friday in place for any organization to commit to being able to be onstage in the demo.
14:15:34 <topol> So jonathan is telling us that by this Friday organizations need to commit to going on stage with their representative and laptop to run the LAMPStack workload with ansible
14:15:55 <rarcea> why with ansible?
14:16:02 <rarcea> we did Teraform
14:16:09 <topol> rarcea, can you do ansible?
14:16:16 <tongli> so not our own laptop?
14:16:24 <topol> the idea would be to show everyone running the same thing
14:16:30 <tongli> hmmm, I think we will just do the lampstack one, right?
14:16:37 <MarkBaker> topol, lots of moving parts need to align here to make that happen - I'll drop you a mail with progress
14:16:39 <rarcea> well, we certainly can - but initially this was not the main goal - so ansible had some issues and we just did it with teraform
14:16:40 <tongli> are we doing both lampstack and dockerswarm?
14:16:43 <dmellado> topol: then LAMPStack would be the one? no prob from my side, just want to prepare the demo
14:16:46 <topol> tongli yes you need to bring your own laptop
14:16:59 <topol> tongli no.
14:17:08 <topol> just LAMPStack
14:17:36 <topol> everyone, should be prepared to run LAMPStack
14:17:56 <rohit404> topol: do we qualify if we have got the workloads running already ? what do you need from the organization - like an email confirming the participation by Friday ?
14:18:06 <tongli> here. https://github.com/openstack/osops-tools-contrib/tree/master/ansible/lampstack
14:18:12 <tongli> that is the link.
14:18:33 <topol> rarcea, I can check with Jonathan on the TerraForm.  But is there anyway to make it run with Ansible. Can tongli help you?
14:18:39 <gema> yeah, what is the limit to run these workloads
14:18:46 <gema> I thought we had another week at least
14:19:15 <tongli> the terraform lampstack miss many functions.
14:19:27 <tongli> please do not use that one.
14:19:31 <dmellado> gema: it should be like that
14:19:35 <dmellado> 'til Oct 11th
14:19:36 <topol> rohit404, can we add this to wiki instead of an email. They we get the global picture
14:19:48 <gema> dmellado: ack
14:19:49 <dmellado> so topol, maybe we can extend the deadline for the designee to that?
14:19:53 <rohit404> topol: already there on the wiki
14:19:59 <rarcea> topol: i'll need to check with the guys why they gave up on ansible in the first place
14:20:10 <topol> gema, unfortunately Jonathan set the friday deadline
14:20:16 <rarcea> tongli: did I miss it somewhere that teraform should not be used? was this discussed?
14:20:20 <gema> topol: this friday?
14:20:22 <rohit404> topol: or you are suggesting creating another column for this purpose in that table
14:20:37 <topol> rohit, yes lets add another collumn
14:20:54 <tongli> @rarcea, yes, quite few times. Please check the past etherpads history.
14:21:04 <topol> so I can ask Jonathan for extensions if there are folks who think they are close
14:21:25 <topol> rarcea, can tongli help you to get ansible working
14:21:37 <GheRivero> we just got assigned to this project, but we can try our best to have it ready for this Friday (HPE Helion 3.0)
14:22:04 <tongli> @GheRivero, if your cloud is ready.
14:22:09 <tongli> get this running is very easy.
14:22:14 <Rockyg> GheRivero, again, tongli is a great help
14:22:15 <tongli> and if you do not want to do the test.
14:22:25 <topol> please update the wiki with who is ready to have a rep, bring their laptp up and demo.
14:22:27 <tongli> create an account for me, I can run it in couple of minutes.
14:22:44 <topol> if youa re close and need an extension make that clear and I'll beg Jonathan for you
14:23:01 <GheRivero> it's almost ready.... just need a couple of conf changes
14:23:35 <topol> rarcea,  any chance you can connect with tongli and see if he can quickly get this running on your cloud?
14:23:46 <gema> tongli: I will create an account on our cloud for you
14:24:02 <rarcea> topol: yes, let me see internally what the issue was, if we need support i'll talk to tongli
14:24:02 <gema> tongli: would be glad to have your help
14:24:04 <Rockyg> gema, ++
14:24:08 <tongli> @gema, If it is public, that is very easy.
14:24:20 <gema> tongli: it is public but images are armv8
14:24:22 <gema> :D
14:24:28 <gema> tongli: will put everything on an email
14:24:45 <tongli> @gema, needs coreos and ubuntu image.
14:24:51 <dicekbz> May I ask a question, Tongli?
14:24:52 <topol> #action all update wiki with new column stating you are ready to demo on stage and who your onstage rep is. IF you need anextension make that clear
14:24:57 <tongli> do not care what hypervisor your cloud use.
14:24:59 <gema> tongli: ok, I will upload the coreos image
14:25:03 <dmellado> gema: ubuntu has arm image, but I'm not sure about coreos
14:25:17 <gema> dmellado: I got that one built last week, only problem is I haven't tried it yet
14:25:19 <dicekbz> Should I folk the github for the LAMPStack test?
14:25:22 <gema> adding that to my list
14:25:24 <gema> today
14:25:33 <rohit404> topol: i'll get the Keynote 2 Demo Readiness column added into the wiki table
14:25:46 <topol> rohit404 Thanks
14:25:46 <tongli> @dicebbz, sure. I am on irc channel every day.
14:26:13 <tongli> @rohit404, nice. and a good idea.
14:26:20 <dicekbz> Again, should I folk the github for this challenge??
14:26:43 <topol> dicekbz, I dont understand the question
14:26:47 <dmellado> fork?
14:26:49 <dmellado> what for?
14:26:50 <tongli> @dicekbz, why you want to fork the github?
14:27:23 <tongli> the workload tests use standard OS APIs.
14:27:24 <dicekbz> No, I thought you check the attendees from forks.
14:27:42 <dicekbz> But if it's not necessary, it's ok for me.
14:27:48 <tongli> https://wiki.openstack.org/wiki/Interop_Challenge
14:28:04 <tongli> I think folks talking about update the table at the bottom of that link.
14:28:07 <topol> #link https://wiki.openstack.org/wiki/Interop_Challenge
14:28:22 <dicekbz> Thanks, I'll check it.
14:28:47 <tongli> not all the way to the bottom, but close to the bottom.
14:29:20 <dicekbz> OK. By the way, I passed to create LAMP Stack workloads on Fujitsu public cloud K5. And so as private cloud.
14:29:23 <tongli> look for this "Current Participants Alphabetical Order"
14:29:41 <dicekbz> I'll send the reports for it by e-mail later.
14:30:00 <topol> dicekbz using Ansible?
14:30:10 <dicekbz> Yes
14:30:17 <dicekbz> Only Ansible.
14:30:19 <topol> dickekbz, excelelnt
14:31:37 <topol> so tongli, where your name is in the wiki for other folks clouds we want to get a person from that cloud running the workload
14:32:01 <topol> So for OVH, it was ? pritchett sp?
14:32:13 <topol> Rockyg do you remember
14:32:46 <topol> dreamhost it was stefano
14:32:47 <Rockyg> Oh, man.  pilgrim something
14:33:18 <topol> Rockyg I  think youa re close. I can look in previous meeting logs
14:33:32 <topol> MarkVoelker around?
14:33:38 <markvoelker> yup
14:34:07 <topol> you following the conversation. You gonna come up on stage at the keynote and run the LAMPStack workload?
14:34:36 <markvoelker> Yep, we can do that.  One minor issue left to work out though, as noted in teh wiki.  Seems pretty trivial, should have a workaround patch up in a day or so.
14:34:46 <skazi> OVH -> pilgrimstack
14:34:55 <topol> skazi, THANKS
14:35:09 <markvoelker> (basically one some virtual disk adapters the cinder volume won't be detected by the guest OS until you rescan the bus)
14:35:41 <topol> pilgrimstack, you around?
14:35:48 <tongli> @topol, I will ask pilgrimstack to put his name there as well. hope he can run the test himself.
14:36:11 <topol> tongli yes, please contact him and fill him in on the plan
14:36:23 <tongli> @topol, will do.
14:36:31 <topol> tongli, contact stefano as well
14:36:36 <topol> from dreamhost
14:36:45 <tongli> @topol, yes master!
14:36:58 <topol> tongli, ouch
14:37:05 <topol> :-)
14:37:11 <tongli> @topol, kidding.
14:37:14 <dmellado> lol
14:37:14 <topol> I know
14:38:17 <topol> so #action all, get a rep, be able to come up with laptop and run Ansible LAMPStack and update the wiki
14:38:38 <gema> topol: do we need to have all the results by Friday or only the lampstack one?
14:38:57 <topol> gema just LAMPStack
14:39:10 <topol> thats what we are all gonna run
14:39:20 <gema> topol: ack
14:39:31 <topol> OK, so that pretty much covered multiple agenda topics
14:39:40 <topol> next easy topic
14:39:57 <topol> #topic Invite  to OpenStack Interop Challenge participants to attend IBM Client Day afternoon social (should have food/alcohol)
14:40:21 <topol> Date:  Wednesday, Oct 26th
14:40:21 <topol> Time:  4:30-5:05pm (Afternoon coffee break on the event schedule)
14:40:21 <topol> Location:  IBM Sponsor Track Room, CCIB 116.
14:40:45 <topol> Feel free to show up here for this social. I was told we will have food and alcohol
14:41:26 <topol> They were have to have interop participants show up and mingle and meet each other at the social
14:41:38 <tongli> @topol, very nice.
14:41:38 <Rockyg> cool
14:41:45 <gema> great, thanks
14:41:53 <luzC> +1
14:41:58 <tongli> so we can finally know put the name on the face.
14:42:03 <GheRivero> ++
14:42:05 <topol> if you think you might attend let me know so I will look for you there
14:42:18 <gema> topol: I will come say hi :D
14:42:28 <topol> luzC will you be able to run the workload on behalf of OSIC?
14:42:47 <luzC> yes I will
14:43:11 <topol> can you update the wiki and coordinate with Kenny from RAX?
14:43:36 <luzC> sure I'll
14:44:12 <tongli> just want to give a bit hint on running the tests.
14:44:16 <topol> #action topol  (this time not tongli :-) ) to send an email out to our participant list regarding the plans for the demo and deadlines
14:44:24 <tongli> sometimes, your cloud may be short on floating IPs.
14:44:47 <topol> #topic open discussion
14:44:50 <topol> Anything else???
14:44:57 <tongli> so make sure at least the account you use have released all the allocated floating IPs.
14:45:36 <tongli> if you have trouble to obtain enough of floating IPs, the tests will halt.
14:45:51 <oshykhkerimov> yep! I have a question if it makes sence to add murano as a tool for deploying workloads
14:45:55 <tongli> I've seen the problem quite few times on various clouds.
14:46:24 <dmellado> tongli: I was thinking about having a tox env added to trigger the workloads directly
14:46:31 <dmellado> something like tox -elampstack
14:46:36 <dmellado> will put up a patch for that
14:47:05 <tongli> @dmellado, sure , sure. will be happy to see that.
14:47:08 <luzC> dmellado good idea
14:47:33 <dmellado> tongli: I've put up this patch first
14:47:40 <dmellado> to allow ansible be aware of venvs
14:47:43 <dmellado> https://review.openstack.org/#/c/382216/
14:47:51 <dmellado> thanks for having a look when you get the chance ;)
14:47:57 <dmellado> thanks luzC ;)
14:48:33 <markvoelker> oshykhkerimov: we discussed Murano a bit in the past...main issue there is only ~4% of production clouds deploy it as of the April user survey. That and we're too close to Summit to add more tools now. =)
14:50:12 <topol> oshykhkerimov I suspect post summit when we talk about next steps for interoperability we should discuss murano and other stuff.
14:52:12 <topol> anything else for today?
14:52:40 <oshykhkerimov> markvoelker topol: got it. Looks like Murano is ready-to-deploy all the listed workloads and even Refstack as application by itself, it's a pity to know that it doesn't take part in challenge as a useful one
14:52:51 <topol> also if someone thinks they are close but just cant make Friday let me know.  We can try and ask for an extension if you think you are close
14:53:16 <topol> so oshykhkerimov
14:53:31 <GheRivero> thx topol for that possibility... just in case
14:54:06 <oshykhkerimov> topol: hope it to be discussed on summit for the next time (:
14:54:12 <topol> can you put this in an email what you propose?  Maybe jonathan will like having that variation on stage too to give murano some visibility. Im happy to ask
14:54:40 <oshykhkerimov> topol: oh, great! gonna try
14:55:12 <topol> oshykhkerimov email me the details to btopol@us.ibm.com and I'll pitch it to jonathan
14:56:04 <oshykhkerimov> topol: thank you, will do (:
14:56:53 <topol> oshykhkerimov I think with murano we talk about how the workloads are getting mainstreamed by being supported by Murano. does that make sense?
14:57:16 <topol> somehting that highlight murano and its value
14:57:41 <topol> oshykhkerimov play salesman and email me a sales pitch
14:58:29 <topol> almost out of time.  any questions email me or contact me on irc.
14:58:30 <oshykhkerimov> topol: :D actually why not, seems to me that Murano perfectly suits for such stuff too
14:59:06 <topol> oshykhkerimov lets work on story/theme we can pitch to jonathan
14:59:27 <oshykhkerimov> topol: deal
14:59:32 <topol> k, great meeting everyone
14:59:45 <Rockyg> thanks!
14:59:48 <topol> #endmeeting