15:00:41 <topol> #startmeeting interop_challenge
15:00:41 <openstack> Meeting started Wed Nov 30 15:00:41 2016 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:46 <openstack> The meeting name has been set to 'interop_challenge'
15:00:53 <markvoelker> o/
15:00:58 <gema> o/
15:00:58 <Rockyg> o/
15:00:59 <topol> Hi everyone, who is here for the interop challenge meeting today?
15:00:59 <topol> The agenda for today can be found at:
15:00:59 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-11-30
15:01:01 <topol> We can use this same etherpad to take notes
15:01:03 <MarkBaker> o/
15:01:08 <skazi_> o/
15:01:23 <JASON___> Hi, jason from huawei
15:01:38 <tongli> o/
15:01:46 <dmellado> o/ hi guys
15:02:10 <topol> #topic review action items from previous meeting
15:02:10 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-11-16-15.00.html
15:02:49 <topol> all, please use #link https://etherpad.openstack.org/p/interop-challenge-postmortem for lessons learned doc
15:02:49 <topol> all, please add all you can to it
15:02:49 <topol> all, sections include tooling, networking, provisioning, metadata, etc.
15:03:29 <topol> I went an looked at the document  I don't believe many of the sections we were thinking about have been added
15:03:47 <topol> so if you have content to contribute for this doc please do
15:04:11 <topol> so let's keep this action running
15:04:35 <tongli> should that be part of the new repository and get reviewed , then merge?
15:04:40 <tongli> I mean even the document.
15:04:42 <topol> #action all, please use #link https://etherpad.openstack.org/p/interop-challenge-postmortem for lessons learned doc and add content
15:05:01 <topol> tongli yes, we will add it to the repo when repo is ready
15:05:16 <topol> #action tongli to migrate doc to repo when ready
15:05:45 <luzC> o/
15:05:55 <dmellado> hiya luzC ;)
15:06:06 <topol> tongli when you have successfully moved it mark it at the top as been moved
15:06:21 <topol> we'll freeze it then
15:06:35 <topol> next item:
15:06:43 <tongli> @topol, got it.
15:06:51 <topol> topol to add an elevator pitch to #link
15:06:57 <topol> this was done
15:07:24 <topol> next item
15:07:38 <topol> all add to etherpad suggestions for work items. After one week. topol will create a doode poll and send out to defcore list
15:08:18 <tongli> the repository is there.
15:08:21 <topol> So I check and did not seen anything added besides cloud foundry and NFV. Did I miss any if these? Did I look in the wrong place.  I held off on the doodle poll
15:08:32 <tongli> we just need to have an agreement on the structure, then we can start doing it.
15:08:44 <topol> tongli, excellent. But lets cover that at the end of the agenda
15:09:15 <topol> But back to the suggested work items.   Did I miss any?
15:09:35 <markvoelker> Looks like we said we were going to add them to https://etherpad.openstack.org/p/interop-challenge-meeting-2016-11-16
15:09:38 <markvoelker> And you got those
15:10:04 <topol> markvoelker. yeah thats what I thought but I needed a sanity check :-)
15:10:20 <topol> if we only have 2 do we need a doodle poll?
15:10:29 <markvoelker> One thing I see in the minutes from last time that doesn't look like it's in the list yet:
15:10:35 <tongli> there are three
15:10:39 <markvoelker> "it would be good to review the user survey for what people are interested in, and what they're running on top of OS today"
15:10:47 <tongli> NFV, Kubernetes, CF
15:10:50 <markvoelker> Not sure we've actually done that?
15:10:53 <luzC> topol quick question... are we still joining app catalog?
15:11:10 <topol> luzC good question
15:11:21 <Rockyg> ++ markvoelker
15:11:53 <topol> markvoelker I think you are correct that that stepwas not done
15:12:03 <topol> Anyone have time to do that?
15:12:46 <markvoelker> I can probably do that...shouldn't take more than 30 minutes or so
15:13:26 <topol> markvoelker ok great.  So how bout you do that and see if anything should be added to our list of 3 items and then we send out the doodle poll?
15:13:37 <markvoelker> Sure
15:13:46 <topol> great.  Thanks!
15:14:14 <topol> #action markvoelker to review user survey to look for more possible work items to add to doodle poll
15:14:40 <topol> luzC on your question let's hold that until we talk about our new repo
15:14:51 <luzC> topol ok, I was asking because I noticed app-catalog only has heat, tosca and murano templates, and glance images, not ansible/terraform
15:15:45 <luzC> topol thats ok, let's talk about it after repo is in place
15:15:52 <topol> Ok let's jump to a todays agenda item
15:15:52 <dmellado> yeah
15:15:58 <topol> luzC +++
15:16:10 <topol> #topic New Meeting time and IRC channel
15:16:40 <topol> So i was informed that where we hold this meeting #openstack-meeting-cp cannot be a long term home for us :-(
15:16:49 <dmellado> :\
15:17:32 <topol> So we have to move to one of the other channels.  I did not see a channel avail at this timelsot.  And frankly determing what channels are availabel at what timelsots is not my strong skill
15:17:42 <gema> topol: create one
15:17:50 <gema> #openstack-forall
15:17:51 <gema> x)
15:18:03 <topol> gema can we???
15:18:09 <gema> of course
15:18:12 <gema> and we can put the bot on it
15:18:16 <gema> and be done with it
15:18:16 <topol> My irc skills are weak
15:18:26 <gema> choose a name and join the channel
15:18:29 <gema> that just creates it
15:18:40 <gema> then we have to put a couple of patches in infra to make the bot enter
15:18:47 <gema> and we can hold the meetings there
15:18:50 <topol> I would love our own channel  at this timeslot.  I vageuly recall some issues with doing that like losing the meeting bot???
15:18:59 <gema> then let's choose a name
15:19:13 <gema> and we can join the channel and get the bot in for next week
15:19:28 <topol> gema I really like that plan
15:19:31 <dmellado> +1
15:19:37 <tongli> @gema, if that is the case, can we keep the same time but a new channel?
15:19:39 <dmellado> #openstack-interop
15:19:40 <dmellado> ?
15:19:47 <topol> Can you create the channel and configure the bot thingy :-)
15:19:48 <gema> tongli: sure, it'd be our channel
15:20:04 <gema> tongli: I can carve some time for that, no problem
15:20:10 <dmellado> gema: a gerritbot would also be awesome xD
15:20:12 <gema> tongli: but tell me the name
15:20:17 <gema> dmellado: do you know how to do that?
15:20:18 <gema> xD
15:20:22 <gema> dmellado: we'll figure it out
15:20:22 <tongli> @gema, sounds like a plan and an action item for @gema.
15:20:23 <topol> #openstack-interop sounds like  a great name to me
15:20:28 <dmellado> heh, well, I did at some point
15:20:30 <dmellado> ao I can lend a hand
15:20:31 <dmellado> xD
15:20:36 <gema> topol: isn't that the new defcore channel?
15:20:37 <dmellado> so
15:20:38 <gema> that's taken
15:20:45 <Rockyg> openstack-interop is already there.  defcore is transitioning to it
15:20:48 <luzC> gema I think so
15:20:53 <dmellado> oh, true!
15:20:56 <gema> topol: or the other thing we could do is ask defcore if they let us hold the meetings on their channel
15:21:00 <topol> can we reuse or should we be slightly different
15:21:01 <gema> and use that one
15:21:20 <gema> topol: up to us, reusing sounds good, we can ask later today if using that channel is ok
15:21:20 <topol> k, so lets have a backup name just in case
15:21:23 <gema> markvoelker: what do you think?
15:21:29 <tongli> if openstack-interop is already there, should we just take the time slot? seems a bit easier?
15:21:45 <topol> tongli I agree if we can get that aproved
15:21:54 <gema> topol: it is up to the entire group, not just up to me
15:21:55 <tongli> our repo is named interop-workloads.
15:21:56 <gema> so we need to ask
15:22:01 <tongli> we can use that as the channel?
15:22:09 <gema> tongli: we could
15:22:10 <tongli> too long maybe
15:22:20 <tongli> or just openstack-workload
15:22:27 <tongli> openstack-workloads
15:22:28 <dmellado> +1 on openstack-workloads
15:22:42 <markvoelker> I think it's probably fine to use the #openstack-interop channel from a DefCore perspective, but note that infra has frowned on holding meetings in non-meeting channels in the past
15:22:43 <luzC> +1 openstack-workloads
15:22:50 <topol> gema I was thinking we reuse openstack-interop and if not openstack-interop-workloads
15:23:03 <topol> I kinda liked the interop in the name
15:23:09 <gema> topol: ok
15:23:09 <Rockyg> meeting is right after this one if you wantto get a quick answer
15:23:21 <gema> topol: so I will ask the interop folks in the meeting later today if they are ok with it
15:23:26 <gema> and then I will also check with infra
15:23:29 <gema> to make sure we are legal
15:23:34 <topol> gema, that would be great
15:23:47 <gema> topol: we are already using the mailing from defcore
15:23:48 <tongli> @topol, I do like that in the name as well. so channel openstack-interop as the first option, if no good, we go with openstack-workloads
15:23:49 <tongli> ?
15:24:46 <topol> do we go with openstack-workloads or openstack-interop-workloads
15:24:52 <topol> as the backup
15:24:58 <gema> topol: do we have a grace period, i.e. whilst we figure it out, can we stay here?
15:25:14 <topol> gema, YES we have a grace period
15:25:18 <gema> topol: ok
15:25:36 <topol> Our landlord is a benevolent one. We wont be evicted immediately :-)
15:25:41 <gema> :)
15:26:09 <topol> does anyone hate the backup name ofopenstack-interop-workloads?
15:26:40 <topol> if everyone hates that for being too long openstack-workloads is fine
15:27:30 <topol> gema If no opinions from anyone you get to choose since you are doing the hard work of setting it up
15:27:35 <tongli> @topol, I have no problems with the name, but it is very long.
15:27:54 <gema> topol: the hardest part is talking to people, the rest is easy
15:28:28 <Rockyg> infra folks areawful nice
15:28:34 <tongli> @gema, @topol, go with openstack-workloads, that is what our repo name is.
15:28:47 <gema> tongli: ok
15:28:54 <topol> tongli makes sense
15:29:09 <topol> and tongli now gets the work item... JUS KIDDING
15:29:16 <gema> so the plan is asking openstack-interop if we can use the channel and check with infra if it is ok to hold meetings in a non-meeting channel
15:29:25 <gema> if any of those two is a no, go for our own channel
15:29:29 <topol> gema +++
15:30:00 <luzC> +1
15:30:09 <topol> #action gema ask openstack-interop if we can use the channel and check with infra if it is ok to hold meetings in a non-meeting channel, otherwise go for own channel openstack-workloads
15:30:09 <persia> One advantage to having meetings in meeting channels is that there is a large passive audience, which can be beneficial when one encounters cross-project activities.  -meeting is especially popular, making it one of the preferred venues.
15:30:31 <gema> persia: the problem is timeslots
15:30:37 <persia> yes :(
15:30:37 <Rockyg> also, ttx recently reviewed open slots on meeting channels.  He could give us the open options
15:30:57 <gema> Rockyg: wanna try to get us this slot on one of the meeting channels?
15:31:01 <gema> maybe that should be option 1
15:31:27 <persia> http://git.openstack.org/cgit/openstack-infra/irc-meetings/tree/meetings also has all the meetings, if you want to do your own review
15:31:29 <topol> gema, I belive hogepoge and I did that. I dont think option 1 was possible
15:31:36 <Rockyg> this slot and 1400utc seems *really* popular
15:31:44 <topol> Rockyg +++
15:31:49 <gema> ok
15:31:52 <persia> #openstack-meeting appears empty currently
15:32:18 <topol> persia check the tree just in case. some meetings are every other week
15:32:34 <topol> that's what makes it messy
15:32:41 <tongli> I would like to have meeting in openstack-meeting channel if that is also possible.
15:32:47 <gema> agreed
15:33:04 <topol> who is good at determining options?
15:33:17 <Rockyg> No one's on it.... lemme check calendar
15:33:23 <topol> risk is we move to a time that is horrible for folks at some location in the world
15:33:34 <tongli> @persia,@gema, if a channel is crowded, we can easily get kicked out if we run a bit long.
15:33:49 <topol> need to be careful if we move to a new timeslot
15:33:55 <gema> tongli: of course, if we go for a meeting channel we have to be on time
15:34:04 <Rockyg> yup. openstack-meeting is available now.  It would go an hour later a daylight savings time
15:34:20 <tongli> @topol, @gema, yeah, that is probably a good thing so that we do not run over.
15:34:27 <topol> Rockyg is it avail every week at this time?
15:34:46 <Rockyg> lemme double check that
15:34:55 <topol> I think someone just has to submit a patch to grab the timeslot
15:35:30 <persia> topol: Yes.
15:35:39 <Rockyg> nope.  neutron dvr has it on the other week.
15:35:59 <topol> Rockyg :-(
15:36:10 <Rockyg> But, lemme ask ttx....
15:36:42 <gema> ok, so Rockyg checks the meeting channels see if there is a slot
15:36:46 <Rockyg> I've got a ping out to him
15:36:48 <gema> if not, we continue down the options
15:36:54 <gema> Rockyg: let me know the outcome
15:37:01 <topol> #action Rockyg to ask ttx if we can grab #openstack-meeting at this timeslot
15:37:10 <Rockyg> I'll put the channels available in todays etherpad
15:37:15 <gema> Rockyg: thanks!
15:37:16 <tongli> looks like we are not changing meeting time, right?
15:37:27 <tongli> all the options are to keep the current time?
15:37:39 <gema> yep
15:37:48 <topol> my pref is to not change the meeting time.  Its really hard to get all you folks a timeslot that works cuz we all have day jobs :-)
15:38:00 <gema> agreed
15:38:15 <topol> #agree whatever option we choose we keep the same timeslot
15:38:30 <tongli> ok. Wednesday 1500 UCT,
15:38:32 <topol> Ok, let's see what else is on the agenda
15:38:45 <tongli> when day light saving time changes, we change that as well.
15:38:50 <topol> #topic new repo
15:38:57 <topol> tongli did this merge?
15:39:14 <topol> do we have a new repo?
15:40:10 <tongli> @topol, I think so.
15:40:19 <tongli> the patch was merged.
15:40:19 <garloff> where?
15:40:21 <tongli> thanks to Chris.
15:40:21 <persia> Rockyg: Hrm?  I thought neutron-dvr was in #openstack-meeting-alt
15:40:23 <dmellado> did we get to the new repo structure?
15:41:00 <tongli> https://github.com/openstack/interop-workloads
15:41:10 <Rockyg> persia,  you're right.  massively distributed clouds has it
15:41:10 <garloff> tongli: thx
15:41:11 <tongli> @dmellado, we have not discussed that item yet
15:41:31 <tongli> I put up a structure in last meeting etherpad.
15:41:37 <tongli> we need to confirm that is what we want.
15:41:39 <topol> Yay #link https://github.com/openstack/interop-workloads is our new repo
15:41:57 <topol> yes, #topic repo structure
15:42:19 <Rockyg> and just an fyi, you can link the meetings file to google calendar and it will display properly.
15:42:26 <topol> suggested strawman is found at #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-11-16
15:43:06 <topol> so a suggestion was
15:43:24 <topol> Can't we just create the repo using cookiecutter, just as in http://docs.openstack.org/infra/manual/creators.html#preparing-a-new-git-repository-using-cookiecutter
15:43:24 <topol> and adapt as needed?
15:44:03 <tongli> use the generic tool name at the top, then api tool, second, then OS
15:44:09 <tongli> is it too deep?
15:44:51 <topol> tongli use cloudfoundry as an example
15:44:56 <tongli> or the platform (debian, redhat,) should be part of the scripts, with a lot of checks? I personally do not really like that.
15:44:58 <topol> what would it look like
15:45:43 <topol> Ideally at the top level are workloads,  cloudfoundry,k8s, etc
15:45:46 <Rockyg> yeah, we *don't* want platform.  That's what we are removing from the equation ;-)
15:45:55 <topol> Rockyg +++
15:46:13 <topol> and you go into cloudfoundry and a readme says how to run the workload
15:46:23 <topol> same for K8s
15:46:24 <tongli> should be like this /ansible/shade/cloudfoundry?
15:46:35 <topol> same for NVF app1 NVF app2
15:46:53 <dmellado> one thing that we should totally do straightforward this time
15:46:58 <tongli> if we do OS API, then /ansible/osapi/cloudfoundry?
15:46:59 <dmellado> is the creation of tox and requirements
15:47:18 <dmellado> I wouldn't like what happened last time with the package version mumble around to be repeated
15:47:20 <Rockyg> ++ dmellado
15:47:43 <topol> I was thinking cloudfoundry/ansible  and cloudfoundry/otherautomationtool
15:47:43 <tongli> @dmellado, that will be nice, not necessarily required but we can add which does not affect the structure, right?
15:47:49 <dmellado> that's why I do suggest to adapt directly from the standard openstack project
15:47:51 <topol> is that horrible?
15:48:07 <dmellado> tongli: well, it will be, kinda
15:48:15 <Rockyg> I agree with dmellado
15:48:28 <tongli> @topol, I am thinking if a company runs these work load, most likely they will prefer a tool.
15:48:28 <topol> dmellado can you give an example
15:48:52 <tongli> for example, I will prefer ansible, then I can grab ansible at the top level not care too much about other top directories.
15:48:58 <dmellado> topol: sure, so if you use cookicutter, it'll create a predefined structure
15:48:58 <Rockyg> , but perhaps we could use cookie cutter with a revised template? change some names but keep the structure?
15:49:03 <dmellado> that we can adapt it later
15:49:10 <tongli> if do what you suggested, then I will have to dig a bit deeper, just my experience.
15:49:12 <dmellado> Rockyg: yeah, that was my idea
15:49:35 <topol> what about tongli's idea of having the automation tool at the top level?
15:49:46 <Rockyg> tongli,  just one or two levels at most.
15:50:03 <tongli> @dmellado, why adding tox will change the structure, I do not get that.
15:50:07 <Rockyg> And that's a variable name
15:50:21 <dmellado> tongli: not that it will change the structure
15:50:28 <dmellado> using cookicutter to generate the main template structure
15:50:32 <dmellado> will make easier to use tox
15:51:03 <topol> dmellado do you know how to use cookiecutter?
15:51:04 <dmellado> tongli: http://paste.openstack.org/show/590977/
15:51:06 <dmellado> for example
15:51:11 <dmellado> this will be the default cookicutter template
15:51:20 <dmellado> just using a demo name
15:51:25 <tongli> @dmellado, ok, so you are ok with /<toolname>/<os_client_library_name>/<workloadname>
15:51:36 <tongli> that is a clear pattern,
15:51:41 <tongli> if that helps.
15:51:56 <dmellado> I'd be fine with that, but inside the default openstack project template ;)
15:52:04 <Rockyg> ++
15:52:07 <tongli> <toolname> will be whatever tool we feel good about.
15:52:30 <tongli> <os_client_library_name> , I can think of is shade, and OS Restful API.
15:52:40 <topol> dmellado so the tricky part is what is the structure in interop_workloads correct?
15:53:09 <dmellado> topol: yeah, on that I'm fine with tongli's approach
15:53:15 <Rockyg> maybe oaktree in future or heat or murano
15:53:47 <topol> dmellado your proposal to have the standard strcuture to make tox easy makes sense to me
15:53:59 <tongli> @Rockyg, certainly if we have people wanting to creat heat and murano. then there will be new top level directories.
15:54:32 <topol> tongli you mean top levels under interop_workloads ?
15:55:29 <tongli> @topol, if heat, or murano, it will be like this /heat/cloudfoundry /heat/nfv.
15:55:48 <tongli> I assume heat will always use OS apis.
15:56:13 <tongli> @topol, yes to your question.
15:56:21 <topol> dmellado would /heat be a top level or under the directory interop_worlkoads?
15:56:37 <dmellado> topol: I'd be fine with that
15:56:38 <topol> tongli ok good
15:56:51 <tongli> @topol, @dmellado, should be top level under interop_workloads.
15:57:11 <dmellado> baically we can have whatever internal structure we want, as long as we keep that under interop_workloads
15:57:12 <Rockyg> topol, everything will be under interop_workloads
15:57:12 <dmellado> yeah
15:57:24 <Rockyg> That's the root.
15:57:34 <tongli> so we should have these under interop_workloads /ansible, /terraform, /heat, /murano
15:57:36 <Rockyg> the repo name.
15:57:37 <dmellado> exactly as Rockyg says ;)
15:57:39 <topol> so we are looking at heat, murano, ansible  etc under the root (interop_workloads)
15:57:51 <Rockyg> yup
15:57:56 <topol> I like that
15:57:58 <tongli> and /doc to hold all the documents in rst format
15:58:19 <topol> any concernswith that structure ?
15:58:20 <dmellado> tongli: cookiecutter already provides you with a root doc
15:58:27 <Rockyg> yup.  and doc would use the dic tox rules
15:58:28 <dmellado> as well as releasenotes with reno
15:58:51 * topol always good to stay in the groove when using tools like tox
15:58:57 <tongli> @dmellado, ok, not familiar with cooklecutter thing, we can work together on that if it helps.
15:59:03 <dmellado> tongli: totally
15:59:18 <Rockyg> cookiecutter does all the base installs if we follow the structure
15:59:36 <dmellado> tongli: in any case it's quite straightforward
15:59:38 <topol> #action dmellado,tongli use cookie cutter to create agreed to structure
15:59:48 <dmellado> think of it as a openstack project template system
15:59:51 <dmellado> http://docs.openstack.org/infra/manual/creators.html#preparing-a-new-git-repository-using-cookiecutter
15:59:53 <tongli> @Rockyg, it just a tool to create an initial project?
15:59:59 <dmellado> tongli: it is
16:00:03 <topol> #agree have these under interop_workloads /ansible, /terraform, /heat, /murano
16:00:16 <Rockyg> yup.  and populate the top level
16:00:19 <tongli> @dmellado, ok, I will take a look.
16:00:37 <topol> I think we are out of time. But made great progress here
16:00:38 <dmellado> tongli: in any case totally up for preparing that together
16:00:43 <tongli> a patch to setup the structure will be submitted soon.
16:00:51 <Rockyg> dmellado, posted the doc link for it earlier
16:01:03 <topol> dmellado,tongli  thanks for the helpful suggestions here
16:01:04 * markvoelker notes that we're out of time and the defcore meeting is starting over on #openstack-meeting-3
16:01:06 <tongli> @Rockyg, I will dig. thanks.
16:01:12 <topol> #endmeeting