15:01:16 <topol> #startmeeting interop_challenge
15:01:16 <openstack> Meeting started Wed Dec  7 15:01:16 2016 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:18 <tongli> o/
15:01:20 <openstack> The meeting name has been set to 'interop_challenge'
15:01:27 <Rockyg> o/
15:01:27 <MarkBaker> o/
15:01:33 <skazi_> o/
15:01:33 <topol> Hi everyone, who is here for the interop challenge meeting today?
15:01:33 <topol> The agenda for today can be found at:
15:01:33 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-12-07
15:01:35 <topol> We can use this same etherpad to take notes
15:02:00 <zhipengh> o/
15:02:18 <topol> #topic review action items from previous meeting
15:02:35 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-11-30-15.00.html
15:02:51 <luzC> o/
15:02:51 <topol> all, please use #link https://etherpad.openstack.org/p/interop-challenge-postmortem for lessons learned doc and add content
15:03:03 <topol> So did anyone add some content here?
15:03:30 <topol> I know its hard to find time to do this but please do your best.
15:03:36 * markvoelker added some a while bc
15:03:42 <markvoelker> *back
15:03:45 <topol> cool
15:03:59 <Rockyg> Do you feel like an old school marm, topol?
15:04:19 <topol> I'll give it until next meeting and we can then all look at it together :-)
15:04:35 <topol> Rockyg I taught a class or two way back when...
15:04:40 <Rockyg> Chiding the recalcitrant children ;-)
15:04:55 <topol> dinosaurs roamed the earth
15:04:55 <Rockyg> Oh, I can imagine it...
15:05:31 <topol> So hopefully everyone saw we got our repo! YAY!
15:05:36 <topol> which brings us to
15:05:38 <topol> tongli to migrate doc to repo when ready
15:05:45 <tongli> should we reformat that etherpad into a lessonslearned.rst in our repo?
15:06:07 <topol> Im taking tongli to a fancy lunch today so no guilt on harassing him on todos!
15:06:12 <tongli> our repo is ready and ansible and terraform scripts all have been migrated over.
15:06:20 <topol> tongli I think so!
15:06:24 <markvoelker> seems like we have enough content to make a start
15:06:33 <tongli> we have a doc directory where I think we should start using the folder for docs like this.
15:06:49 <tongli> @markvoelker, @topol. cool.
15:06:59 <tongli> I will take a first stab and put up a patch set.
15:07:10 <tongli> for the doc, then we can review and add more stuff over the time.
15:07:17 <topol> Ok, so folks let's not add any more content to the etherpad version. Let's let tongli push a patch with an rst
15:08:01 <topol> #action tongli to push the our postmortem doc as a patch to the new repo!
15:08:05 <gema> o/
15:08:14 * gema is at a sprint, sorry for the delay
15:08:26 <topol> tongli hopefully you are finding reviews are getting done quicker.
15:08:38 <tongli> totally, day and night.
15:08:46 <Rockyg> yay!
15:08:48 <tongli> thanks to all the reviewers.
15:08:57 <Rockyg> That's the  important part
15:09:24 <topol> BTW,  are we using standard OpenStack core reviewer rules?  need two reviews from other than the author to +2 before someone can +A
15:09:49 <topol> and not all reviewers from the same company as the author
15:09:54 <topol> everyone okay with those?
15:10:06 <markvoelker> sure
15:10:09 <luzC> yes
15:10:10 <tongli> @topol, we should. yes.
15:10:18 <Rockyg> yup
15:10:44 <topol> #agree Standard OpenStack core reviewing guidelines are in effect for the new interop repo
15:10:57 <topol> next item
15:11:08 <topol> markvoelker to review user survey to look for more possible work items to add to doodle poll
15:11:17 <topol> markvoelker any luck?
15:11:27 <markvoelker> Yeah, I took a look around.
15:11:34 <topol> any gold nuggets?
15:11:35 <markvoelker> We already had some container and NFV stuff on our list
15:11:42 <topol> K
15:11:44 <markvoelker> Other than that, some other areas of interest included:
15:12:05 <markvoelker> bare metal (probably not a good candidate on account of how few clouds support it)
15:12:22 <topol> good point :-)
15:12:45 <markvoelker> hybrid cloud (this is something we might be able to showcase partly through tooling...e.g. can part of a workload run on OpenStack and part on something else, or parts on two different openstack clouds, etc)
15:12:54 <tongli> @markvoelker, I would love to try some of bare metal, bringing ironic in the picture.
15:12:58 <markvoelker> PaaS (we mentioned CloudFoundry already)
15:13:28 <markvoelker> IoT (this could be done mostly as "the app that rides on top of OS"...e.g. maybe we spin up a ZettaJS service or something)
15:13:34 <tongli> yeah, I like that as well. all openstack clouds or openstack and microsoft or aws?
15:13:39 <topol> tongli you could try bare metal as an incubator to investigate
15:13:42 <markvoelker> And finally hardware accelerators, whcih again may not be a real good candidate
15:13:58 <Rockyg> federation....but usually that's not a tenant cloud-tenant cloud thing
15:14:10 <Rockyg> i.e. multicloud
15:14:16 <tongli> among these 3, I think hybrid sounds sexy.
15:14:29 <topol> sounds like a lot of stuff we could add to the doodle poll
15:14:34 <tongli> ok, multicloud == hybrid?
15:15:10 <markvoelker> I'd probably say hybrid and IoT are viable options for the doodle poll.  We'd probably want to flesh them out a bit though, particularly hybrid.
15:15:30 <Rockyg> kinda.  but openstack to openstack other vendor
15:16:17 <Rockyg> and usually geo location spaced
15:17:25 <tongli> not sure if OS + AWS (or Microsoft) is an option.
15:17:25 <zhipengh> IoT is a little bit too broad
15:17:54 <topol> we need to have some we for sure can complete during the upcoming cycle
15:17:57 <tongli> @zhipengh, right. need a bit more specific.
15:18:12 <MarkBaker> tongli using Juju we can deploy to OS + AWS
15:18:20 <tongli> and it needs to be attractive as well.
15:18:54 <Rockyg> that would be cool.
15:19:21 <zhipengh> i think play with oak-tree and tricircle for multi-cloud, could be attractive :P
15:19:48 <topol> My guess is we should have one that we all start with first that is pretty solid. and at the same time have others as incubators where individual folks could investigate those
15:19:55 <topol> does that make sense?
15:20:11 <Rockyg> that too ;-)  but oaktree is just starting, so not sure this cycle would work for that.
15:20:45 <topol> So if someone is excited about IOT or bare metal I dont want to stop them even they might take some time to bake
15:21:20 <topol> or oak-tree for that matter
15:21:31 <tongli> yeah, get it done in two cycles if need more time.
15:21:48 <Rockyg> ++
15:22:28 <tongli> oak-tree is based on shade.
15:22:32 <topol> so even if the doodle poll doesnt come back with your favorite feel free to do it as an incubator. I think we need to start with one that we feel we can all do
15:22:42 <tongli> if we do not like shade, why should we like oak-tree?
15:22:56 <topol> I like shade :-)
15:22:59 <tongli> I thought someone has asked to fall back to OS Rest APIs.
15:23:21 <tongli> @topol, I know, just saying that there are people seem really dislike shade.
15:23:36 <tongli> if oak-tree is built on top of shade, would it be even worse?
15:23:43 <topol> I think shade is covering up some uglies that people wish were fixed
15:24:07 <topol> oak-tree just is like shae but allows you to bind to multiple languages besides python
15:24:14 <tongli> @topol, I am just very skeptical about oak-tree. that is what I am trying to say.
15:24:25 <Rockyg> ++  arch wg is going to try to shine some light on that.  anyone interested, come and join the fun
15:24:46 <topol> tongli, its like everything else.  feel free to doubt until the code talks :-)
15:24:56 <tongli> haha, yeah.
15:25:05 <topol> I would view it as an incubator option
15:25:24 <tongli> ok, we got a quite big candidates pool now, I think.
15:25:37 <topol> so let's review the candidate pool.
15:26:10 <tongli> 1. Cloud Foundry
15:26:11 <topol> Cloud Foundry, Kube, NFV, IOT, Bare Metal,
15:26:15 <tongli> 2. NFV
15:26:22 <tongli> oh, ok.
15:26:27 <topol> keep going tongli
15:26:31 <topol> your way better
15:26:38 <tongli> hybrid/multi-cloud
15:26:46 <tongli> ok.
15:26:51 <tongli> 1. Cloud Foundry
15:26:54 <tongli> 2. NFV
15:27:04 <tongli> 3. Kubernetes
15:27:07 <Rockyg> need #info
15:27:14 <tongli> 4. Hybrid/multi-cloud
15:27:21 <tongli> 5. IOT
15:27:37 <tongli> 6. Bare Metal (or this should be a small piece of a larger workload)
15:27:47 <topol> tongli I think you are being asked to put #info before each option
15:28:16 <tongli> specifics of each?
15:28:28 <Rockyg> ++ but I think this is liely good enough to start
15:29:24 <tongli> trying to give a list to @markvoelker for his doodle pool.
15:29:59 <topol> so my question for things like IoT and Bare Metal, how close are we to having automated workloads
15:30:29 <tongli> @topol, not close in my view.
15:30:54 <topol> Ideally we pick something where we think we can get to having automated scripts for everyone to try in a few weeks
15:30:59 <Rockyg> agreed
15:31:14 <topol> otherwise the options should be placed in incubator
15:31:21 <skazi_> are we talking about real baremetal here or some simulated stuff (e.g. pxe-ssh)?
15:31:47 <topol> skazi_ good question
15:31:56 <topol> I dont even know
15:32:02 <markvoelker> IMO baremetal is going to rule out a lot of clouds that don't run ironic.  But I'll let my voting in the doodle poll reflect that opinion. =)
15:32:26 <tongli> @markvoelker, yes. let the pool decide.
15:32:35 <skazi_> mixing baremetal and VMs in one cloud is a tricky subject itself
15:32:56 <topol> yes but if the poll picks something have the clouds cant support we are dead on arrival
15:33:05 <topol> err half the clouds
15:33:41 <tongli> so what the goal should be?
15:33:49 <topol> poll is good for seeing what is most popular, but there maybe pragmatics we have to deal with
15:34:10 <topol> goal should be a workload we think at least has a chance of running on all the clouds
15:34:31 <skazi_> tongli: what happened to the dockerswarm? is this still on the table?
15:34:52 <tongli> @skazi_, great question.
15:34:59 <tongli> should we expand on that?
15:35:00 <topol> if we pick something we know immediately cannot run on half the workloads that does not seem intersting
15:35:19 <tongli> let's add dockerswarm back to the list, @markvoelker,
15:35:28 <topol> agreed. good point
15:36:21 <topol> my guess is bare metal perhaps should be incubator if it simply cant run on several clouds. It's like how we chose not to do Heat in the first round
15:36:43 <tongli> @topol, agreed.
15:36:52 <topol> Besides bare metal are there any that also seem like they could not be done by everyone?
15:37:09 <markvoelker> Just from memory: as of the April user survey less than a quarter of respondants were running ironic, and less than 10% in production.
15:37:18 <markvoelker> Hardware accelerators might also be problematic
15:37:42 <topol> Lets keep bare metal and hardware accelerators off the doodle poll
15:37:55 <topol> Make sense?
15:38:10 <Rockyg> ++
15:38:28 <topol> feel free to individually play around on those as incubators.
15:38:33 <topol> for those interested
15:39:20 <topol> for the rest of the the items is there any a particular person feels could theoretically be done on their cloud?
15:39:35 <topol> err could not be done on their cloud
15:40:10 <skazi_> maybe we could combine couple of those options? e.g. kubernetes based pool of "simulated" IoT devices (agents) reporting some stats to central database cluster (InfluxDB+grafana)?
15:40:40 <topol> skazi_ that may be possible
15:40:56 <topol> depends how good our skills are
15:41:48 <skazi_> topol: as always :)
15:41:57 <Rockyg> oooh, we could do a ddos from hacked iot devices....
15:42:00 <topol> How about we go ahead with the doodle poll and see what shakes out from that and then evaluate as  a group
15:42:07 <markvoelker> yeah, I don't think these are all mutually exclusive.  I think the poll just tells us primary focus areas vs secondary.
15:42:22 <skazi_> Rockyg: +1 :)
15:42:23 <tongli> we need to make a decision before Christmas.
15:42:24 <topol> also who will the poll be open to?
15:42:46 <tongli> if we continue discussion, we may not be able to complete a nice workload for next summit.
15:42:52 <topol> anyone in the community? Just us?
15:43:26 <topol> tongli I agree we should get the poll out, and quickly after evaluate and make a decision
15:43:33 <markvoelker> It's a nonbinding poll, so I was just figuring we'd send it to the ML per the norm
15:43:45 <topol> markvoelker. that works
15:43:46 <tongli> @markvoelker, that is right. pick a direction, and pieces here and there to make it useful and nice.
15:44:20 <tongli> one can vote multiple times?
15:44:24 <topol> so who wants to create the poll?  Is that on tong and brad after we goto cheesecake factory today?
15:44:25 <tongli> if that is the case, it is not good.
15:44:40 <topol> tongli honor system?
15:44:49 <tongli> sure.
15:44:56 <topol> do we need a concord poll?
15:45:27 <topol> markvoelker what do folks typically use for these things?
15:45:30 <topol> doodle?
15:46:00 <markvoelker> doodle usually works fine.  I don't expect it to be complicted.  If you guys are going to be in a food coma I can take care of it this afternoon. =p
15:46:14 <Rockyg> Nah.  doodle good enough.  But, need to advertise on multiple mls
15:46:26 <topol> Ha Ha. markvoelker. sure. its all yours
15:47:17 <tongli> @markvoelker, please.
15:47:18 <topol> #action markvoelker to create doodle poll and post to ML.
15:47:34 <topol> THANKS markvoelker
15:47:40 <topol> k, next item
15:48:06 <tongli> meeting channels?
15:48:11 <Rockyg> Yeah.
15:48:11 <topol> gema ask openstack-interop if we can use the channel and check with infra if it is ok to hold meetings in a non-meeting channel, otherwise go for own channel openstack-workloads
15:48:11 <topol> Rockyg to ask ttx if we can grab #openstack-meeting at this timeslot
15:48:33 <topol> gema had a crit sit to go work but said she briefed some of you
15:48:34 <Rockyg> So, #openstack meeting is only available every other week.
15:48:52 * markvoelker notes that there is currently a thread going about creating a new meeting channel
15:49:07 <Rockyg> In fact, our ask got a mail thread going about another meeting channel or meeting in group channels
15:49:10 <topol> should we try and wait and grab this slot on the new channel?
15:49:35 <markvoelker> #info thread proposing to create #openstack-meeting-5 http://lists.openstack.org/pipermail/openstack-dev/2016-December/108604.html
15:49:45 <Rockyg> The one issur *we* have is that we shift times twice yearly for DST
15:49:54 <topol> I think we can squat in meeting-cp a little longer as long as we afent permanent
15:49:59 <Rockyg> everyone else keeps the utc time
15:49:59 <topol> arent permanent
15:50:14 <Rockyg> agree with that, too.
15:50:33 <tongli> hmmm, so should we stick to utc time?
15:50:38 <topol> Rockyg yeah that happens to me with the keystone meeting. for us with DST thats just life
15:50:40 <Rockyg> we should consider squatting on a single time all year long, too.
15:51:09 <Rockyg> we got offered 1600 utc, I think.
15:51:23 <tongli> on openstack-meeting?
15:51:26 <Rockyg> And there is time at 1200 utc, just not current time
15:51:44 <topol> Rockyg is that one hour later - 1600 utc?
15:51:46 <tongli> if we can grab that time for utc1600 every week, I would call to change our time.
15:51:52 <Rockyg> Uh, not sure which room, but ironic freed up a time slot
15:52:06 <Rockyg> lemme double check....
15:52:21 <tongli> utc1600 is 11:00am our time now, 10:00am DST.
15:52:23 <topol> can everyone meet at 1600 utc?
15:52:24 <tongli> I think.
15:52:32 <topol> I can make that work
15:52:44 <markvoelker> 1600UTC is the defcore committee timeslot, so if we keep it on wednesdays I'll be out
15:52:55 <topol> then its no good !
15:53:00 <topol> we need markvoelker
15:53:24 <tongli> who else will be doing the pool. no way.
15:53:41 <topol> exactly tongli. we know where our doodle poll bread is buttered
15:53:41 <Rockyg> no, it was later in the day....
15:53:54 <markvoelker> Kinda feels like the meeting channel discussion is close to being resolved...maybe we just table this discussion for one more week and see if our current time becomes available on a new channel?
15:54:08 <topol> markvoelker that sounds good
15:54:20 <tongli> @Rockyg, it should be 11:00am. ours is current UTC1500.
15:54:41 <topol> let's wait and see what happens with the new meeting channel
15:54:44 <tongli> which 10:00am EDT.
15:54:57 <tongli> I would think utc1600 is 11:00am EDT.
15:55:08 <topol> 2 more quick items
15:55:11 * markvoelker glances at the clock and notes that (speaking of the defcore/interopWG meeting) it starts in 5 minutes...
15:55:13 <Rockyg> it mighta been 1800...
15:55:38 <topol> im gonna move quick folks
15:55:39 <tongli> k. as long as we can use this channel, I am ok.
15:55:45 <topol> #item PTG meeting
15:55:57 <topol> are folks going? Tong Li and I will be going
15:56:05 * markvoelker is planning to attend
15:56:07 <Rockyg> but, yeah.  I'll post the actual options.  I think we could get 1400 now, but that's 6am out here
15:56:11 <topol> do we need to ask  for our own space there
15:56:18 <topol> ?
15:56:35 <markvoelker> topol: PTG space is mostly reserved for big tent teams, so it may be difficult to get space there.
15:56:38 <Rockyg> Yeha, I'll be there.
15:56:41 <topol> how much time at PTG do you all want to spend on interop?
15:57:05 <topol> hopefully they have some flex space
15:57:07 <Rockyg> we can always meet at a coffee shop, or better, over beers
15:57:11 <topol> I can ask ttx
15:57:40 <topol> so let's plan on meeting a little there
15:57:48 <tongli> big thanks to Christopher for setting up the new repo.
15:58:00 <topol> but folks can still focous on their primary areas
15:58:04 <Rockyg> yay aedo!
15:58:09 <topol> #item new repo is up
15:58:17 <topol> Thanks caedo
15:58:29 <tongli> ansible and terraform workloads are all moved already.
15:58:30 <topol> new repo structure is in
15:58:36 <topol> thanks tongli
15:58:40 <tongli> now need a bit discussion on tox.
15:58:44 <tongli> which is enabled.
15:58:51 <tongli> but we can talk about that next time.
15:58:51 <topol> we only have 1 minute
15:58:55 <topol> k
15:58:57 <topol> perfect
15:59:16 <topol> #action topol ask ttx about flex space
15:59:28 <topol> #endmeeting