14:00:31 <topol> #startmeeting interop_challenge
14:00:32 <openstack> Meeting started Wed Jan  4 14:00:31 2017 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:37 <openstack> The meeting name has been set to 'interop_challenge'
14:00:40 <tongli> o/
14:00:43 <skazi> o/
14:00:47 <topol> Hi everyone, who is here for the interop challenge meeting today?
14:00:47 <topol> The agenda for today can be found at:
14:00:47 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-04
14:00:48 <markvoelker> o/
14:00:49 <topol> We can use this same etherpad to take notes
14:01:04 <garloff> Happy new year everyone!
14:01:26 <topol> first topic:
14:01:36 <topol> #topic Welcome everyone to our 2017 Kickoff
14:01:46 <topol> WELCOME and Happy New Year!!!
14:02:11 <topol> next topic
14:02:22 <tongli> thanks Brad
14:02:26 <topol> #topic Refresh everyone on the decisions we made in December
14:02:42 <topol> AGREED: Kubernetes and NFV will be our top priority workloads for this round of the interop challenge
14:02:53 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-12-14-14.00.html
14:03:38 <topol> So that's gets us all refreshed
14:03:52 <topol> #topic Review last meeting action items
14:03:52 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-12-14-14.00.html
14:04:14 <topol> eeiden to push up the NFV workload to new repo as soon as possible
14:04:28 <topol> Is eeiden here? Has this been done?
14:04:47 <topol> I don't recall seeing any patches on this
14:04:56 <tongli> @topol, I did not see any patches.
14:05:21 <topol> K.  We'll keep that action goin then
14:05:37 <topol> #action eeiden to push up the NFV workload to new repo as soon as possible
14:05:49 <topol> next action.
14:06:04 <topol> tongli to start on kubernetes
14:06:17 <topol> tongli, how is that going?
14:06:24 <tongli> @topol, yes, already started working on that.
14:06:51 <topol> Willing to share some details? Enquiring minds want to know
14:07:28 <topol> When might you have a patch for folks to review?
14:07:51 <tongli> probably in two weeks.
14:08:02 <topol> tongli, excellent!
14:08:08 <topol> Keep going!
14:08:10 <tongli> then we can add more things if it is too basic.
14:08:18 <topol> Very cool
14:09:04 <topol> next action
14:09:07 <topol> tongli to create lauchpad for our repo
14:09:27 <topol> Looks lije hogepodge did this correct?
14:09:49 <hogepodge> maybe docado?
14:09:55 <tongli> @topol, that is for bug tracking, right?
14:10:02 <topol> tongli yes
14:10:11 <tongli> if it is, then it is there already, and I have created a bug.
14:10:12 <topol> here is the link #link https://bugs.launchpad.net/interop-workloads
14:10:22 <tongli> right.
14:10:25 <topol> wasnt you hogepodge?
14:10:32 <topol> it was docado?
14:10:39 <tongli> it is all working, Chris created that for us. Thanks Chris.
14:10:39 <topol> THANKS docado!!!
14:10:58 <hogepodge> topol: yes, docadeo did it
14:11:24 <topol> docado gets a Gold Star!
14:11:50 <tongli> @topol, yes,
14:11:55 <topol> looks like we even have a bug posted
14:12:38 <topol> tongli looks like you triaged it
14:12:54 <topol> tongli were you going to try and fix it
14:12:59 <tongli> yes, I have been trying that for awhile.
14:13:07 <tongli> withno success.
14:13:12 <topol> #link https://bugs.launchpad.net/interop-workloads/+bug/1649949
14:13:13 <openstack> Launchpad bug 1649949 in Interop Challenge Workloads "wordprocess failed to run wp core install" [Undecided,New]
14:13:22 <tongli> something went in actually break the lampstack workloads.
14:13:32 <tongli> I can not successfully run it any more.
14:14:14 <topol> so we get a new version of wordpress and that one no longer installs?
14:14:14 <tongli> I went all the way back (probably 10 patches back), it worked for ubuntu env.
14:14:35 <tongli> I think that the patches added to support fedora maybe the problem.
14:14:53 <tongli> but I can not be sure, spend quite few days on this already.
14:15:30 <topol> tongli is there someone you think can help us to debug this?
14:16:31 <tongli> @topol, anyone from the last summit can actually help.
14:16:50 <tongli> thinking who added the fedora support probably can fix it.
14:17:51 <topol> So this was a patch on the old repo? can we do a git blame check and see who added it?
14:17:55 <garloff> would be good indeed if the "old" workload stays in a working state ...
14:18:04 <tongli> sure.
14:18:07 <topol> garloff +++
14:18:19 <topol> Thats putting it mildly
14:18:23 <topol> :-)
14:18:37 <tongli> I think we need to fix the old workloads.
14:18:50 <tongli> it bothers me a lot having the latest stuff not working.
14:19:05 <topol> tongli yes we most certainly do.  Let's see if we can track down who added it
14:19:28 <topol> #action tongli, topol to track down who added the fedora patch
14:19:43 <topol> #action all please help trying to get wordpress back working
14:20:26 <topol> Next item:
14:20:28 <topol> all review and add stuff to the lessons learned doc
14:20:56 <tongli> is there a way for us to find a ftp/http repository so that we can put something there such as the superuser theme, content.
14:21:10 <tongli> just so that these content can be used by workloads.
14:21:38 <topol> tongli Im not sure I understand your question
14:21:51 <tongli> rely on some external site is sometimes difficult, when the content changes, the workloads may break.
14:22:23 <tongli> currently our workload download stuff such as wordpress code, theme, and content from external sites
14:23:16 <tongli> for example, we get the latest wordpress from wordpress site, however, when they release new ones, the new release of wordpress may no longer work in our workloads.
14:23:33 <tongli> due to changed deployment methods or changed format.
14:23:45 <topol> so we could do that, but then we live in our own insulated bubble
14:24:15 <tongli> using the latest wordpress release, we can no longer import the example content because of the format change.
14:24:29 <tongli> true, I do not know what is the best way.
14:24:51 <topol> let's see how often wordpress continues to break us
14:25:08 <tongli> I found that one of the problems contributing to the current workload breakage is the wordpress content format change.
14:25:09 <topol> ideally, they dont break us too often and we stay up to date
14:25:10 <hogepodge> If this is meant to be a test environment, pinning to known working releases makes sense, since we're not testing wordpress, we're testing OpenStack
14:25:29 <tongli> @hogepodge, exactly.
14:25:47 <hogepodge> Or, just accept that if external dependencies break you fail and test for them (which is more of the 'OpenStack way')
14:25:54 <tongli> different wordpress release requires different way of deploy it,
14:26:06 <tongli> and the content could be different as well.
14:26:37 <tongli> the current sample wordpress content was downloaded from another site , which has to be modified slightly to import to new wordpress release.
14:26:55 <topol> hogepodge, that is true.   But not working on them over the long haul results in us convincing oursleves that "this is fine"  but for real world folks we dont work
14:27:09 <tongli> I was thinking if we can have  a ftp or http repository just to save some of these static content (do not want to put these in git hub)
14:27:23 <tongli> that probably can help. But I am open for other good ideas.
14:27:59 <hogepodge> It all depends on the model of updates you want to have. Fix on fail means you're up to date, but have unexpected outages.
14:28:14 <hogepodge> Fix on schedule means you can fall behind, especially if you don't honor the schedule.
14:28:18 <tongli> @hogepodge, yes.
14:28:25 <topol> my fear is that if we can't show workloads running with the latest wordpress and others run into that we have done them a disservice
14:29:10 <tongli> @topol, even with that, we still need to have a repo for content like openstack superuser award site.
14:29:20 <topol> Since were not in "important demo mode next week"  my gut says seeing failures and fixing them is most valuable
14:29:38 <tongli> I suspect for kubernetes and nfv we will need something as well.
14:29:51 <skazi> for wordpress itself, we can pin the version by downloading from: https://wordpress.org/download/release-archive/ instead of the latest tarball
14:29:57 <hogepodge> for context, I've spoken a bit with some of the kubernetes folks about testing on OpenStack. They do not want to test using OpenStack master, and will only accept a stable release
14:30:02 <topol> tongli, why cant we use our own repo to store anyting you want static?
14:30:18 <tongli> @skazi, yes, we can do that for the wordpress itself, but not for the content.
14:30:58 <skazi> tongli: true :o|
14:31:13 <tongli> @topol, I was thinking about that but do we want to store these tars , zips in the code stream?
14:31:41 <topol> tongli if we put them in a separate folder I think its fine
14:31:56 <topol> and then they get reviewed and controlled like everything else
14:32:08 <tongli> is everyone ok with that?
14:32:22 <tongli> I do not mind doing that.
14:32:34 <zhipengh> sounds great
14:32:37 <tongli> do we have an agreement?
14:32:43 <topol> Let's try it
14:32:58 <tongli> ok. sounds good to me.
14:33:09 <tongli> this helps , folks, thanks.
14:33:11 <topol> any concerns? actually folks can voice concerns when they see your patch
14:33:24 <tongli> sure, sure
14:33:59 <skazi> are there any size limitations on those repos?
14:34:30 <tongli> @skazi, good question. I do not really know. let me do a search.
14:35:05 <topol> K, let's see what happens.  I see the benefits both ways.  Pinning the wordpress version gives us stability.  Eventually somone might complain we arent working with latest wordpress
14:35:27 <tongli> 1 GB per repo.
14:35:35 <tongli> 100 MB per file.
14:35:44 <tongli> that is the strict limit.
14:35:54 <topol> so hopefully are zips and tars are under these limits?
14:35:59 <tongli> any file bigger than that will be rejected.
14:36:01 <topol> err our zips and tar
14:36:19 <hogepodge> topol: mu suggestion would be to just schedule mainteance to bring it up to date, but I know some would throw things at me for that suggestion
14:36:36 <topol> hogepodge I like that idea
14:37:22 <topol> tongli markvoelker, thoughts?
14:37:48 <topol> you want to try pinning the old wordpress for now?
14:38:18 <tongli> well, we do want to specify a release for sure.
14:38:29 <markvoelker> Seems like it would be relatively easy to provide option to try the latest wordpress or use a local copy.  Best of both worlds?
14:38:32 <tongli> blindly using the latest release will be an issue regardless.
14:38:50 <markvoelker> E.g. maybe have a variable for the tarball location which can be a url or file:/// ?
14:38:53 <topol> markvoelker, good point
14:39:06 <skazi> tongli: with such limits I would suggest to pin as much as possible from external resources and keep only our/modified content on the repo
14:39:07 <tongli> we already have the option (in configuration file) for you to select a release (where to get the wordpress).
14:39:18 <tongli> but the code to deploy them is the same.
14:39:45 <tongli> @skazi, we can try that.
14:40:06 <topol> skazi that plan sounds good to me as well
14:40:13 <tongli> smaller file can go in to the git hub repo, bigger file, other means.
14:40:50 <topol> Ok, let's try that
14:41:24 <topol> tongli with that approach will we be able to get wordpress bck runing soon?
14:41:47 <tongli> @topol, I hope so,
14:42:03 <topol> Ok, lets hope for the best
14:42:11 <tongli> it is just the time. I really really want to spend some time fixing the existing workload first.
14:42:17 <tongli> then dive into the kubernetes.
14:42:22 <topol> tongli, thats fine
14:42:26 <tongli> priority thing.
14:42:29 <topol> go ahead
14:42:37 <topol> your priority makes sense to me
14:43:09 <topol> most folks arent back to work for another week anyway :-0
14:43:23 <topol> next item:
14:43:34 <topol> topol create a short blog article to update everyone on the status of the interopchallenge
14:43:41 <topol> I will get this done this week :-)
14:44:09 <topol> Will include some pictures I took of everyone at the summit
14:44:42 <topol> #topic open discussion
14:44:57 <topol> anything else we need to discuss?
14:45:24 <tongli> @topol, couple of things.
14:45:29 <topol> go ahead tongli
14:45:38 <tongli> there is a comment to the lesson's learnt patch.
14:45:49 <tongli> I copied the comment to the etherpad,
14:45:49 <zhipengh> o/ that was me
14:45:55 <tongli> please take a look.
14:46:18 <tongli> @zhipengh, please let everybody know what you mean. I am not sure I can address your comment.
14:46:57 <zhipengh> okey. I do like the current content of the lesson leanrt doc, however it might just be too techy for some users
14:47:14 <zhipengh> therefore what I suggested is to have an overview section
14:47:35 <zhipengh> describe in a broad stroke that what interop chanllege has found/fixed
14:47:48 <zhipengh> then go into the details like what we have now
14:48:21 <topol> zhipengh Having an overview section makes sense to me.  Will you push a patch with a first draft?
14:48:39 <zhipengh> sure no problem :)
14:48:45 <tongli> @zhipengh, I would like to have the current patch in, then you can change based on this.
14:48:56 <zhipengh> tongli okey
14:48:58 <tongli> otherwise, it will be just sitting there. which is what happened.
14:49:01 <topol> zhipeng, cool
14:49:19 <topol> tongli does your patch need some +2's?
14:49:27 <topol> tongli got a review link?
14:49:36 <tongli> in the etherpad.
14:49:44 <tongli> @topol, yes.
14:50:18 <tongli> https://review.openstack.org/#/c/409847/
14:50:22 <topol> Folks it s #link https://review.openstack.org/#/c/409847/
14:50:25 <tongli> sorry, I lied, it was not in the etherpad.
14:50:43 <topol> Im gonna +2 it even though tongli lied and made me check the etherpad
14:51:08 <tongli> @topol, most forgiven leader I ever had.
14:51:14 <tongli> @topol, thanks.
14:53:06 <topol> anyone else able to +2 and +A and then zhipeng can add to the merged patch?
14:53:16 <topol> tongli :-)
14:53:42 <tongli> Mark can, luzC can, zhipengh can
14:54:02 * markvoelker is looking again as I haven't read it since before the holiday break...stand by
14:54:45 <topol> we can keep adding patches that revise it.
14:54:52 <tongli> @markvoelker, please take a look again.
14:55:12 <tongli> @topol, yes, that is the point of having the github so that we can always update it.
14:55:13 <markvoelker> done
14:55:23 <topol> cool! Thanks
14:55:51 <tongli> thanks guys.
14:56:14 <topol> #action zhipengh to add overview section to lessons learned doc
14:56:21 <topol> 4 mins left. anything else?
14:56:40 <zhipengh> will we have ptg sessions ?
14:57:24 <topol> zhipengh, we definitely should. Do we want informal sessions or do we want to lock in a time
14:57:45 <topol> I believe there will be plenty of rooms/space for us to meet
14:58:16 <zhipengh> is it required to book a room through Thiery ?
14:58:57 <topol> I asked him and he told me we could wither use some of the refstack room or their would be informal meeting space as well
14:59:17 <zhipengh> cool
14:59:28 <topol> I logged his response in one of our last meetings
14:59:34 <topol> so space is covered.
14:59:53 <topol> its more how much time folks want to carve out and use for interop? A day?
15:00:24 <topol> lets discuss this at next weeks meeting
15:00:33 <tongli> half day maybe enough.
15:00:41 <topol> #action all discuss PTG time allotment
15:00:46 <topol> THANKS EVRYONE
15:00:49 <zhipengh> agree tongli
15:00:49 <topol> #endmeeting