14:01:29 <topol> #startmeeting interop_challenge
14:01:30 <openstack> Meeting started Wed Jan 11 14:01:29 2017 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:35 <openstack> The meeting name has been set to 'interop_challenge'
14:01:38 <markvoelker> o/
14:01:38 <zhipeng> #info zhipeng
14:01:45 <topol> Hi everyone, who is here for the interop challenge meeting today?
14:01:45 <topol> The agenda for today can be found at:
14:01:45 <topol> # https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-11
14:01:47 <topol> We can use this same etherpad to take notes
14:02:04 <tongli> o/
14:02:20 <topol> #topic Review last meeting action items
14:02:34 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-01-04-14.00.html
14:02:49 <topol> eeiden to push up the NFV workload to new repo as soon as possible
14:03:11 <topol> Is eeiden here? Any progress on this?
14:03:28 <skazi_> o/
14:03:58 <tongli> @topol, I think eeiden put a link somewhere, but it is not the patch to our repo.
14:04:34 <topol> tongli will eeiden push a patch soon?
14:04:51 <topol> tongli can you follow up with eeiden?
14:04:55 <tongli> @topol, I hope so. but I have not seen any.
14:04:59 <topol> K
14:05:10 <tongli> @topol, I can ask
14:05:26 <topol> #action tongli to check on eeiden about NVF workload
14:05:48 <topol> next item
14:05:49 <topol> tongli, topol to track down who added the fedora patch
14:06:06 <topol> I didnt do anything on this. tongli any progress?
14:06:09 <tongli> @topol, I fixed these problems.
14:06:24 <tongli> remember the big patch that was merged last week?
14:06:31 <topol> tongli very nice!
14:06:44 <tongli> these problems are now fixed and we also support ubuntu 16.04 and 16.10
14:07:03 <tongli> I have started working on the k8s workload.
14:07:22 <topol> tongli THATS GREAT!  Thank you very much for that.  Did you mark the bug closed?
14:07:34 <tongli> provisioning and destroy roles are pretty much copied from lampstack code (of course some changes).
14:07:49 <tongli> started looking into k8s master and worker node setups.
14:07:54 <tongli> should have something soon.
14:08:37 <tongli> @topol, the bug, I thought when the patch merges, the bug gets closed automatically. let me check though.
14:08:45 <topol> great.  #action tongli leading an effort to complete the k8s workload
14:09:08 <topol> tongli I think you are correct... If we have everything configured correctly
14:09:16 <tongli> @topol, wow, I was right, these two bugs were closed automatically.
14:09:27 <topol> tongli perfect
14:09:39 <topol> next item
14:09:56 <topol> topol to write Interop Challenge phase 2 update article
14:10:47 <topol> This is done. Will be published today. I'll tweet out a link to it. (Follow me on twitter :-) )
14:11:23 <topol> next item is done thanks to tongli
14:11:26 <topol> all please help trying to get wordpress back working
14:11:30 <topol> so thats done
14:11:33 <topol> next item
14:11:47 <topol> zhipengh to add overview section to lessons learned doc
14:12:06 <tongli> @topol, few companies in China are now running the lampstack workloads.
14:12:15 <tongli> talked to Daisy last night.
14:12:15 <topol> zhipengh, did you push a patch on this. I dont recall seeing it
14:12:45 <topol> tongli let's cover that in the open discussion time. folks will be excited to here about your China company efforts
14:12:50 <zhipeng> i've not
14:12:52 <topol> err hear
14:12:58 <zhipeng> will try it before the end of this week
14:13:11 <topol> zhipeng.  Sounds great. Thank you!
14:13:53 <topol> #action zhipeng to add overview section to lessons learned doc
14:14:24 <topol> #topic Time needed for Interop Challenge Project in PTG (A day or half day)
14:15:02 <tongli> I think last time we said to have half day.
14:15:11 <topol> I believe folks felt a half day was the right amount to allocate for Interop Challenge at PTG.  Anyone feel we should deidicate more or less time?
14:15:46 <garloff> You can do a lot in half a day if everyone is well prepared ..
14:15:57 <topol> garloff +++
14:16:15 <topol> OK let's stick with that.
14:16:19 <tongli> @topol, it may help if we list things that we want to do there.
14:16:56 <tongli> for example, let's find an appropriate way to support different platforms,
14:16:59 <hogepodge_> Can you make sure to coordinate with introp wg, as they'll be using the same space
14:17:07 <topol> tongli,  I agree.
14:17:31 <tongli> I started doing that in the lampstack workload, but for k8s and nfv, we may take that approach.
14:17:35 <topol> hogepodge, so good point.  Space issue.  Here is what ttx told me
14:17:38 <tongli> so the workload scripts will be cleaner.
14:17:50 <topol> 14:18:27 <topol> 11:45 ttx: actually InteropWG has a room
14:17:50 <topol> 14:18:27 <topol> 11:45 ttx: together with RefStack
14:17:50 <topol> 14:18:46 <topol> ttx: so you can use that space on Monday-Tuesday
14:17:52 <topol> 14:18:46 <topol> 11:46 ttx: otherwise there will be room for extra meetings anyway
14:18:19 <tongli> what is the date for PTG?
14:18:29 <hogepodge_> That's my understanding too
14:18:30 <topol> So choices are we can coordinate with InteropWG/RefStack and have guaranteed space
14:18:39 <gema> 20 - 24 feb
14:18:41 <gema> Atlanta
14:19:15 <topol> #link https://www.openstack.org/ptg/
14:19:30 <topol> or take our chances with "other space"
14:19:42 <gema> topol: are there starbucks in atlanta?
14:19:46 <gema> I am always up for coffee
14:19:50 <topol> My guess is RefStack/InteropWg want to be at our topics as well
14:20:04 <gema> probably
14:20:11 <topol> gema all over the place. Great restaurants too. I lived there for 9 years many years ago
14:20:12 <tongli> haha. @gema, or tea for these who do not drink coffee.
14:20:24 <gema> tongli: indeed
14:20:52 <topol> so markvoelker is on. Any chance we grab the InteropWG room for half a day?
14:21:17 <tongli> I remember someone from ATT posted a link to the NFV script, I took a brief look, it is a very simple script.
14:21:19 <topol> hogepodge_?
14:21:22 <tongli> but I could not find the url.
14:21:22 <markvoelker> topol: we're already sharing that space with RefStack and are still ironing out agendas, so we'll have to coordinate
14:21:34 <gema> tongli: the other thing we could do is organise a dinner in kind of thing
14:21:42 <gema> topol: sorry, wrong tab
14:21:49 <gema> topol: and do the meeting in the evening
14:22:00 <tongli> @gema, yeah, I am always up for a meal.
14:22:06 <topol> markvoelker, Makes sense.  If you think you can carve out time to put us in your agenda let us know
14:22:13 <gema> like the women of openstack organise breakfasts
14:22:26 <tongli> can we put the things we need to do in the etherpad?
14:23:06 <topol> ideally we set things up so all the InteropWg folks can participate in our half day session. We have like a full week there correct?
14:23:51 <topol> markvoelker, how many days does RefStack/InteropWG get a room for?
14:24:05 <topol> tongli yes we shoud start an etherpad
14:24:35 <markvoelker> Monday and Tuesday
14:24:41 <topol> #action tongli to create an etherpad for topics real fast so we can put the link in this meeting
14:25:11 <tongli> @topol, let's just use today's etherpad
14:25:29 <tongli> https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-11
14:25:37 <tongli> I have put few items there already at the bottom.
14:25:40 <topol> tongli, thats fine
14:26:12 <topol> #agreed #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-11  will be our PTG Agenda etherpad
14:26:51 <tongli> @all, please add the things that you would like to do there.
14:27:05 <topol> So markvoelker let us know if you/RefStack need the room for two full days. If so we hold our half day after that and then you all can attend. Does that make sense?
14:27:37 <markvoelker> Sure.  I'm sure we can find some time, just have to figure out when and how much.
14:27:53 <topol> Folks should start adding agenda items to the etherpad.  We can figure out the when details later
14:27:54 <tongli> PTG is in Atlanta, got address? should we book the hotels?
14:27:59 <topol> markvoelker sounds good
14:28:19 <topol> tongli, I provided a link
14:28:31 <topol> try and book where its being held
14:28:40 <topol> I think the hotel is in OTR
14:28:59 <tongli> @topol, the link again please.
14:29:15 <topol> K, #action all please add items to the PTG agenda etherpad #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-11
14:29:33 <topol> we can review these next meeting.
14:29:52 <topol> next topic,
14:30:00 <topol> #topic open discussion
14:30:42 <topol> So it turns out the there is a big effort in China on OpenStack interop.   tongli is our liasion to that effort so we can all join forces
14:30:49 <topol> tongli can you say a few words
14:31:37 <topol> tongli?
14:31:38 <tongli> @topol, yes,
14:31:57 <tongli> there will be a kick off meeting for Interop China chapter next week.
14:32:08 <tongli> I was asked to be there talking,
14:32:21 <gema> tongli: where does this effort come from?
14:32:33 <gema> any particular company or is it many of them or ...?
14:32:34 <topol> geam China government sponsored it I believe
14:32:40 <gema> ahh, great
14:32:45 <topol> tongli which comapnies?
14:32:47 <tongli> and 2 of the companies are currently running lampstack workloads on there cloud.
14:32:54 <tongli> let me get the list
14:32:56 <zhipeng> not government sponsored I think
14:33:44 <topol> zhipeng, I thought it was. Or Govt. standards body sponsored
14:33:46 <tongli> zhipeng, I think there is one body which belongs to the government.
14:33:53 <tongli> I am not sure about all the short names.
14:34:01 <zhipeng> I think the local chapter, China or other country, should not create forks from our work here
14:34:18 <zhipeng> tongli topol yes many are related :P
14:34:21 <topol> zhipeng. We agree! That's why we are send tongli!
14:34:58 <topol> zhipeng. I don't want any forks either. If you can help keep that from happening please do
14:35:05 <gema> tongli: ah, ok, thanks
14:35:06 <tongli> looks like CAICT, Huawei, ZTE, T2Cloud, FiberHome, JD, Cloudin.
14:35:09 <gema> ta!
14:35:10 <tongli> these are the names I got.
14:35:22 <gema> great!
14:35:24 <zhipeng> topol definitely
14:35:38 <tongli> only know few.
14:35:39 <topol> tongli where and when is the meeting? Beijing?
14:35:56 <tongli> but I was told they are pretty hot on interop and eager to hear what we have to say.
14:36:02 <topol> zhipeng where are you located?
14:36:05 <tongli> yes, in Beijing,
14:36:08 <zhipeng> Shenzhen
14:36:29 <tongli> in April, there will be a summit there right before Boston summit.
14:36:40 <zhipeng> tongli the air condition in Beijing might not be very well
14:36:42 <topol> zhipeng, did you want to goto the Beijing meeting?
14:37:01 <zhipeng> topol I won't but I think we have other colleagues going over
14:37:12 <topol> zhipeng. Ok good
14:37:14 <tongli> zhipeng, I know. I will bring few masks.
14:37:30 <zhipeng> tongli quite a few is better :P
14:37:42 <tongli> really happy to see that the real users of OpenStack from China really want to do the interop stuff.
14:37:56 <topol> so in any case, we are hoping tongli can go to this interop group and make sure we all work together. Right tongli?
14:38:03 <zhipeng> the main thing is the input I think
14:38:27 <topol> At the end of the day, we have a repo we can all store sample workloads in
14:38:35 <tongli> absolutely, I like to ask the people there to contribute test scenarios. such as how you use the openstack.
14:38:43 <tongli> and what is the most use cases.
14:39:25 <tongli> the worst thing we can do is to cook up some workloads and they do not matter.
14:39:53 <topol> so that meeting is around Jan 17 I believe.  tongli can give us an update when he gets back
14:40:04 <tongli> 16 to 17.
14:40:04 <garloff> hogepodge_, markvoelker: how do we feed what we learn from InterOp-Challenge into InterOp (DefCore) certification? Should things we find in the challenge inform the things we want to push into the DefCore standards?
14:40:06 <topol> tongli, maybe they have an NFV workload
14:40:11 <tongli> I still do not have a flight ticket yet.
14:40:23 <topol> tongli work with Vince
14:40:35 <tongli> @topol. yes. thanks.
14:40:52 <topol> garloff great topic
14:40:54 <zhipeng> garloff that would be ideal
14:41:13 <tongli> so I probably will attend this meeting next from Beijing.
14:41:24 <topol> tongli sounds good
14:41:43 <markvoelker> garloff: generally, if we're finding things that we have to work around in the workloads b/c they're not interoperable those are good candidates for analysis as to why
14:41:50 * topol just an FYI, I need to end this meeting 10 minutes early today
14:42:03 <topol> markvoelker +++
14:42:18 <markvoelker> garloff: also, API-level analysis of what we're actually using in the workloads to see how they compare to what's in the guidelines
14:42:37 <garloff> markvoelker: Great, that's what I was hoping ...
14:43:17 <topol> markvoelker, Excellent!
14:43:29 <garloff> Let's make sure we close that loop, so we have a weak correspondence here. Like passing DefCore means passing InterOp Challenge is easy.
14:44:30 <topol> garloff, makes sense.  Or put another way, if your OpenStack environment can run all our workloads you got a pretty good OpenStack environment
14:44:57 <topol> garloff nice to have real workloads to verify
14:45:33 <topol> any other topics for today?
14:46:30 <garloff> topol: Exactly -- InterOp comes more from a bottom up view, while IOp Challenge more top down
14:46:49 <topol> garloff, yep!
14:47:10 <topol> OK, if folks are okay with this I will give you 13 minutes back
14:47:19 <topol> Thanks everyone for participating
14:47:24 <tongli> @topol, thanks. good day
14:47:37 <topol> #endmeeting