14:03:20 <topol> #startmeeting interop_challenge
14:03:20 <openstack> Meeting started Wed Jan 25 14:03:20 2017 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:24 <openstack> The meeting name has been set to 'interop_challenge'
14:03:35 <topol> The agenda for today can be found at:
14:03:35 <topol> # https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-25
14:03:35 <topol> We can use this same etherpad to take notes
14:03:39 <hogepodge> o/
14:04:03 <tongli> o/
14:04:12 <topol> Agenda:
14:04:12 <topol> #topic Review last meeting action items
14:04:12 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-01-18-15.01.log.html
14:04:13 <zhipengh> o/
14:04:30 <topol> Use this link as the others were corrupted due to moderator error :-)
14:04:51 <topol> please dont ask me about my ID10T error at last weeks meeting :-)
14:05:21 <topol> tongli to work with shamail to reserve evening timeslot on meeting5 for china interop
14:05:32 <topol> Hi tongli, any progress on this?
14:06:01 <tongli> @topol, sorry, that has not be done. I will follow up.
14:07:02 <topol> K no worries, sounds good
14:07:18 <gema> o/
14:07:24 <topol> hi gema!
14:07:27 <topol> all, please review and update PTG agenda with topics #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-11
14:07:37 <topol> let's all go take a quick look
14:08:20 <topol> Make sure to add your name to the participants list on the etherpad.
14:08:30 <topol> I'm pretty sure markvoelker will be there
14:09:15 <topol> Also we will be sharing space with the RefStack/ Interop Workgroup crowd so we will not overlap with their agendas :-)
14:09:50 <topol> gema, luz are there other responsibilities besides those that would cause you to have to miss?
14:10:03 <gema> topol: kolla meetings
14:10:17 <gema> topol: but that is a personal challenge I have, making it all fit
14:10:43 <topol> gema. Understandable. Hopefully it will all work out
14:10:45 <gema> topol: I will attend enough of everything not to be blocked/be a blocker
14:10:53 <topol> gema excellent
14:11:18 <topol> Any additions to the agenda?  We can always add something later but don't b shy
14:11:57 <gema> topol: what is the meaning of "platform" on the topics we have there?
14:12:04 <tongli> if we want to run these workloads, then we need folks to be prepared.
14:12:25 <topol> tongli whats your def of platorm?
14:12:29 <tongli> like have account, etc.
14:12:31 <topol> platform
14:13:01 <tongli> like running on ubuntu, possibly redhat (if anyone develops for it) and fedora,
14:13:09 <gema> tongli: those are distros
14:13:11 <gema> not platforms
14:13:14 <tongli> that is what lampstack supports.
14:13:16 <topol> tongli good point about prepred. Perhaps add somehting to the page that says.  Recommended activities befor you show up at PTG
14:13:18 <tongli> ok. distros.
14:13:25 <tongli> sorry for the confusion.
14:13:27 <gema> and intel/aarch64 are architectures
14:13:42 <gema> tongli: no worries, was just making sure I understood what we were going to discuss
14:13:42 <tongli> if everyone thinks that ubuntu is good enough, I won't object to it.
14:13:49 <topol> #action, tongli to update agenda with corrected terminology
14:13:51 <gema> tongli: for the VMs?
14:14:17 <tongli> @gema, yes
14:14:24 <tongli> @topol, updated.
14:14:26 <gema> tongli: I'd argue that if we are going to run any docker/kubernetes we may want to use coreos
14:14:28 <topol> #action tongli to add a recommended actions before you show up at PTG section to the agenda etherpd
14:14:51 <gema> I'll propose, rather
14:14:51 <tongli> @gema, people probably just want to use ubuntu for k8s.
14:14:57 <gema> oh, ok
14:15:13 <gema> tongli: why?
14:15:17 <topol> tongli, not so sure. wouldnt most folks in production use coreos?
14:15:24 <gema> topol: I would
14:15:35 <tongli> need discussion about that.
14:15:39 <gema> ack
14:16:11 <topol> if there are issues with running coreos that sounds really interesting to me
14:16:19 <gema> I am not against using ubuntu, on the contrary, it makes things rather easy
14:16:26 <gema> but, I'd like to show some variety
14:16:32 <topol> so worth a discussion. Add to the agenda for PTG?
14:16:42 <gema> else we may be sending the message, if you want your workloads to work across clouds, use ubuntu
14:16:50 <gema> which is the wrong one, imo
14:17:05 <topol> gema. I think you are onto something intersting here
14:17:18 <gema> topol: linaro has to be perceived as being platform independent
14:17:32 <gema> we cannot just run on one thing, we need to guarantee we foster the entire ecosystem
14:17:39 <topol> If we just ignore coreos we might accidentally hide a lot of issues that operators would hit
14:17:46 * gema nods
14:18:19 <topol> So I think it is worth discussing. My view is anytime we hit something like that and things break we learn a lot
14:18:27 <gema> agreed
14:18:31 <tongli> if we decide to use coreos, then it is a lot easier than using ubuntu since docker will be already there.
14:18:54 <gema> tongli: I am sure I can pull some coreos people to help also if we needed new images or something
14:19:07 <topol> Again, we arent under the pressure of must make keynote demo work for this release. So we can be more adventurous
14:19:32 <gema> sounds good to me
14:19:46 <topol> gema, is it good enough if we add discuss using coreos as an alternative image for k8s ?
14:20:09 <gema> topol: yep, makes a lot of sense
14:20:22 <topol> perhaps we have both.  My guess is tongli may have a lot done already on ubuntu and does not want to waste that work
14:20:32 <gema> topol: fair enough
14:20:40 <tongli> then the script will be quite different. we will see.
14:20:51 <topol> I'll add an agenda item to cover this
14:20:58 <tongli> I added it to the agenda.
14:21:12 <topol> #action topol to add agenda item to discuss using coreos for k8s workload
14:21:22 <gema> tongli: if you point me to the script I can have a look
14:21:27 <topol> next item
14:21:41 <topol> tongli to use binary to do kube, will add an app/scenario on top. looking for suggestions
14:22:04 <topol> I know tongli has been very busy hanging out with IBM CEO this weekend (Lucky!)
14:22:14 <tongli> @topol, haha.
14:22:18 <gema> hehe
14:22:21 <tongli> it was stressful.
14:22:39 <topol> tongli any chance to to make progress on the k8s workload? If not I more than understand
14:22:44 <tongli> I have never saw that many top executives in my life.
14:22:49 * topol he really was with her this weekend!
14:23:09 <gema> I saw the pic on twitter, I think
14:23:12 <topol> you met more than me friend. So any progress?
14:23:16 <tongli> yes, I did see her. Sahdev even took a picture with her, true story.
14:23:28 <tongli> not much.
14:23:33 <topol> K, no worries
14:23:46 <topol> sad you didnt get a selfie with Ginni though
14:23:54 <topol> next topic
14:24:10 <topol> #topic Patches that need review  #link https://review.openstack.org/#/q/status:open+project:openstack/interop-workloads,n,z
14:25:06 <topol> two patches out there.  please all review.  I will review today as well. THANKS
14:25:27 <topol> #action all, please review patches #link https://review.openstack.org/#/q/status:open+project:openstack/interop-workloads,n,z
14:25:43 <topol> #topic NFV, any updates from ATT on this? ZTE, Huawei from Interop China Chapter are planning to submit for this.
14:25:57 <topol> eeiden, you around?
14:26:39 <topol> tongli, the China interop team is workng on a NFV workload correct?
14:27:07 <zhipengh> From Huawei, we might have our colleagues from OPNFV teams
14:27:17 <zhipengh> they have ample scenarios and testcases
14:27:21 <topol> zhipengh, That is excellent
14:27:40 <topol> zhipengh are you coming to the PTG?
14:28:12 <zhipengh> yep
14:28:14 <tongli> @zhipengh, Jason is trying to get these people doing it  and I have had a phone call with them as well. hope that they can start working on it.
14:28:32 <zhipengh> yes we are starting to gather people around
14:28:39 <tongli> @topol, I believe Jason (Huawei) will be there as well.
14:29:44 <topol> thats great zhipengh can you make sure your name and Jason names are added to the participant list on our etherpad #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-11
14:30:19 <topol> #topic Timeslot for Interop Challenge at PTG
14:30:43 <zhipengh> topol I've already added it
14:31:25 <topol> zhipengh Thanks So last I heard from Cathering
14:31:57 <topol> So last I heard from cdiep I think we get time on Tuesday for our agenda.  I'll confirm the exact time
14:32:19 <topol> #action topol to confirm exact PTG schedule time allocation with cdiep
14:33:54 <topol> BTW, here is the list of participants that I see so far:
14:33:58 <topol> Brad Topol
14:33:58 <topol> Tong Li
14:33:58 <topol> Daniel Mellado
14:34:00 <topol> Gema Gomez (depending on time and other groups commitments)
14:34:02 <topol> Luz Cazares (depends on time and other groups commitments)
14:34:04 <topol> Howard Huang
14:34:06 <topol> Chris Hoge
14:34:26 <topol> I know markvoelker will be there as well
14:34:42 <topol> #topic open discussion
14:34:45 <markvoelker> Yep
14:34:51 <topol> any other issues
14:34:56 <topol> I'll add Mark then!
14:34:58 * markvoelker sneaks in the back as he is traveling today
14:35:32 <topol> and as usual Mark is way faster than old man Brad
14:35:48 <topol> so open discussion. Any other issues for today?
14:36:42 <tongli> @markvoelker, will you be at ptg?
14:36:49 <tongli> do not see your name there.
14:37:05 <markvoelker> yes, I'll be there
14:37:29 <topol> tongli refresh, he added it
14:37:39 <tongli> cool.
14:37:52 <topol> any other topics for today?
14:38:04 <tongli> I do not have anything else to add. China will be on Chinese New Year in two days.
14:38:14 <topol> if not free time back for all.
14:38:16 <tongli> that will last about two weeks. so you won't hear anything from them.
14:38:27 <topol> tongli. Good to know.
14:38:37 <topol> Ok, free time back for everyone
14:38:40 <tongli> cool. great. thanks Brad.
14:38:44 <topol> Thanks for joining today
14:39:12 <topol> #endmeeting