14:00:24 <topol> #startmeeting interop_challenge
14:00:28 <openstack> Meeting started Wed Feb 15 14:00:24 2017 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:31 <openstack> The meeting name has been set to 'interop_challenge'
14:00:44 <topol> Ping dmellado tongli gema zhipengh markvoelker daniela_ebert skazi luzC
14:00:50 <tongli> o/
14:00:52 <gcb> o/
14:00:55 <markvoelker_> o/
14:00:58 <topol> Hi everyone, who is here for the interop challenge meeting today?
14:00:58 <skazi> o/
14:01:08 <gcb> hi everyone
14:01:11 <hogepodge> o/
14:01:30 <gcb> This is my first time, I'm ChangBo Guo
14:01:44 <zhipeng> o/
14:01:49 <topol> Hi ChanBo Guo, welcome!
14:01:52 <tongli> @gcb, welcome.
14:01:57 <topol> gcb skazi hodgepodge
14:02:06 <topol> gcb skazi hodgepodge
14:02:16 * topol Adding thse folks to my ping list
14:02:33 <skazi> topol: I was there already :)
14:03:07 <topol> skazi you are there twice cuz I like you best :-)
14:03:17 <topol> skazi its fixed :-0
14:03:35 <topol> The agenda for today can be found at:
14:03:35 <topol> # https://etherpad.openstack.org/p/interop-challenge-meeting-2017-02-15
14:03:35 <topol> We can use this same etherpad to take notes
14:03:49 <topol> Agenda:
14:03:49 <topol> #topic Review last meeting action items
14:03:49 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-02-08-14.01.html
14:04:07 <topol> all please review patches #link https://review.openstack.org/#/q/status:open+project:openstack/interop-workloads,n,z
14:04:43 <tongli> We have now 4 open including the kubernetes workload (draft).
14:04:57 <topol> wowsers! We have lots of patches to review! thats awesome
14:05:12 <tongli> I am guilty of tox version one. did not have time to try various versions.
14:05:15 <tongli> need to do that.
14:05:49 <topol> K, I have been guilty too. I will start reviewing
14:06:09 <topol> any concerns about the patches we need to discuss here or do folks just need to find time to review?
14:06:28 <topol> let us know
14:06:30 <tongli> also need to try various ansible version against kubernetes workload as well.
14:07:07 <topol> next action item:  dmellado to push a new patch for #link https://review.openstack.org/#/c/409180/
14:07:45 <tongli> I will really appreciate it if someone else can take that action, I mean setup env with different ansible versions and try to run the workload to see what ansible versions we can support.
14:08:05 <tongli> should be fairly easy if you do in a VM.
14:08:50 <tongli> other patches are fairly small, please run and review.
14:09:36 <topol> tongli, so hopefully someone can take the different ansible version action item. if not could you help someone to do this at PTG if they dont know how to do this? With some pair rogramming?
14:09:55 <tongli> @topol, yes, absolutely.
14:10:14 <tongli> wanted to get the kubernetes workload out for people to see where we are going.
14:10:30 <topol> so folks even if you are not sure how to do this perhaps we can look at this at PTG
14:10:46 <topol> tongli, worst case put it on our PTG agenda :-)
14:10:46 <tongli> still need a bit more work on the workload such as dns if people think it is needed, load balancer maybe.
14:11:00 <tongli> I think I already have it there.
14:11:42 <topol> #action all, please look at the new kubernetes workload patch.   I can see us running this at the Boston Summit :-)
14:11:57 <topol> back to the action items
14:12:16 <topol> demellado we are still waiting on an updated patch from you correct?
14:13:30 <topol> I think so.  tongll can you follow up with dmellado?
14:13:35 <tongli> I think we will definitely need to add Kubernetes UI addon to the workload, so that there will be stuff showing on screen, other than the command line.
14:13:54 <tongli> @topol, I thought that one was merged.
14:14:05 <tongli> we can do specs/blueprint now.
14:14:46 <tongli> everyone can register blueprint.
14:15:02 <tongli> https://blueprints.launchpad.net/interop-workloads
14:15:22 <topol> tongli looks like https://review.openstack.org/#/c/409180/ has not been merged yet
14:15:22 <tongli> notice the blue link in the middle of the page, you can click on that to register blueprint.
14:15:38 <tongli> and I already have one patch for the NFV blueprint posted last night I think.
14:15:43 <tongli> need to start reviewing that.
14:16:08 <topol> tongli, can we hold the bp discussion til later. I cant multitask like that
14:16:09 <tongli> no, I did not do the nfv blueprint, I mean we have one NFV blueprint.
14:16:19 <tongli> haha. ok.
14:16:45 <topol> so on my gerrit review https://review.openstack.org/#/c/409180/ still has not merged. Am I wrong
14:16:54 <tongli> PTG agenda is here. https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-11
14:17:28 <tongli> @topol, you are not wrong, that is the ansible version one we just talked about above.
14:17:35 <topol> K.
14:17:38 <topol> moving on
14:17:53 <topol> tongli to follow up to make sure commit message gets updated in https://review.openstack.org/#/c/430631/
14:18:07 <topol> this looks done
14:18:34 <tongli> yeah. both me and mark oked it.
14:20:07 <topol> tongli excellent! its merged!
14:20:34 <topol> HelenYao, zhipengh_,tongli to work together to get a blueprint submitted
14:20:45 <topol> tongli you may now talk about blueprints
14:20:48 <topol> :-)
14:21:21 <yaohelan> I am using this id as I switched the client. Hi, everyone
14:21:26 <tongli> the patch for NFV blueprint has been submitted last night, we need all parties from all companies to start reviewing it
14:21:28 <yaohelan> the bp is submitted
14:21:46 <topol> tongli, what the link?
14:22:04 <zhipeng> it is on the etherpad
14:22:10 <tongli> https://review.openstack.org/#/c/434042/
14:22:28 <topol> #link https://review.openstack.org/#/c/434042/
14:23:05 <topol> K great, #action all please review the blueprint #link https://review.openstack.org/#/c/434042/
14:23:22 <tongli> Helen, does that require something special?
14:23:30 <topol> Lots of stuff happening right before we meet for PTG. This is great!
14:23:30 <zhipeng> please feedback what do you think is missing from the BP
14:23:41 <tongli> since at the end it says a person can make a call.
14:24:02 <zhipeng> tongli we just need a sip client to be installed
14:24:07 <zhipeng> it should be rather easy
14:24:15 <yaohelan> tongli: just a calling client is needed, x-lite can be a candidate
14:24:35 <tongli> can we add that to the blueprint as requirement or something?
14:24:50 <yaohelan> sure
14:24:59 <topol> tongli +++ yes good to mentiont that
14:25:01 <tongli> or dependency.
14:25:01 <yaohelan> I will submit a patch with it
14:25:08 <yaohelan> amend
14:25:09 <tongli> please thanks.
14:25:12 <topol> thanks yaohelan
14:25:18 <tongli> yeah amend patch.
14:25:35 <topol> Ok, great
14:26:17 <topol> Now to todays agenda which I think we magically already covered most of it:
14:26:25 <yaohelan> your feedback is really appreciated
14:26:33 <topol> #topic  Kubernetes workload is now submitted. status: WIP review here: #ink https://review.openstack.org/#/c/433874/
14:26:39 <topol> we covered that :-)
14:26:52 <topol> #topic Discuss the NFV blueprint
14:26:55 <topol> we covered that
14:27:09 <topol> #topic Update from China Chapter Meeting
14:27:34 <tongli> They had a meeting last week. the meeting will be bi-weekly for now.
14:27:50 <topol> K, anything interesting to report back?
14:28:18 <tongli> the meeting has specified a person also to work on NFV use case, I have not hear back from.
14:28:28 <tongli> http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-02-08-01.30.html
14:28:36 <tongli> that is the meeting summary.
14:29:01 <tongli> they are running existing workloads and have moved onto dockerswarm.
14:29:07 <topol> tongli, how did we get an english meeting summary?
14:29:15 <tongli> because of that, they have found some issues and provided two patches, I think.
14:29:17 <topol> did you translate?
14:29:36 <tongli> the language used were mixed,
14:29:51 <tongli> specially for actions I think people just used English.
14:30:11 <tongli> you noticed that the some of the action lines are blank.
14:30:12 <topol> tongli, that is a huge help, please ask them to keep doing that
14:30:20 <tongli> I bet these lines were in Chinese.
14:30:35 <topol> tongli I trust your judgement on this topic
14:30:37 <tongli> I guess we just found the bug on the bot.
14:31:00 <topol> K, might want to tell fungi
14:31:19 <tongli> but this is mixed in both lang
14:31:21 <tongli> http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-02-08-01.30.log.html
14:31:32 <topol> tongli, any other updates from that team. Looks like they are making good progress catching up
14:32:10 <tongli> they spend quite a lot of time talking about the April summit.
14:32:17 <topol> K
14:32:19 <tongli> looks like it will be a big meeting.
14:32:50 <tongli> the on stage demo is their focal point now. you know that task will take a lot of effort.
14:33:09 <topol> tongli, yes I've been there :-)
14:33:18 <topol> #topic open discussion
14:33:37 <topol> anything  folks want to discuss. Last meeting before we meet at PTG...
14:33:41 <tongli> any other requirement on kubernetes workload, I am thinking adding UI addon.
14:33:57 <tongli> probably load balancer, but if you have other ideas, please let me know.
14:34:00 <topol> UI is always good
14:34:26 <tongli> yes. I think I can add next couple of days. and also address few review comments.
14:34:51 <topol> pretty quiet crowd today
14:35:03 <topol> how many folks are going to the PTG?
14:35:11 <hogepodge> I'll be there
14:35:15 * markvoelker_ wonders if everyone is just in a sugar coma from Valentine's day
14:35:28 <hogepodge> (At 6 am I'm very quiet)
14:35:30 <markvoelker_> I'll be there through Wednesday evening
14:35:31 <tongli> Brad Topol
14:35:31 <tongli> Tong Li
14:35:31 <tongli> Daniel Mellado
14:35:33 <tongli> Luz Cazares (depends on time and other groups commitments)
14:35:35 <tongli> Howard Huang
14:35:37 <tongli> Chris Hoge
14:35:39 <tongli> Mark T. Voelker
14:35:41 <tongli> Rocky Grober
14:35:43 <tongli> Jason shi
14:35:45 <tongli> Yumeng Bao
14:35:49 <tongli> That is the list on the etherpad at present. not sure how much it will be changed.
14:35:59 <topol> did you add your name to the participant list and do you know when we are meeting?  Hint its tuesday afternoon in the refstack room :-)
14:36:53 <topol> See #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-01-11 for details
14:36:54 <tongli> my number is 919-521-0306 and wechat is email4tong just incase you need to contact for our meeting.
14:37:36 <topol> tongli good idea. my number is 919-656-1478 and @bradtopol on twitter
14:37:40 <tongli> I know some of the folks from China may not be able to make phone calls while in US. please contact me by wechat.
14:38:18 <topol> so between tongli and I hopefully folks have contacts if they have questions
14:38:43 <topol> anything else for today or folks can go back to eating Valentines day candy :-)
14:39:09 <tongli> haha.
14:39:39 <tongli> not from me. I think we are good.
14:39:47 <topol> K. safe travels evryone. looking forward to seeing folks in person at the PTG next week!
14:40:05 <topol> #endmeeting