14:00:28 <tongli> #startmeeting interop_challenge
14:00:29 <openstack> Meeting started Wed Mar  8 14:00:28 2017 UTC and is due to finish in 60 minutes.  The chair is tongli. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:33 * markvoelker is in Germany today but will try to listen in if able
14:00:33 <openstack> The meeting name has been set to 'interop_challenge'
14:00:56 <tongli> Hi everyone, who is here for the interop challenge meeting today?
14:01:17 <tongli> @markvoelker, that is no problem at all.
14:01:40 <tongli> brad is at the OS board meeting today, he can not attend neither.
14:02:07 <skazi__> o/
14:02:21 <tongli> let's wait couple minutes to get the meeting started.
14:04:23 <tongli> The agenda for today can be found at: #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-03-08
14:04:35 <tongli> We can use this same etherpad to take notes
14:04:42 <HelenYao_> o/
14:04:56 <tongli> Agenda: #topic Review last meeting action items
14:05:14 <tongli> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-03-01-14.00.html
14:05:41 <tongli> #link https://review.openstack.org/#/q/status:open+project:openstack/interop-workloads,n,z
14:06:03 <tongli> There are quite few patch sets waiting to be reviewed, can everyone please review them?
14:07:23 <tongli> The k8s workload has grow quite big since I am trying to get coreos supported and on top of that foundation wants to deploy cockroachDB cluster to show off OS capabilities.
14:07:45 <tongli> so I will be adding more code to support coreos and cockroachdb cluster install.
14:08:19 <tongli> Please review these patch sets and comments and run the workload in your cloud.
14:08:48 <tongli> #topic PTG Updates and decisions
14:09:03 <tongli> brad has asked to show the following information with everyone.
14:09:05 <mnaser> hi everyone (a bit late, sorry) - mohammed naser from vexxhost
14:09:22 <tongli> @mnaser, not a problem.
14:09:26 <tongli> we just started.
14:09:46 <tongli> Brad has emailed all the  Platinum and Gold Foundation Board members requesting folks participate in the Challenge
14:10:55 <tongli> this is to urge the board members to have their people to participate in the interop challenge development and Boston Keynote
14:11:16 <tongli> Brad will also follow up in person at the Board meeting this week.
14:12:36 <tongli> #topic Upodate from MarkCollier/ Alex Polvi of coreos Kube Workload Enhancements
14:13:22 <tongli> at present, after I finished the k8s deployment workload on Ubuntu, I am moving to target coreos.
14:14:05 <tongli> that takes a bit of time, I think I can get it done by EOD this Friday, then I will move onto deploy cockroachdb cluster onto K8S.
14:14:26 <tongli> probably will have cockroachDB UI enabled.
14:14:39 <mnaser> k8s on coreos should be a bit easier as most of the tooling is there :>
14:15:11 <tongli> I think foundation has also asked to move database between clouds, not sure if that will be done.
14:15:20 <tongli> we need some feekback on that from everyone.
14:15:49 <mnaser> that *could* be a bit complicated depending on how every environment is deployed
14:15:59 <tongli> I think last time when we talked about this, we decided not to do that, but my memory fade quite quickly.
14:16:00 <mnaser> more in terms of networking
14:16:33 <tongli> @mnaser, true, so I do not think we have committed to that, we can talk about this more next week.
14:16:53 <tongli> #action decide if we would like to move data between clouds.
14:17:50 <tongli> @mnaser, I was having some issue getting kube-apiserver, scheduler, controller manager  pods running
14:18:12 <tongli> you have some doc on how to do that? I can use some help.
14:18:32 <mnaser> tongli there's a ton on the coreos docs to deploy k8s specifically
14:18:57 <mnaser> however as an alternative, perhaps if you have some efforts from redhat, we could potentially deploy openshift (which is really k8s with a bit of tooling)
14:19:26 <mnaser> but that's just throwing an idea out there
14:19:46 <tongli> well I just need some help on deploy kube-apiserver, scheduler pods using kubelet-wrapper.
14:20:23 <tongli> the docs that I can find is not detailed enough or out dated.
14:20:40 <tongli> any good pointer will be helpful.
14:20:41 <mnaser> most of our k8s deploys have been built up with openshift -- but those aren't working well for you? https://coreos.com/kubernetes/docs/latest/
14:21:28 <tongli> that is what I have been looking at.
14:21:47 <mnaser> there's a scripted install here: https://coreos.com/kubernetes/docs/latest/kubernetes-on-generic-platforms.html
14:22:20 <mnaser> which probably would work way better (and if you have problems with them, im sure folks are coreos would be happy to help)
14:22:35 <tongli> ok.
14:23:01 <mnaser> should be easily scriptable too as it's just generating ssl certs and running shell scripts
14:23:19 <tongli> #topic China interop challenge chapter updates
14:24:05 <tongli> China interop Challenge chapter had a meeting last night (EST 8:30pm), they have 9 companies participated in the meeting.
14:24:23 <tongli> most of them have already finished LAMPStack, and DockerSwarm workload.
14:24:34 <tongli> some have already moved onto the k8s workload testing.
14:24:59 <tongli> they are organizing the summit in Beijing, April 19 to 20.
14:25:23 <tongli> Interop workload run will be in the keynote sessions.
14:25:41 <tongli> I think they are considering using k8s workload as well.
14:26:04 <tongli> I think that is all the items for today.
14:26:20 <tongli> Anyone has any questions, comments?
14:28:02 <tongli> ok, if no questions or comments, I think we can get 30 minutes back. Please review our patches and help with workload development.
14:28:20 <tongli> #endmeeting