01:31:03 <Daisy> #startmeeting interop_challenge
01:31:04 <openstack> Meeting started Wed Mar 22 01:31:03 2017 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:31:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:31:08 <openstack> The meeting name has been set to 'interop_challenge'
01:31:13 <Daisy> 早上好
01:31:21 <kongwei> 早上好
01:31:35 <Daisy> 谁在会议室里参加中国地区的互操作项目会议。
01:31:47 <Daisy> 早上好, kongwei
01:32:00 <Daisy> 不知道还有没有其他人来参加,稍微等一两分钟。
01:32:39 <davidshi> 早
01:32:44 <Daisy> 早 davidshi
01:32:47 <kongwei> 史天和李响应该都在的
01:33:09 <kongwei> davidshi,第一次见面,你好。我是zte的孔炜
01:33:50 <kongwei> 李彤,您好
01:33:59 <davidshi> hi,我是中联润通的史天,之前在HPE做OpenStack
01:34:08 <Daisy> 好的,现在到会的有zte孔炜和李响, IBM Daisy和tongli, 中联润通史天
01:34:20 <tongli> o/
01:34:31 <Daisy> 今天马飞因为连不上IRC,由我来代他主持。
01:34:52 <Daisy> #topic Review last meeting action items
01:35:01 <Daisy> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-03-08-01.30.html
01:35:11 <Daisy> Action items
01:35:11 <Daisy> 1.     easystack to finish LAMP test by next week
01:35:11 <Daisy> 2.     all to start k8s test in this week
01:35:13 <Daisy> 3.     all to finish k8s test by next two weeks
01:35:36 <Daisy> Easystack的代表在的话,请说句话。
01:35:47 <Daisy> 其他家的代表,请将将k8s的测试进展。
01:35:55 <Daisy> @kongwei @davidli
01:36:05 <Daisy> @davidshi
01:36:06 <kongwei> daisy,我有份ems去拿,出去一下。ZTE完成了ubuntu 16上的k8s测试
01:36:13 <Daisy> wonderful!
01:36:21 <kongwei> 我暂时用手机上irc
01:36:30 <Daisy> kongwei, 听说你们改了一些代码,等你回来方便讲一下吗?
01:36:43 <kongwei> 好的。
01:36:53 <Wei_Liu> Morning
01:37:00 <Daisy> 早上好Wei_Liu
01:37:10 <Daisy> 我们正谈到各家的测试进展。
01:37:46 <Daisy> Wei_Liu, 你们开始测试k8s了吗?
01:38:07 <Wei_Liu> Easystack 完成了LAMP,正在测k8s的ubuntu
01:38:18 <Daisy> good work, Wei_Liu !
01:38:22 <Daisy> 谢谢,非常棒的进展。
01:38:35 <Daisy> zuozongming,早上好。
01:39:01 <zuozongming> 早上好,早上堵车不好意思来晚了
01:39:10 <Daisy> zuozongming,请讲讲云英的测试进展,开始测试k8s了吗?
01:39:17 <Daisy> mafei来了
01:39:19 <mafei> 我通过手机进来了
01:39:32 <zuozongming> 正在测试k8s
01:40:04 <Daisy> 太好了,我们正在谈测试进展。ZTE完成了 K8s,不过修改了一些代码,一会我们谈一下;Easystack完成了LAMP;云英和EasyStack都在进行K8s的测试。
01:41:15 <Daisy> 等kongwei回来听听他讲讲k8s测试时碰到的问题,以及他的解决方法。
01:41:23 <Wei_Liu> cool
01:41:39 <Daisy> tongli: 可以给我们谈谈现在k8s 测试脚本的开发进展吗?
01:41:54 <tongli> daisy, it is now finished.
01:42:14 <Daisy> 选择了哪个app ?
01:42:16 <tongli> I have also made changes so that you can use local repo.
01:42:25 <tongli> cockroachdb cluster.
01:42:35 <Daisy> great progress.
01:42:54 <tongli> you do not have to access container repos to finish the workload.
01:42:57 <Daisy> 波士顿峰会演示会使用CentOS吗?
01:43:20 <Daisy> 几个节点?
01:43:29 <tongli> I made some changes, so that you can setup a local http server to hold things needed.
01:43:36 <tongli> it will run very fast,
01:43:48 <tongli> I think doing at least 5 nodes.
01:43:48 <kongwei> 太好了。
01:43:53 <tongli> meaning 5 VMs.
01:44:04 <tongli> sorry, I mean 6 VMs.
01:44:15 <tongli> 5 cockroachdb nodes.
01:44:28 <Wei_Liu> tongli: vm
01:44:35 <Daisy> kongwei你现在方便了吗?讲讲你在测试k8s的时候碰到的问题和解决办法。会场上的Easystack和云英都正在进行中。
01:44:40 <Wei_Liu> vm 的配置有要求吗
01:44:58 <kongwei> 我已经回到办公室了
01:45:07 <tongli> VM must be coreos openstack image (that is what boston summit requires)
01:45:22 <tongli> but the workload can also use Ubuntu 16.xx image.
01:45:41 <tongli> no other requirements.
01:45:46 <Daisy> ok
01:46:13 <Daisy> 谢谢李彤的更新。这些信息对于想要在波士顿峰会演示的厂家非常有帮助。
01:46:42 <Daisy> kongwei请你讲讲吧。
01:46:47 <tongli> if I use total of 6 VM, it will finish in about 6 minutes.
01:46:49 <kongwei> 好的,我使用的是一周前的版本。可能李彤已经修改过了。我先列一下我遇到的问题和处理方式吧
01:46:55 <tongli> it is a lot fast than lampstack workload.
01:47:27 <tongli> I am planning to make changes to lampstack so that it will also run fast. My goal is making it finish within 8 minutes.
01:47:34 <tongli> a lot faster
01:48:05 <Daisy> tongli: 您的这些计划打算什么时候完成?我们的4月峰会演示,将使用最新版的LAMP
01:48:27 <Daisy> kongwei: 你继续讲吧。可以多线程发言。
01:48:33 <tongli> I hope I can get it done within next few days.
01:49:08 <Daisy> 一周之内吗?tongli
01:49:11 <kongwei> Label the master node, 这个步骤中,我修改了node的参数
01:49:19 <kongwei> 原先是/opt/bin/kubectl --server={{ private_ip }}:8080 label --overwrite=true nodes.k8sonos master dashboardId=master
01:49:33 <kongwei> 我修改成了:/opt/bin/kubectl --server={{ private_ip }}:8080 label --overwrite=true nodes master dashboardId=master
01:50:01 <tongli> kongwei, take a look at the latest patch, it has been changed to use overwrite
01:50:28 <tongli> but in any case, since I am now using fqdn, that is not needed anyway.
01:50:34 <kongwei> 李彤,是的,我看见最新版本也是这么修改过的
01:50:36 <tongli> but the latest patch has been added that.
01:51:17 <kongwei> 第二个是我们系统的配置问题
01:51:27 <kongwei> Create volumes for the node 部分。
01:51:37 <tongli> it did not work on the earlier patch set due to the dhcp_domain configuration problem.
01:51:40 <kongwei> availability_zone: "{{ app_env.availability_zone }}"
01:51:58 <tongli> dhcp_domain="" should have been set in the nova.conf file.
01:52:06 <tongli> but some cloud does not do that.
01:52:12 <tongli> results to wrong hostname.
01:52:20 <kongwei> 我们没配置cinder的availability_zone
01:52:29 <kongwei> 所以我删除了这个
01:52:32 <tongli> that was the cause. not sure how your os cloud set that up.
01:53:00 <tongli> I think you can leave it blank.
01:53:23 <kongwei> 是的
01:53:41 <kongwei> 最后一个遇到的问题
01:54:22 <kongwei> vm启动后,sudo执行会报错。我后来是手动登录到vm。把hostname添加到/etc/hosts里的
01:54:28 <kongwei> 否则会出现执行超时
01:55:14 <Daisy> kongwei: 用的什么虚拟机镜像?
01:55:23 <kongwei> ubuntu 16
01:55:37 <tongli> hmmm. the k8s workload should do that for you already
01:55:39 <kongwei> 从社区下载的原始镜像
01:56:01 <tongli> also lampstack workload does the same thing.
01:56:12 <kongwei> 那我今天更新到最新的k8s脚本再运行一下吧
01:56:17 <Daisy> kongwei: 你们测试LAMP 的时候没有问题,对吧?
01:56:23 <Daisy> 没有hostname的问题,对吧?
01:56:26 <kongwei> 是的,lampstack没遇到
01:56:37 <Daisy> 好的。
01:56:44 <kongwei> 可能是我的k8s脚本不是最新的吧
01:57:04 <kongwei> daisy,我的发言结束了。
01:57:24 <Daisy> ZTE碰到的三个问题,第一个最新版的代码已经修改了;第二个ZTE系统的特殊配制导致;第三个hostname问题,很奇怪
01:58:22 <zuozongming> 我们在lampstack测试时里遇到了hostname 的问题 当时在脚本里添加了hostname 咱们需要统一镜像吗?感觉是镜像的原因
01:58:22 <liuyuqi> 各位,请教个问题吧,k8s测试的时候启动docker报错,Unit containerd.service not found,大家有遇到过吗
01:58:29 <Daisy> 因为ZTE报名了波士顿峰会的演示,所以关于第二个问题,我的建议是kongwei和tongli看一下是不是可以修改一下脚本,将availability_zone变为可以配置的选项,解决这个问题。
01:58:52 <tongli> liuyuqi, that problem has been fixed today
01:59:00 <tongli> I made a mistake. it should be ok now.
01:59:18 <liuyuqi> 那我也更新一下最新代码试试,非常感谢
01:59:34 <tongli> @liuyuqi, that only happens with ubuntu target. I have fixed it today.
01:59:43 <Daisy> kongwei, tongli: 需不需要把availability_zone变为可以配置的选项?
01:59:47 <tongli> use the latest patch set 37 (I believe).
02:00:02 <tongli> availability_zone is configurable.
02:00:44 <Daisy> ok. 最终目标是不改代码,而只是改配置,可以在不同的环境中把测试用例跑起来。
02:01:09 <kongwei> 好的
02:01:20 <Daisy> #action kongwei test with latest k8s code and report progress in the next meeting
02:01:59 <Daisy> #action davidshi and Wei_Liu continue the k8s test and report progress in the next meeting
02:02:08 <Daisy> 谢谢大家,讨论的很细致
02:02:11 <Daisy> 下一个话题
02:02:24 <Daisy> #topic About the new LAMP workload
02:02:29 <tongli> @kongwei, @daisy, that is exactly right. if each party keeps changing the code to pass the workload test, that means we have failed.
02:02:52 <Daisy> 在4月份的北京开源峰会上,已经决定我们将演示最新版的LAMP场景。
02:03:30 <Daisy> 还有不到4个星期的时间准备了,马飞会筹备几次面对面的预演,来备战峰会上的演示。
02:03:48 <tongli> I would like to ask everyone who has finished lampstack test, how long did it take you to finish the run?
02:03:58 <Daisy> 好的。
02:04:04 <tongli> we have to make sure the run finishes within 8 minutes.
02:04:41 <tongli> I will arrive on 4/16 evening. Hope I can participate at least one rehearsal.
02:04:48 <Daisy> #action all to test with the latest LAMP code, calculate the test running time, report the time to tongli by WeChat as soon as possible.
02:05:37 <Daisy> 这项任务关系到咱们4月北京峰会演示的效果,请大家一定要放到高优先级,尽快完成。
02:06:02 <Daisy> tongli: 如果你还想修改LAMP的效率提升速度,也建议你早点完成修改,这样维持一个稳定的最终版。
02:06:28 <Daisy> 刚才zuozongming提到要不要统一虚拟机镜像的问题,tongli你有建议吗?
02:06:28 <tongli> I know.
02:06:51 <tongli> yeah, I think we should use ubuntu 16.04
02:07:14 <Wei_Liu> for LAMP?
02:07:18 <Daisy> zuozongming,kongwei,Wei_Liu: 我们的目标是不要修改代码,只修改配置文件,完成LAMP的测试。如果测试中有任何问题,请及时在微信群里沟通。
02:07:42 <kongwei> 好的
02:07:58 <Wei_Liu> ok
02:08:05 <Daisy> #decision: we will use ubuntu 16.04 downloading from official website in the InterOp show in Beijing
02:08:15 <kongwei> lampstack我使用的是社区的ubuntu 14版本测试。我继续测试ubuntu 16吧
02:08:34 <kongwei> 下次会议上反馈测试进展
02:08:36 <Daisy> 大家尽量去测试。先按照这个要求去做,有问题在群里及时沟通。
02:08:50 <Daisy> 目的就是4月的峰会演示,一起加油~
02:09:05 <Daisy> 下一个话题
02:09:13 <Daisy> #topic Discuss  the interop challenge scheme of the global cloud computing summit in April
02:09:41 <Daisy> 马飞草拟了一个峰会演示的agenda,请大家提提意见。
02:09:49 <tongli> how many companies will be on stage now?
02:09:49 <Daisy> 主持人:马飞
02:09:49 <Daisy> 互操作能力展示分为两个环节/部分
02:09:49 <Daisy> 第一部分:openstack基金会非常重视互操作(15分钟)
02:09:51 <Daisy> Mike介绍OpenStack基金会情况(5分钟)
02:09:53 <Daisy> 郭长波介绍基金会董事成员包括个人董事(5分钟)
02:09:55 <Daisy> 李彤介绍interop工作组以及现在工作进展(5分钟)
02:09:57 <Daisy> 
02:09:59 <Daisy> 第二部分:国内企业互操作能力展示及颁奖(15分钟)
02:10:01 <Daisy> 马飞介绍LAMP工作做了哪些事情(3分钟)
02:10:03 <Daisy> 然后随机采访台上演示人员,目前的工作进展(10分钟)
02:10:05 <Daisy> 最后给所有参与企业颁发一个奖章(5分钟)
02:10:19 <Daisy> 8, including IBM and Huawei
02:10:33 <Daisy> 我们一共有30分钟的上台时间。
02:10:43 <tongli> ok, 10 will be nice.
02:11:15 <Daisy> 包括Mike的演讲,郭长波董事的演讲,tongli的演讲,以及我们的展示环节和颁奖环节。
02:11:16 <tongli> the first part is on the first day and the second part is on the second day?
02:11:36 <Daisy> 在一起,第二天上午的第一个节目。
02:11:45 <Daisy> 好像是9:30-10:00
02:11:54 <tongli> oh, ok.
02:12:35 <tongli> so, I am not doing the second part, right? Mafei will be doing it?
02:12:49 <Daisy> 我感觉这个时间安排应该有可以重复利用的时间段。
02:13:05 <Daisy> 看起来是你的演讲在第一部分的5分钟里。
02:13:14 <Daisy> 需要马飞确认一下你是不是在第二部分里面讲话。
02:13:24 <Daisy> 可以去群里讨论。
02:13:33 <tongli> I was surprised by that. I thought I will be conducting the demo.
02:14:20 <Daisy> mafei不在,咱们待会去微信群里和他讨论一下吧。
02:14:40 <Daisy> zuozongming,kongwei,Wei_Liu: 关于4月峰会的展示的安排,你们有什么问题吗?
02:15:34 <Daisy> 没有问题我们结束这个环节的讨论。
02:15:44 <Daisy> #topic Open discussion
02:16:17 <Daisy> zuozongming,kongwei,Wei_Liu,tongli: 有什么问题想继续讨论吗?
02:16:30 <Wei_Liu> 没有问题,
02:16:36 <Daisy> 谢谢。
02:16:37 <tongli> I think we need to confirm the rehearsal time.
02:16:47 <Daisy> good suggestion
02:16:57 <tongli> especially if I will be conducting it.
02:17:08 <Daisy> #action Mafei to decide the rehearsal date and time
02:17:13 <LiXiang> 4月初是否还要到北京做一下预先演练?
02:17:21 <tongli> the demo is on day 2, so last rehearsal should be Monday.
02:17:32 <Daisy> 我记得马飞想安排几次面对面的预演。
02:18:08 <LiXiang> 因为我们在南京,因此希望如果需要面对面演练的话,最好集中在一两天内,我们可以请孔炜去北京出差。
02:18:13 <Daisy> mafei来了。能说话吗?
02:18:14 <tongli> I think have couple more rehearsals is a good idea.
02:18:25 <Daisy> 好的。
02:18:31 <Wei_Liu> 2次吧,第二次4月17号,让mafei定第一次的时间?
02:18:34 <Daisy> LiXiang: 好的,我转达给马飞。
02:18:47 <Daisy> mafei来了,能说话吗?
02:18:57 <LiXiang> 第一次排练是什么时间?
02:19:09 <Daisy> 大家的提议都看到了,等马飞决定。
02:19:27 <mafei> 第一次会提前通知大家,在10号那周的前几天
02:19:35 <mafei> 10或者11号
02:19:52 <LiXiang> ok
02:20:12 <tongli> I will make some changes to lampstack workload.
02:20:16 <Wei_Liu> tongli: 大概什么时候能完成LAMP的修改?
02:20:18 <Daisy> 所以是两次,第一次是10号或者11号,第二次是会议前一天,对吧?
02:20:24 <mafei> 第二次在会前17、18号
02:20:30 <tongli> the main change is to make the vm provision parallel.
02:20:33 <mafei> 对的
02:20:34 <Daisy> 好的。收到,mafei
02:20:37 <tongli> it is to reduce the workload run time.
02:20:58 <tongli> I am hoping I can finish that by EOD this Friday. but I need all of you to review it.
02:21:06 <tongli> otherwise, it can not be merged.
02:21:52 <Daisy> #action all to review tongli's patch to LAMP
02:22:02 <tongli> I do not want to push my own patch set, not nice , so I need everyone to review the patch.
02:22:04 <Daisy> tongli: 你提交之后,在群里跟大家说一声,我们去review
02:22:31 <tongli> once I have it submitted, I will let everybody know.
02:22:38 <Daisy> 好的,多谢tongli
02:22:40 <Wei_Liu> tongli: 能不能让lampstack也用local repo?
02:22:55 <tongli> hi, btw, I can bring some stuff to beijing from US. if anyone wants something.
02:23:01 <tongli> I mean something small.
02:23:17 <tongli> and something won't get me into trouble.
02:23:37 <tongli> Wei_Liu, lampstack can use local repo already
02:25:12 <Daisy> 大家还有想在会上讨论的吗?没有的话,我就结束IRC会议,大家可以转战微信群,继续关心的话题。
02:25:42 <Wei_Liu> no
02:26:04 <Daisy> 好的,那我就结束IRC会议了。谢谢各位的参与和支持。
02:26:08 <tongli> bye
02:26:19 <Wei_Liu> bye
02:26:25 <Daisy> #endmeeting