14:01:23 <tongli> #startmeeting interop_challenge
14:01:24 <openstack> Meeting started Wed Mar 22 14:01:23 2017 UTC and is due to finish in 60 minutes.  The chair is tongli. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:25 <dmellado> tongli: it gives me headaches just thinking about that xD
14:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:28 <openstack> The meeting name has been set to 'interop_challenge'
14:02:02 <tongli> can you guys do an o/ again so that the meeting minutes get your name recorded?
14:02:14 <markvoelker> o/
14:02:20 <dmellado> o/
14:02:21 <beisner> o/
14:02:21 <zhipeng> o/
14:02:31 <mnaser> o/
14:02:36 <skazi_> o/
14:02:42 <tongli> Thanks.
14:02:48 <mafei> o/
14:03:00 <tongli> topic Review last meeting action items
14:03:09 <Thor_> o/
14:03:10 <tongli> #topic Review last meeting action items
14:03:32 <tongli> http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-03-15-14.01.html
14:04:05 <tongli> there are only two actions other than review patch sets from last week.
14:04:29 <tongli> BTW, Brad is in Vegas, he most likely will miss today's meeting.
14:04:45 <vkmc> o/
14:04:50 <dmellado> welcome vkmc ;)
14:04:52 <tongli> action #1 was Mark look into the copy right, license thing.
14:04:57 <vkmc> thx!
14:05:06 <HelenYao_> o/
14:05:07 <tongli> @markvoelker, any updates?
14:05:50 <markvoelker> I haven't quite finnished the patch, but it's mostly just elbow grease.  Should have that ready soon (today I'm pretty booked, so likely later this week)
14:06:27 <tongli> @markvoelker, great. thanks. so you are planning to add headers to workload files or creating a new file?
14:06:54 <markvoelker> My current iteration ammends existing files per the guidelines we discussed last week
14:07:13 <tongli> so your patch will be on top of my patch?
14:07:21 <dmellado> yep, IIRC that's what we agreed to and was on the guidelines
14:07:24 <markvoelker> yep, just an iteration
14:07:31 <dmellado> it should be fairly simple, in any case
14:07:37 <tongli> ok. great. Thanks @markvoelker.
14:07:40 <markvoelker> I thought the easiest way to do it would be to make it a separate patch that's dependant on yours
14:07:40 <dmellado> just adding a ton of #Apache, I assume ;)
14:07:47 <markvoelker> That way we can keep them separate in gerrit
14:07:54 <markvoelker> dmellado: basically, yes. =)
14:08:03 <tongli> @markvoelker, agreed.
14:08:27 <tongli> so please, please review this patch set. https://review.openstack.org/#/c/433874/
14:08:50 <tongli> ok, the second action was for daniel look at the os-client-config.
14:09:04 <dmellado> tongli: I was overcommited this week, but it's on my TODO ;)
14:09:09 <tongli> I think the discussion was during the NFV workload configuration
14:09:40 <dmellado> also if there aren't any more items I wanted to start a discussion on wether we should try to put even if a reduced version
14:09:43 <dmellado> of the workload
14:09:58 <tongli> ok. please work with @HeleYao on the NFV workload regarding the configuration.
14:09:59 <dmellado> so we can add it to the openstack CI, to have some kind of 'minimum-workload' around
14:10:09 <dmellado> will do ;)
14:10:16 <tongli> @dmellado, thanks.
14:10:37 <tongli> I believe that is all the actions from last week, but guys, please review the workload patches.
14:10:44 <tongli> we really need to get them merged.
14:11:06 <markvoelker> ++
14:11:13 <tongli> #topic patches that need reviews.
14:11:31 <tongli> https://review.openstack.org/#/q/status:open+project:openstack/interop-workloads,n,z
14:11:44 <tongli> we only have two.
14:12:02 <tongli> please review and we need to at least have the k8s workload merged.
14:12:18 <tongli> #topic k8s patch set issues.
14:12:43 <tongli> Earlier I had some issues when I run the workload using ubuntu image,
14:13:06 <dmellado> tongli: the k8s one?
14:13:16 <dmellado> oh, nevermind, saw the topic
14:13:19 <tongli> later I found I was misconfigured docker on ubuntu
14:13:26 <tongli> that has been now fixed.
14:14:06 <tongli> I had another issue earlier as well, after I deploy cockroachdb cluster, I found that if I use even number of nodes for cockroachdb,
14:14:23 <tongli> the cluster won't be very stable, sometimes I see pod craches.
14:14:41 <tongli> but when I use odd number of nodes for cockroachdb cluster, then it has no issues.
14:14:55 <tongli> I think I will need more tests on this.
14:15:03 <kgarloff> cluster quorum stuff?
14:15:17 <markvoelker> YEah, pretty typical for distributed systems.
14:15:19 <dmellado> tongli: did that happen all the times?
14:15:23 <tongli> be aware that cockroachdb docker image is Alpha.
14:15:32 <dmellado> I mean, all time, even, crashed
14:15:36 <dmellado> odd, worked all the time?
14:15:44 <tongli> @dmellado, not all the time even with even number of cockroachdb nodes.
14:15:51 <zhipeng> i remember once read their blog about the scalability issue
14:15:52 <dmellado> hm
14:15:56 <tongli> yes, odd number of nodes worked fine.
14:16:01 <tongli> very stable.
14:16:14 <tongli> so it will be very nice if everybody run the workload and see the behaviors.
14:16:24 <tongli> please do read the README.rst file.
14:16:41 <tongli> if stack_size is set to 5, cockroachdb cluster will be 4 nodes.
14:16:59 <dmellado> +1, will try to do some tests
14:17:08 <kgarloff> tongli: so we need to set to 6?
14:17:11 <markvoelker> Even numbers of nodes in a distributed DB are almost always a bad idea. =)
14:17:17 <tongli> one node is used as master node, cockroachdb cluster won't use that node. so we end up with stack_size -1 cockroachdb nodes.
14:17:44 <tongli> @markvoelker, that is what I suspected, I think cockroachdb master node election may have some issues.
14:17:50 <tongli> but in theory it should work.
14:18:12 <tongli> but anyway, at patch set #37, I have everything working.
14:18:23 <tongli> and I am planning to give a demo next week to Mark.
14:18:35 <tongli> if the time is confirmed, I invite everybody to participate.
14:19:10 <tongli> this will be a remote meeting with Mark to show what has been developed,
14:19:15 <dmellado> tongli: pls do send an invite by then ;)
14:19:20 <tongli> so he may have some suggestions.
14:19:25 * markvoelker notes for posterity that tongli is talking about the other Mark (aka Sparky Collier)
14:19:30 <tongli> @dmellado, yes I will send out invite.
14:19:40 <dmellado> markvoelker: thanks for the clarification xD
14:19:51 <tongli> @markvoelker, yes, sorry, Mark Collier from the foundation.
14:20:29 <tongli> @markvoelker, I will show it to Brad Friday since he has been traveling so much lately.
14:20:51 <luzC> o/
14:20:59 <tongli> at the moment, the k8s workload is done.
14:21:12 <tongli> it works on both ubuntu and coreos images.
14:21:13 <mnaser> is there any docs so that we can try it on our existing clouds
14:21:21 <mnaser> just to have an idea
14:21:38 <dmellado> mnaser: it should mostly work as it is
14:21:44 <tongli> @mnaser, yes, please read the README.rst file.
14:21:45 <dmellado> just download tongli 's patch
14:21:53 <mnaser> may i ask for the link to the repos
14:22:02 <tongli> https://review.openstack.org/#/c/433874/37/workloads/ansible/shade/k8s/README.md
14:22:18 <dmellado> https://github.com/openstack/interop-workloads
14:22:21 <dmellado> mnaser: ^^
14:22:22 <mnaser> merci tongli and dmellado
14:22:25 <dmellado> + pls tongli 's patch
14:22:28 <tongli> that is the readme. the patch link is above. I post here again. https://review.openstack.org/#/c/433874/
14:22:39 <dmellado> you're welcome mnaser
14:23:23 <tongli> the patch set is now at #37, I am a bit tired keeping adding to it. please guys get it merged.
14:23:52 <tongli> if there are bugs (I am pretty sure it does), we can fix it.
14:24:03 <dmellado> +1, tongli I'll give it a spin locally
14:24:18 <dmellado> and if it's ok I'd say we can merge it and have it as a starting point at least
14:24:23 <tongli> I certainly do not want to be the champion in terms of number of patch set.
14:24:32 <dmellado> heh
14:25:14 <tongli> also, guys I would like everybody know that If I have stack_size set to 6, the workload finishes within 6 minutes.
14:25:23 <luzC> +1 tongli
14:25:30 <mnaser> ive done a lot of ansible work so
14:25:38 <mnaser> i can throw in patches which could speed/clean things up
14:25:40 <tongli> I have also made changes that does docker load container images.
14:26:01 <mnaser> i agree with merging stuff so that we can tweak it as we go with smaller patches, it makes review easier
14:26:14 <tongli> so that you do not have to wait for the docker images to be extracted from container image repo especially the cockroachdb image is quite big,
14:26:15 <mnaser> no one wants to go through a big merge :) (sorry you had to go through that tongli )
14:26:35 <dmellado> mnaser: feel free to propose any change you might want to ;)
14:26:50 <mnaser> i would like to do so but ideally once that big patch merges :)
14:27:18 <dmellado> worst case you can just do as markvoelker did and make your change dependant on tongli's
14:27:32 <tongli> #action, tong schedules a demo meeting with Mark Collier next week and send out invite to everybody.
14:27:49 <vkmc> +1 to smaller patches
14:28:22 <tongli> BTW, I have also requested to have a OSCI account open, so that I can run the workload against more clouds.
14:28:39 <tongli> thanks to @luzC for making it happen.
14:28:56 <luzC> you mean osic cloud tongli
14:29:08 <tongli> @luzC, yes, osic cloud
14:29:34 <luzC> ahh yes... we have a project for the challenge...
14:29:36 <luzC> :)
14:29:40 <tongli> I can log in to it, but can not create router, which needs to be resolved.
14:30:09 <dmellado> having that on OSIC would be cool ;)
14:30:22 <tongli> oh, huge updates from Interop Challenge China Chapter.
14:30:31 <dmellado> but tongli luzC actually (and maybe we can discuss that in person at boston for future work)
14:30:36 <dmellado> we'd *need* some kind of CI
14:30:51 <dmellado> I don't think that it's good at a long term to have that
14:30:59 <dmellado> 'it runs on my cloud' review approach :\
14:31:09 <tongli> there was a meeting last night and decided to use improved LAMPStack work for the keynote demo in BJ in April Global OpenSource Summit.
14:31:13 <luzC> dmellado I agree
14:31:14 <dmellado> otherwise I'll go to Boston with the 'it works on devstack t-shirt'
14:31:32 <tongli> @dmellado, haha.
14:31:38 <vkmc> hahaha yes, that would be amazing
14:31:44 <dmellado> so we would need to have maybe a subset
14:31:51 <dmellado> that would fit openstack CI requirements
14:32:02 <tongli> @dmellado, can you help with that?
14:32:20 <dmellado> I can help, but won't be able to handle that myself
14:32:33 <dmellado> I'll try to coordinate that, though
14:32:44 <dmellado> I tried squeezing everything on a 8GB dsvm
14:32:48 <dmellado> and it was a disaster
14:32:58 <tongli> @dmellado, please, let us know if someone else can help.
14:33:01 <mnaser> did you try disabling the unnecessary services
14:33:02 <dmellado> so how about getting first the workload merged and then afterwards
14:33:09 <dmellado> let's strip it out
14:33:14 * mnaser can help with some stuff
14:33:18 <dmellado> mnaser: yeah, totally
14:33:27 <dmellado> but we can sync on that if you have the time ;)
14:33:42 <mnaser> yeah, feel free to pm (do we have an interop channel where everyone spends time at)
14:33:50 <tongli> #action dmellado and mnaser work together to get CI working.
14:34:11 <dmellado> mnaser: we actually do, @openstack-interop
14:34:14 <tongli> there is #openstack-interop channel.
14:34:17 <dmellado> #
14:34:24 <mnaser> okay, cool, thanks
14:34:32 <dmellado> so far only the doc gate is enabled
14:34:47 <dmellado> I do plan to enable at least some linters once the code's around
14:34:50 <tongli> @dmellado, I would love to have more stuff tested at the gate.
14:35:04 <mnaser> we can do some linting but i think the more intresting part is having it tested against other clouds
14:35:14 <mnaser> ex: id love to gate it against our cloud? (or document how to do that)
14:35:23 <dmellado> hmm maybe a third party CI
14:35:32 <mnaser> following the "external CI" pattern used in other projects like Cinder or Neutron for example
14:35:38 <dmellado> mnaser: exactly
14:36:06 <mnaser> i'll do a bit of reading about that
14:36:06 <dmellado> I'll need to check if we can actually do that while disabling that job for the upstream one
14:36:09 <dmellado> as it just won't fit
14:36:22 <tongli> @mnaser, so at present what are the options for the third party CI?
14:36:38 <mnaser> so every $provider can listen to changes at gerrit for the interop repo
14:36:53 <mnaser> and then it would check out the change, run it against their cloud, and report results back
14:37:21 <mnaser> tongli https://review.openstack.org/#/c/338139/
14:37:28 <dmellado> that could be cool, of course at first I just won't count the 3rd party CI voting
14:37:30 <mnaser> see how there is external CIs of providers (IBM, etc)
14:37:37 * dmellado has some concerns about some external CIs, tbh
14:37:43 <mnaser> of course
14:37:45 <tongli> ok. thanks for the info.
14:37:55 <mnaser> it's a step in the right direction at least
14:38:01 <mnaser> if 6 clouds fail even if they're all non voting
14:38:05 <tongli> @mnaser, agreed.
14:38:16 <mnaser> i think we can agree we broke something :-P
14:38:25 <tongli> haha.
14:38:47 <tongli> #topic Boston SUmmit On Stage Keynote Committed Parties.
14:39:02 <tongli> currently we have 11 parties, 5 spots left.
14:39:12 <mnaser> i am not sure how we can say we'd like to do it
14:39:25 <tongli> if your company is not on the list, please make sure there is someone from your company commits to it.
14:39:31 <beisner> hi all - question: is there a reason Ocata isn't targeted in that list?
14:39:48 <mnaser> where can we find "the list" :-p
14:39:49 <kgarloff> tongli: Working on it!
14:40:00 <kgarloff> We want to be there -- just need to make sure we can run the workload
14:40:27 <tongli> @heisner, no, I just do not think we require Ocata or any particular version of OpenStack.
14:40:31 <luzC> mnaser https://wiki.openstack.org/wiki/Interop_Challenge#Boston_Summit_On_Stage_Keynote_K8S_Demo_Commited_Parties
14:40:32 <kgarloff> Or maybe I should enter there right now?
14:40:33 <dmellado> mnaser: https://wiki.openstack.org/wiki/Interop_Challenge
14:40:50 <tongli> probably not many public/private production cloud uses Ocata yet.
14:41:20 <markvoelker> beisner the idea is to test the workload on real-world products that people can get today.  No particular version is required, the list there is just what versions people have productized right now.
14:41:25 <mnaser> luzC / dmellado : thanks, added
14:41:44 <beisner> markvoelker, ok tyvm.
14:42:05 <tongli> ok, only 4 spots left.
14:42:21 <tongli> please review the patch sets, please please please.
14:42:22 <krtaylor> OpenPower is working to be there too
14:42:48 <tongli> @krtaylor, great. would love to see how the workload runs on the cloud.
14:42:49 <krtaylor> making sure we can run the workload atm
14:43:22 <mnaser> can i ask what is stopping us from merging tongli work
14:43:22 <tongli> @HelenYao, do you have any updates on the NFV workload?
14:43:33 <krtaylor> tongli, thanks, I'll ping you in channel later with a few questions
14:43:55 <tongli> @maser, good question, need +1 and +2s haha.
14:43:57 <mnaser> by 37 patch sets i think most of the things are ironed out (and its been over a month).. maybe good to get to the bottom of it
14:44:06 <HelenYao_> tongli: i am working on the test improvement
14:44:16 <HelenYao_> the deployment should be working
14:44:25 <mnaser> we can do improvements in further patches
14:44:27 <HelenYao_> the test cases are required to be polished
14:44:41 <markvoelker> mnaser: just review time.  Lots of folks traveling/out lately.  I expect it'll land shortly (I know I'm planning to finish up this week)
14:44:48 <mnaser> okay coool
14:44:49 <tongli> @HelenYao_, that is great. I have not had time to try it yet. thanks for working on it though.
14:45:22 <zhipeng> HelonYao_ we test the deployment on the M version ?
14:45:50 <HelenYao_> it supports both M and previous version
14:45:53 <dmellado> tongli: I'll +2+A your k8s patch
14:46:09 <dmellado> let's work from that -into smaller patches, please-
14:46:26 <luzC> I already +2 it
14:46:27 <HelenYao_> the deployment is tested on newton and mitaka
14:46:57 <tongli> #@luzC, thanks.
14:47:01 <dmellado> luzC: saw it, that's why I think that +2+A it
14:47:07 <dmellado> and let's split the reviews from now on
14:47:12 <dmellado> #action smaller patches, please xD
14:48:16 <zhipeng> folks could we discuss the nfv workload ? Please help review it
14:48:31 <dmellado> zhipeng: I'll review it again too
14:48:39 <tongli> @zhipeng, agreed, please review that patch set as well,
14:48:42 <zhipeng> HelenYao_ has been working crazy to meet the deadline Brad mentioned last time
14:48:48 <dmellado> overall, IIRC (and pls let me go again thru it before)
14:49:05 <dmellado> that it'd be great to have the tech details that HelenYao_ kindly explained
14:49:10 <dmellado> re: juju charms usage and so on
14:49:26 <dmellado> but I need to go again over it, will do that later on today
14:50:07 <zhipeng> i think it is better to run the workload first to see if it works, get a visional sense :)
14:50:15 <zhipeng> then dig into the tech details
14:51:05 <HelenYao_> yes. get a rough view about the process will help you better grasp the tech details
14:51:20 <HelenYao_> ping me anytime if you have problem
14:52:00 <tongli> @HelenYao_, yes. that is right, thanks a lot for your help on the workload.
14:52:34 <dmellado> I'll get to that, thaks HelenYao_ and zhipeng ;)
14:53:03 <HelenYao_> any bugs and feedback are appreciated :)
14:53:17 <zhipeng> another issue is that, let say if we were able to catch the deadline and also demo the nfv workload on stage
14:53:25 <zhipeng> we might need actual pod on the stage
14:54:00 <zhipeng> HelenYao_ plz correct me if i'm wrong, if we test the App behind VPN, there will be sound issue
14:54:24 <zhipeng> so it is better to present the demo using actual hardware
14:54:32 <zhipeng> like the OPNFV Doctor demo at Barcelona
14:54:51 <HelenYao_> yes, the VPN might block the multimedia transmission (voice/video)
14:55:31 <HelenYao_> in my lab, the VPN does not allow the multimedia
14:55:55 <tongli> @HelenYao_, we got 5 minutes left. Can we pick up this topic next week if we run out time?
14:56:54 <dmellado> +1, I also need to leave
14:56:56 <tongli> @HelenYao_, so we need to run this in a cloud which does not block voice and video?
14:56:57 <dmellado> thanks everyone!
14:57:13 <tongli> @dmellado, thanks.
14:57:26 <HelenYao_> tongli: i am fine with discussing it next week
14:57:41 <tongli> ok. let me put that on agenda for next week.
14:57:41 <HelenYao_> tongli: the VPN is supposed to allow the multimedia
14:58:02 <HelenYao_> sounds good, thx
14:58:10 <tongli> #action place NFV workload requirement discussion on next week agenda.
14:59:05 <tongli> ok, I think we pretty much run out of the time, any last minute item?
14:59:47 <tongli> all right. I think we are good for today.
14:59:54 <beisner> thanks, all
14:59:59 <tongli> Thanks everyone! have a great day!!
15:00:05 <tongli> #endmeeting