14:00:10 <tongli> #startmeeting interop_challenge
14:00:11 <openstack> Meeting started Wed Apr  5 14:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is tongli. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <openstack> The meeting name has been set to 'interop_challenge'
14:00:27 <vkmc__> o/
14:00:29 <topol> o/
14:00:31 <HelenYao> o/
14:00:33 <mnaser> o/
14:00:45 <rarcea> o/
14:00:49 <skazi_> o/
14:01:13 <tongli> let start our meeting.
14:01:22 <dmellado> o/
14:01:35 <tongli> since we had demo last meeting, we did not have a lot of time to work on the IRC things.
14:01:46 <tongli> I did not see any action item listed in the discussion.
14:01:55 <tongli> so let's look at our patches.
14:02:07 <tongli> #topic patches need review
14:02:24 <tongli> #link https://review.openstack.org/#/q/status:open+project:openstack/interop-workloads,n,z
14:02:42 <tongli> we have quite few patch sets there for review.
14:02:45 <mnaser> i made a small promise to go over these reviews, test them out and do some cleanup on them but i did not get the time :(
14:03:21 <tongli> Helen has been updating the patch and address the issues/comments.
14:03:28 <dmellado> yep, on that
14:03:29 <tongli> thanks to @HelenYao.
14:03:36 <dmellado> I've a recurrent one which hasn't been addressed yet
14:03:43 <HelenYao> thx for ur comments:)
14:03:49 <tongli> Thank to @dmellado for reviewing and with comments.
14:03:49 <dmellado> and I think it's not really that tough, besides some nits and comments
14:04:06 <dmellado> HelenYao: I was thinking that maybe I wasn't clear enough re tox env
14:04:10 <tongli> I've also added some comments there as well.
14:04:12 <dmellado> do you need some clarifications on help on it?
14:04:22 <dmellado> s/on/or
14:04:26 <tongli> the main one is that the patch does not follow the convention we have.
14:04:36 <HelenYao> dmellado: I saw ur latest comment. I will address it tomorrow:)
14:04:40 <tongli> please put it in workload/ansible/xxx/nfv.
14:04:44 <dmellado> sup, thanks HelenYao ;)
14:04:55 <tongli> xxx should be the thing that the workload uses.
14:04:58 <zhipeng> ZOOM meeting started
14:05:05 <tongli> most of our workload uses openstack shade.
14:05:14 <tongli> so they are in workload/ansible/shade
14:05:15 <dmellado> let's see if I can get zoom to work
14:05:21 <HelenYao> nfv does not use shade
14:05:26 <tongli> this one may use something else, but it is an ansible.
14:05:39 <tongli> right, that is what I was saying.
14:05:57 <tongli> whatever it uses, it should be in the sub directory.
14:06:14 <tongli> create a directory for it under ansible since this is clearly an ansible script.
14:06:32 <tongli> when you put it in nfv under workload, you have ansible, nfv at the same level.
14:06:47 <tongli> not nice. and we should not do that.
14:06:56 <tongli> there are few other smaller patch sets.
14:06:57 <HelenYao> how about I put the nfv under ansible directly?
14:07:20 <HelenYao> before we figure out what should be assigned to xxx
14:07:48 <tongli> hmmm. let's talk offline on that.
14:07:54 <HelenYao> four people are on zoom
14:08:08 <HelenYao> https://zoom.us/j/710677126
14:08:11 <HelenYao> here is the zoom link
14:08:38 <tongli> there are few other smaller patches, please review them.
14:09:02 <tongli> so @HelenYao, you wanna start the demo now due to the time limit?
14:09:09 <HelenYao> sure
14:09:17 <mnaser> what is zoom?
14:09:20 <tongli> ok, all right. let's do that.
14:09:32 <tongli> @mnaser, I assume it is the screen sharing app.
14:09:33 <HelenYao> mnaser: just click the link https://zoom.us/j/710677126
14:09:37 <mnaser> okay
14:09:39 <tongli> click on that
14:09:42 <zhipeng> mnaser it is non-gtm non-webex
14:09:45 <mnaser> nstalling
14:09:47 <HelenYao> i am sharing the screen now
14:11:18 <tongli> I can hear you fine.
14:12:13 <tongli> so that xxx should be juju (seems to me) at least.
14:12:44 * mnaser has no audio right now so ill try to tag along
14:13:12 <tongli> @mnaser, click on the button (I saw that after installed the plugin)
14:13:50 <tongli> 13 or 30?
14:13:52 * dmellado doesn't have audio either
14:13:57 <dmellado> even after installing the app...
14:14:06 <tongli> hmmmm. do not know why, I can hear her fine.
14:14:38 <mnaser> given the nfv workload isnt something i know much about, i guess i can wait part out :) sorry
14:14:58 <dmellado> tongli: nevertheless, I guesss I'm getting it
14:15:00 <dmellado> ;)
14:15:16 <dmellado> vkmc__: do you have audio there?
14:15:49 <vkmc__> dmellado: no, I'm trying to fix it
14:16:14 <dmellado> oh, got audio!!!
14:16:21 <dmellado> can heaer you now HelenYao
14:16:23 <dmellado> ;)
14:16:28 <tongli> haha. good deal.
14:16:34 <dmellado> vkmc__: it seems that the default audio output was wrong in my setup
14:16:47 <vkmc__> dmellado: got audio too!
14:24:16 <zhipeng> i'm also recording the demo now, will posted it later on youtube
14:25:08 <dmellado> thanks zhipeng
14:25:16 <tongli> haha. @zhipeng, that will be nice.
14:38:27 <zhipeng> my home network just crashed my ZOOM ...
14:42:20 <tongli> #action need to schedule the meeting with Mark to show him the demo
14:45:15 <tongli> ok, we are back.
14:45:24 <tongli> back on the agenda.
14:45:32 <beisner> o/   good to see that in action thx HelenYao
14:45:46 <topol> back from the two dimensional world to the one dimensional world (typing text only) :-)
14:45:51 <tongli> #topic, on stage show requirements and dates.
14:46:18 <tongli> I created this etherpad for the show.
14:46:21 <tongli> #link https://etherpad.openstack.org/p/interop-challenge-boston-onstage
14:46:49 <tongli> please start fill up the information. The foundation will be using this to communicate with everybody
14:46:57 <dmellado> tongli: so, just a quick question
14:46:59 <tongli> make sure that you have accurate information on the pad.
14:47:01 <dmellado> re: that one
14:47:06 <dmellado> so, we're supposed to have
14:47:11 <dmellado> saturday *or* sunday
14:47:16 <dmellado> then monday
14:47:22 <dmellado> and then the final one, isnt' it?
14:47:40 <tongli> @dmellado, yes, let's talk about that, I have it after this topic,
14:47:45 <tongli> but that is fine.
14:48:11 <tongli> seems to me everybody is prefer having two rehearsals on Sunday & Monday,
14:48:17 <tongli> not Saturday & Monday,
14:48:23 <tongli> is that correct?
14:48:26 <dmellado> +1 on Sun/Mon
14:48:33 <dmellado> it'll be really, really tight for me at least
14:49:11 <markvoelker> +1 for sun/mon
14:49:15 <tongli> if no objection, I will tell Tamara that we will show up on Sunday afternoon for tech check (first rehearsal).
14:49:22 <tongli> then Monday for the second.
14:49:24 <vkmc> +1 on Sun/Mon
14:49:47 <tongli> most likely I will be there Saturday (Brad oks it I assume).
14:50:17 <tongli> let me know if you need help or at least keep me posted so that I can talk to Tamara on what is going on.
14:51:05 <tongli> is there any other questions after you go through the Etherpad on dates, requirements, company logo, etc?
14:51:38 <tongli> every company has to send high resolution logo to Maria. this is absolutely mandatory.
14:51:53 <dmellado> tongli: any deadline on the logo, just to be safe on that?
14:52:17 <ksumit> +1 for Sun/Mon
14:52:27 <tongli> 4/17 is the deadline for everything like signup, commit to the on stage demo
14:53:13 <tongli> ok. if no question, then we move on to the next topic.
14:53:32 <tongli> #topic running the workload and report results.
14:54:24 <tongli> has any one run the k8s workload already? any problems?
14:54:37 <dmellado> yep, working
14:54:46 <dmellado> posted the results on the wiki, no problems so far
14:55:01 <tongli> @dmellado, thanks. anybody else?
14:55:38 <tongli> I think that the foundation may want to have multiple public cloud to join one bigger cockroachdb cluster.
14:55:46 <tongli> as we have discussed during last meeting/demo.
14:55:55 <tongli> how many of you guys can do that?
14:56:12 <dmellado> hmm, tongli how would you propose to do that?
14:56:35 <tongli> this basically means we setup one cockroachdb cluster, then ask the second cloud nodes to join.
14:56:43 <tongli> then third, then fouth.
14:57:14 <tongli> say I stand up 3 nodes cockroachdb cluster, then @dmellado, your nodes will join mine.
14:57:28 <tongli> other public clouds follow.
14:57:31 <dmellado> I'm just wondering about the routing and so forth
14:57:44 <vkmc> yeah, are there some guidelines on how to set up this?
14:57:44 <dmellado> and that we should get to try that before any demo'ing
14:57:46 <tongli> if you have public cloud, this should not be a problem.
14:57:56 <vkmc> that is something we should test in advance
14:58:11 <tongli> @vkmc, we need to look into the details, in theory, there should be no problem.
14:58:42 <dmellado> tongli, I'd say that this could be a nice to have, but not mandatory
14:58:44 <skazi_> @tongli: what about the time? how long does it take for the nodes to sync?
14:58:44 <tongli> @vkmc, agreed, we have to try everything and make sure no breaks.
14:59:00 <dmellado> and that we should focus on getting at least the k8s thinkg up and running
14:59:02 <tongli> @skazi_, have no idea.
14:59:04 <dmellado> and we'll see after it
14:59:14 <dmellado> I don't want ourselves to overcommit and fail on stage
14:59:17 <dmellado> that's just my 2 cents
14:59:20 <tongli> ok, please run the workload. and report back.
14:59:25 <tongli> we run out of time.
14:59:32 <tongli> we will be kick out of the channel.
14:59:41 <beisner> cheers, all
14:59:47 <tongli> let's talk more offline. thanks guys.
14:59:50 <dmellado> +1
14:59:51 <tongli> #endmeeting