14:01:30 <topol> #startmeeting interop_challenge
14:01:31 <openstack> Meeting started Wed Apr 19 14:01:30 2017 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:34 <openstack> The meeting name has been set to 'interop_challenge'
14:01:52 <topol> Hi everyone, who is here for the interop challenge meeting today?
14:02:08 <ksumit> Here!
14:02:11 <skazi_> o/
14:02:22 <HelenYao_> o/
14:02:24 <rarcea> o/
14:02:25 <vkmc> o/
14:02:28 <mnaser> o/
14:02:35 <dmellado> o/
14:02:36 <zhipeng> o/
14:02:45 <topol> Tong Li is in China today and not able to connect to IRC so I'm running the meeting today
14:03:11 <topol> The agenda for today can be found at:
14:03:12 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-04-19
14:03:12 <topol> We can use this same etherpad to take notes
14:03:17 <zhipeng> Tong is in Beijing ?
14:04:22 <topol> Yes I believe so.  The big Open Source conference being held there
14:04:52 <zhipeng> yeah i'm here as well
14:04:54 <zhipeng> lol
14:05:01 <dmellado> zhipeng: just grab him along xD
14:05:07 <topol> Look for him!
14:05:21 <zhipeng> gotta do that tmr
14:05:39 * topol tongli needs to learn zhipeng magic tricks for conencting to irc from China
14:05:41 <zhipeng> topol will Mark be here today ?
14:05:55 <topol> zhipeng not sure. I dont think so
14:06:02 <topol> Agenda:
14:06:02 <topol> #topic Review last meeting action items
14:06:02 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-04-12-14.01.html
14:06:20 <zhipeng> i think last week Mark said he could review the demo this week ?
14:06:41 <topol> zhipeng which demo?
14:06:48 <topol> NFV one?
14:07:00 <zhipeng> yep
14:07:29 <topol> K, will have to take an action item on that unless Mark shows up
14:07:34 <topol> sparkcollier?
14:07:45 <topol> sparkycollier
14:08:04 <topol> so here is what  I have
14:08:04 <zhipeng> sparkycollier_
14:08:12 <topol> please required information on the boston onstage etherpad.
14:08:12 <topol> Identify if your cloud is public or private on the boston onstage etherpad.
14:08:13 <topol> Identify if your cloud will be able to allow access on port 26257
14:08:14 <topol> Remember to identify phase 1 only folks so they get screen time as well
14:08:42 <beisner> o/
14:08:59 <dmellado> o/ hey topol, check the etherpad, I've added some topics there too
14:09:00 <dmellado> ;)
14:09:17 <dmellado> should we go quickly over the in-review patches
14:09:18 <dmellado> ?
14:09:35 <topol> dmellado sure.
14:09:50 <mnaser> fyi anyone who wants to put that information - https://etherpad.openstack.org/p/interop-challenge-boston-onstage
14:09:51 <topol> the only thing Iwanted to mention is #link https://etherpad.openstack.org/p/interop-challenge-boston-onstage
14:10:09 <topol> only has 13 folks. we are missing 3. Tamara wants those added ASAP
14:10:42 <dmellado> topol: pls do note that basically vkmc and me are each other backup
14:10:42 <topol> but demallado go ahead with the in-review patches
14:10:55 <dmellado> but we'd love to make it so both of us have access and so ;)
14:10:58 <dmellado> so on the patches
14:11:04 <dmellado> #link https://review.openstack.org/#/q/status:open+project:openstack/interop-workloads,n,z
14:11:20 <topol> dmellado noted.  so you won't both be on stage/
14:11:30 <dmellado> from my side I'd love to have some eyes on https://review.openstack.org/#/c/457199/
14:11:44 <dmellado> topol: yep, exactly, but we'd need access granted for both of us, just in case
14:12:07 <topol> #action all please review #link  https://review.openstack.org/#/c/457199/
14:12:51 <dmellado> on the NFV from zhipeng, could you please rebase it? a recent change has put it on merge conflict ;)
14:12:57 <dmellado> https://review.openstack.org/#/c/439492/
14:13:02 <topol> #action dmellado and vkmc please email tamara and let her know your alls intentions and cc topol and tongli
14:13:09 <dmellado> will do ;)
14:13:12 <zhipeng> helen could do it
14:13:30 <vkmc> :)
14:13:47 <HelenYao_> dmellado: sure, I will solve the conflict
14:14:13 <dmellado> topol: on your side I'm not sure if you'd like to make some comments on here
14:14:15 <dmellado> https://review.openstack.org/#/c/456446/
14:14:25 <dmellado> I guess phase2 would depend on it, isn't it?
14:14:28 <topol> dmellado I'll take a look
14:15:21 <dmellado> Anyone wants to comment any another patches?
14:15:27 <dmellado> topol: thanks!
14:15:35 <topol> dmellado why was centOS support needed?
14:15:49 <mnaser> a silly randomness... https://review.openstack.org/#/c/454711/
14:15:53 <dmellado> topol: I wanted to add that on top of only having ubuntu/coreOS
14:15:53 <topol> the cockroach guys need it?
14:15:59 <mnaser> (which i really really had to fix because i cant stand messed up rst links :D)
14:16:06 <dmellado> basically to mimic what's on the upstream openstack CI
14:16:34 <dmellado> rarcea: I'm not sure if you'd be interested on adding opensuse there too
14:16:35 <topol> dmellado do you plan to run centos on stage?
14:16:59 <dmellado> topol: well, I guess we'll all have to agree on the same image, but wanted to discuss that too
14:17:00 <rarcea> dmellado: might be a good idea, but short on time
14:17:15 <topol> rarcea +++
14:17:24 <mnaser> rarcea ++
14:17:30 <topol> short on time is correct
14:17:44 <topol> I will do a review
14:17:48 <dmellado> thanks topol
14:17:50 <mnaser> we need to make sure this is as stable as it gets and freeze it to avoid on-stage embarassements :X
14:18:02 <topol> hoping the patch doesnt break what we have :-)
14:18:27 <dmellado> well, documentation should be good, and we have at least CI for it xD
14:18:31 <topol> mnaser. yes exactly.  Need to goto critical fix only very soon
14:19:11 <dmellado> should we go to the next topic?
14:19:22 <topol> tongli and I fly to Austin next week for rehearsal.  Will be hard to get us to add anything new after that
14:19:33 <topol> dmellado. sure
14:19:34 <dmellado> gotcha
14:19:38 <dmellado> #topic     Issues with cockroachdb container image
14:19:43 <dmellado> I sent an email to tongli about this
14:19:50 <dmellado> but it seems that there's a bug on the cockroach image
14:19:56 <vkmc> so everything that is going to be on the summit has to be merged before next week?
14:20:08 <dmellado> #link https://hub.docker.com/r/cockroachdb/cockroach-k8s-init/
14:20:12 <vkmc> this includes tongli's patch on having a multicluster cockroach db deploy
14:20:17 <topol> vkmc that would be my preference
14:20:26 <topol> but I may get outvoted if need be
14:20:29 <dmellado> hmm maybe we'll be short on time for that...
14:20:39 <dmellado> so, on here I propose to deprecate the var of custom domain name
14:20:49 <topol> I'll check with Tongli to see what he's comfortable with
14:20:49 <dmellado> as it makes the cockroachdb unable to deploy
14:20:52 <mnaser> if the multicluster doesnt get merged, it means phase 2 of the demo doesn't happen
14:20:55 <dmellado> idk if anyone tried that
14:21:10 <topol> mnaser then we need to merge that
14:21:20 <dmellado> #action review phase 2 patch (all)
14:21:32 <sparkycollier_> Sorry I'm late y'all
14:21:33 <topol> obviously anything needed for phase 2 we will need to get merged
14:21:45 <topol> hi sparkycollier_
14:21:59 <dmellado> o/
14:22:03 <topol> some folks thought they were going to show you a demo today?
14:22:13 <sparkycollier_> Oh I'm sorry
14:22:26 <dmellado> topol: if it's going to be like that maybe we should send a FF email to the ml, with the agreed date
14:22:27 <sparkycollier_> I am in a car
14:22:54 <topol> dmellado are we not close?
14:23:05 <mnaser> dmellado ++
14:23:06 <dmellado> we are totally close
14:23:13 <topol> sparkycollier. maybe demo next week then?
14:23:18 <mnaser> i think having a hard cutoff would be good
14:23:23 <dmellado> but IMHO it'd be cool to have this done so folks are aware
14:23:50 <topol> whats a cutoff date everyone finds reasonable?
14:24:11 <sparkycollier_> Sure next week is good
14:24:12 <topol> Tong and I have rehersals next Tuesday
14:24:33 <sparkycollier_> We can just view it next week in Austin during rehearsal
14:24:42 <sparkycollier_> I will be there
14:24:56 <dmellado> so let's assume 1 week
14:24:58 <dmellado> at least
14:25:06 <dmellado> does this sound reasonable to all?
14:25:22 <mnaser> so that means that on the next meeting
14:25:49 <mnaser> we close things out and dont touch the code anymore (barring major issues)
14:25:52 <mnaser> i think that's reasonable. it gives us one more meeting before the event as well to run through things
14:25:54 <topol> mnaser lets try and freeze stuff by next meeting
14:26:02 <dmellado> +1
14:26:03 <vkmc> I think that's reasonable
14:26:09 <dmellado> topol: will you be sending the email then?
14:26:09 <ksumit> +1
14:26:11 <dmellado> ;)
14:26:18 <topol> dmellado sure
14:26:26 <mnaser> and then for the may 3rd meeting, it would be nice if everyone ran the workload after the 26th freeze
14:26:33 <mnaser> so that on the 3rd, we can discuss any bugs anyone ran into
14:27:06 <mnaser> and then on the 3rd hopefully we have no bugs and everything is 100% frozen till the demo date
14:27:29 <topol> #action topol to send we freeze demo on the 26th email to the list  and on the 3rd discuss any bugs
14:27:41 <dmellado> should we go ahead?
14:27:54 <mnaser> i think it makes sense
14:27:57 <topol> who wanted to demo NFV to sparkycollier_
14:28:08 <HelenYao_> topol: me
14:28:09 <zhipeng_> me and helen I think
14:28:27 <sparkycollier_> Ah ok I forgot it was for nfv
14:28:54 <sparkycollier_> I'll be at a computer in about 10 minutes if that's not too late
14:28:58 <sparkycollier_> Or we can do it next week
14:29:16 <topol> I rather do that in 10 minutes
14:29:22 <zhipeng_> agree
14:29:27 <topol> next week I think will be packed
14:29:31 <sparkycollier_> Ok great
14:29:43 <topol> ping us when you are at a computer
14:29:46 <sparkycollier_> K
14:29:54 <topol> next item
14:30:02 <dmellado> #topic     Make sure all folks who plan to demo are on the onstage etherpad.  we should have 16 listed.
14:30:08 <dmellado> I guess you asked for this before, topol
14:30:19 <dmellado> but pls anyone who still hasn't signed up there, do so
14:30:33 <topol> yes. yes I did. we are missing 4 I think
14:30:53 <dmellado> #topic     Identify which cloud can demo phase 2.
14:30:57 <topol> since you and vkmc are one really
14:31:05 <dmellado> we've got this tracked on the etherpad
14:31:14 <topol> K
14:31:16 <dmellado> but it'd be cool to identify which public clouds are around
14:31:48 <dmellado> and regarding this idk if we'll be in a rush
14:31:49 <mnaser> o/ public cloud
14:31:50 <topol> #topic Clouds should start record their workload run results.
14:32:05 <topol> mnaser fdid you putthat on the etherpad
14:32:09 <mnaser> yep :)
14:32:19 <topol> mnaser gold star! awesome
14:32:36 <daniela_ebert> already done and recorded at the etherpad ;)
14:32:45 <dmellado> so, on this topic I guess you refer to the wiki
14:32:47 <topol> everyone please start trying to runt he workloads. we always hit surprieses
14:33:00 <topol> dmellado ++
14:33:11 <dmellado> https://wiki.openstack.org/wiki/Interop_Challenge
14:33:17 <mnaser> on that note, do we have a 'backup' plan at all for if things go wrong?
14:33:27 <mnaser> (murphy's law)
14:33:28 <dmellado> mnaser: we just go for beers
14:33:29 <dmellado> xD
14:33:50 <mnaser> lol!
14:33:54 <sparkycollier_> I'll just have the beers brought out
14:34:02 <mnaser> i dont know what everyone thinks but i was thinking that we have 2 tenants on clouds
14:34:10 <vkmc> topol, dmellado and I are two different engineers, he is not my alter ego
14:34:10 <mnaser> we do a deploy beforehand and leave it, then do one live
14:34:20 <mnaser> if the live works, great, if not, then we can just show the already deployed
14:34:26 <dmellado> lol
14:34:38 <dmellado> vkmc: what he meant by that is that we won't be both of us at the stage
14:34:44 <dmellado> unless you want to join the fun xD
14:34:48 <vkmc> dmellado, oh yes, that would be awkward
14:34:51 <topol> of course I like vkmc.  I can just barely tolerate dmellado :-)
14:34:59 <dmellado> lol
14:35:06 <topol> j/k
14:35:10 <vkmc> lol
14:35:13 <zhipeng_> for nfv demo, please join https://zoom.us/j/333408319
14:35:49 <mnaser> so any input on the "backup environment" idea or everyone's 100% confident?
14:35:57 <topol> so where did folks add public? I dont see it on the wiki
14:36:22 <dmellado> topol: it's on the etherpad, I assume that anyone listed there for phase2 should be count as 'public'
14:36:23 <mnaser> oh i dont see it on the wiki but i see it on the interop challenge etherpad
14:36:51 <topol> ok lets all make sure we update in the same place. which is?
14:36:59 <mnaser> https://etherpad.openstack.org/p/interop-challenge-boston-onstage
14:37:17 <topol> mnaser YES! #link https://etherpad.openstack.org/p/interop-challenge-boston-onstage
14:37:22 <topol> put it there
14:37:53 <topol> I need to go thru and find the 3 folks on the wiki that arent on https://etherpad.openstack.org/p/interop-challenge-boston-onstage
14:38:26 <topol> with my diff skills that could only take an hour or two :-0
14:38:37 <mnaser> silly question but how come there's two people from redhat?
14:38:45 <dmellado> mnaser: scroll up
14:38:50 <dmellado> we're not two of us at the same time
14:38:59 <topol> mnaser I think they are worried one wont make the prep meeting?
14:39:04 <dmellado> we put our details as vkmc will be backing me up in case ;)
14:39:09 * mnaser totally knew that
14:39:19 <mnaser> just testing everyone's attention, onto the rest
14:39:22 <vkmc> I'm the backup!
14:39:34 <topol> they will flip a coin to see who gets on stage.  its like the preshow
14:39:47 <vkmc> haha
14:39:55 <topol> Here was the note from Tamara and then I think we should do the demo
14:40:00 <topol> that was my last topic
14:40:26 <dmellado> Here I added another one
14:40:27 <topol> Hi Tong -
14:40:27 <topol> I’d like to schedule the Interop Demo Tech on Sunday, May 7th as follows:
14:40:27 <topol> Arrive: 3:15pm
14:40:29 <topol> Tech 3:25-3:55pm
14:40:31 <topol> If there are a few people who cannot arrive right at 3:15pm, that will be fine since it takes some time to get everyone plugged in & up / running in our system.
14:40:33 <topol> Decision we have made during the meeting:
14:40:35 <topol> 
14:40:37 <topol> 1. phase 1 of the demo is to stand up kubernetes cluster on top of openstack. every cloud can participate.
14:40:39 <topol> 2. phase 2 of the demo is to create a cockroachdb cluster on top of k8s across multiple clouds, hope all clouds can join.
14:40:41 <topol> 3. work on the app so that running cockroachdb cluster will have some load to show actitivites on the cockroachdb dashboard.
14:40:43 <topol> 4. create a simple app for clouds to get the IP information about the first cockroachdb node so that they can join.
14:40:45 <topol> 5. that simple app will be started before the demo so that that IP can be used in all cloud workload configuration
14:41:07 <dmellado> I'm concerned about how log would this last if we need to run both phase 1 and 2 taking into consideration that this lasts for around 10' each
14:41:22 <dmellado> shouldn't we settle for phase1 and check on the demo day if phase2 would be feasible
14:41:24 <dmellado> ?
14:41:51 <topol> Tong and I will be with sparkycollier next week testing out the flow
14:42:08 <topol> there are ways we can speed up phase 2
14:42:20 <topol> can do cooking show if necessary
14:42:26 <mnaser> topol ++
14:42:37 <dmellado> mybe just not respawning the whole k8s cluster but deploying an additional pod
14:42:39 <dmellado> for the phase 2
14:42:50 <topol> sparkycollier_ you in front of a computer yet?
14:43:00 <sparkycollier_> i'm on a computer now
14:43:16 <zhipeng_> please join https://zoom.us/j/333408319
14:43:33 <topol> K, lets all switch to  zoom
14:58:30 <topol> #endmeeting