14:01:52 <tongli> #startmeeting interop_challenge
14:01:53 <openstack> Meeting started Wed Apr 26 14:01:52 2017 UTC and is due to finish in 60 minutes.  The chair is tongli. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:56 <openstack> The meeting name has been set to 'interop_challenge'
14:02:05 <markvoelker> o/
14:02:11 <skazi_> o/
14:02:12 <tongli> Hi everyone, who is here for the interop challenge meeting today?
14:02:14 <vkmc> o/
14:02:16 <ksumit> o/
14:02:17 <vkmc> hi all!
14:02:19 <topol> o/
14:02:26 <zhipeng> o/
14:02:31 <dmellado> o/
14:02:51 <kongwei> o/
14:03:03 <tongli> glad to see a lot of folks here.
14:03:22 <tongli> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-04-26
14:03:34 <tongli> that is the etherpad with today's agenda.
14:04:10 <tongli> before I start with that, I would like to give you some updates on the rehearsal Brad and I did with Mark in Austin yesterday
14:04:56 <tongli> many people from foundation who play various roles for the summit were there while brad and I showed the demo.
14:05:09 <tongli> the demo went well. here is how we are going to do this.
14:05:45 <tongli> Mark and cockroachdb and coreos guys will start a session on coreos/cockroachdb for about 5 minutes.
14:05:57 <tongli> that is like a prelude for our session.
14:06:29 <tongli> during that session they will create the first cockroachdb cluster.
14:07:07 <tongli> then the show will move on to ours, mark will call out the long tables (two this time) and all the demoers to be on stage.
14:08:00 <tongli> then he will give a signal for everybody to start the workload, at this time, you only suppose to setup k8s cluster on your openstack cloud. while you are doing that, Brad and Mark will start talking
14:08:36 <tongli> this is the called the first phase of the demo.
14:09:12 <tongli> while you are running the workload, Mark and Brad probably will ask you some questions about the workload such as what it is doing at present.
14:09:33 <tongli> your screen will be shown to the audience.
14:09:49 <tongli> you suppose to talk about what is going on with the workload.
14:10:25 <tongli> possibly showing the console which has the workload running and scrolling.
14:10:54 <tongli> possibly the openstack dashboard, showing created security groups, rules, vms, volumes.
14:10:55 <tongli> etc.
14:11:25 <tongli> Once the workload is complete, you may be asked to show the k8s dashboard,
14:11:59 <tongli> show the pods, services, nodes etc. it is to show that the k8s is indeed up running on openstack cloud.
14:12:01 <beisner> o/
14:13:01 <tongli> once this part is done, Mark will ask one demoer at a time to do the second phase which is to join the cockroachdb cluster that was created in the prelude.
14:13:42 <tongli> hopefully that an IP address is reserved so that everybody will have that IP address before the summit get started.
14:14:01 <topol> one small fix.  Brad and Mark will talk about  whats new in this Interop Challenge for about a minute before Mark tells everyone to start the challenge (kick off their Ansible scripts)
14:14:11 <tongli> it is possible that Mark may ask up to 4 or 5 clouds to join in.
14:14:44 <tongli> @topol, thanks Brad for the correction.
14:15:09 <tongli> if you are private cloud, most likely you will be asked during the first phase.
14:15:28 <daniela_ebert> tongli: and mark will show in 5 minutes, how th join the cluster, right?
14:15:38 <tongli> if you are public cloud, most likely you will be asked to join the cockroachdb cluster created in the prelude.
14:16:09 <tongli> that will be the entire show.
14:16:24 <tongli> @daniela_ebert, I do not think I understand your question.
14:16:48 <topol> at the end the cockroachdb guys will show the public clouds joining their cockroachdb cluster
14:17:31 <tongli> Mark will ask one demoer at a time to join the first cockroachdb cluster which gets created before our segment.
14:18:03 <daniela_ebert> @tongli: are there instructions, how to join the cluster?
14:18:03 <tongli> when he asks, demoer will simply run a command ansible-playbook with tags
14:18:18 <tongli> that part should complete within 20 seconds.
14:18:21 <daniela_ebert> tongli: got it
14:18:49 <tongli> then mark and the cockroachdb guys will show the cockroachdb dashboard while your screen is also displayed.
14:19:17 <tongli> the cockroachdb dashboard will display increased number of nodes in its cluster.
14:19:30 <skazi_> tongli: are you going to put some data on the initial cluster?
14:19:52 <tongli> @skazi_, that is up to the prelude session.
14:20:21 <tongli> when our node join the first cluster, we have one container in the cockroachdb pod which generate loads.
14:20:36 <dmellado> tongli:
14:20:57 <dmellado> in any case, I would've liked to have been aware of all these plans beforehand
14:21:04 <tongli> the initial cluster gets created by cockroachdb guys before our show, we can careless what is there already.
14:21:12 <dmellado> and discussed them...
14:21:24 <dmellado> the multi cluster patch's still on review...
14:21:27 <dmellado> https://review.openstack.org/#/c/456446/
14:21:50 <tongli> yes, it is. wished more people review them and run them and commented on.
14:22:04 <tongli> but that was the code I showed to Mark and foundation yesterday.
14:22:17 <tongli> Any other questions on the flow of the show?
14:22:51 <ksumit> Will we be rehearsing beforehand to point to Mark who has a private cloud (phase 1) and public cloud (phase 2) ?
14:23:26 <tongli> @ksumit, we will have rehersal Monday afternoon.
14:23:39 <dmellado> wasn't on Sun afternoon too?
14:23:51 <vkmc> it feels wrong that the patch for the phase 2 haven't been merged yet and we are considering it to show on stage
14:23:51 <tongli> Sunday afternoon is just tech check.
14:23:59 <dmellado> I mean, I get the feeling that we're been to rush on this
14:24:10 <dmellado> to/too
14:24:12 <tongli> making sure that the equipment all work like your laptop can show on the big screen. connection, etc.
14:24:14 * dmellado blames his keyboard...
14:24:58 <tongli> @vkmc, summit is in exactly two weeks.
14:25:09 <vkmc> I'm aware
14:25:15 <tongli> well actually one day less than two weeks.
14:25:23 <tongli> we just need to get things done.
14:25:37 <dmellado> @tongli that's quite rushed for me, if you take bank holidays also into consideration...
14:25:37 <tongli> start running the workload and review the workload.
14:25:55 <tongli> @dmellado, I know.
14:25:58 <dmellado> + we set a FF for *today* actually
14:26:02 <markvoelker> tomgli: so for the second part of the demo, are we only doing public clouds?  Just wondering if I should still be planning to execute this in an environment w/external access.
14:26:11 <vkmc> I agree, but we cannot show something that is not ready
14:26:56 <tongli> @markvoelker, as long as you have a way to make sure that the pods can communicate with external world, then you are ok.
14:27:18 <markvoelker> tongli: ok, thanks. I'll continue planning for such an environment then.
14:27:22 <dmellado> @tongi, overall, besides what vkmc said, my concern is that there are quite a few plans that have been set up without taking all the participants into consideration
14:27:23 <tongli> like the pod can hit other cloud and other cloud can hit your pods.
14:27:31 <dmellado> I mean, all that stuff about cockroachdb guys and so
14:27:39 <dmellado> cool, but we shoul've discussed it as a part of a meeting
14:27:51 <dmellado> should've
14:28:12 <topol> dmellado, the cockroach stuff was Mark Colliers vision
14:28:28 <tongli> @dmellado, yeah, I know. many things came quite late.
14:28:29 <topol> if we want on his keynote stage we have to make him happy
14:28:38 <markvoelker> dmellado: I feel like we've been talking about the technical part of the demo for quite some time.  The flow tongli laid out is pretty much what I had pictured really.  Just my opinion though.
14:28:40 <dmellado> topol: but who knew this? who discussed it? basically you and the foundation, leaving us aside...
14:29:08 <dmellado> I mean, I can live with it but would've loved to set the things in a more open way
14:29:10 <topol> thats not true. check the meeting notes. we have even had the cockroach guys at our irc meetings
14:29:20 <dmellado> topol: I'll check
14:29:38 <dmellado> I couldn't make it for a few meetings so that could've been it
14:30:05 <tongli> @dmellado, please do, the cockroachdb patch has been in for quite some time.
14:30:25 <tongli> ok. if no other question on the flow of the show, we should go into our agenda.
14:30:34 <tongli> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2017-04-26
14:30:38 <tongli> that link again.
14:30:55 <topol> in any case the cockroach piece is a phase two that does a wrap up. none of our screens are shown. they will show the cockroachdb display from the cockroach guys
14:31:11 <tongli> @topol, that is not true.
14:31:22 <tongli> remember we talked about the screen in screen.
14:31:36 <topol> tongl thats true.
14:31:46 <tongli> both demoer's screen and cockroachdb guys dashboard will be shown at the same time.
14:31:55 <tongli> and you can be asked for questions.
14:32:10 <topol> but my point is the focus will be on seeing the public clouds show up on the cockroach display
14:32:23 <tongli> @topol, true.
14:32:34 <tongli> ok. action items
14:32:37 <topol> I think it will mostly be Mark pointing at folks and saying "now you join"
14:32:45 <tongli> #topic action items from last meeting.
14:32:59 <tongli> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-04-19-14.01.html
14:33:30 <tongli> there is an action for dmellado and vkmc.
14:33:50 <tongli> any update on that @dmellado and @vkmc?
14:33:57 <dmellado> oh, to contact the foundation about the backup status
14:34:01 <dmellado> will do that today
14:34:13 <dmellado> shouldn't be affecting the demo in any case ;)
14:34:30 <tongli> ok. good. I was in China and had no idea what that is about.
14:34:56 <tongli> I wonder who has not sent the high definition company logo to Maria yet.
14:35:27 <tongli> if yours is still missing, I am not sure if foundation has time to make a logo for you. so please double check with Maria.
14:35:50 <tongli> other actions are for reviewing patches and freeze the code.
14:36:00 <tongli> seems conflicting each other.
14:36:19 <dmellado> tongli: totally, well, originally we were speaking about having a Code Freeze today
14:36:31 <dmellado> but obviously that can't be done if your patch's on review
14:36:32 <tongli> well, any way, let's look at the patch sets to be reviewed.
14:36:35 <topol> at this only essential bug fixes and what we need to support the cockroach phase 2 should go in
14:36:53 <topol> defer the rest til after the challenge
14:37:13 <tongli> #topic patch set review
14:37:24 <tongli> @topol, I am ok with that.
14:37:32 <tongli> #link https://review.openstack.org/#/q/status:open+project:openstack/interop-workloads,n,z
14:37:58 <vkmc> we have sent RH logo already, so that is done
14:38:12 <dmellado> https://review.openstack.org/#/q/project:openstack/interop-workloads+status:open
14:38:28 <tongli> I have reviewed most of these patch sets. cores please review and at least let the author know what you think.
14:39:26 <dmellado> I wanted to discuss on what to do with the NFV workload too
14:39:26 <tongli> the main one is this one
14:39:36 <tongli> #link https://review.openstack.org/#/c/456446/
14:40:04 <tongli> only daniel and Mark reviewed it. need everybody start running it.
14:40:15 <dmellado> zhipeng: I can live with it merged, but I'd love to have a follow up patch on some stuff ;)
14:40:50 <tongli> @markvolker, please get some errors, I can take a look when I get back. still in Austin now, will be home tonight.
14:40:53 <markvoelker> tongli: I was picking through this a little more last night.  I have a two-or-three liner that would swap this back to using the private address for the k8s cluster
14:41:34 <tongli> @markvoelker, using floating IP should work even in standalone case.
14:41:36 <markvoelker> tongli: The basic problem is that in many setups nodes on the same private subnet need to use private addresses for communication with each other due to either port security or the way SNAT is setup w/various networking plugins
14:41:48 <tongli> I've also tested that many times.
14:41:51 <zhipeng> dmellado no problem :)
14:42:00 <dmellado> tongli: markvoelker btw, do you know if we addressed OVH issues with non-FIP?
14:42:07 <dmellado> zhipeng: thanks!
14:42:19 <markvoelker> I actually only ran into this b/c I happened to run it in an environment that happened to have such a SNAT issue with an older version of SDN plugin
14:42:33 <tongli> @markvoelker, are you saying that the floating IP can not be used to talk to machines on the same tenant network?
14:42:50 <markvoelker> tongli: Yes.
14:43:17 <tongli> @markvoelker, I do not know if that is a good thing. probably should be considered an issue with the cloud?
14:43:22 <markvoelker> (not in all setups, but in many...this is very dependent on the network plugin and topology)
14:43:52 <markvoelker> tongli: It's often associated with security decisions.  From an interoperability point of view, I think it's a risk.
14:44:44 <markvoelker> tongli: to be clear, I can personally make this work, but I think from a broader perspective it's a bit risky from an interop perspective.
14:45:24 <tongli> @markvolker, so in this case, you would rather use private IPs?
14:45:48 <markvoelker> It's also kind of undesirable from a networking perspective in that in many topologies you'll be hairpinning traffic through a router and NAT unnecessarily
14:45:58 <tongli> that can be done easily, just a bit more code. I was thinking about that and actually did that in earlier patch set.
14:46:43 <markvoelker> tongli: I think it would be more interoperable if we did use private IP's.  It's quite simple to do (like I said: a couple lines of code).
14:46:48 <markvoelker> I'd like to test that with phase 2 though
14:46:57 <tongli> @markvoelker, my concern is that when you setup the first cluster (which is standalone), then you have others join in.
14:47:13 <tongli> in that case, if your first cluster is using the private IP, the whole thing breaks down.
14:47:43 <markvoelker> tongli: Ah.  To be clear, I'm talking about using private IP's for the K8s cluster, not the cockroach bits.
14:47:57 <markvoelker> This might be clearer if I just sent you some code once I test it this afternoon. =)
14:48:13 <tongli> hmmm. I thought the issue was for the cockroachdb cluster.
14:48:25 <tongli> ok. we can talk offline.
14:48:29 <tongli> we run out time.
14:48:41 <dmellado> tongli: besides that I put a comment on the etherpad
14:48:58 <dmellado> on the proposed dates for checking in May
14:49:00 <tongli> the bank holiday? @dmellado?
14:49:05 <dmellado> yep
14:49:08 <markvoelker> YEah, basically later today I'll have two separate environemnts set up that I can test the changes with for phase 2 and I'll ping you after.
14:49:29 <tongli> I am planning to have a one hour window that all of us get on irc channel and start running the workload.
14:49:33 <dmellado> I'd be easier if we could move that maybe to 5/4 and 5/4
14:49:39 <tongli> that will be the only time we can actually do this together.
14:49:44 <dmellado> 5/3 and 5/4
14:49:53 <tongli> if we do it Monday, we may get a bit of time to fix issues.
14:50:21 <tongli> the early next week will be the only time for us to do this unless we want to do it on Friday.
14:50:31 <dmellado> I get your point, but a ton of folks, me included, won't be working
14:50:40 <tongli> 5/1?
14:50:48 <dmellado> 5/1 and 5/2 are bank holidays
14:50:58 <tongli> ah, both days?
14:51:01 <dmellado> yep
14:51:24 <tongli> I should move to europe.
14:51:35 <dmellado> worst case if you want, keep one day there and move another one to have US / EMEA
14:51:37 <dmellado> xD
14:51:38 <markvoelker> Hmm...personally I'm not sure I'll have an externally-facing environment on 5/1-2 actually, but I'll check.
14:51:42 <tongli> how about others?
14:52:13 <vkmc> I can make it on 5/2, but 5/1 is a holiday for me too
14:52:14 <tongli> @dmellado, I am thinking doing once,
14:52:26 <dmellado> tongli: then how about 5/3
14:52:27 <markvoelker> tongli: actually, is it possible that we could just get the first cluster up and let people try connecting to it on their own time next week rather than trying to all get together and do it at once?
14:52:29 <tongli> so 5/3 then?
14:52:37 <daniela_ebert> 5/1 is a bank holiday in germany too. I could make it at 5/2
14:52:44 <markvoelker> Would be a lot easier than coordinating across timezones...
14:52:53 <dmellado> +1 on markvoelker approach
14:53:00 <dmellado> and maybe set a meeting on 5/3
14:53:02 <dmellado> for checking issues
14:53:17 <tongli> having a time everybody can get on is to communicate better when you have issues.
14:53:40 <tongli> I can setup the first cluster and send out an email so that you can join.
14:53:57 <dmellado> tongli: that'd work for me, and we can keep 5/3 to check stuff in any case
14:54:08 <tongli> so 5/3 1400 UTC? that will be our meeting time as well for next week.
14:54:13 <dmellado> +1
14:54:29 <vkmc> +1
14:54:33 <daniela_ebert> +1
14:54:36 <markvoelker> tongli: How about both?  Folks that can get together 5/3 do so, but leave the cluster up so others can try throughout the week and report back?
14:54:46 <dmellado> markvoelker: that was my suggestion ;)
14:54:56 <tongli> @markvoelker, I will setup a cluster so that anyone can join.
14:55:11 <tongli> I will get that up running as soon as I get home tonight.
14:55:25 <markvoelker> tongli: Excellent, thanks!
14:55:56 <tongli> ok, one last thing, please get yourself familiar with workload, openstack dashboard,
14:56:05 <tongli> k8s dashboard and cockroachdb dashboard.
14:56:26 <tongli> k8s dashboard will be at port 30000, you can hit any node floating IP.
14:56:54 <tongli> cockroachdb dashboard is at port 8090 and also you can hit any cockroachdb node.
14:57:13 <tongli> in stand alone mode, cockroachdb first node is on master.
14:57:17 * topol 3 mins left
14:57:35 <tongli> in non stand alone mode, corkroachdb is only on worker node.
14:57:52 <tongli> so stack size 3 means only two worker nodes for cockroachdb.
14:58:19 <tongli> anything else?
14:58:37 <tongli> if not, I need to head to airport.
14:58:48 <dmellado> let's close it off for today
14:58:57 <ksumit> Safe travels @tongli!
14:58:58 <dmellado> and sync next week ;)
14:58:59 <markvoelker> Safe travels tongli--thanks for all the work on this!
14:59:01 <dmellado> safe travels!
14:59:05 <tongli> #agreed, work together and create big cockroachdb cluster on 5/3 1400 UTC.
14:59:08 <vkmc> safe travels!
14:59:12 <vkmc> thx for your work
14:59:13 <vkmc> o/
14:59:23 <tongli> great. thanks guys, this will be great.
14:59:38 <tongli> #endmeeting