16:01:34 <eglute> #startmeeting interopwg
16:01:34 <openstack> Meeting started Wed Feb  8 16:01:34 2017 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:38 <markvoelker> o/
16:01:38 <openstack> The meeting name has been set to 'interopwg'
16:01:43 <eglute> #chair markvoelker hogepodge
16:01:43 <openstack> Current chairs: eglute hogepodge markvoelker
16:01:44 <hogepodge> o/
16:01:51 <eglute> #topic agenda
16:01:59 <eglute> #link https://etherpad.openstack.org/p/DefCoreRoble.12
16:02:11 <catherine_d|1> o/
16:02:13 <eglute> Hello Everyone, please review and update agenda as needed
16:02:32 <hogepodge> I'm on mobile and about to get on a train to Seattle, so my participation may be a bit spotty
16:03:09 * eglute has been on that train from Portland to Seattle
16:03:31 <eglute> #topic PTG
16:03:46 <eglute> once again, a reminder of PTG in a couple of weeks
16:04:02 <eglute> please add any topics you wish to see: https://etherpad.openstack.org/p/RefStackInteropWGAtlantaPTG
16:04:40 <eglute> we need to do a schedule planning. perhaps markvoelker hogepodge and i can do so before next meeting
16:04:56 <eglute> any comments on PTG?
16:05:20 <eglute> #topic #Boston Summit
16:05:53 <Rockyg> o/
16:05:54 <eglute> the deadline to submit proposals got extended, so if you have a great idea, you still have time.
16:06:05 <eglute> also, if you have submitted something, let us know :)
16:06:38 <eglute> there is a submitted sessions section on etherpad: https://etherpad.openstack.org/p/DefCoreRoble.12
16:07:17 <eglute> hogepodge do you know if there will be space for working groups?
16:07:21 <eglute> in Boston?
16:07:48 <hogepodge> Yes, but I have no details
16:08:14 <gema> I am wondering if I should be going to boston
16:08:21 <gema> there is no design summit anymore, is there?
16:08:22 <eglute> cool, for barcelona it was part of the abstract submission process but i didnt see that this year
16:08:27 <Rockyg> Uh, I know a bit.
16:08:59 <Rockyg> Thechairs can request either or both space for BoF and working sessions
16:09:23 <eglute> Rockyg do you know if thats been communicated?
16:09:34 <eglute> and by when we need to request?
16:09:47 <Rockyg> You go to the presentations and submit.
16:09:59 <Rockyg> It went out on the UC mailing list
16:10:01 <eglute> oh it is part of the submission process? ok then
16:10:13 * eglute needs to subscribe to that mailing list
16:10:28 <eglute> i am really glad the deadline is extended then
16:10:43 <eglute> #action eglute submit WG session for Boston
16:11:01 <Rockyg> Yeah. If the wg and BoF don't show up, sumit a ticket to the email on the web page
16:11:18 <eglute> gema i think you should still come for all the working group sessions and other content, if you can.
16:11:26 <eglute> thanks Rockyg
16:11:31 <Rockyg> np
16:11:33 <gema> eglute: ok, will try
16:12:05 <eglute> would love to see everyone at every event, though i know travel can be hard. especially when it is a long flight.
16:12:19 <eglute> anything else regarding boston?
16:12:40 <eglute> #topic Flagging two network-l2-CRUD capabilities
16:12:51 <eglute> #link https://review.openstack.org/#/c/422715/
16:13:17 <eglute> this looks good to me, any new comments or feedback?
16:13:39 <markvoelker> I think most of the concerns have been addressed now.
16:14:14 <eglute> in that case, i think it is ready to merge
16:15:16 <eglute> will merge it after the meeting unless there are any last minute comments
16:15:29 <eglute> #topic Flag tests that require second set of user credentials
16:15:36 <eglute> #link https://review.openstack.org/#/c/428847/
16:16:11 <eglute> that looks good to me, except markvoelker is right and next.json should also be updated
16:16:37 <Rockyg> agree.
16:16:53 <catherine_d|1> yea I will make the change to 2016.08 and next .. if we agree to flag it
16:16:57 <catherine_d|1> them
16:17:06 <eglute> i am in favor of flagging
16:17:14 <eglute> thank you catherine_d|1
16:17:34 <catherine_d|1> I would still put them as flag in next instead of remove .
16:18:10 <eglute> works for me
16:18:23 <catherine_d|1> ok will do ..
16:18:29 <eglute> thank you catherine_d|1
16:18:37 <eglute> any other comments on this patch?
16:18:48 <catherine_d|1> only issue is now many capabilities will have no tests
16:19:14 <catherine_d|1> are we OK with that?
16:19:34 <markvoelker> Well, some of these things are sort of inherently two-party things
16:19:37 <markvoelker> E.g. ACL's
16:19:47 <markvoelker> You can test creation of an ACL with a single user
16:20:10 <markvoelker> But can't really test that it's allowing users it should an denying users it shouldn't without a second set of credentials
16:20:23 <markvoelker> If we can't come up with tests that meet criteria, we'll have to drop the capability
16:20:34 <catherine_d|1> markvoelker: yup that is why we would still leave them in llag and not remove for chnances of test update
16:20:46 <markvoelker> But I think there's room on some of these for that to happen, so agree with flagging for now
16:21:14 <Rockyg> Sounds like a discussion we should have with the QA team
16:21:15 <eglute> i think that is a good compromise for now, and maybe we can ask for new tests were feasible
16:21:49 <eglute> who could talk to QA team about these tests?
16:22:10 <Rockyg> I thtink they'll be at PTG...
16:22:39 <gema> meeting at the same time as us
16:22:53 <catherine_d|1> that is the bad part for PTG ...
16:22:54 <Rockyg> :-(
16:23:08 <gema> I hate the fact that I cannot meet most of the people I need to talk to
16:23:17 <gema> due to the scheduling
16:23:24 <catherine_d|1> 2 days overlapse  ... in the past we can still attend some QA sessions
16:23:52 <Rockyg> Yeah.  Scheduling all the crossproject suff a the same time.  Meh.  We'll see how that works
16:24:10 <eglute> yeah, first time PTG will be interesting I am sure
16:24:17 <eglute> anything on the flagging patch?
16:24:19 <gema> Rockyg: I am going to have to favor kolla over interop, QA and infra :(
16:24:36 <eglute> gema :( so sad to hear that
16:24:50 <gema> eglute: cannot be in all of them , it's a shame
16:25:17 <eglute> gema need to work on cloning tech!
16:25:22 <gema> yep
16:25:47 <Rockyg> speeaking of which, how is mini Egle;-?
16:26:32 <eglute> Elena is great! She is going to PTG as well.
16:26:41 <eglute> #topic Glance change: Implement and Enable Community Images
16:26:54 <eglute> I do not remember who was going to look at that
16:28:27 <markvoelker> o/
16:28:42 <eglute> markvoelker have you had a chance? it is not urgent i dont think.
16:29:17 <markvoelker> I did some poking last week.  Given the tests we're currently requiring, I don't think this is going to impact us for now.
16:29:33 <eglute> great, thank you for looking!
16:30:07 <markvoelker> It probably wouldn't hurt to poke a little more at the effect of the column change on older versions of OpenStack with the current tests, but I'm not seeing any "red flags" here that wouldn't be flushed out by the usual flagging process.
16:30:38 <eglute> thank markvoelker.
16:30:39 <markvoelker> So in other words: I think vendors should continue to test and if they do hit problems (likely only on very new OpenStacks), do the usual flag request thing
16:30:52 <eglute> works for me.
16:31:16 <eglute> I updated etherpad with a short note, and we will just keep an eye on flags
16:31:42 <eglute> any other comments on the image patch?
16:32:22 <eglute> #topic name change
16:32:31 <eglute> markvoelker any updates on repo migration?
16:32:36 <markvoelker> A couple:
16:32:57 <markvoelker> 1.) I have the necessary patches ready to go locally and plan on submitting them this week.
16:33:33 <markvoelker> 2.)  Note that there are a couple of light patches to governance too: e.g. things in projects.yaml like refstack's entry that mention DefCore
16:33:44 <markvoelker> (catherine, unless you want to do it yourself I'll take of those too =p)
16:34:31 <markvoelker> 3.)  The last thing to be done is to get this on infra's agenda.  I think there's an order here, so I'll surface it on their radar but we'll probably want a couple of the other patches to land before they get gears grinding.
16:34:51 <eglute> thanks markvoelker!
16:34:57 <catherine_d|1> markvoelker: go for it ...thanks
16:35:31 <markvoelker> That's all for me.
16:36:06 <eglute> thank you for all the work and updates markvoelker
16:36:40 <eglute> i added notes to etherpad. i guess you will need to coordinate the refstack patch with catherine_d|1 anyways
16:37:21 <eglute> anything else on the renames?
16:37:36 <markvoelker> eglute: I think they're mostly independent actually.  Stuff like the projects.yml patch is just housekeeping of the verbage and shouldn't actually affect day-to-day work
16:37:45 <eglute> ah cool
16:37:46 <markvoelker> But yes, I'll keep them in the loop. =)
16:37:59 <eglute> but refstack pulls things from defcore repo, no?
16:38:09 <eglute> like the guidelines?
16:38:15 <markvoelker> Yeah, that bit is more closely tied
16:38:41 <eglute> cool, i imagine it is a simple patch as well
16:39:00 <eglute> i can help if needed
16:39:31 <eglute> anything else?
16:39:42 <eglute> #topic Schema v2.0
16:39:50 <eglute> hogepodge are you still online?
16:39:54 <hogepodge> I sent up a first patch
16:40:11 <eglute> #link https://review.openstack.org/430556
16:40:19 <hogepodge> It's a wip, and I'd love feedback as I work on it
16:40:21 <eglute> thank you!
16:40:46 <gema> hogepodge: you are writing comments to your own patch?
16:40:54 <hogepodge> Starting essentially as a design doc, then once we have the details down I will formalize the spec
16:40:55 <eglute> gema he is!
16:40:58 <gema> lol
16:41:11 <gema> that's the next level of talking to yourself when working from home
16:41:26 <hogepodge> gema some are points of discussion :-)
16:41:35 <gema> hogepodge: +1 will review :D
16:41:36 <eglute> hogepodge are you starting to add new programs to the schema?
16:41:44 <hogepodge> But yes, I need to keep myself company ;-)
16:42:08 * eglute thinks hogepodge is always in great company
16:42:19 <hogepodge> What I have there is an example of how the schema would look
16:42:39 <hogepodge> Trying to demonstrate the different use cases
16:42:42 <eglute> hogepodge can you talk briefly on why "database" would have heat? are those just examples?
16:43:16 <hogepodge> Yes, I started with heat and ended up changing my mind without changing the example
16:43:17 <eglute> oh, it has children, got it
16:43:42 <eglute> cool cool
16:43:54 <eglute> where would we define what an addon is?
16:44:05 <Rockyg> You know there's a ton of context missing in this discussion
16:44:50 <hogepodge> Nothing I'm doing is set in stone, and I'll add more b notes and design decisions as it evolves
16:45:17 <eglute> Rockyg i think the idea is to have something for PTG
16:45:18 <eglute> we had a lot of discussion last midcycle in san antonio
16:45:24 <Rockyg> I'm just saying casual glance at the discussion leads to Whaaa?
16:45:30 <eglute> and i think thats what hogepodge is going based on
16:45:33 <hogepodge> eglute: probably the lexicon and process documents
16:45:40 <eglute> hogepodge cool
16:45:45 <Rockyg> suddenly children.  Made me do a double take
16:46:01 <eglute> Rockyg i agree! and last midcycle was a while ago
16:46:17 <eglute> hopefully at PTG we will have great discussion on this
16:46:18 <hogepodge> I've already made a note to change that.
16:46:24 <gema> maybe Rockyg means that a Readme or a doc to go with the schema would help
16:46:27 <eglute> and a productive discussion :)
16:46:48 <hogepodge> The goal is to have a solid draft by ptg for discussion and review
16:46:59 <gema> ack
16:47:11 <hogepodge> Yes to all of that
16:47:18 <eglute> hogepodge thank you for that!
16:47:20 <Rockyg> kewl
16:47:26 <hogepodge> I just needed to get the seed out, and I promised today
16:47:32 * catherine_d|1 Luz has a patch ready whenever the defcore repo is renamed to Interop WG https://review.openstack.org/#/c/390881/
16:48:02 <eglute> catherine_d|1 luzC perfect!
16:48:15 <hogepodge> In general, programs come in two flavors
16:48:34 <hogepodge> They are composed of components
16:48:48 <hogepodge> And components can have dependencies on other components
16:50:01 <hogepodge> That's all I have for now
16:50:20 <eglute> hogepodge what flavors for programs do you have in mind
16:51:23 <Rockyg> Yeah. I really want to dig into this at the ptg.  Haven't had much time of late
16:51:35 <hogepodge> The names, not final, are platform and addon
16:51:57 <hogepodge> Platform can stand alone, like OpenStack Powered Compute
16:52:08 <hogepodge> Addon needs a platform
16:52:18 <eglute> cool, that makes sense
16:52:29 <eglute> thats what we talked about during midcycle too
16:52:37 <hogepodge> So you can have things like OpenStack Powered Compute with Database
16:52:50 <Rockyg> yup.  cool.
16:52:56 <hogepodge> (Where Database is an add-on)
16:53:08 * mguiney nods
16:53:11 <mguiney> makes sense
16:53:30 <eglute> yup, pretty simple
16:53:36 <hogepodge> Oh, I need to introduce mguiney !
16:53:46 <mguiney> oh! hello all!
16:53:56 <eglute> hello mguiney!
16:53:57 <hogepodge> She just joined the foundation on Monday and will be working on QA and Interop
16:54:15 <eglute> awesome!! welcome mguiney to interop!!!
16:54:19 <eglute> glad to have you
16:54:25 <catherine_d|1> mguiney: hello again:-)
16:54:28 <Rockyg> Excellent!  Welcome!
16:54:32 <mguiney> thank you, I'm very excited!
16:54:34 <gema> mguiney: welcome!
16:54:58 <Rockyg> was wondering who was gonna do this with hogepodge 's new stuff
16:55:24 <eglute> since we are talking about new programs, markvoelker would you give a summary on NFV?
16:55:33 <markvoelker> Sure.
16:55:36 <eglute> thank you markvoelker
16:55:41 <markvoelker> Very briefly since we're low on time:
16:56:02 <markvoelker> We had a preliminary chat with a couple of folks from the OPNFV community this week
16:56:30 <markvoelker> THis was basically a "let's introduce ourselves and figure out what we're all trying to do and if we can/should work together" sort of thing
16:56:35 <hogepodge> Thanks everyone with your patience on my very rough first draft
16:57:17 <eglute> hogepodge great first draft, will help us with the discussion in atlanta
16:57:25 <markvoelker> As folks in this meeting are aware, we've been lightly discussing vertical programs for some time, and NFV seems to be a consensus pick for a good proving ground for this sort of thing
16:57:51 <markvoelker> There will be some NFV folks in Atlanta at the PTG joining us to discuss this a bit more and get some wheels turning together
16:58:08 <markvoelker> In the meantime, folks may want to take a look at this section of this deck starting around slide 40: http://www.slideshare.net/markvoelker/interopwg-intro-vertical-programs-jan-2017
16:58:26 <hogepodge> +1 they want to learn from our process and use it if it's a good fit. We're trail blazers here
16:58:28 <markvoelker> (you've probably seen most of the rest of it before; it's the introductory "Dr. Who deck" I did a while back
16:58:49 * eglute is a big fan of Dr Who.
16:58:58 <mguiney> that is a great set of slides
16:59:19 * markvoelker can't take credit for good sci-fi, but is happy to use it where he's able
16:59:46 <Rockyg> ++
17:00:02 <markvoelker> Anyway, this is all kind of "setting the table" stuff...in ATL I'll hopefully have some more prototype content to give us something concrete to talk about
17:00:19 * markvoelker glances at the clock and shuts up
17:00:30 <eglute> thanks markvoelker for a quick summary
17:00:41 <eglute> happy to answer questions in interop channel
17:00:57 <catherine_d|1> markvoelker: could you give the link Dr Who set ?
17:01:11 <markvoelker> #link http://www.slideshare.net/markvoelker/interopwg-intro-vertical-programs-jan-2017
17:01:17 <eglute> thanks everyone!! I am out next week, so markvoelker and hogepodge will be running this meeting
17:01:18 <eglute> #endmeeting