16:00:42 <eglute> #startmeeting interopwg
16:00:44 <openstack> Meeting started Wed Mar 15 16:00:42 2017 UTC and is due to finish in 60 minutes. The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:48 <openstack> The meeting name has been set to 'interopwg'
16:00:52 <markvoelker_> o/
16:00:54 <hogepodge> o/
16:01:10 <eglute> #topic agenda
16:01:11 <mnaser> o/
16:01:12 <eglute> #link https://etherpad.openstack.org/p/DefCoreRoble.15
16:01:17 <zhipeng> o/
16:01:24 <eglute> everyone, please review agenda and add/update as needed!
16:01:53 <eglute> #topic 2017.08 Guideline
16:02:21 <eglute> We need to start IDing new capabilities.
16:02:37 <eglute> I was traveling last week, so I don't have any updates on my part
16:02:48 <eglute> We still need a volunteer for Nova
16:02:54 <catherineD> o/
16:02:59 <eglute> anyone would like to try their hand at nova?
16:03:16 <eglute> if you are not sure what/how, we will help
16:03:48 <markvoelker_> I can probably help if no one else picks it up...next couple of weeks are mighty busy for me though
16:04:34 <eglute> thank you markvoelker_
16:04:58 <eglute> we can ask on mailing list too if anyone interested in helping with this.
16:05:08 <zhipeng> i think I could help with this
16:05:16 <eglute> zhipeng that would be great!
16:05:24 <zhipeng> but I need help from others as well :) since i'm new to this
16:05:38 <eglute> markvoelker_ hogepodge and myself will help
16:05:41 <eglute> others too
16:06:04 <zhipeng> great :)
16:06:19 <eglute> thank you for your help!
16:06:32 <eglute> next, Cinder- hogepodge have you had a chance to look at it?
16:07:35 * eglute wishes IRC client would let her know if someone was typing
16:07:56 <kbaikov> o/
16:08:02 <eglute> hogepodge also has Glance, we will wait for him to come back
16:08:11 * eglute waves to kbaikov
16:08:13 <hogepodge> no
16:08:22 <eglute> thanks hogepodge
16:08:23 <hogepodge> I haven't started yet
16:08:34 <eglute> last week was a busy week
16:08:50 <eglute> markvoelker_ any updates on neutron?
16:09:49 <eglute> I have not touched swift yet. Hopefully by next meeting.
16:09:55 <markvoelker_> Not really (I was traveling in Europe all last week). I did start picking through a few things we mentioned in previous scoring rounds (get-me-a-network, etc), but not much to report just yet.
16:10:06 <eglute> thank you markvoelker_
16:10:25 <eglute> get-me-a-network- how does that look?
16:11:14 <markvoelker_> Hard to say yet...I suspect it's not going to be widely enough supported, but it's early
16:11:51 <eglute> will be interesting to see how it scores. thank you for looking at it markvoelker_
16:12:12 <eglute> luzC any updates on keystone?
16:12:49 <luzC> o/
16:13:07 * eglute waves to luzC
16:13:17 <eglute> luzC any updates on keystone?
16:13:18 <luzC> hey I just started looking to the API and sent email to the PTL...
16:13:46 <eglute> great! hopefully PTL responds to you soon
16:14:19 <luzC> I noticed guideline has v2 as designated section and since v2 is deprecated I guess I should remove it from the next guideline...
16:14:56 <eglute> i think deprecated get moved to removed status?
16:15:43 <eglute> deprecated -> removed, then removed removed :)
16:15:52 <hogepodge> yeah
16:15:58 <luzC> ok, I'll do that, will take a look
16:16:04 <eglute> thank you luzC!
16:16:35 <eglute> any more updates or comments on 2017.08?
16:16:58 <eglute> #topic patches
16:17:20 <eglute> fix flake8: #link https://review.openstack.org/#/c/441004/
16:17:42 <eglute> i know nothing about flake8
16:17:57 <eglute> does that look accurate?
16:18:31 <mnaser> flake8 is just a python linter to enforce pep8 style guide mostly
16:18:50 <eglute> ah ok
16:18:58 <mnaser> so while i dont know much about that project but it seems to have added flake8 tests which seems reasonable
16:19:02 <eglute> i thought we already had that fixed at some point
16:19:09 <eglute> i guess not
16:19:10 <mnaser> enforces things like 80 character line, etc etc
16:19:27 <eglute> thank you mnaser
16:19:39 <mnaser> np! :)
16:19:44 <eglute> please comment on the patch?
16:19:57 <mnaser> sure
16:20:02 <eglute> thank you!
16:20:27 <luzC> but do defcore need it? how many python scripts are hosted on defcore repo?
16:20:41 <markvoelker_> We already had a flake8 defined in tox.ini, this just adds it as a dep for the pep8 testenv I think, no?
16:20:57 <markvoelker_> luzC: a few. Not many; just some utilities.
16:21:00 <eglute> luzC: probably 2 scripts :)
16:21:48 <eglute> markvoelker_ i thought i seen it before. i am ok merging the patch if it doesnt break anything
16:22:05 <luzC> markvoelker_, eglute thanks, I'll take a look at the patch and comment there :)
16:22:13 <eglute> thank you luzC!
16:22:58 <eglute> zhipeng you commented -1, was it just for the lack of commit message?
16:24:09 <zhipeng> yep
16:24:17 <zhipeng> no other questions
16:24:34 <eglute> cool, thank you for reviewing it :)
16:24:51 <eglute> next: Flag a must-pass test that appears in two capabilities
16:24:58 <eglute> #link https://review.openstack.org/#/c/445217/
16:25:19 <eglute> this looks good to me, but would appreciate other reviews as well
16:25:25 <eglute> thank you catherineD for submitting it
16:25:36 <catherineD> eglute: yw
16:26:37 <eglute> any comments/concerns around that patch?
16:28:18 <eglute> Flag tests that require second set of user credentials: #link https://review.openstack.org/#/c/428847/
16:28:55 <eglute> this looks good to me... but hogepodge has a concern i think
16:29:23 <hogepodge> I think catherineD answered it
16:29:27 <eglute> any other comments/concerns?
16:29:31 <eglute> cool, thank you hogepodge
16:30:05 <eglute> anything else on any of the patches?
16:30:49 <eglute> #topic Name change
16:30:59 <catherineD> I think we need to make decision on the second set user patch soon
16:31:10 <eglute> catherineD i am ok to merge it
16:31:12 <catherineD> as people start to test against 2017.01
16:31:33 <catherineD> they need to know whether they should test with 1 or 2 users
16:31:50 <mguiney> makes sense
16:32:02 <catherineD> as for allowing testing for 2 users ...
16:32:17 <markvoelker_> Given the discussion we had in ATL and since, I think consensus was we're ok with merging this.
16:32:22 <eglute> seems like we are in agreement!
16:32:30 <eglute> merged!
16:32:52 <eglute> except now it is in a conflict
16:33:07 <catherineD> thank you
16:33:08 <eglute> so catherineD if you update it, i will merge it
16:33:17 <catherineD> oh I will update
16:33:33 <eglute> thank you catherineD!
16:34:25 <eglute> markvoelker_ regarding name change- any updates?
16:35:15 <markvoelker_> Nope. We figured infra would start looking at this once the PTG was behind us, but I haven't heard anything new. Probably need to pop into an infra meeting and bring it up for attention.
16:35:31 <eglute> cool, thank you markvoelker_
16:35:42 <eglute> can i assign that AI to you?
16:36:03 <markvoelker_> sure
16:36:05 <eglute> #action markvoelker_ will get into infra meeting and ask about renaming repo
16:36:14 <eglute> thank you markvoelker_!
16:36:32 <eglute> hogepodge any updates on storyboard?
16:36:37 <hogepodge> it's happening Monday
16:36:54 <hogepodge> that's the plan with infra, at least
16:37:00 <eglute> awesome!
16:37:02 <eglute> thank you hogepodge!
16:37:11 <hogepodge> along with refstack (catherineD you should get in touch with diablo_rojo if that's a surprise to you)
16:37:42 <catherineD> hogepodge: great will do :-)
16:38:06 <catherineD> hogepodge: thanks!
16:38:34 <eglute> anything else on renames?
16:39:11 <eglute> #topic Schema v2.0
16:39:17 <eglute> hogepodge any updates?
16:39:25 <eglute> #link https://review.openstack.org/#/c/430556/
16:39:28 <hogepodge> eglute: markvoelker_ took that ai
16:39:37 <eglute> thank you hogepodge
16:39:58 <markvoelker_> We had discussed some simplifications to this--I got about half of it written up on my way home from Germany last week
16:40:04 <markvoelker_> Should be able to submit something by Friday
16:40:12 <eglute> thank you markvoelker_!
16:41:02 * markvoelker_ notes that he never wants to write schemas from the confines of an overseas flight in cattle class again, so he has extra incentive to finish it this week since he has another trip coming up
16:41:39 * eglute is grateful for all the work markvoelker_ does
16:41:55 <eglute> markvoelker_ thanks for working on this. I look forward to reviewing the chanegs
16:42:23 <eglute> Last topic is NFV, but i think that is also waiting on schema 2.0 correct?
16:42:33 <markvoelker_> happy to help
16:42:53 <markvoelker_> largely, yes. I need to sync up with Jose again now that he's had some time to digest though.
16:43:11 <eglute> cool, thank you markvoelker_
16:43:19 <markvoelker_> I'd like to get moving on identifying capabilities sooner rather than later on the NFV front though
16:43:33 <catherineD> seems like their testing is going ok after a few rounds of debugging with us
16:43:34 <markvoelker_> We don't need a schema just to put together a list of capabilities and tests to start kicking around
16:43:58 <eglute> sounds like catherineD was working with them?
16:44:02 <catherineD> that is based on the 2016.08 capabilities as the starter
16:44:41 <catherineD> yea there are few email exchanged
16:44:59 <eglute> thanks catherineD
16:45:03 <eglute> let us know if we can help
16:45:50 <eglute> anything else regarding NFV?
16:46:27 <eglute> #topic open discussion
16:46:31 <eglute> anything else?
16:46:36 <beisner> o/ hi, I'll be participating in boston interopwg on behalf of Canonical. I attended a couple of sessions @ PTG but was also juggling a few rooms that wk, so wanted to say hi here too. Looking forward to working with the group.
16:46:50 <eglute> hello beisner!
16:46:54 <beisner> thx eglute :)
16:46:57 <beisner> hello
16:47:02 <eglute> glad to have you join us.
16:47:19 <eglute> there is a separate meeting, also on Wed, just for interop challenge
16:47:21 <markvoelker_> Just a quick FYI: I'll be away in Europe again the last week of March. eglute/hogepodge will you be able to run the meeting that week?
16:47:35 <eglute> markvoelker_ i should be around
16:47:49 <hogepodge> I won't, as I'll also be in Europe and Washington DC the last week of March and the first week of April
16:48:24 <eglute> how about for march 22 meeting next week? hogepodge markvoelker_ are you going to be able to attend?
16:48:33 <markvoelker_> yes
16:48:40 <hogepodge> yes
16:48:55 <eglute> cool
16:48:56 <eglute> great!
16:49:43 <eglute> beisner let us know if you have any questions related to interop. we want more people involved!
16:50:01 <beisner> eglute, curious - how does one officially sign up for a slot on the challenge keynote?
16:50:43 <beisner> referencing the closing comments @ http://eavesdrop.openstack.org/meetings/interop_challenge/2017/interop_challenge.2017-03-15-14.01.log.html
16:50:52 <markvoelker_> beisner: https://wiki.openstack.org/wiki/Interop_Challenge#Boston_Summit_On_Stage_Keynote_K8S_Demo_Commited_Parties
16:50:55 <beisner> looks like i munged meeting times. clocks are hard.
16:50:58 <eglute> beisner so there is a separate meeting for the interop challenge. this meeting is just for interop working group. The names are similar and confusing :)
16:51:04 <markvoelker_> Add yourself there and ping tongli
16:51:08 <beisner> ack thx ma
16:51:21 <beisner> markvoelker_, even. keyboards are hard too.
16:51:23 <eglute> beisner but if you would like to help with interop guidelines, we would like to have you :)
16:51:53 <beisner> indeed, i'd like to take some time to take in the current activities, needs, and direction - and eventually chip in where i can.
16:52:14 <eglute> that would be great.
16:52:38 <eglute> let us know if you have any questions, we are usually around on the #openstack-interop channel
16:52:59 <beisner> thx eglute
16:52:59 <eglute> any other comments/questions?
16:53:37 <eglute> in that case, we can end a few minutes early. thanks everyone!!
16:53:40 <eglute> #endmeeting