16:01:04 <markvoelker> #startmeeting interopwg
16:01:04 <openstack> Meeting started Wed Mar 22 16:01:04 2017 UTC and is due to finish in 60 minutes.  The chair is markvoelker. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:08 <openstack> The meeting name has been set to 'interopwg'
16:01:23 <markvoelker> Hi everyone
16:01:31 <hogepodge> o/
16:01:34 <catherine_d|1> o/
16:01:36 <markvoelker> #link https://etherpad.openstack.org/p/DefCoreRoble.16 Today's agenda
16:02:11 <markvoelker> Let's jump right in...
16:02:12 <markvoelker> #topic 2017.08 Guideline
16:02:31 <eglute> o/
16:02:36 <kbaikov> o/
16:02:38 <mguiney> o/
16:02:46 <markvoelker> As a reminder, today is March 22 and we're looking to have scoring submissions for 2017.08 by April 8
16:02:47 <zhipeng> o/
16:03:20 <markvoelker> If you're playing point on something and are not going to be able to meet that deadline, please reach out to us so we can find you some help. =)
16:03:34 <markvoelker> Let's check in on individual projects...
16:03:39 <markvoelker> Nova: zhipeng
16:03:48 <markvoelker> Anythign to report?
16:04:37 <zhipeng> okey as I indicated on my email to you and egle, I will start propably later this week to contact Matt more in detail about the scoring
16:04:48 <zhipeng> however i did have a short conversation with him
16:05:10 <zhipeng> one thing Matt bring up is that if we should include microversioning in 2017.08 ?
16:06:01 <zhipeng> another thing he mentioned is that back in 2017.01, he thinks
16:06:20 <zhipeng> the resume/suspend capability should not be there
16:07:02 <zhipeng> not all virt drivers implement that
16:07:19 <zhipeng> that would be all for my report :)
16:07:49 <markvoelker> Ok, regarding microversioning: basically this partly boils down to tests
16:08:14 <markvoelker> I suspect part of the question here was also about the waiver program on extended attributes: https://github.com/openstack/defcore/blob/master/working_materials/additional_properties_waiver.rst
16:08:40 <markvoelker> (this program expired with the 2017.01 guideline, fwiw)
16:09:03 <zhipeng> Matt thinks one of the down side of having microvseriosing is we might need to mandate a certain minimum version
16:09:26 <zhipeng> for all the clouds
16:09:48 <markvoelker> Well, we already do that actually...for example: https://github.com/openstack/defcore/blob/master/2017.01.json#L10
16:10:16 <markvoelker> But I think generally my gut reaction would be that we don't need an explicit test for a particular minimum microversion
16:10:35 <markvoelker> RAther what we need to look at is the individual tests used for individual capabilities
16:10:43 <zhipeng> okey
16:11:00 <markvoelker> If the capability (say, "servers-create") requires some minimum microversion, I'd expect that to be enforced by the test
16:11:24 <markvoelker> Rather a lot of the capabilities we cover probably won't need a particular microversion.
16:12:11 <markvoelker> (and naturally: if the microversion needed by a test is newer than the minimum version listed in the Guideline, we'd not include it until a later guideline)
16:12:23 <markvoelker> Make sense?  Anyone else have comments?
16:12:36 <zhipeng> i think it does
16:13:07 <markvoelker> Cool.  Ok, let's move on to Cinder unless there's anything further on Nova?
16:13:21 <zhipeng> nothing further :)
16:13:26 <markvoelker> Great, thanks zhipeng
16:13:27 <eglute> thank you zhipeng
16:13:29 <catherine_d|1> To me, the true meaning of interop is required-capabilities should be supporedt regardless of versions.
16:14:09 <eglute> catherine_d|1 +1. i think thats what markvoelker was saying too
16:14:19 <markvoelker> catherine_d|1: Right, that's why I wouldn't favor a "minimum microversion capability".
16:15:05 <markvoelker> In some sense, microversions are just another expression of which a particular capability was added to the code, and that capability is subject to the same rules as all other capabilities. =)
16:15:22 <markvoelker> s/which/when/ ...silly autocorrect
16:15:40 <markvoelker> OK, hogepodge: what's up in cinder-land?
16:16:15 <hogepodge> I have nothing to report. And I won't have a chance to look at it for a few more weeks because of upcoming international travel
16:16:33 * markvoelker knows that feeling well since I'm in Europe again next week
16:16:49 <markvoelker> Ok, still comfortable submitting scoring by the 8th, or do you need some help?
16:17:20 <hogepodge> it's going to be tough. I'll see if I can take care of a draft before I leave
16:17:41 <markvoelker> Ok, please reach out if you end up needing assistance
16:18:05 <markvoelker> Next up: glance.  hogepodge: that's you again. =)
16:18:27 <hogepodge> same, if someone can take that off my hands, I'm far less prepped for that one
16:18:41 <markvoelker> Any volunteers folks?
16:18:58 <hogepodge> or I'll just check in again this week and see if we need an update
16:20:18 <markvoelker> Ok, let me see what I can do offline to round up some help on Glance...may have someone who can help.
16:21:11 <markvoelker> #action markvoelker to seek help with Glance scoring for hogepodge
16:21:30 <markvoelker> Ok, next up is Neutron, which is me.
16:22:01 <markvoelker> Not much to report this week...still digging through a couple things to send over to the PTL, but I'm comfortable with the April 8 target
16:22:18 <eglute> thanks markvoelker!
16:22:43 <markvoelker> I'm a bit further behind than I'd like at this stage due to some unexpected events this week, but I'm aiming to have my first pass done before I head overseas again next week
16:22:52 <mguiney> (I'd be interested in helping with Glance, if that would be acceptable)
16:23:00 <markvoelker> mguiney: sure!
16:23:05 <eglute> mguiney thank you!!!
16:23:14 <markvoelker> mguiney: Can you and hogepodge sync up offline to level-set?
16:23:27 <hogepodge> +1
16:23:51 <markvoelker> thanks
16:23:59 <markvoelker> Ok, any questions on Neutron before we go on?
16:24:07 <mguiney> can do!
16:25:15 <markvoelker> Ok, moving along.  Next up is Swift. eglute: that's you
16:25:39 <eglute> i am also behind. i am reviewing swift release notes before contacting ptl
16:26:20 <markvoelker> Still comfortable with April 8?
16:26:32 <eglute> i also need to create a patch with the additional tests PTL proposed last cycle. I think so!
16:27:44 <markvoelker> Great.  Need any assistance?
16:27:51 <eglute> not yet
16:27:55 <eglute> thank you!
16:27:59 <hogepodge> If we pushed by one week I'd be thrilled with my schedule :-D
16:28:29 * markvoelker wishes he could push all his deadlines by a week =)
16:28:33 <eglute> hogepodge i think that would reasonable. what do you think markvoelker
16:29:24 <markvoelker> Personally I'd like to continue to target the 8th and re-evaluate once we get there.  I'd like to stick to the timelines the BoD approved if at all possible, but if we need wiggle room we can discuss when we come to that bridge.
16:29:35 <hogepodge> markvoelker: just a leap week where nobody asks anything from me would suffice. :-D
16:29:44 <eglute> hogepodge heheh
16:30:14 * markvoelker would totally spend a leap week backpacking on a mountain somewhere and not get anything done
16:31:15 <markvoelker> Ok, can we agree to keep pressing for the 8th if possible and we'll check in again as that date gets closer?
16:31:26 <hogepodge> ok
16:32:01 <markvoelker> Next up is keystone.  luzc: any news to report?
16:34:22 * markvoelker notes that luzC may not be around today
16:35:00 <markvoelker> Ok, we'll catch up with luzC later then.  Anything else to discuss on 2017.08 scoring?
16:35:14 <eglute> i am good!
16:35:32 <markvoelker> #topic Name Change
16:35:47 <markvoelker> First item is the repo name changes, which is me
16:36:02 <markvoelker> I noticed that at least one of those patches now needs a rebase, which I'll take care of shortly
16:36:12 <eglute> thank you markvoelker
16:36:35 <markvoelker> Unfortunately I was not able to attend the infra meeting last week, but I'll either do that this week or just ping them via email
16:37:38 <markvoelker> In bug-tracking news, hogepodge and diablo_rojo got us moved over to StoryBoard. =)  hogepodge, anything you want to say about the move?
16:38:00 <hogepodge> We have a whopping nine issues
16:38:14 <hogepodge> If everyone could take a chance to look at them, and see if any can be closed, that would be great.
16:38:37 <hogepodge> https://storyboard.openstack.org/?#!/project/877
16:39:04 <hogepodge> Also, changing the name of the storyboard is dependent on the repository moving, but it's an easy change, so that will be pending work
16:39:46 <eglute> thanks hogepodge for working on this!
16:40:27 <markvoelker> hogepodge: I think we still had links and docs and stuff that mention Launchpad...has anyone combed through yet to fix pointers?
16:41:12 <hogepodge> no
16:41:59 <hogepodge> 6 instances of that in the repo
16:42:03 <markvoelker> Ok, I'll have a quick look when I'm finishing up a couple of other patches and see if I pick up anything.  Should be simple fixes.
16:42:05 <hogepodge> I'll send a patch after the meeting
16:42:10 <markvoelker> Even better
16:42:52 <markvoelker> Ok, anything else on renaming?
16:43:04 <eglute> nope
16:43:11 <markvoelker> Ok, moving on...
16:43:18 <markvoelker> #topic New components/add-on programs
16:44:11 <markvoelker> I have an outstanding AI to send up some proposed simplifications that got waylaid by engagements in asiapac last week (sawwww-wee!).
16:44:30 <markvoelker> I'll likely get those finished up Thursday night
16:45:16 <eglute> thank you markvoelker! surprise work is never fun
16:45:48 * eglute also got surprise work
16:45:56 <markvoelker> ON the NFV front, I've been working with a few folks offline to start identifying some capabilities.  Probably not comprehensive, but a starting point to get the ball rolling
16:46:10 <eglute> awesome!
16:46:38 <markvoelker> One point to be aware of is that we'll likely need to discuss some Heat in this program
16:47:07 <eglute> interesting
16:47:23 <catherine_d|1> markvoelker: Is this work related to the OpenNFV testing by the folk attended at PTG meeting?
16:47:42 <markvoelker> catherine_d|1: yes and no...
16:48:10 <markvoelker> It is concerned with creating an "OpenStack Powered NFV" or "NFV Ready OpenStack" (or whatever we end up calling it) program
16:48:25 <markvoelker> It's not directly related to OPNFV adding some of our tests to functest
16:48:37 <zhipeng> For NFV some use Heat some use MANO modules
16:48:54 <markvoelker> zhipeng: yes, exactly.  There are a lot of ways to do orchestration
16:49:00 <catherine_d|1> markvoelker: ic ..thanks!
16:49:03 <markvoelker> That's why I suspect we'll have a good discussion
16:49:46 <catherine_d|1> markvoelker: does this work depending on schema 2.0?
16:50:20 <zhipeng> markvoelker will we have a formal discussion with the concerned parties within the WG ?
16:50:52 <markvoelker> catherine_d|1: ultimately we'll write the guideline proposal using 2.0, yes.  But it's not a blocking factor right now: coming up with a simple list of tests to start discussing doesn't actually require 2.0 to land.
16:51:01 <markvoelker> zhipeng: absolutely
16:51:23 <markvoelker> zhipeng: right now basically we're jsut working on a first pass so we actually have something concrete to discuss. =)
16:51:56 <zhipeng> understood :)
16:52:18 <markvoelker> I expect the first pass will be a long way from complete and will be designed to spark some healthy conversation/debate.
16:53:14 <markvoelker> Ok, anything else we need to talk about on this topic today folks?
16:53:58 <markvoelker> #topic Open Floor
16:54:12 <markvoelker> With that, we have about six minutes if anyone has other items to discuss
16:54:50 * eglute is good.... well, besides the horrid head cold
16:55:47 <markvoelker> Ok, hearing nothing then...let's adjourn for the day a few a minutes early.  THanks everyone!
16:55:49 <markvoelker> #endmeeting