16:01:10 <eglute> #startmeeting interopwg
16:01:12 <openstack> Meeting started Wed Apr  5 16:01:10 2017 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:15 <openstack> The meeting name has been set to 'interopwg'
16:01:16 <markvoelker> o/
16:01:20 <hogepodge> hi
16:01:22 <catherineD> o/
16:01:29 <eglute> #topic agenda
16:01:31 <eglute> #link https://etherpad.openstack.org/p/DefCoreRoble.18
16:01:36 <eglute> please review and update!
16:01:42 <eglute> #chair hogepodge markvoelker
16:01:42 <openstack> Current chairs: eglute hogepodge markvoelker
16:02:16 <mguiney> o/
16:02:20 <eglute> Hello Everyone!
16:02:32 <eglute> #topic Fix incorrect test case name
16:02:44 <eglute> #link https://review.openstack.org/#/c/450346/
16:03:02 <eglute> we discussed this a bit last week- catherineD can you explain the dilema here?
16:03:18 <catherineD> sure
16:03:54 <catherineD> So the test case name is wrong ... no Tempest can ever be able to run this test ...
16:04:36 <catherineD> so for the approved guideline, an alias of the correct name is added.  For next, just replace the incorrect name with the correct one
16:05:17 <rockyg> o/
16:05:30 <eglute> should we just correct the name rather than adding an alias, since it never worked in the first place?
16:05:34 * markvoelker was away in Europe last week and is wondering if the concern is just not keeping the alias around...otherwise this looks pretty straightforward
16:06:39 <hogepodge> I don't think we can require a test that was never run on previous clouds
16:06:45 <catherineD> yes the concern is if the alias is incorrect for any Tenpest version.  Should we keep it?
16:06:47 <hogepodge> following our flag guidance.
16:06:54 <catherineD> hogepodge: ++
16:07:05 <hogepodge> So we should add the correct name to next and flag in current, imo
16:07:14 <catherineD> That is the idea.  Ttotally agree with hogepodge:
16:07:27 <markvoelker> works for me
16:07:30 <eglute> hogepodge flag it or add an alias?
16:07:38 <hogepodge> eglute: flag it
16:07:45 <hogepodge> and fix in next
16:08:07 <eglute> flag it and add an alias?
16:08:16 <hogepodge> no alias
16:08:31 <hogepodge> well, I guess it doesn't matter. Actually, flag it and fix the name
16:08:40 <eglute> catherineD does that work for you?
16:08:46 <hogepodge> no need to propogate an error. Flagging it makes it non-required.
16:09:04 <rockyg> ++
16:09:04 <catherineD> work for me ... I will update the patch
16:09:43 <markvoelker> Well, there's no need to flag it here b/c it's not a required capability right?
16:09:45 <hogepodge> I will take a work item to add a gate check to make sure tests exist
16:09:46 <markvoelker> It's advisory
16:09:53 <hogepodge> so this doesn't happen again
16:10:14 * hogepodge clearly didn't read the patch
16:10:33 <eglute> ok, so just fix it in 2017.01?
16:10:42 <eglute> no alias and no flag?
16:10:47 <catherineD> I think we should flag it so we have hint in the future patch for reason of correction
16:11:23 <eglute> catherineD but since it is advisory, i dont think we flag advisory
16:11:33 <catherineD> we do have flag in the advisory section in the past for people who look forward for passing future guideline ( I am one of them)
16:12:17 * eglute doesn't remember all the details
16:12:23 <markvoelker> Yeah, typcially we used that for tests taht needed rewriting though I think
16:12:28 * markvoelker looks
16:13:07 <markvoelker> To me it feels like adding an alias in 2017.01 and correcting it in next fixes this, which is what the patch does
16:13:17 <luzC> o/
16:13:27 <eglute> i am ok with leaving the patch as is
16:14:46 * markvoelker +2's it as-is
16:15:01 * luzC luzC +1 as-is
16:15:07 <eglute> thanks everyone!
16:15:46 <eglute> Moving on!
16:16:08 <eglute> #topic 2017.08 guideline
16:16:16 <eglute> Nova: is zhipeng around?
16:17:07 <eglute> or whoever updated notes on nova?
16:17:22 <eglute> hogepodge?
16:17:27 <markvoelker> hogepodge was just having a discussion about some Nova stuff over on #openstack-dev =)
16:17:37 <rockyg> I thin it might have been mreidmann
16:17:41 <hogepodge> I updated the notes
16:17:49 <eglute> ah nice, thank you
16:17:55 <rockyg> ah.  thanks
16:18:15 <eglute> anything else to add besides what is in the notes?
16:18:51 <hogepodge> we have azs in cinder but not in nova
16:18:54 <hogepodge> that should be fixed
16:19:14 <eglute> ok, so that means new capabilities for nova?
16:19:23 <hogepodge> yup
16:19:29 <hogepodge> advisory, of course
16:19:35 <eglute> of course
16:19:58 <hogepodge> his timing for reaching out to us is perfect. it's exactly the sort of feedback we want
16:20:08 <eglute> since zhipeng is not around, can someone else take a stab at adding them?
16:20:24 <hogepodge> i have spare time next week
16:20:34 <hogepodge> and can do cinder then too
16:20:36 <eglute> thank you hogepodge
16:20:48 <hogepodge> tl;dr ive done no scoring yet :-(
16:21:03 <hogepodge> but I'm freed up on Friday afternoon for it
16:21:25 * eglute looks at timeline
16:21:48 <hogepodge> I'm behind
16:21:50 <eglute> i think we are ok. just need to try and get new caps added before summit
16:22:00 <hogepodge> definitely doable
16:22:37 <rockyg> lemme know if I can help.  Not great at proposing, but can review
16:22:44 <eglute> thank you rockyg!
16:23:29 <eglute> maybe hogepodge can lean on rockyg for some scoring
16:23:48 <eglute> Skipping cinder, and onto glance
16:24:07 <eglute> mguiney has submitted a patch, thank!
16:24:11 <eglute> thank you!
16:24:16 <rockyg> That could work!
16:24:21 <eglute> #link https://review.openstack.org/#/c/451167/
16:25:17 <eglute> if you havent reviewed it yet, please do so. basically, no new capabilities, just some comments on ones that score high bu are not added
16:25:17 <mguiney> re the scoring of the two capabilities that have nof tests or are may not be expose/req. two users
16:25:42 <mguiney> I was hoping to get some opinions on that point
16:25:59 <eglute> to me, the ones that score high but are not added to the guideline indicate a scoring problem. but i am not sure that this is a time to discuss it :)
16:26:04 <hogepodge> mguiney: mriedem was just saying that he wants to write more tests, maybe you could ping him :-D
16:26:41 <mguiney> awesome! I will do that!
16:26:44 <eglute> so i think for those two capabilities, they would not be added regardless of tests.
16:26:53 <rockyg> Yes!  yeah.  If we could list requirements for tests to verify interop, the tests could get written'
16:27:47 <mguiney> pinged
16:27:49 <eglute> more tests are good, but i dont think these two are a good example
16:28:12 <eglute> not for images-v2-share or images-v2-remove
16:28:25 <mguiney> it appears that he was more interested in compute, anyways
16:28:53 <eglute> so i think we are good with glance, unless someone else has more comments?
16:28:54 <rockyg> ++  he is the nova ptl
16:29:12 <mguiney> awesome! no, nothing new there, other than that
16:29:58 <hogepodge> I'm at a workshop right now, and need to drop off to participate.
16:29:59 <markvoelker> regarding requirements for tests rockyg: that sounds a lot like https://github.com/openstack/defcore/blob/master/working_materials/interop_test_spec.rst unless you meant "a list of tests we need written/revamped"
16:30:15 <hogepodge> I'll be back next week. Thanks everyone.
16:30:18 <markvoelker> (which I'd propose we use storyboard to track)
16:30:19 <eglute> thanks hogepodge
16:31:00 <rockyg> the list, with a few requirements probably listed in the spec ;)
16:31:09 <eglute> i agree, lets use storyboard for tests that need writing
16:31:21 <rockyg> markvoelker, sounds very good.
16:31:34 * mguiney nods
16:31:43 <mguiney> sounds like a very useful way to track
16:32:09 <eglute> #action everyone  come up with a list of tests that need writing and add them to storyboard
16:32:10 * markvoelker notes that we already have storyboard issues open for a couple of tests, too
16:32:30 * eglute needs to go look at storyboard
16:32:30 <markvoelker> #link https://storyboard.openstack.org/#!/project/877 Storyboard
16:33:10 <eglute> thank you markvoelker
16:33:29 <eglute> next is neutron
16:33:33 <eglute> markvoelker any updates?
16:34:17 <markvoelker> I am back from Deutschland and don't have to get on an aeroplane again for a whole 5 more days!
16:34:31 <markvoelker> Joking aside: that means I should get a preliminary patch up this week.
16:34:38 <markvoelker> Two big things I want to think through on Neutron:
16:34:54 <markvoelker> 1.) Subnet pools.  I think the time has come and I see some evidence of wider adoption.
16:35:30 <markvoelker> 2.) Routers.  We've discussed this once or twice in the past and it's been languishing in advisory status for a while now.  Feels like time to either drop it or make it required.
16:35:36 <markvoelker> I expect 2 to be more contentious. =)
16:35:46 <rockyg> yeah.  those are important.  but more for big sites
16:36:47 <eglute> thanks markvoelker. will be interesting to see.
16:36:53 <rockyg> could we do a forum session with dev and ops on routers?  That could be really good to lay the groundwork for lots of netwrk stuff
16:36:56 <luzC> markvoelker: how do you know if capability have a wider adoption... with refstack results?
16:37:01 <eglute> I wonder if we have any data on how many clouds passed the advisory tests
16:37:43 <markvoelker> luzC: the concern on that specific capability last time was around tool adoption.  I think I've found some spots where it's been added to various tools, so it's less of a concern now.  I don't have the list handy, but I'll put a note in the patch about it.
16:37:53 <catherineD> eglute: mostly no... because people only test with passing in required test list
16:38:13 <markvoelker> luzC: see https://github.com/openstack/defcore/blob/master/working_materials/scoring.txt#L107-L118 for context
16:38:17 <eglute> catherineD thats too bad
16:38:33 <luzC> markvoelker thanks
16:38:52 * markvoelker yields the floor
16:39:22 <eglute> if no more on neutron, we will look forward to the patch
16:39:27 <catherineD> yea we would like people to test all API tess ..
16:40:09 <eglute> catherineD that would be nice... maybe we can discuss in boston how to get more of that
16:40:19 <eglute> Moving onto Swift.
16:40:29 <eglute> I attempted to score it, #link https://review.openstack.org/#/c/453453/
16:40:50 <eglute> i dont think there will be any new capabilities this time around
16:41:06 <eglute> but i still need to talk to PTL about it
16:41:33 * markvoelker notes that people are already encouraged to run all tests as per https://www.openstack.org/brand/interop/ ("We prefer that you run the complete set of non-admin API tests, however, Tempest can be run with a precompiled inventory of tests available from the RefStack server guidelines page.") but it's still not mandatory
16:42:26 <eglute> lets discuss making it mandatory in boston, what does everyone think?
16:43:08 <luzC> eglute: +1 lets discuss it
16:43:14 <mguiney> +1
16:43:29 <eglute> I started adding topics, will move to own etherpad soon
16:44:09 <eglute> back to Swift! Please review patch #link https://review.openstack.org/#/c/453453/
16:44:09 <eglute> let me know if you have any comments
16:44:15 <catherineD> yea that is one of the goal of RefStack ... collecting data
16:45:37 <luzC> I have a general question, if a capability is already on the guideline as required... should it still  be scored?
16:45:40 <eglute> catherineD +1
16:46:06 <eglute> luzC you can take a look at it and re-score it if you think it is needed
16:46:07 <markvoelker> luzC: I generally do rescore existing capabilities, though often they don't change.
16:46:41 <luzC> eglute: markvoelker: ok, thanks
16:46:58 <eglute> Moving on! Keystone is next
16:47:05 <markvoelker> luzC: the primary thing I look for is stuff where changes may cause a capability to drop out: for example, a major-version API deprecation or responsibility for a thing shifting to another project or something.
16:47:25 <eglute> luzC any updates on keystone?
16:47:41 <luzC> yes, I have the capability list from PTL...
16:48:04 <luzC> probably just one new capability - identity-v3-validate-token - but I need to check if there is test cases and if non-admin...
16:48:13 <eglute> luzC great!
16:48:43 <luzC> I'm submitting the patch later this week
16:48:48 <rockyg> Mark, sounds like it might be good to capture some of your wisdom on rescoring.
16:48:50 <eglute> thank you luzC
16:49:15 * catherineD BTW just want to let everyone know that luzC: is now RefStack core reviewer
16:49:21 * markvoelker adds another thing to his list of stuff to write whilst flying around in aeroplanes
16:49:45 <eglute> Congratulations luzC!!!
16:49:56 <rockyg> Con gratz luzC and thanks markvoelker !
16:50:04 * eglute is happy that she is not flying as much as markvoelker
16:50:35 <eglute> anything else on keystone?
16:50:49 <luzC> eglute, rockyg thank you, also thank you to catherineD for the nomination :)
16:50:59 <eglute> :D
16:51:03 <luzC> eglute no that's it
16:51:08 <eglute> moving on..
16:51:18 <eglute> #topic Name change
16:51:23 <eglute> markvoelker any updates?
16:52:44 <markvoelker> That patch seems to be just sitting in the infra queue with no attention, but I was away during the infra meeting again.  Sounds like I just need to go ping somebody on IRC.
16:52:53 <eglute> thanks markvoelker
16:53:11 <eglute> #topic New components/add-on programs
16:53:35 <eglute> markvoelker that was also waiting on you i think... any updates?
16:53:48 <rockyg> markvoelker, they were talking about doing a batch of repo changes over the past weekend.  Maybe it got postponed
16:54:23 <markvoelker> Nothing new this week...hogepodge and I were both in Germany last week but didn't manage to sit down over a nice German beer and discuss, so I'll queue it up again this week.
16:54:43 <eglute> thanks markvoelker!
16:55:03 <eglute> hope there is less flying in your future!
16:55:34 <eglute> except, of course, there is Boston Summit coming up
16:55:44 <eglute> #topic Boston Summit Sessions
16:56:10 <eglute> please add your sessions that were accepted, anything interop or refstack
16:56:19 <eglute> we will share it with the mailing list
16:56:47 <eglute> I also started etherpad for topics during our WG sessions https://etherpad.openstack.org/p/InteropWGBostonSummit
16:57:12 <eglute> I asked for 2 sessions back to back, hopefully the calendar will be updated to reflect that soon
16:57:21 <eglute> but please start updating https://etherpad.openstack.org/p/InteropWGBostonSummit
16:58:21 <eglute> with that, i think we are done. I have a conflict next week, so will rely on markvoelker and hogepodge to run this meeting
16:58:28 <eglute> any last minute comments?
16:59:03 <eglute> if none, thanks everyone!!
16:59:11 <eglute> #endmeeting