16:01:23 <eglute_s> #startmeeting interopwg
16:01:24 <openstack> Meeting started Wed Jun 21 16:01:23 2017 UTC and is due to finish in 60 minutes. The chair is eglute_s. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:28 <openstack> The meeting name has been set to 'interopwg'
16:01:43 <eglute_s> Hello Everyone! if you are here for interopwg, raise your hand!
16:01:53 <eglute_s> #link agenda: https://etherpad.openstack.org/p/InteropVertigo.5
16:01:59 <eglute_s> please update agenda as needed!
16:02:02 <hogepodge> o/
16:02:03 <eglute_s> #chair hogepodge
16:02:04 <openstack> Current chairs: eglute_s hogepodge
16:02:56 <eglute_s> Mark is not able to attend today
16:03:12 <eglute_s> anyone else besides hogepodge and mrhillsman here for interop?
16:03:36 <mguiney> o/
16:03:44 * eglute_s waves
16:03:52 <luzC> o/
16:04:17 <eglute_s> Hello Everyone! Once again, agenda is here: https://etherpad.openstack.org/p/InteropVertigo.5
16:04:37 <eglute_s> #topic Denver PTG
16:04:57 <Rockyg> o/
16:04:58 <eglute_s> Thanks hogepodge for confirming us for Monday/Tuesday!
16:05:13 <eglute_s> everyone, please book your travel to PTG. Hope to see you all there!
16:05:39 <eglute_s> we will start the agenda etherpad for PTG when it gets a little closer i think
16:05:52 <eglute_s> #topic 2017.08 Guideline
16:06:07 <eglute_s> #link https://review.openstack.org/#/c/472848/
16:06:25 <eglute_s> everyone, please review the 2017.08 guideline
16:06:33 <eglute_s> #action everyone review https://review.openstack.org/#/c/472848/
16:06:55 <eglute_s> we still have one outstanding patch: https://review.openstack.org/#/c/467528/
16:07:16 <eglute_s> mguiney i guess it is failing on Jenkins?
16:07:39 <mguiney> yeah, i have a fix that i think will remedy that, i just have to finish testing it
16:07:57 <eglute_s> cool, thank you so much!
16:08:57 <eglute_s> so if this test gets added, are we still ok to add the test to the 2017.08?
16:09:09 <eglute_s> what do you think hogepodge
16:09:45 <eglute_s> and everyone else?
16:09:51 <hogepodge> I think so, yeah
16:10:02 <luzC> me too,
16:10:06 <mguiney> cool
16:10:07 <eglute_s> cool... thank you mguiney for working on this
16:10:29 <eglute_s> anything else regarding 2017.08 guideline?
16:11:23 <eglute_s> #topic
16:11:24 <eglute_s> Add tokens validate capability as 2017.08 advisory
16:11:31 <eglute_s> #topic Add tokens validate capability as 2017.08 advisory
16:11:38 <eglute_s> #link https://review.openstack.org/#/c/475906/
16:11:45 <eglute_s> thank you luzC for submitting the patch
16:12:05 <eglute_s> I think it is missing actual patch to 2017.08?
16:13:10 <eglute_s> luzC?
16:13:11 <luzC> ah since Mark's patch is not merged yet I only modified next.json
16:13:19 <eglute_s> ah ok
16:13:26 <eglute_s> yeah that complicates things
16:13:37 <eglute_s> could you modify Mark's patch?
16:13:50 <eglute_s> i guess can be done after this one is merged
16:13:56 <eglute_s> thank you so much!
16:14:25 <eglute_s> #action everyone review https://review.openstack.org/#/c/475906/
16:14:31 <luzC> and yes I can modify Marks's patch :)
16:15:28 <eglute_s> thanks!
16:16:08 <eglute_s> i will do proper review after the meeting, but there is a 2015.05 required date
16:16:12 <eglute_s> i think that needs updating
16:16:44 <eglute_s> anything else on this?
16:16:59 <eglute_s> #topic Fix html_last_updated_fmt for Python3
16:17:10 <eglute_s> #link https://review.openstack.org/#/c/475220/
16:17:38 <eglute_s> Python 3 compliance patch. looks good to me, if no objections, i will merge it later today
16:17:51 <eglute_s> so please take a quick look and let me know if there are any issues there
16:18:59 <eglute_s> #topic Adding python35 support to jsontorst script
16:19:06 <eglute_s> #link https://review.openstack.org/#/c/475031/
16:19:23 <eglute_s> another python 3 patch. thank you luzC!
16:19:31 <eglute_s> everyone, please review.
16:20:12 <mguiney> thank you!
16:20:18 <mguiney> or rather, ca do!
16:20:31 <eglute_s> great, thanks mguiney
16:20:32 <mguiney> scrolled up too far, sorry
16:20:37 <eglute_s> heheh
16:21:02 <Rockyg> ++
16:21:20 <eglute_s> #topic 2.0 schema
16:21:32 <eglute_s> #link https://review.openstack.org/#/c/430556/
16:21:58 <eglute_s> if you have not had a chance to review schema 2.0, please do so
16:22:09 <hogepodge> So, no reviews since last week.
16:22:14 <eglute_s> I think it looks good, except for a few minor things
16:22:29 <hogepodge> (well, not no, but just one from egle)
16:22:34 <eglute_s> heheh
16:22:51 <hogepodge> I'm going to get working on formalizing it. Please review asap so I can take your comments into account.
16:22:56 <eglute_s> I actually tried to think of what might be missing,
16:23:06 <luzC> I'll
16:23:07 <eglute_s> and came to the conclusion that we will find the missing things once we try to add the add-ons.
16:24:01 <eglute_s> i do like how simple it makes having add-ons or standalone programs
16:24:31 <eglute_s> any other comments on schema?
16:24:39 <eglute_s> we presented this draft to the board yesterady
16:25:03 <eglute_s> had good discussion, the board seems to be on board with this
16:25:27 <hogepodge> +1
16:25:50 <eglute_s> thank you hogepodge for working on the schema
16:25:55 <eglute_s> #Create rough draft of extension programs
16:26:10 <eglute_s> #link https://review.openstack.org/#/c/472785/
16:26:27 <eglute_s> Same here. please review and let us know if you have any comments or issues
16:27:15 <eglute_s> any comments on Mark's draft?
16:27:24 <Rockyg> gotten through half of it. Will finish up after this meeting
16:27:51 <eglute_s> thank you Rockyg
16:27:59 <mrhillsman> same here
16:28:09 <eglute_s> thanks mrhillsman
16:28:23 <luzC> I think it looks really good, but since I'm familiar with all the context it makes sense... wondering about other teams in the community
16:28:33 <eglute_s> luzC good point
16:28:47 <eglute_s> i think it would be worth while to send it out to the community to review
16:29:03 <Rockyg> getting some on the tc to review. we'gve got two so far
16:29:12 <eglute_s> for me as well all of it makes sense, since we been talking a lot about it
16:30:05 <eglute_s> i dont think we sent these yet to dev/ops lists yet for review
16:30:12 <eglute_s> i can do that later today
16:30:32 <eglute_s> oh actually we did
16:30:57 <Rockyg> yup
16:31:28 <luzC> yes, Mark sent an email
16:31:28 <eglute_s> ok, then i will not be sending out again
16:31:43 <eglute_s> #topic Mandatory submission of test results
16:32:09 <eglute_s> so last week hogepodge said he will work on draft of what that might look like
16:32:13 <eglute_s> hogepodge any updates?
16:32:20 <hogepodge> no, not on that
16:32:51 <eglute_s> cool,
16:33:05 <eglute_s> not super urgent in any case
16:33:22 <eglute_s> #topic Vertical Programs
16:33:42 <eglute_s> So Friday morning we are invited to join OPNFV meeting
16:33:46 <eglute_s> if you can, please join.
16:34:17 <eglute_s> if you are interested in NFV, or are knowledgeable about it, it would be very helpful
16:34:20 <Rockyg> Can you send an invite with info?
16:34:34 <eglute_s> yes, i can forward invite to the mailing list
16:34:41 <Rockyg> Thanks.
16:34:46 <luzC> eglute_s: are you sending meeting details?
16:34:48 <Rockyg> I'll try to make it
16:34:53 <mrhillsman> it is on the agenda as well
16:35:16 <mrhillsman> but email does not hurt :)
16:35:23 <eglute_s> #action eglute_s to forward the invite to OPNFV to the ML
16:35:25 <luzC> mrhillsman: I see, thanks
16:35:34 <eglute_s> yes, i will forward. it is very early
16:35:42 <eglute_s> especially for those in PST time zone
16:36:02 <eglute_s> most participants are in europe i think, hence the early meetings
16:36:11 <Rockyg> dang.
16:36:28 <eglute_s> 6:00 AM PST
16:36:51 <eglute_s> any other comments on this?
16:36:54 <mrhillsman> coocoo clock :)
16:36:58 <eglute_s> heheh
16:37:12 <eglute_s> #topic Implementing "Defcore additional properties waiver" at RefStack
16:37:21 <eglute_s> #link https://review.openstack.org/#/c/370534/
16:37:23 <Rockyg> I think I'll work from home that day =P
16:37:41 <eglute_s> luzC added this,
16:38:17 <eglute_s> everyone, please review
16:38:33 <luzC> yes, so the patch is not working right now ant I might take a while to fix it, since waiver time is almost gone
16:38:33 <eglute_s> luzC any additional comments on this patch?
16:38:35 <Rockyg> Yeah. What was the end of the waiver period?
16:39:04 <Rockyg> I think it will be gone by 2017.08?
16:39:12 <luzC> we were wondering if we should still pursue adding this into refstack or are we ok to drop the effort?
16:39:31 <eglute_s> is the waiver period already over?
16:39:42 <eglute_s> i imagine in the future there might be other waivers
16:39:46 <Rockyg> That's the 64k question!
16:39:48 <eglute_s> so might be useful
16:39:53 <hogepodge> I don't know who will be using it any more. eglute_s and Rockyg probably have the best insights as consumers of the waiver
16:40:11 <mrhillsman> what is "the waiver"?
16:40:18 <Rockyg> hogepodge, wich guideline did it get put on?
16:40:39 <eglute_s> if it is only 2 companies that asked for the waiver, then might not be worth the coding effort
16:40:45 <Rockyg> I know that latest releases for Huawei are passing, I *think* without waivers
16:41:06 <luzC> mrhillsman: Defcore committee approved a waiver that allows vendors who are using the Nova 2.0 API with additional properties to disable strict response checking when testing products for the OpenStack Powered program in 2016.
16:41:29 <mrhillsman> thx
16:42:05 <eglute_s> i think if the code is there, should probably be merged
16:42:35 <Rockyg> When 2017.08 hits, then, the waivers should be over. Last two rule
16:42:55 <hogepodge> Rockyg: I don't remember exactly, one of the older versions of Fusion Sphere I think
16:43:09 <eglute_s> unless someone asks for the same extension of the waiver?
16:43:21 <hogepodge> maybe the DT cloud? I'd have to consult my notes.
16:43:54 <mrhillsman> i do not know much about this but i guess i would ask could waivers exist in the future for other cases?
16:43:57 <Rockyg> Yup. That was a Juno version. I think the new one is ok. Did you see the waiver used on the latest cert?
16:44:29 <Rockyg> No, DT will qualify against 2017.01 next cert.
16:44:29 <hogepodge> we gave a year so that products could move off of it.
16:45:07 <eglute_s> a year starting when? do you remember hogepodge
16:46:01 <Rockyg> I suspect that if you used the waiver, it happened against a 2016, so recert would be no waiver.
16:46:28 <Rockyg> But maybe someone certified against current guideline with the waiver?
16:46:43 <luzC> https://github.com/openstack/interop/blob/master/working_materials/additional_properties_waiver.rst
16:47:23 <eglute_s> thank you luzC
16:47:24 <hogepodge> 2016.08 was supposed to be the last available guideline, so waiver will end in 2017.08
16:47:34 <Rockyg> thanks, luzC The waiver period is over
16:47:55 <Rockyg> once .08 is out ;-)
16:48:09 <hogepodge> because 2017.01 and 2016.08 are the current guidelines
16:48:19 <eglute_s> I think it is up to refstack team if they want to keep the code for wavers
16:48:37 <eglute_s> i am ok with the refstack supporting them
16:48:44 <Rockyg> so, someone could still get waiver if they submit with 2016.08 before the new release
16:49:11 <eglute_s> correct
16:49:31 <luzC> the implementation was very specific to this waiver not having generic waivers...
16:49:38 <eglute_s> ah ok
16:49:53 <luzC> but let me go back to refstack to see what is the consensus
16:50:05 <eglute_s> thank you luzC
16:50:18 <eglute_s> anything else on this?
16:51:40 <eglute_s> #topic open discussion
16:51:44 <eglute_s> anything else today?
16:52:18 <eglute_s> if not, we can end a few minutes early
16:52:21 <eglute_s> thank you everyone!
16:52:25 <eglute_s> #endmeeting