16:01:35 <eglute> #startmeeting interopwg
16:01:36 <openstack> Meeting started Wed Sep 20 16:01:35 2017 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:40 <openstack> The meeting name has been set to 'interopwg'
16:01:52 <eglute> Hello Everyone!
16:01:57 <eglute> #topic agenda
16:02:08 <ildikov> o/
16:02:08 <georgk> hi
16:02:09 <eglute> Please review+update agenda #link https://etherpad.openstack.org/p/InteropVertigo.15
16:02:41 <markvoelker> o/
16:02:41 <hogepodge> hi
16:02:42 <eglute> #chair hogepodge markvoelker
16:02:43 <openstack> Current chairs: eglute hogepodge markvoelker
16:03:11 <eglute> #topic Denver PTG
16:03:24 <eglute> thanks everyone that participated in Denver PTG!
16:03:46 <catherineD> o/
16:04:17 <mguiney> o/
16:04:17 <eglute> PTG notes are linked from main etherpad: #link https://etherpad.openstack.org/p/InteropDenver2017PTG
16:04:46 <Rockyg> o/
16:05:12 <hogepodge> I tried to collect all of the action items at the top of that pad, and have transferred them to the meeting agenda so we can track them.
16:05:29 <hogepodge> Please make any additions or corrections that you feel are appropriate
16:05:34 <eglute> thank you hogepodge!!!
16:06:23 <eglute> lots of action items!
16:07:02 <eglute> i think everyone in this meeting participated in the PTG
16:07:45 <eglute> so i will not provide any additional summaries unless there are questions?
16:08:52 <georgk> fine with me
16:08:53 <eglute> I think most action items will get worked as part of the agenda items
16:09:03 <eglute> any other comments on PTG?
16:09:42 <eglute> #topic board meeting
16:10:03 <eglute> The board has approved the new guideline as well as extension programs
16:11:06 <eglute> we didnt get as much discussion as i was expecting. Only concern is dilution of the program with too many add-ons
16:11:20 <eglute> so need to keep an eye on that
16:11:32 <eglute> #topic OPNFV CVP/Dovetail
16:11:39 <eglute> ildikov go ahead!
16:11:44 <ildikov> eglute: thanks!
16:12:29 <ildikov> I wanted to give a heads up on the OPNFV certification program
16:13:04 <ildikov> as most of you know we are collaborating with them in that area and also helping them to put together their program and being able to check OpenStack as part of the OPNFV reference platform
16:13:23 <ildikov> in this sense our program and tests are referenced in some of the documents
16:13:57 <ildikov> you can find reference to RefStack and the OpenStack Powered program in the CVP addendum
16:14:07 <ildikov> #link http://artifacts.opnfv.org/dovetail/docs/testing_user_cvpaddendum/index.html
16:14:46 <eglute> great, thank you ildikov!!
16:15:15 <ildikov> I would like to draw the attention to the note in the 'Scope of the Danube-release of the CVP' section on having tests covered from the OpenStack Powered Compute program does not imply OpenStack certification granted
16:15:34 <eglute> #action everyone please review #http://artifacts.opnfv.org/dovetail/docs/testing_user_cvpaddendum/index.html and provide feedback to ildikov
16:15:42 <ildikov> please check the wording of it and raise if you find any issues to georgk and/or me
16:15:45 <eglute> #action everyone please review #link http://artifacts.opnfv.org/dovetail/docs/testing_user_cvpaddendum/index.html and provide feedback to ildikov
16:16:18 <ildikov> you can also find DefCore references replaced with 'OpenStack Interoperability tests and guidelines' in a patch under review
16:16:21 <ildikov> #link https://gerrit.opnfv.org/gerrit/#/c/41601/
16:16:29 <eglute> thanks ildikov I will review and let you and georgk know about any feedback
16:16:39 <kgarloff> dito
16:16:44 <ildikov> eglute: sounds great, thank you
16:17:01 <ildikov> you can find all the documents on the OPNFV Dovetail wiki in case interested
16:17:07 <ildikov> #link https://wiki.opnfv.org/display/dovetail/Dovetail+%28Danube%29+Documentation+for+Review
16:17:16 <eglute> thank you!
16:17:24 <ildikov> georgk: is there anything I missed and would be worth mentioning?
16:17:46 <georgk> nothing I am aware of
16:17:55 <ildikov> georgk: cool, thanks
16:17:58 <georgk> if there are any questions, just reach out
16:18:08 <eglute> thanks georgk and ildikov!
16:18:10 <ildikov> eglute: that would've been my quick update unless there are questions
16:18:31 <eglute> thanks! no questions from me right now
16:18:43 <ildikov> cool, thanks!
16:19:03 <eglute> #Ideas to simplify Interop process
16:19:07 <ildikov> I'm also available for any questions after the meeting if anyone has any
16:19:16 <eglute> thanks ildikov!
16:19:31 <eglute> So this is something I would like everyone to start thinking about
16:19:57 <eglute> right now, we have weekly meetings with continuous scoring+updates to the programs.
16:20:23 <eglute> it takes a lot of time+coordination, and I think we need to make this simpler+easier
16:20:56 <eglute> if you have any ideas, please share
16:21:07 <eglute> i will also start a separate etherpad
16:21:32 <eglute> #link https://etherpad.openstack.org/p/SimplifyInterop
16:22:24 <eglute> any ideas right now?
16:22:49 <hogepodge> eglute: what were your initial thoughts on simplification?
16:23:26 <eglute> I think the scoring+updating new guidelines takes a lot of time. with more programs, even more time
16:23:52 <eglute> I am not sure where to start though to make this process simpler
16:24:40 <eglute> i need to give it more thought!
16:24:53 <eglute> perhaps there is not much we can do
16:25:03 <eglute> but thats why i need everyone's input here
16:26:03 <markvoelker> I think the most time-consuming ones are the early-phase projects.  The existing Powered programs seem like they're taking less time since we're not adding/removing a lot of stuff nowadays and have the division of labor down.
16:26:11 <markvoelker> Not to say there isn't room for improvement of course. =)
16:26:24 <eglute> in any case, just wanted to get the conversation started and getting eveyrone thinking about this
16:26:37 <eglute> and markvoelker is right
16:27:46 <hogepodge> Offloading some work to projects will help. Trusting them to spec out their own interop requirements will go a long way.
16:28:02 <eglute> hogepodge true
16:28:06 <eglute> i like that idea
16:28:58 <eglute> #action everyone to think about how to simplify the process and update ehterpad #link https://etherpad.openstack.org/p/SimplifyInterop
16:28:58 <georgk> for the NFV-related program, OPNFV folks should be able to take some of the load
16:29:06 <eglute> thanks georgk!
16:29:26 <georgk> with some initial guidance, of course :-)
16:29:39 <eglute> georgk of course! and we are glad to help
16:30:04 <eglute> talking of NFV, i think time for next topic
16:30:24 <eglute> #topic Vertical Program Update
16:30:26 <hogepodge> nice segue eglute ;-)
16:30:36 <eglute> markvoelker, any updates there besides ildikov's update?
16:31:36 <markvoelker> Not yet--I have an AI to boil down the stuff in our pads from the PTG into an API list and scoring worksheet, but I just got back at 1am Monday so not much there yet. =)
16:31:55 <eglute> markvoelker understood! and thank you!
16:32:03 <georgk> i have started to compile a list of OpenStack APIs used by OPNFV projects
16:32:10 <georgk> it is far from being complete yet
16:32:22 <georgk> i need a bit more time, but i am working on it
16:32:24 <eglute> georgk great, glad to hear it
16:32:43 <Rockyg> cool.
16:32:50 <eglute> georgk i am looking forward to seeing the list!
16:33:43 <eglute> anything else on NFV?
16:34:05 <markvoelker> FWIW, ONAP multi-vim has given me a similar API list too, so we're headed in the right direction. =)
16:34:42 <eglute> markvoelker excellent!
16:34:43 <Rockyg> ++
16:34:55 <ildikov> +1
16:35:17 <markvoelker> Folks may also want to take note of this if they're unaware (I'm sure georgk is):
16:35:24 <markvoelker> #link https://github.com/opnfv/dovetail/blob/master/docs/testing/developer/testscope/index.rst dovetail test list
16:35:45 <georgk> :-)
16:37:00 <eglute> looks like georgk started that doc :)
16:37:38 <eglute> anything else on this topic?
16:38:23 <eglute> #topic Scoring 2018.01 guideline
16:38:43 <eglute> thanks everyone that volunteered to score for the new guideline
16:39:58 <markvoelker> Note for posterity since I volunteered to handle Neutron:
16:39:59 <eglute> since we have slightly less time than usual, i think the timeline for scoring should be a bit compressed
16:40:07 <markvoelker> #link https://review.openstack.org/#/c/502308/ New Neutron PTL (not quite official yet)
16:40:11 <Rockyg> ++
16:40:18 <markvoelker> ++
16:40:24 <eglute> hogepodge markvoelker how much time do you think we need
16:40:43 <eglute> thanks markvoelker
16:41:25 <hogepodge> eglute: I don't know
16:41:48 <eglute> 2 weeks enough for initial scoring?
16:41:54 <markvoelker> Personally I'm hoping to have patches up this month, because next month is sort of bananas for me.
16:42:24 <eglute> thanks markvoelker
16:42:36 <eglute> me thinks that this year in general is fruity
16:43:05 <hogepodge> Two weeks is not enough. I'm still catching up on my PTG backlog this this week is out for me.
16:43:17 <eglute> hogepodge ok, 1 month then
16:43:27 <eglute> would that work?
16:43:39 <Rockyg> well, it's better...
16:44:11 <markvoelker> For the Powered program, that might work.  I suspect the add-ons and verticals might need a longer comment period.
16:44:50 <Rockyg> agreed
16:44:59 <eglute> ok. i am sure it will work out
16:45:21 <hogepodge> Can we mock up a schedule in the meeting etherpad like we've done before?
16:45:53 <eglute> hogepodge sure! I will do that. but the schedule used to rely on 6 month cycle, so will need to compress it a bit
16:46:16 <markvoelker> eglute: that'd be good...a concrete proposal is always easier to consider
16:46:18 <hogepodge> sure
16:48:24 <eglute> ok, so i started the schedule. Based on the schedule, we should aim to get scoring done at the first half of October
16:48:39 <eglute> but I would be happy if we get it done before the summit
16:48:49 <Rockyg> That's a month...
16:49:49 <Rockyg> how about initial target mid oct, then going thrugh them as they land and trying to finalize all by summit?
16:50:00 <eglute> Rockyg i think that will work
16:50:24 <eglute> Summit -1 months (October 6): Score Capabilities
16:50:50 <eglute> but it doesnt say whether thats when we start or finish ;) So i would like to aim for mid october and finish before the summit
16:51:34 <eglute> we can also move the guideline approval to February. i need to see if there is a planned meeting in February
16:51:35 <Rockyg> so, the10/6 is submit drafts by...aprove scores by is summit
16:52:23 <eglute> correct
16:52:38 <Rockyg> and the new pregrams can exrend approval to end of nov/start od dec?
16:52:59 <Rockyg> blech. one hand typing
16:53:02 <eglute> Rockyg what do you mean? scoring for new programs?
16:53:37 <Rockyg> opnvv, etc.  They should have more time for discussion
16:54:23 <eglute> Rockyg yes, any new programs can have as much time as needed.
16:54:39 <Rockyg> a formal review session with the OPNFV team/interested parties
16:54:52 <eglute> it just means they might miss being approved at a certain date, but thats ok
16:55:22 <eglute> 5 min left for today's meeting
16:55:34 <eglute> #topic Future project consultation
16:55:42 <eglute> any updates on those projects?
16:55:58 <markvoelker> Not from me (see earlier comment about just getting back)
16:56:06 <eglute> i know it is immediately after PTG, so I am not expecting any
16:56:16 <markvoelker> I did speak a little with a couple of Senlin folks and they seem ammenable.
16:56:25 <eglute> thanks markvoelker
16:56:26 <markvoelker> Just casual over lunch though
16:56:44 <eglute> if you can document that at some point, might help in the future
16:56:53 <Rockyg> any chance you talked to dragonflow?
16:57:13 <markvoelker> Rockyg: not I
16:57:15 <eglute> Rockyg i think there was talk of cloudkitty not having enough contributors
16:58:30 <Rockyg> I think we could use a timeline of project first releases in the o.o website.  Make our lives easer ;-)
16:58:49 <eglute> everyone, as you talk to different projects, please document the discussion so that we know the status. even an email to ML would be helpful
16:59:28 <eglute> almost out of time today
16:59:31 <eglute> any last words?
16:59:53 <Rockyg> word
17:00:11 <eglute> lol!
17:00:21 <eglute> thanks everyone!!!
17:00:24 <eglute> #endmeeting