16:00:26 <eglute> #startmeeting interopwg
16:00:28 <openstack> Meeting started Wed Jan  3 16:00:26 2018 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:30 <markvoelker> o/
16:00:31 <openstack> The meeting name has been set to 'interopwg'
16:00:42 <eglute> #chair markvoelker hogepodge
16:00:42 <openstack> Current chairs: eglute hogepodge markvoelker
16:00:48 <eglute> #topic Agenda
16:00:54 <eglute> #link https://etherpad.openstack.org/p/InteropWhistler.2
16:01:09 <eglute> Hello Everyone, Happy New Year!
16:01:16 <eglute> please review and update agenda as needd
16:01:20 <eglute> as needed
16:01:57 <eglute> Anyone else here for the interop meeting?
16:02:01 <mguiney> o/
16:02:13 * eglute sends coffee to mguiney and markvoelker
16:02:28 <hogepodge> happy new year!
16:02:34 * markvoelker could use another coffee actually...it's darned cold here this week
16:03:09 <eglute> record colds in TX i think
16:03:52 <markvoelker> Woke up to 13 degrees today which was a bit warmer than yesterday morning.  Schools opened late yesterday, closing early today. Nuts. =)
16:04:09 <eglute> markvoelker that does sound nuts! Stay warm!
16:04:12 <mguiney> oof
16:04:19 <georgk> hi
16:04:30 <eglute> hello georgk!
16:04:31 <eglute> so i think we have enough people for the meeting today. Hope everyone had a nice break :)
16:04:46 <eglute> #topic 2018.02 guideline
16:05:09 <eglute> Thanks markvoelker for verifying that there are no updates to neutron
16:05:17 <eglute> any other updates that we are missing from the next guideline?
16:05:35 <eglute> at a quick glance, i think the approval date needs changing, but that is all?
16:06:28 <markvoelker> Seems mostly ok to me, I'll have a glance over it this afternoon
16:06:31 <eglute> if you can spot any other issues with it, let us know.
16:06:33 <markvoelker> Pretty minor changes this go-around
16:06:45 <eglute> thanks everyone who helped with the scoring!
16:07:08 <eglute> i think minor changes means that the guideline is pretty solid
16:07:24 <eglute> #topic Add-on programs
16:07:46 <eglute> updates on NFV vertical? i know georgk has a couple patches
16:08:18 <markvoelker> #link https://review.openstack.org/527390 Scoring of networking-bgp for NFV vertical
16:08:32 <georgk> well, just the two I pushed before christmas - I´ll get going next week again
16:08:34 <markvoelker> #link https://review.openstack.org/519732 First attempt at scoring trunk ports for NFV vertical
16:10:07 <georgk> for the trunk port patch, there are a few comments from Luz on my first patchset open
16:10:12 <georgk> feedback is very welcome
16:10:28 <eglute> yes, thanks to luzC on the thorough review.
16:11:08 <eglute> it all looks good to me, but i dont know much about NFV
16:11:25 <georgk> regarding the bgpvpn, there is a general question regading test coverage
16:11:47 <eglute> yes, that was going to be my question as well- are there tests?
16:11:52 <georgk> currenlty, there are some really simple test cases missing, such as listing and showing objects
16:12:02 <georgk> there are  more complex ones :-)
16:13:20 <georgk> and negative ones, e.g. you cannot list objects that don´t belong to you, but there is no test testing the positive case
16:13:32 <eglute> georgk i guess it would be good to see a a patch with json listing the tests?
16:13:40 <georgk> I discussed that with the bgpvpn team, but someone probably needs to create them...
16:13:53 <eglute> also, what do you mean by "dont belong to you"?
16:14:12 <georgk> oh, yes. I think I have that - just need to push it
16:14:27 <georgk> objects created for another tenant
16:14:28 <eglute> thank you georgk
16:14:34 <eglute> georgk ah ok
16:15:09 <eglute> also, regarding missing tests- do you know who might create them?
16:15:33 <georgk> ok, I´ll push an update and then kindly ask you for a brief review
16:15:48 <eglute> thank you georgk!
16:16:27 <georgk> well, there is a launchpad item for this now, but it has not been assigned. I was asked to do it, but didn´t find the time
16:16:51 <eglute> georgk do you have a link?
16:17:10 <georgk> eglute: oh, let me see...
16:18:58 <georgk> #link https://bugs.launchpad.net/bgpvpn/+bug/1737773
16:18:59 <openstack> Launchpad bug 1737773 in networking-bgpvpn "tempest: add API tests for listing, showing and deleting BPGVPN(s)" [Undecided,New]
16:19:18 <eglute> thank you georgk will put that in the notes for tracking
16:20:12 <eglute> everyone, please review the two NFV patches
16:20:21 <eglute> anything else on NFV vertical?
16:22:26 <eglute> thanks markvoelker for adding notes on listing API versions
16:23:09 <eglute> Regarding add ons, there is also a patch on Heat
16:23:10 <eglute> #link https://review.openstack.org/#/c/529836
16:23:17 <eglute> everyone, please review
16:23:28 <eglute> some new capabilities added there
16:24:04 * markvoelker thinks we ought to add version discovery to this one too...keeps coming up from the client community
16:24:27 <eglute> markvoelker would you comment on the patch and ask?
16:24:32 <markvoelker> will do
16:24:44 <eglute> thank you markvoelker
16:25:09 <eglute> i have not had a chance to fully review the patch myself, so appreciate all the feedback
16:25:27 <eglute> but i think,
16:26:13 <eglute> last time we had capabilities as advisory presented to the board, and they are ready to move to required?
16:26:28 <eglute> hogepodge do you think the add-on is ready for that?
16:27:15 <hogepodge> I think so for a few of them
16:27:49 <eglute> ok, can you comment which ones are ready to be moved? if not all that were advisory last time?
16:28:05 <hogepodge> DNS, orchestration
16:28:22 <eglute> hogepodge i mean more specifically for https://review.openstack.org/#/c/529836
16:28:38 <eglute> there are new capabilities added, under advisory
16:28:46 <eglute> so all old and new are still advisory
16:29:38 <eglute> hogepodge when you have a chance if you could review it that would be helpful
16:30:00 <hogepodge> Ok
16:30:04 <eglute> thank you hogepodge
16:30:22 <eglute> #action everyone review #link https://review.openstack.org/#/c/529836
16:30:39 <eglute> anything else on heat add on?
16:31:51 <eglute> moving on... did patches out of order today... There was one of note that was merged: https://review.openstack.org/#/c/521587/
16:32:06 <eglute> hogepodge does Heat require the same tag?
16:33:07 <hogepodge> Designate is looking for the tag to be considered a core project for their reasons
16:33:41 <hogepodge> We're not constrained by the TC, we have our own criteria for choosing projects
16:33:54 <eglute> ok, makes sense
16:33:59 <markvoelker> Heat already has that tag anyway: https://github.com/openstack/governance/blob/master/reference/projects.yaml#L477
16:34:22 <eglute> thanks markvoelker!
16:34:42 <hogepodge> Add ons mess with the TC tempest resolution, which i think was a bit reactionary and short sighted in retrospect
16:34:54 <eglute> :)
16:35:10 <eglute> which brings us to this patch: https://review.openstack.org/#/c/521602/
16:35:22 <eglute> seems to have died in review,
16:35:39 <eglute> or at least comments stopped for a bit
16:36:40 <eglute> if anyone cares to comment on it, please do
16:37:10 <eglute> otherwise, we are ready to move to the next topic
16:37:11 <eglute> #topic Dublin PTG
16:37:35 <eglute> if you are planning on attending, please update etherpad #link https://etherpad.openstack.org/p/InteropDublin2018PTG
16:38:15 <eglute> hogepodge do you know if the schedule is same as before?
16:38:34 <eglute> there is a very strong possibility that the board meeting is on Monday of that week
16:38:54 <hogepodge> I'm looking for a day for refstack, day for interop, depending on confirmed attendance
16:39:29 <eglute> hogepodge i think that would work
16:39:56 <markvoelker> Schedule: Inter-project work Monday/Tuesday, Single-project meetings Wednesday-Friday
16:40:05 <markvoelker> #link https://www.eventbrite.com/e/project-teams-gathering-dublin-2018-tickets-39055825024 Tickets and schedule
16:40:41 <eglute> thanks markvoelker
16:41:52 * eglute wonders how cold Dublin is at the end of February
16:42:03 <mugsie> above freezing
16:42:10 <mugsie> but windy
16:42:43 <eglute> mugsie i hope it is a nice balmy weather :)
16:43:33 <mguiney> oooooh i miss balmy
16:44:10 <eglute> heheh
16:44:21 <eglute> I think this is it for today's agenda
16:44:27 <eglute> #topic openfloor
16:44:32 <eglute> anything else for today?
16:44:35 <mrhillsman> ;-; I had another meeting, will catch up via eavesdrop
16:45:08 * eglute waves to mrhillsman
16:45:09 <eglute> mugsie do you live in Dublin?
16:45:21 <mugsie> yup
16:45:53 <eglute> mugsie nice!
16:46:11 <mrhillsman> I'll be in Dublin looking to get my keys dirty helping with something during work sessions
16:46:22 <eglute> will have someone to ask questions about what to do/see there, besides PTG!
16:46:43 <mugsie> yeah, I am putting a list together at the moment :)
16:46:49 <eglute> mrhillsman hope that is refstack and interop :)
16:46:49 <mugsie> a lot of people have the same idea
16:47:09 <eglute> mugsie nice, looking forward to seeing it
16:47:20 <eglute> anything else today?
16:47:23 <mrhillsman> ++
16:47:48 <eglute> if not, we can stop early. As usual, find us in the interop channel or email if needed
16:48:04 <eglute> thanks everyone, and hope everyone stays nice and warm
16:48:08 <eglute> #endmeeting