16:01:38 <eglute> #startmeeting interopwg
16:01:39 <openstack> Meeting started Wed Jan 10 16:01:38 2018 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:43 <openstack> The meeting name has been set to 'interopwg'
16:01:55 <eglute> hello everyone!
16:01:59 <eglute> #topic agenda
16:02:07 <eglute> #link https://etherpad.openstack.org/p/InteropWhistler.3
16:02:08 <luzC_> o/
16:02:11 <georgk> hi
16:02:14 <mguiney> o/
16:02:27 <hogepodge> Hi
16:02:32 <eglute> good to see everyone! Mark is not available today
16:02:38 <eglute> #chair hogepodge
16:02:39 <openstack> Current chairs: eglute hogepodge
16:02:49 <eglute> Please review agenda and update as needed #link https://etherpad.openstack.org/p/InteropWhistler.3
16:03:36 <eglute> #topic 2018.02 guideline
16:04:37 <eglute> I think we are mostly good for 2018.02 guideline, ready to create actual 2018.02.json
16:05:14 <dims_> o/
16:05:26 <eglute> if you could help with 2018.02.json, let me know
16:05:58 <eglute> if not, I will create it.
16:06:08 <eglute> #action eglute to create 2018.02.json guideline
16:06:30 <eglute> also the add-on guidelines need to be updated to have required capabilities
16:06:39 <eglute> need volunteers for that as well :)
16:08:56 <eglute> hogepodge mguiney could either of you help with that?
16:09:42 * eglute thinks everyone needs more coffee
16:09:51 <hogepodge> yes,
16:10:01 <eglute> thank you hogepodge
16:10:08 <hogepodge> thank you eglute :-)
16:10:48 <luzC_> eglute hogepodge do we have some test results for the add-on guidelines?
16:10:55 <eglute> #action hogepodge to update add-on designate and heat guidelines from advisory to required capabilities
16:11:22 <luzC_> are all the capabilities being moved to required?
16:11:30 <eglute> luzC_ good quesions
16:11:41 <eglute> i think we need to determine that
16:11:48 <hogepodge> Unless there are objections, yes.
16:11:49 <eglute> regarding test results, i am not sure
16:11:59 <eglute> hogepodge have you had anyone submit them yet?
16:12:05 <hogepodge> We should probably set up a devstack gate against all the guidelines.
16:12:10 <hogepodge> eglute: no
16:12:27 <eglute> ok. i guess would be interesting to run those tests
16:12:54 <eglute> anyone have clouds with designate + heat to test on?
16:14:03 <luzC_> I don't
16:14:04 <hogepodge> heat is easy, not sure about designate
16:14:19 <eglute> i have ansible all-in-ones that they can be tested on. i can chat with luzC_ and hogepodge offline about running tests
16:14:56 <eglute> have some with designate as well
16:15:11 <eglute> well, or could deploy a new one with designate
16:15:51 <eglute> so i will try to get those tests run in the next couple weeks
16:16:06 <luzC_> sounds good to me
16:16:19 <eglute> thanks luzC_ for bringing that up
16:16:40 <eglute> i was hoping we would have clouds that would want to get those add-ons listed :)
16:17:23 <eglute> anything else regarding 2018.02?
16:17:26 <hogepodge> eglute: in my experience cloud providers don't really take interest in something until it's required or "official"
16:17:37 <eglute> hogepodge good point
16:17:42 <hogepodge> eglute: so we're targeting approval at the PTG board meeting?
16:17:47 <eglute> yes
16:18:00 <eglute> hogepodge is that still ok?
16:18:34 <hogepodge> Yeah, just sorting the timing in my head
16:18:41 <eglute> cool
16:18:49 <eglute> let me know if you can think of any issues
16:19:24 <eglute> #topic Clarify testing for interop programs
16:19:38 <eglute> this discussion is still ongoing. #link https://review.openstack.org/#/c/521602/
16:19:41 <hogepodge> I want to check with our marketing team to see if we can be ready to launch in March
16:19:42 <eglute> feel free to comment
16:19:50 <eglute> hogepodge ok, let us know!
16:20:07 <eglute> #action hogepodge to check with foundation marketing team on add-on programs
16:20:49 <eglute> everyone- if you have an opinion on https://review.openstack.org/#/c/521602/ please comment
16:21:22 <eglute> #topic scoring trunk ports for NFV vertical
16:21:39 <eglute> georgk has a few questions for #link https://review.openstack.org/#/c/519732/
16:21:51 <eglute> "define cutoff score for vertical. currently it is 74 which is just copied from the existing programs"
16:22:11 <eglute> georgk do you think 74 works for NFV? i think each program can have its own score
16:22:20 <georgk> those are mostly comments by luzC_ which I extracted here
16:22:44 <eglute> luzC_ and georgk what are your opinions on scoring
16:23:37 <georgk> I have no particular opinion. It should work as a start, I believe
16:23:37 <luzC_> I was wondering if the same criteria applies for the power platform guideline and the NFV one...
16:24:12 <georgk> I need to score other features as well to get a better understanding
16:24:32 <luzC_> or should we create something like the add-on criteria which highlights some differences (as a result cutoff is also different)
16:25:02 <luzC_> #link https://github.com/openstack/interop/blob/master/add-ons/criteria.txt
16:26:12 <eglute> luzC_ we could create a new cutoff, but the scoring should show whether current cutoff works. i think current cut off works, since all 3 scored at 76
16:26:32 * mguiney nods
16:26:57 <eglute> so unless georgk adds capabilities with more varied scores that shows a different trend, i think we are ok to leave 74 as cutoff
16:26:58 <mguiney> if all of them pass, consistency makes sense
16:27:06 <georgk> ok
16:27:26 <luzC_> eglute: ahhh ok, in that case cutoff looks good
16:27:28 <georgk> regarding the criteria, an updated version for the vertical might be useful, highlighting some differences
16:27:53 <georgk> for instance, ¨widely deployed¨ is only considered in teh context of NFV deployments
16:28:04 <eglute> georgk agree
16:28:11 <georgk> and - more importantly - do we relax the non-admin criterion
16:29:04 <hogepodge> special guideline, special circumstances. I'm ok with that.
16:29:15 <eglute> hogepodge agree
16:30:22 <eglute> next question, "remove mitaka and include queens"
16:30:35 <eglute> yes, i think mitaka can removed
16:31:11 <eglute> unless others disagree
16:31:27 <eglute> i think we will be removing mitaka from 2018.02 as well\
16:31:37 <mrhillsman> bah
16:31:42 <mrhillsman> time mixup
16:32:09 * eglute waves to mrhillsman
16:32:37 <eglute> "neutron repo reference to put in guideline" -- luzC_ georgk i am not sure which is the proper one
16:33:52 <eglute> luzC_ suggestions?
16:35:05 <luzC_> eglute: I think Mark mentioned that a stable branch where test cases are available and working for the guideline should be enough
16:35:56 <luzC_> on the patch I suggested a SHA from Dec 2nd
16:36:08 <eglute> luzC_ ah ok. i think that works
16:36:14 <luzC_> https://github.com/openstack/neutron/commit/e971f0c317805c89d2ce3e72e6f771a9163839d9
16:36:32 <eglute> thank you luzC_
16:37:07 <georgk> ok, I ´ ll update the patchset accordingly
16:37:11 <eglute> thank you georgk
16:37:11 <georgk> thanks for the input
16:37:32 <eglute> i think that covers questions for https://review.openstack.org/#/c/519732/
16:37:39 <eglute> any other questions for this patch
16:37:41 <eglute> ?
16:39:09 <eglute> #topic Scoring of networking-bgp project for NFV vertical
16:39:11 <eglute> #link https://review.openstack.org/#/c/527390/
16:39:46 <eglute> thanks georgk for adding tests #link https://review.openstack.org/#/c/531582/
16:40:16 <eglute> georgk is that sufficient for bgp project?
16:40:21 <eglute> or do you need more?
16:40:46 <georgk> the test coverage is sufficient now
16:41:57 <eglute> great!
16:42:00 <eglute> thank you
16:42:28 <eglute> oh looks like you updated the patch earlier today
16:43:17 <georgk> yes, I added the new tests
16:43:17 <eglute> did you have a chance to add "Should also add one for listing API versions"?
16:43:23 <eglute> i will review later today
16:43:53 <luzC_> me too
16:43:57 <georgk> eglute: oh, I think I missed that
16:44:08 <georgk> ...
16:44:22 <eglute> :)
16:44:35 <eglute> do you know if there are appropriate tests for that?
16:45:00 <georgk> there are no tests for that - I would have to create them, too
16:45:11 <eglute> georgk ok... sorry :)
16:45:16 <georgk> well...
16:46:53 <eglute> georgk yes?
16:47:16 <georgk> eglute: ah, I will put it on my todo list
16:47:44 <eglute> georgk great, thank you
16:48:16 <eglute> anything else on https://review.openstack.org/#/c/527390/ ?
16:50:04 <eglute> #topic Heat Orchestration add-ons
16:50:26 <eglute> everyone, please review #link https://review.openstack.org/#/c/529836
16:50:45 <eglute> Mark has noted one missing item
16:51:47 <eglute> any comments on this?
16:52:03 <eglute> #topic Dublin PTG
16:52:18 <hogepodge> I confirmed we get a day.
16:52:26 <eglute> please add your name if you are coming to the etherpad: #link https://etherpad.openstack.org/p/InteropDublin2018PTG
16:52:26 <hogepodge> One day for Interop, one day for RefStack
16:52:41 <eglute> hogepodge ok, that will work. thank you!!!
16:53:33 <eglute> anything else on PTG? we will need to start building schedule
16:53:54 <eglute> #topic open floor
16:53:59 <eglute> anything else for today?
16:54:47 <eglute> thanks everyone! Have a good the rest of the day, see you next week, same place, same time!!!
16:55:11 <eglute> #endmeeting