16:01:28 <eglute> #startmeeting interopwg
16:01:29 <openstack> Meeting started Wed Mar 21 16:01:28 2018 UTC and is due to finish in 60 minutes. The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:33 <openstack> The meeting name has been set to 'interopwg'
16:01:38 <markvoelker> o/
16:01:39 <eglute> #chair hogepodge markvoelker
16:01:40 <openstack> Current chairs: eglute hogepodge markvoelker
16:01:46 <eglute> Hello Everyone!
16:01:53 <eglute> Agenda: https://etherpad.openstack.org/p/InteropWhistler.9
16:01:59 <eglute> #topic Agenda
16:02:32 <eglute> Raise your hand if you are here for the interopwg meeting o/
16:02:47 <georgk> o/
16:02:58 <hogepodge> hi
16:03:29 <mguiney> o/
16:03:35 <eglute> Daylight savings time has moved this meeting for most of us i think
16:04:24 <eglute> also, just a reminder that for now we will be meeting every other week unless we need to meet more often
16:04:47 <eglute> #topic Creating orchestration.2018.02.json guideline
16:05:02 <eglute> #link https://review.openstack.org/#/c/547692/
16:05:09 <eglute> looks like i need to update the patch, i will see what Rico refers to
16:05:12 <luzC_> o/
16:05:34 * markvoelker makes note to update eavesdrop with the every-other-week meeting thing
16:06:11 <eglute> thanks markvoelker
16:06:24 <eglute> if you all have other comments on https://review.openstack.org/#/c/547692/ let me know
16:06:36 <eglute> #topic flag broken test_update_snapshot_metadata
16:06:44 <eglute> #link https://review.openstack.org/#/c/554359/
16:07:04 <eglute> thanks to prometheanfire for submitting this
16:07:35 <eglute> I am not sure what is going on there, I thought it was straightforwar
16:08:14 <eglute> has a -1 from a couple people, so needs updating
16:08:52 <markvoelker> I think it's actually ok as-is. Dirk requested a couple of more changes for a different set of tests which we can take up in a separate review
16:09:10 <eglute> ok... so ok to merge as is?
16:09:27 <eglute> markvoelker please comment on the patch and merge?
16:09:34 <eglute> unless other comments?
16:09:45 <markvoelker> I think so, and we can deal with the others separately. They actually already have aliases in place, so with this change I think folks trying to pass can do so.
16:10:24 <eglute> great thank you markvoelker
16:10:40 <eglute> any other comments on this patch?
16:11:07 <hogepodge> i do
16:11:25 <hogepodge> Less on the patch, more on the circumstances behind it (and the last agenda item I added).
16:11:44 <eglute> hogepodge do share
16:11:53 <hogepodge> Just, we need a gate job here and possibly one in tempest to not allow merges that break guidelines.
16:12:10 <eglute> hogepodge is that the topic that you added?
16:12:55 <hogepodge> On this side to make sure anything we add actually exists in Tempest, on the Tempest side to prevent anyone from submitting a patch that would break our guideline. Then everyone would be forced to reconcile rather than having a fire drill at a random time.
16:13:31 <hogepodge> Unless there are objections, I can take that as an action item.
16:13:33 <eglute> hogepodge ok... what do we need to do to make it happen
16:13:41 <eglute> hogepodge no objections from me
16:13:45 <markvoelker> I agree that would be useful. We talked a bit about the mechanics that would allow us to build one in the past (e.g. using a decorator on required tests) but they didn't care for that solution. I suppose we could write a job that just grabs the guidelines and checks changes against that?
16:14:08 <hogepodge> Write tox jobs for both and add them to the zuul definitions.
16:15:14 <hogepodge> markvoelker: that's pretty much it, something that grabs the interop repo and builds idempotent_ids and name mappings, then guarantees their existence in Tempest.
16:15:42 <markvoelker> Ah, ok...so you're thinking just something that covers the issue where a couple of tests were combined into a single test?
16:16:08 <markvoelker> (and the one where a test is deleted)
16:16:13 <markvoelker> (obviously)
16:16:37 <hogepodge> Just anything that makes it so a guideline doesn't work. A test is renamed in Tempest and there's no alias in Interop, boom test failure. Test and idempotent_id is removed but not flagged? Boom test failure.
16:17:12 <eglute> hogepodge that sounds good to me
16:17:57 <hogepodge> we spell a name wrong in next.json? It's caught.
16:18:01 <markvoelker> Makes sense. Ideally it'd be nice to have it somehow flag "hey, you modified a test that's in a guideline so be careful", but I'm not sure anyone reads the logs as long as they get a +1. Problem for another day I suppose.
16:18:15 <hogepodge> we could have a non-voting job
16:18:53 <markvoelker> Let's do baby steps. =) What you described is easy, so do that first. We can expand later to cover the trickier cases.
16:19:20 <hogepodge> Yeah, if the TC wants us to have a tight relationship with Tempest, we should encode it. ;-)
16:19:50 <hogepodge> I don't want to be embarrassed by guidelines not working either. :-)
16:19:54 <hogepodge> Anyway, that's all.
16:19:58 <eglute> thanks hogepodge
16:20:01 <hogepodge> #action hogepodge write test jobs
16:20:19 <eglute> thanks hogepodge i think that will be helpful!
16:20:31 <eglute> #topic Move next.json to schema 2.0
16:20:46 <eglute> thanks markvoelker for updating next.json to schema 2.0
16:21:00 <markvoelker> Sure. Looks like we still have some gate failures that I need to debug though.
16:21:03 <eglute> #link https://review.openstack.org/#/c/554395/
16:21:26 <eglute> yes, thank you
16:21:54 <markvoelker> The docs job build failure is new...hrm.
16:22:36 <markvoelker> Well anyway, I'll keep plugging at it. If anyone gets there before me (I'm booked up until late today), feel free to leave a comment and let me know what I missed. =)
16:23:16 <eglute> thanks markvoelker. i know going through the schema and updating guidelines is not the easiest thing
16:23:40 <eglute> though i wonder if we need to check with some tool that the other guidelines match the schame
16:23:43 <eglute> the schema
16:23:43 <markvoelker> Oddly it should be easy enough, because it's built directly from a document that already made it through the gate. =) Oh well.
16:23:51 <eglute> hah
16:24:24 <markvoelker> As for schema checking, that should already be built in...you can just run tox locally.
16:24:36 <eglute> ah ok
16:25:02 <eglute> anything else on this?
16:25:18 <eglute> the next topic on the gate already covered, correct hogepodge?
16:25:36 <eglute> #topic Next guideline: 2018.08
16:25:48 <hogepodge> eglute: yeah, that was my topic
16:26:00 <markvoelker> Oh, I wonder if the docs job failure is related to http://lists.openstack.org/pipermail/openstack-dev/2018-March/128594.html perhaps. I'll look into it tonight.
16:26:08 <eglute> hogepodge do we need to discuss more or we are good there?
16:26:45 <hogepodge> good there
16:27:12 <eglute> cool thank you
16:27:46 <eglute> so, regarding 2018.08 guideline- the board meeting date not set yet, i guess will be during the next PTG.
16:28:09 <eglute> I dont think PTG location/date have been announced yet, unless you heard differently
16:29:09 <eglute> as discussed in Dublin, we dont expect many changes to the next guideline
16:29:22 <eglute> #topic Scoring 2018.08
16:29:53 <eglute> In etherpad we have a list of capabilities to score, any updates to that list?
16:30:13 <markvoelker> Not from me
16:30:24 * markvoelker was camping in the Everglades all last week and therefore made zero progress on anything
16:31:02 <eglute> cool... markvoelker how were the pythons?
16:31:14 <eglute> anything else for today then?
16:31:26 <eglute> any updates on NFV? georgk?
16:31:42 <markvoelker> No pythons detected (other than in captivity), but saw just about every other sort of critter...
16:31:53 <georgk> I did a bit of research regarding EPA
16:32:17 <eglute> georgk any updates on that?
16:32:20 <georgk> actually, a nice overview is this one, giving also indications how to test stuff
16:32:22 <georgk> https://software.intel.com/en-us/articles/openstack-epa-feature-breakdown-and-analysis
16:32:28 <luzC_> eglute: do you have scoring etherpad link?
16:32:32 <georgk> still, the tool question remains
16:33:04 <georgk> and the available capabilities of the OpenStack CI
16:33:12 <eglute> luzC_ https://etherpad.openstack.org/p/InteropWhistler.9 is the scoring assignment list. if you would like to take any, please do- i dont think anyone would mind :)
16:33:21 <georgk> in terms of hardware and configuration
16:33:31 <georgk> so, only a little progress
16:33:49 <eglute> georgk cool, thank you
16:33:56 <luzC_> eglute: ok, I'll take a look
16:34:08 <eglute> thank you luzC_, always appreciate your help
16:34:33 <eglute> anything else for today?
16:35:49 <eglute> in that case, thanks everyone! See you all in 2 weeks!
16:35:53 <eglute> #endmeeting