16:01:45 <eglute> #startmeeting interopwg
16:01:45 <openstack> Meeting started Wed Aug 8 16:01:45 2018 UTC and is due to finish in 60 minutes. The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:48 <openstack> The meeting name has been set to 'interopwg'
16:02:05 <hogepodge> hi
16:02:15 <eglute> #chair hogepodge
16:02:16 <openstack> Current chairs: eglute hogepodge
16:02:17 <eglute> hello!
16:02:27 <eglute> I do not see Mark online
16:02:51 <eglute> Anyone else here for the interop meeting?
16:02:57 <eglute> #topic agenda
16:03:07 <eglute> #link https://etherpad.openstack.org/p/InteropWhistler.16
16:04:17 <eglute> Well, looks like it is just the two of us hogepodge
16:04:21 <eglute> do you have any updates?
16:04:39 <chandankumar> hogepodge: hello
16:05:27 <eglute> hello chandankumar
16:05:36 <chandankumar> eglute: Hello
16:05:43 <tosky> hi
16:05:51 <eglute> hello!
16:06:04 <hogepodge> We should add rolling refstack into interop wg into the agenda
16:06:18 <eglute> hogepodge would you like to put that at the top?
16:06:22 <hogepodge> sure
16:06:29 <eglute> ok go ahead!
16:06:36 <hogepodge> #topic refstack
16:07:06 <hogepodge> ok, so the team working on refstack-server and refstack-client is basically me now, and is being removed as an official openstack project
16:07:33 <hogepodge> We're looking at rehoming it as interop-wg project, but that leaves the question of what do do with python-tempestconf
16:07:55 <hogepodge> chandankumar: tosky: have you all given some thought to it with your team?
16:08:30 <chandankumar> hogepodge: I spoke with QA team, but the answer is as usual np
16:08:34 <chandankumar> *no
16:08:41 <tosky> to be honest, not so much discussion about what to do
16:08:52 <tosky> but as you know the TC showed us the possible ways
16:09:13 <hogepodge> I'm disappointed that QA isn't accepting of it.
16:09:22 <tosky> the easiest one would be fold us too into the interop wg; the difference is that we wouldn't partecipate to the TC election
16:09:41 <hogepodge> yeah, that's my concern
16:10:15 <tosky> but TC said that we can changed the decision later (like going as independent project, with a PTL, or unofficial project, or part of some other WG or SIG, either related to TC or community)
16:10:31 <chandankumar> Once we move to the interop wg, how are things going to work?
16:11:02 <hogepodge> chandankumar: nothing will really change, you'll keep the autonomy over the project and code review/etc will continue as it's been going
16:12:24 <chandankumar> ok
16:12:45 <chandankumar> tosky:so I think we are good with interop wg then?
16:13:34 <tosky> chandankumar: I still don't know if the interop wg is fine with getting us :)
16:13:48 <eglute> Yes we will take you :D
16:13:55 <tosky> oki
16:14:24 <eglute> hogepodge is there anything official that needs to be migrated?
16:14:38 <hogepodge> Some project repository updates
16:15:06 <eglute> ok, who needs to do those?
16:15:06 <hogepodge> in the infra/governance repositories, mostly formalities
16:15:10 <eglute> ah ok
16:15:26 <hogepodge> One of us, it's just a code review
16:15:26 <eglute> hogepodge is that action item for you or for tosky and chandankumar
16:15:33 <chandankumar> hogepodge: for tempestconf and refstack one i can do that
16:15:46 <tosky> I do apologize, but I need to leave
16:15:48 <hogepodge> chandankumar: cool, thanks. fungi can probably point out the right place for it.
16:15:59 <tosky> I will read the logs though
16:15:59 <hogepodge> tosky: no problem, I understand it's late there. thanks or your time
16:16:02 <tosky> thanks for moving this forward
16:16:12 <hogepodge> s/or/for
16:16:59 <eglute> #action hogepodge tosky chandankumar will update tempestconf and refstack infra/governance repositories
16:17:55 <eglute> welcome to interopwg tosky and chandankumar!
16:18:00 <hogepodge> :-)
16:18:31 <eglute> anything else on refstack topic?
16:18:38 <hogepodge> no
16:19:26 <eglute> #topic PTG
16:19:46 <eglute> We need to start planning for PTG topics. hogepodge are you planning on having any refstack topics there?
16:20:30 <eglute> #link https://etherpad.openstack.org/p/InteropRefstackPTGDenver_2018
16:20:34 <chandankumar> hogepodge: eglute python-tempestconf team will be there
16:20:35 <hogepodge> If folks are there we can have a single planning session, I don't think we need much more.
16:20:57 <hogepodge> chandankumar: excellent, let's make sure you have sessions for your team also
16:21:05 <chandankumar> I will let the team know to add the topic there also
16:21:29 <fungi> oh, thanks, yes happy to provide guidance
16:21:47 <fungi> (on the python-tempestconf topic)
16:22:28 <eglute> Yes please update ehterpad :) https://etherpad.openstack.org/p/InteropRefstackPTGDenver_2018
16:24:19 <eglute> #topic Build Gate Job against Tempest
16:24:30 <hogepodge> hey, that's mine, and it's stalled
16:24:46 <eglute> hogepodge lack of time or some other reason?
16:24:48 <hogepodge> (as is all my interopwg work)
16:25:02 <hogepodge> lack of time, I've had a lot of responsibility shifts in the last six months
16:25:26 <eglute> understand
16:25:29 <chandankumar> eglute: https://review.openstack.org/#/c/541273/ will addjob running tempest tests using refstack tests
16:25:43 <chandankumar> it is coming with the python-tempestconf integration
16:26:11 <eglute> thanks chandankumar!
16:26:11 <chandankumar> but it is based on devstack, if any modification is needed we are happy to help
16:26:34 <eglute> hogepodge is that what is needed? I am not familiar with the gates
16:27:42 <hogepodge> what we need is something different
16:28:02 <hogepodge> something that checks the tests listed in intopwg guidelines are actually the tests in tempest
16:28:28 <hogepodge> and same on the other side
16:28:33 <eglute> chandankumar would you have some time to help hogepodge wiht the interopwg gate job?
16:28:47 <hogepodge> this will make sure tests aren't accidentally moved or renamed without being reflected in interopwg
16:28:52 <chandankumar> eglute: I will take a look to make that happend
16:28:54 <hogepodge> (or removed)
16:29:08 <eglute> chandankumar that would be awesome, thank you so much
16:29:27 <hogepodge> So these jobs would live in interopwg repository and in tempest repository
16:29:53 <chandankumar> hogepodge: one of the thing on tripleo side I am working on running refstack tests on each python-tempestconf patch https://review.openstack.org/#/c/570719/
16:30:05 <chandankumar> I would love to get your feedback also there
16:30:10 <eglute> #action chandankumar and hogepodge will work on interopwg gate job
16:31:40 <eglute> hogepodge i think the rest of the topics depend either on you or mark
16:32:04 <eglute> there are also 3 outstanding reviews needed
16:32:19 <hogepodge> reviews for the next guideline?
16:32:22 <eglute> please review:
16:32:24 <eglute> #link https://review.openstack.org/#/c/585772/
16:32:34 <hogepodge> ah, I can take a look at those
16:32:34 <eglute> #link https://review.openstack.org/#/c/585606/
16:32:45 <eglute> #link https://review.openstack.org/#/c/565878/
16:32:52 <eglute> the last one needs updates too i think
16:32:57 <eglute> cinder scoring
16:34:14 <eglute> if chandankumar and tosky want to get involved in the scoring, we would welcome some help :)
16:34:21 <eglute> #link https://etherpad.openstack.org/p/InteropWhistler.16
16:35:32 <eglute> hogepodge if no other updates, we can end the meeting early
16:35:43 <hogepodge> sounds good to me.
16:35:48 <hogepodge> thanks eglute
16:35:59 <eglute> thank you hogepodge chandankumar and tosky!
16:36:04 <eglute> #endmeeting