16:00:34 <markvoelker> #startmeeting interopwg
16:00:35 <openstack> Meeting started Wed Aug 22 16:00:34 2018 UTC and is due to finish in 60 minutes.  The chair is markvoelker. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:38 <openstack> The meeting name has been set to 'interopwg'
16:00:45 <markvoelker> #chair hogepodge eglute
16:00:48 <openstack> Current chairs: eglute hogepodge markvoelker
16:00:52 <markvoelker> o/
16:00:54 <hogepodge> hi!
16:00:57 <eglute> o/ for as long as my internet permits
16:01:19 <markvoelker> #link https://etherpad.openstack.org/p/InteropWhistler.17 Today's Agenda
16:01:57 * markvoelker gives folks a moment to look it over and make changes/additions
16:02:44 <markvoelker> #topic Build Gate Jobs against Tempest
16:02:52 <markvoelker> Oops, skipped the PTG...
16:02:57 <markvoelker> #topic PTG
16:03:15 <markvoelker> There is schedule link and some proposed topics in the etherpad
16:03:40 <markvoelker> PRoposed topics looks thin-ish right now...I'll try to flesh that out some this week between aeroplane rides
16:03:47 <markvoelker> #link https://etherpad.openstack.org/p/InteropRefstackPTGDenver_2018 PTG proposed topics
16:03:50 <eglute> thank you Mark
16:04:26 <markvoelker> Any particular points we need to talk about on PTG stuff right now?
16:04:53 <eglute> I don't think so... any pressing refstack issues hogepodge?
16:05:12 <markvoelker> Possibly worth noting here that https://review.openstack.org/#/c/590179/ has landed so Refstack governance has moved over
16:05:36 <markvoelker> (Somewhat of a formality, but....)
16:05:42 <hogepodge> refstack client now has auto-config capabilities
16:06:05 * markvoelker fumbles for his shades because of the shinyness
16:06:10 <hogepodge> thanks to the python-tempestconf team for their hard work and patience on that patch
16:06:23 <markvoelker> ++
16:06:41 <hogepodge> One more nova flag needs to be enabled for the configuration to be complete, just have to find the 10 minutes to send the patch up
16:07:32 <markvoelker> Neat.  Anything else?
16:08:10 <hogepodge> subunit upload work is on hold while I continue my search for a new intern. If any of you know some bright CS students looking for open source work please send the my way.
16:09:02 <markvoelker> Will do.  Any particular requirements?  Might be chatting with some folks at NCSU soonish, would be happy to put out some feelers.
16:09:44 <hogepodge> just a willingness to do python, javascript, and ruby programming.
16:10:03 <hogepodge> job is posted on the jobs board (I have PNW as preferred area, but will accept from wider)
16:10:54 <markvoelker> 10-4.  Was just in the PNW yesterday btw....I hope Portland is less smokey than Seattle was. =)  But I digress...
16:11:16 <hogepodge> It's not 😢
16:11:32 <markvoelker> #topic Build Gate Job Against Tempest
16:11:44 <markvoelker> hogpeodge: the floor is yours again
16:11:57 <hogepodge> I wish I could say I've moved this forward.
16:12:08 <hogepodge> some of the python-tempestconf folks have talked about working on it
16:13:16 <markvoelker> Is this another possible intern project, or is it more of a "someone with a little more background and more than a semester needs to look at it"?
16:13:53 <hogepodge> It's mostly a scripting issue
16:14:18 <hogepodge> We need to parse the json file and pull all the function names out of it, then use code reflection to match them with functions in tempest
16:14:25 <hogepodge> and uuids
16:14:51 <hogepodge> so on the interop side, the algorithm is at least one alias of all tests needs to be in tempest
16:15:30 <hogepodge> all uuids in interop must exist in tempest
16:16:05 <hogepodge> run as gate jobs against both projects to guarantee that changes that break interop don't merge without dependent changes to both projects identifying the changes
16:16:31 <hogepodge> I'd say that it's more than a day but less than a week of work
16:16:51 <markvoelker> Got it.  Ok, thanks.
16:17:28 <markvoelker> #topic Should we consider an existing tool such as OPNFV yardstick
16:17:53 <markvoelker> Not sure we quite have the right folks here for this, so it may be something to park until PTG.
16:18:42 <markvoelker> IIRC the basic concern is that the Foundation would like tests used to produce a branded certification (something like "OpenStack Powered NFV Solution" or whatever) to be under OpenStack governance, yes?
16:20:16 * markvoelker parks it for now
16:20:35 <markvoelker> #topic Next guideline timing
16:20:40 <hogepodge> I'm not sure where the opnfv teams and foundation execs are, but I can bring it up again with them
16:20:50 <markvoelker> thanks
16:21:28 <markvoelker> We can do useful things either way I think, but knowing the intended outcome might help us figure out the best avenues for everyone.
16:22:20 <markvoelker> As noted in the pad, no BoD meeting in August and the September one is by phone.  We could shift to November to do an in-person update and approval, as we often do....
16:22:45 <markvoelker> Thoughts?  I'm pretty agnostic.  The updates don't look like they're going to be particularly complex, so I think we could do either way.
16:23:05 <hogepodge> I think November would work just fine for me, but I'm always more optimistic about my availability further out in the future. I'm sure there's a name for that psychological condition
16:23:33 * markvoelker is fine with that too
16:24:14 <hogepodge> is eglute still here?
16:24:32 <eglute> yes, my internet in and out
16:24:38 <markvoelker> She had an electrician coming over today and warned me she might lose power/internet
16:24:41 <hogepodge> what do you think about the timing?
16:24:57 <eglute> i think november is a good time :)
16:25:33 <markvoelker> Ok, works for me...shall I submit a patch to next.json to reflect timing?
16:25:40 <hogepodge> +1
16:25:41 <markvoelker> Now that this whole process is more mature, it feels like there's less need to adhere to a strict cadence than in the past...might be worth updating the governance docs to clarify target dates at some stage.
16:26:34 <markvoelker> #action markvoelker submit updated date for next.json
16:26:59 <markvoelker> Anyone not here today can voice their opinion on that patch, if they have one. =)
16:27:24 <markvoelker> #topic Scoring 2018.08^H^H11
16:27:53 <markvoelker> #link https://review.openstack.org/#/c/585772/ Clean up advisory list
16:28:11 <markvoelker> eglute, I think I missed your comment on this while I was out on the road...I'll have a look at that this afternoon
16:29:05 <hogepodge> markvoelker: yes, is the removal list permanent?
16:29:23 <hogepodge> I'm +2/+1 on it with that question answered
16:29:49 <markvoelker> Hm, I don't think we've kept it permanent in the past, but I'll double check and update the review
16:30:44 <markvoelker> #action markvoelker check comments on https://review.openstack.org/#/c/585772/ and respond/revise
16:31:19 <markvoelker> Other scoring stuff: no major updates from me on Nova/Neutron.  Updates from anyone else?
16:31:26 <hogepodge> not here
16:31:43 <markvoelker> eglute I saw https://review.openstack.org/#/c/585606/ and will sort through it today
16:32:02 <markvoelker> But it basically looks like no changes
16:33:04 <markvoelker> Ok, if no major updates on scoring stuff then looks like we need to review https://review.openstack.org/#/c/585606/ and https://review.openstack.org/#/c/565878/
16:33:16 <markvoelker> #action all please review https://review.openstack.org/#/c/565878/
16:33:25 <markvoelker> #action all please review https://review.openstack.org/#/c/585606/
16:33:48 <markvoelker> #topic Open Floor
16:33:56 <markvoelker> Anything else we want to discuss today?
16:35:23 <markvoelker> Hearing nothing, I think we're done!
16:35:33 <markvoelker> #endmeeting