#openstack-meeting: ironic

Meeting started by devananda at 19:00:27 UTC (full logs).

Meeting summary

  1. agenda (devananda, 19:00:54)
    1. https://wiki.openstack.org/wiki/Meetings/Ironic (devananda, 19:00:59)

  2. object models (devananda, 19:01:58)
    1. https://review.openstack.org/#/c/33920/ (devananda, 19:03:41)
    2. ACTION: devananda to review all the BP's more carefully (devananda, 19:18:01)

  3. API and RPC stuff (devananda, 19:18:54)
    1. https://github.com/openstack/ironic/blob/master/ironic/api/controllers/v1.py#L50 (devananda, 19:22:12)
    2. ACTION: romcheg to refactor api/controllers/v1.py into a more maintainable modular structure (devananda, 19:26:12)
    3. ACTION: devananda to implement RPC layer for API actions that require lock management (devananda, 19:26:51)
    4. https://review.openstack.org/#/c/34115/ (devananda, 19:26:56)

  4. image utils & pxe driver (devananda, 19:28:26)
    1. ACTION: devananda to get more eyes on the glanceclient image-tools patch (devananda, 19:32:15)

  5. ironic diskimage-builder element (devananda, 19:39:19)
  6. open discussion (devananda, 19:46:14)
    1. http://docs.openstack.org/developer/ironic/api/ironic.drivers.base.html (devananda, 19:49:06)
    2. ACTION: devananda to create stackforge repo and import the native ipmi driver from sourceforge (devananda, 19:51:52)
    3. ACTION: devananda to create stackforge repo and import the native ipmi library from sourceforge (devananda, 19:52:04)


Meeting ended at 19:59:32 UTC (full logs).

Action items

  1. devananda to review all the BP's more carefully
  2. romcheg to refactor api/controllers/v1.py into a more maintainable modular structure
  3. devananda to implement RPC layer for API actions that require lock management
  4. devananda to get more eyes on the glanceclient image-tools patch
  5. devananda to create stackforge repo and import the native ipmi driver from sourceforge
  6. devananda to create stackforge repo and import the native ipmi library from sourceforge


Action items, by person

  1. devananda
    1. devananda to review all the BP's more carefully
    2. devananda to implement RPC layer for API actions that require lock management
    3. devananda to get more eyes on the glanceclient image-tools patch
    4. devananda to create stackforge repo and import the native ipmi driver from sourceforge
    5. devananda to create stackforge repo and import the native ipmi library from sourceforge
  2. romcheg
    1. romcheg to refactor api/controllers/v1.py into a more maintainable modular structure


People present (lines said)

  1. devananda (117)
  2. jbjohnso (28)
  3. NobodyCam (28)
  4. romcheg (23)
  5. anteaya (12)
  6. linggao (11)
  7. GheRivero (7)
  8. romcheg_ (5)
  9. JimJiang1 (3)
  10. openstack (3)
  11. dkehn (1)


Generated by MeetBot 0.1.4.