#openstack-meeting: ironic

Meeting started by devananda at 19:00:52 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Ironic (devananda, 19:01:37)

  1. to XML or not to XML (devananda, 19:04:36)
    1. AGREED: no XML support in rev1, to streamline our work on the JSON API (devananda, 19:08:02)

  2. PATCH request format (devananda, 19:08:16)
    1. http://docs.openstack.org/api/openstack-image-service/2.0/content/update-an-image.html (lucasagomes, 19:08:44)
    2. http://tools.ietf.org/html/draft-ietf-appsawg-json-patch-10 (lucasagomes, 19:08:49)
    3. http://docs.openstack.org/api/openstack-image-service/2.0/content/update-an-image.html (devananda, 19:10:36)
    4. http://tools.ietf.org/html/draft-ietf-appsawg-json-patch-10 (devananda, 19:10:41)
    5. https://github.com/stefankoegl/python-json-patch (lucasagomes, 19:11:44)
    6. https://pypi.python.org/pypi/jsonpatch/0.6 (lucasagomes, 19:12:08)
    7. http://tools.ietf.org/html/rfc5789 (martyntaylor, 19:20:57)
    8. ACTION: continue debate about PATCH support (devananda, 19:27:46)

  3. RPC hooks (devananda, 19:27:59)
    1. AGREED: proceed with importing RPC serliazers (devananda, 19:29:12)

  4. testing (devananda, 19:29:15)
    1. https://blueprints.launchpad.net/ironic/+spec/db-migration-tests (romcheg, 19:30:55)
    2. ACTION: devananda to review bp: ironic/db-migration-tests (devananda, 19:31:11)
    3. ACTION: romcheg to post BP for devstack / tempest integration with ironic (devananda, 19:33:58)

  5. copyright lines (devananda, 19:34:33)
    1. https://wiki.openstack.org/wiki/LegalIssuesFAQ#Copyright_Headers (devananda, 19:34:42)
    2. ACTION: jog0 to update us to use hacking 0.6 (devananda, 19:36:43)

  6. keystone auth (devananda, 19:39:09)
    1. ACTION: romcheg to continue discussion about keystone v3 and domains (devananda, 19:46:56)

  7. PXE driver (devananda, 19:47:32)
  8. diskimage-builder (devananda, 19:49:36)
  9. WSME response object (devananda, 19:52:55)
  10. open discussion (devananda, 19:54:25)


Meeting ended at 20:00:24 UTC (full logs).

Action items

  1. continue debate about PATCH support
  2. devananda to review bp: ironic/db-migration-tests
  3. romcheg to post BP for devstack / tempest integration with ironic
  4. jog0 to update us to use hacking 0.6
  5. romcheg to continue discussion about keystone v3 and domains


Action items, by person

  1. devananda
    1. devananda to review bp: ironic/db-migration-tests
  2. jog0
    1. jog0 to update us to use hacking 0.6
  3. romcheg
    1. romcheg to post BP for devstack / tempest integration with ironic
    2. romcheg to continue discussion about keystone v3 and domains


People present (lines said)

  1. devananda (110)
  2. NobodyCam (33)
  3. lucasagomes (32)
  4. martyntaylor (31)
  5. romcheg (28)
  6. jog0 (12)
  7. openstack (3)
  8. boris-42 (2)
  9. anteaya (2)


Generated by MeetBot 0.1.4.