19:00:15 <NobodyCam> #startmeeting ironic
19:00:16 <openstack> Meeting started Mon Sep  2 19:00:15 2013 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:19 <openstack> The meeting name has been set to 'ironic'
19:00:30 <NobodyCam> Good AtNoon
19:00:47 <GheRivero> o/
19:00:48 <romcheg> o/
19:00:50 <lucasagomes> :)
19:00:50 <NobodyCam> whos here for the Ironic meeting this fine labor day
19:00:56 <dkehn> here
19:01:07 <NobodyCam> hey hey dkehn welcome
19:01:48 <NobodyCam> I try and keep the agenda upto date
19:01:54 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic
19:02:18 <NobodyCam> #topic Testing env
19:02:25 <NobodyCam> ok thats me
19:02:30 <NobodyCam> for dib
19:02:50 <NobodyCam> I have updated the patches and are working thru
19:02:59 <NobodyCam> we have landed one.
19:03:06 <NobodyCam> still working it
19:03:27 <NobodyCam> dev stack looks like one +2
19:03:41 <romcheg> Yes
19:03:54 <romcheg> I have poked several core devs during the week
19:04:06 <romcheg> I have also sent an email to the mailing list today
19:04:06 <NobodyCam> it the FF rush
19:04:13 <romcheg> I think so
19:04:14 <NobodyCam> ok
19:05:01 <NobodyCam> just checking the action items from last week
19:05:03 <NobodyCam> :)
19:05:12 <NobodyCam> any q / c ?
19:05:13 <romcheg> There was one for me AFAIR
19:05:23 <NobodyCam> you answered it
19:05:24 <NobodyCam> :)
19:05:40 <NobodyCam> #topic in-progress tasks
19:05:51 <NobodyCam> pxe has one +2
19:06:11 <romcheg> I have some news about keystone
19:06:11 <NobodyCam> would like to give deva the chance to review it.
19:06:20 <NobodyCam> :)
19:06:28 <NobodyCam> do tell
19:06:53 <romcheg> The bug seems to be fixed to I was able to make the required set up and to try the things
19:07:05 <NobodyCam> woot
19:07:07 <romcheg> So good news everyone :)
19:07:15 <lucasagomes> nice
19:07:26 <NobodyCam> thing are falling into place
19:07:26 <romcheg> We don't have to change any code to support v3 domains
19:07:35 <NobodyCam> dkehn: want to glot?
19:07:55 <dkehn> ah
19:08:28 <romcheg> I have made some investigation of the code in keystone and found that roles are taken from either domains or tenants depending on the supplied token
19:09:24 <NobodyCam> wanted to note the dkehn quantum (notes starting name) pxe support patch landed
19:09:27 <romcheg> Investigating the code was really easier than making a dialog with keystone devs — everyone is so busy
19:10:07 <dkehn> yes, both in nova and neutron, the only thing outstanding is the python-neutronclient
19:10:37 <NobodyCam> :)
19:10:53 <NobodyCam> ok any q / c?
19:11:13 <NobodyCam> #topic API discussion
19:11:13 <lucasagomes> kudos :)
19:11:21 <lucasagomes> I can see bm deploy helper dying soon :)
19:11:30 <NobodyCam> :)
19:11:35 <dkehn> since landing the neutron code yesterday I have been getting requests for supporting bigswitch, ml2, nicitra, etc., so we will be soring this out
19:12:32 <NobodyCam> dkehn: I'll bet
19:12:50 <NobodyCam> ok on to 42690
19:12:57 <NobodyCam> #link https://review.openstack.org/#/c/42690/
19:13:10 <lucasagomes> cool, about the API, there's a patch (42690) that allows us to use the PATCH http model to update the resources
19:13:18 <NobodyCam> lucasagomes: did I see a new upload this morning
19:13:27 <lucasagomes> yea, actually was a rebase
19:13:39 <lucasagomes> cause of the problem we had with wsme
19:14:08 <NobodyCam> ahh
19:14:16 <NobodyCam> and I see docs!
19:14:44 <lucasagomes> yup :) native english speakers feel free to review that doc please
19:15:12 <NobodyCam> lucasagomes: this allows us to actually delete a option
19:15:25 <NobodyCam> did we ever get a bug for that?
19:16:00 <lucasagomes> NobodyCam, yes, removing attributes will act different depending on the attribute
19:16:06 <lucasagomes> for example removing something from a collection
19:16:16 <lucasagomes> is different than removing something from the root document
19:16:18 <lucasagomes> e/g
19:16:42 <lucasagomes> multi-valued attributes like "properties" in the node resource
19:17:02 <lucasagomes> will be able to actually remove things from it
19:17:18 <NobodyCam> yes we did get a bug
19:17:19 <NobodyCam> ?
19:17:39 <lucasagomes> not really
19:17:44 <lucasagomes> I can file one
19:17:55 <NobodyCam> should we havea bug for not being about to remove "properties"
19:17:57 <NobodyCam> ??
19:18:07 <NobodyCam> might be worth it?
19:18:16 * lucasagomes a bit confused
19:18:35 <lucasagomes> we have a bug in the moment where we can't set attributes to NULL for example
19:19:13 <lucasagomes> because our implementation in the moment (partial PUT) just allows us to replace attributes with another value
19:19:22 <lucasagomes> but not set the to null
19:20:40 <lucasagomes> NobodyCam, that's the problem u r talking about?
19:20:46 <NobodyCam> yes
19:20:53 <NobodyCam> was looking at bug list
19:21:04 <NobodyCam> I'll look later
19:21:13 <lucasagomes> so no, we don't have a a bug for that AFAIK
19:21:21 <lucasagomes> but we should
19:21:32 <NobodyCam> :) and linked to this review
19:21:43 <NobodyCam> :-p
19:21:50 <lucasagomes> yup, will do it
19:22:03 <NobodyCam> sweet :) /me is thought he was going nuts
19:22:27 <NobodyCam> ok any other q / c on put vs patch?
19:22:57 <NobodyCam> #topic API discussion
19:23:45 <NobodyCam> vendor pass_thry
19:23:50 <NobodyCam> vendor pass_thru even
19:23:58 <lucasagomes> is yuri here?
19:24:07 <romcheg> No, he's not
19:24:18 <romcheg> He took a day off
19:24:23 <lucasagomes> I see
19:24:43 <NobodyCam> lucasagomes: did you want to go over any conserns
19:25:10 <romcheg> lucasagomes: He will read the meeting logs tomorrow, so you can share your thoughts
19:25:28 <NobodyCam> *concerns
19:25:34 <lucasagomes> right, so... vendor_passthru will allow vendors extend our api to expose
19:25:41 <lucasagomes> some vendor specific features
19:26:26 <lucasagomes> #link https://review.openstack.org/#/c/43441/
19:26:56 <lucasagomes> so right now, the API offers a way to clients invoke those methods, but we also need to expose a way
19:27:11 <lucasagomes> to clients retrieve information about the state of their request
19:28:08 <NobodyCam> lucasagomes: how would we track which request they are getting status on?
19:28:45 <lucasagomes> so I was thinking about using the name of the method called as an identifier
19:28:56 <lucasagomes> so the same way you do a PUT in a <method>
19:29:18 <lucasagomes> you would do a GET on that method and it would return the status of the current state of that call
19:29:35 <lucasagomes> but I have to talk to yuri to see how it should work, since he's implementing it
19:29:41 <lucasagomes> ideas are very welcome :)
19:30:02 <lucasagomes> s/PUT/POST/g
19:30:25 <NobodyCam> my fear is to people using the passthru method on different hosts
19:31:02 <NobodyCam> wounder if we need some kind fed-ex like tracking number
19:32:13 <lucasagomes> we might... this resource is very unique I'vent seem it in others apis
19:32:41 <lucasagomes> and it opens a big door for exploits and stuff, we have to think carefully how we are going to implement that
19:33:17 <NobodyCam> yes
19:34:08 <NobodyCam> we can chat with yuri tomorrow
19:34:28 <lucasagomes> right, yea we def need his input on this
19:34:52 <NobodyCam> any other Q /c's?
19:34:54 <lucasagomes> but if there's anyone here that wants to give some ideas, comments, etc... please do
19:35:54 <NobodyCam> ok then we'll get with Yuri tomorrow and get his imput
19:36:02 <NobodyCam> ok moving on
19:36:05 <NobodyCam> #topic Food For Thought / Open Discussion
19:36:28 <NobodyCam> FFT: how will ironic interface with nova
19:37:53 <lucasagomes> there's any initial idea on how it should work?
19:38:57 <NobodyCam> in devas head
19:38:58 <NobodyCam> lol
19:39:06 <NobodyCam> i'm sure
19:39:13 <NobodyCam> just tossing it out
19:39:37 <lucasagomes> hehe
19:39:54 <NobodyCam> i was looking at hacking a power driver and replicing nova bm powerdriver with ronic
19:40:00 <lucasagomes> maybe nova will have a "driver" which will just talk to ironic
19:40:05 <NobodyCam> ya
19:40:42 <NobodyCam> at least for testing i was thinking some hack that would allow pice by pice replacement of nova bm
19:41:08 <NobodyCam> *piece
19:41:34 <NobodyCam> any thoughts?
19:41:45 <lucasagomes> I see yea... so as I see it
19:41:56 <lucasagomes> you could use both, nova as an interface to ironic
19:42:05 <lucasagomes> or use the ironic api directly
19:42:41 <NobodyCam> so is it easier to add a ironic driver or teach nova ironic api
19:43:04 <lucasagomes> for some specific tasks ironic api will be the only way to do it, since some actions won't fit in nova
19:43:31 <lucasagomes> NobodyCam, I'm not sure
19:43:40 <lucasagomes> I gotta think more about it, I'm just dumping some thoughts here
19:44:21 <NobodyCam> thats what this #topic is for
19:44:27 <lucasagomes> :D
19:44:43 <NobodyCam> any one else want to jump in
19:44:49 <lucasagomes> yea... so, hmmmmmmm maybe we could do a small prototype with nova
19:44:51 <NobodyCam> there are no wrong answer here
19:45:03 <lucasagomes> and try to implment a way to list the nodes in ironic using nova
19:45:11 <NobodyCam> the power driver is a clean cut
19:45:19 <NobodyCam> no no
19:45:29 <lucasagomes> kinda like a nnova baremetal-node-list
19:45:32 <NobodyCam> well
19:45:57 <NobodyCam> ya thats a queston we need to think about
19:46:03 <NobodyCam> how will that work
19:46:37 <NobodyCam> ironic could nave nodes that the current user does not have access to
19:47:29 <NobodyCam> we have no way of flitering resources by user
19:49:21 <NobodyCam> also some FFT: How will Ironic handle > then 1 conductor
19:50:46 <NobodyCam> well well while we were meeting
19:50:52 <NobodyCam> #ling https://review.openstack.org/44566
19:51:00 <NobodyCam> merged
19:51:25 <lucasagomes_> my connection was gone :(
19:51:32 <NobodyCam> lol :)
19:51:46 <NobodyCam> there you go
19:51:50 <lucasagomes_> yea, sorry
19:51:53 <lucasagomes_> urgh...
19:51:55 <NobodyCam> heheh
19:52:04 <NobodyCam> did you get hte scroll back?
19:52:09 <lucasagomes_> will read the logs later, what topic we are now?
19:52:16 <lucasagomes_> not really
19:52:21 <NobodyCam> also some FFT: How will Ironic handle > then 1 conductor
19:52:45 <NobodyCam> just tossed that out
19:52:55 <NobodyCam> its open floor
19:53:04 <romcheg> I can investigate that
19:53:07 <lucasagomes_> oh yea, the scalling out problem
19:53:16 <romcheg> I need a new task anyway
19:53:21 <NobodyCam> romcheg: :)
19:53:27 <lucasagomes_> romcheg, that would be good
19:53:56 <NobodyCam> also we have no way of flitering resources by user
19:54:04 <romcheg> That's an # action isn't it?
19:54:19 <NobodyCam> yep
19:54:30 <romcheg> NobodyCam: Since we only allow admin requests the only filter might be based on domain
19:54:46 <NobodyCam> #action romcheg to look into How will Ironic handle > then 1 conductor
19:55:26 <NobodyCam> romcheg: yes but how will that play with nova baremetal-node-list
19:55:55 <NobodyCam> JUST FFT:
19:56:27 <romcheg> Can you please add that to the wiki?
19:56:35 <NobodyCam> last 5 minutes any last thoughts
19:57:06 <NobodyCam> which one? user filter? will do
19:57:20 <romcheg> The filtering
19:57:44 <NobodyCam> is the aganda ok for the FFT section for everyone?
19:57:53 <NobodyCam> it kinda just ended up there
19:58:06 <romcheg> I think it's better to move that to the start page
19:58:24 <NobodyCam> start?
19:58:39 <lucasagomes_> I'm happy with the FFT being the last topic
19:58:51 <romcheg> https://wiki.openstack.org/wiki/Ironic
19:59:04 <NobodyCam> :) we can at least get a link
19:59:16 <NobodyCam> lucasagomes_: +1
19:59:39 <NobodyCam> also every one can edit the agenda
19:59:47 <romcheg> ok then
20:00:22 <NobodyCam> :) alright if there are no parting words we can make way for the TripleO team
20:00:32 <NobodyCam> Thank you everyone
20:00:37 <lucasagomes_> :)
20:00:40 <NobodyCam> #endmeeting