19:00:43 <NobodyCam> #startmeeting Ironic
19:00:43 <NobodyCam> #chair devananda
19:00:43 <NobodyCam> agenda found at:
19:00:43 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:00:44 <openstack> Meeting started Mon Oct  7 19:00:43 2013 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:46 <NobodyCam> #toplic Greetings, roll-call and announcements
19:00:48 <openstack> The meeting name has been set to 'ironic'
19:00:48 <NobodyCam> Greetings everyone, who's here for the Ironic Meeting?
19:00:49 <openstack> Current chairs: NobodyCam devananda
19:00:58 <lucasagomes> o/
19:01:01 * devananda waves
19:01:03 <dkehn> hi
19:01:03 <romcheg> o/
19:01:11 <NobodyCam> hey all :)
19:01:23 <yuriyz> hi
19:01:30 <NobodyCam> hi yuriyz
19:01:33 <NobodyCam> Ok the offical announcement: Hoodies.. "are in progress!".. w00t!
19:01:43 <lucasagomes> NobodyCam, nice!
19:01:44 <romcheg> w00t!
19:01:45 <linggao> hi
19:02:01 <devananda> :)
19:02:20 <NobodyCam> We're looking good on Our call for summit papers!
19:02:27 <NobodyCam> :)
19:02:27 <martyntaylor1> howdy!
19:02:34 <NobodyCam> hey martyntaylor1
19:02:46 <devananda> re: summit proposals, i would like to point outthat there are several overlapping sessions proposed
19:03:19 <NobodyCam> I'me good with squishing them down to one
19:03:21 <GheRivero> o/
19:03:31 <NobodyCam> o/ GheRivero
19:03:36 <devananda> i'm happy to help coordinate between folks, and/or just pick the one that seems to have the most detail in teh description
19:04:15 <devananda> i'm also thrilled to see that folks have similar (but slightly different) ideas about al lthese things :)
19:04:22 <NobodyCam> We're a small enough group at this point I thing we can merge them down
19:04:34 <devananda> yes -- and we have to. we only get 5 slots
19:04:55 <NobodyCam> :)
19:05:11 <devananda> so far I havent seen any bad proposals. but I'll have to merge a few, so dont take that as a rejection
19:05:13 <NobodyCam> when do we have to have that done by?
19:05:38 <devananda> lemme check.. i think it's basically the-day-before-summit
19:05:52 <NobodyCam> ahh ok
19:06:17 <GheRivero> nice
19:06:40 <NobodyCam> anyone have anything else on summit paper while deva looks that up?
19:06:41 <rloo> are the summit proposals avail at that 'view proposed Ironic talks here' link in agenda?
19:07:06 <romcheg> Who is going to arrive to HK earlier?
19:07:07 <NobodyCam> that gives me a forbidden
19:07:16 <dkehn> me 2
19:07:18 <NobodyCam> use the other link and sort by topic
19:07:22 <rloo> yes, that's why I'm asking ;)
19:07:26 <NobodyCam> lol
19:07:38 <dkehn> its the lemming effect
19:07:47 <NobodyCam> :)
19:08:01 <NobodyCam> i tied to look in to that
19:08:21 <NobodyCam> but seems that what happens after the talks are accepted
19:08:26 <NobodyCam> ????
19:08:33 <NobodyCam> so thats all I have
19:08:36 <NobodyCam> on theat
19:08:39 <NobodyCam> *that
19:09:20 <NobodyCam> devananda: do you know what the ironic TALK that was accepted is?
19:09:24 <NobodyCam> :-p
19:09:34 <NobodyCam> and is there a updated link?
19:09:58 <devananda> k, wiki has nothing on closing-dates for the design summit. Let's assume 1-week-before to be safe
19:10:41 <devananda> NobodyCam: there is a talk on baremetal provisioning by me
19:10:42 <NobodyCam> #action nobodycam to add agenda topic to discuss summit papers
19:10:59 <devananda> NobodyCam: and a talk by some other folks at HP about their work with baremetal on moonshot
19:11:17 * devananda finds links
19:11:21 <NobodyCam> :)
19:11:48 <NobodyCam> going to move on while you get those
19:11:57 <devananda> #link http://openstacksummitnovember2013.sched.org/event/24f97e7cbb87119571f7b120e3d52e12#.UlMHdIaJBOU
19:12:02 <NobodyCam> :)
19:12:03 <devananda> #link http://openstacksummitnovember2013.sched.org/event/84364e80c063035bde40253a344fdbc7#.UlMHeIaJBOU
19:12:09 <NobodyCam> awesomeness
19:12:27 <NobodyCam> ok to move on?
19:12:42 <NobodyCam> #topic Outstanding, in-progress or Action Item updates
19:12:42 <devananda> sure
19:12:43 <NobodyCam> I've got a couple of older ones on the list.
19:13:04 <NobodyCam> romcheg: your almost the entire list
19:13:13 <NobodyCam> lol several are old
19:13:49 * NobodyCam 9/30/2013): romcheg to propose a non-gating job to -infra
19:13:49 * NobodyCam 9/30/2013): romcheg to add python-ironicclient to devstack install scripts
19:13:52 * NobodyCam 9/16/2013): devananda to think about a Transifex project for Ironic
19:13:55 * NobodyCam 9/16/2013): romcheg looking at Ukrainian and Russian transifex translations
19:13:58 * NobodyCam 9/16/2013): romcheg Check how i18n conplient we are
19:14:18 <romcheg> ok, about i18n
19:14:27 <NobodyCam> :)
19:14:58 <devananda> i'm pinging clarkb to see where I dropped the ball on transifex. I'lll get that going again
19:15:07 <NobodyCam> w00t
19:15:29 <romcheg> In the most of the code we use gettext so we can start translating as soon as we got a project on transifex
19:15:55 <romcheg> After the project was created we will need an infra job for translation
19:16:00 <devananda> any LOG or exception messages not using gettext should be considered a bug and fixed
19:16:44 <lucasagomes> and -1'd on reviews :)
19:16:49 <romcheg> +1
19:16:50 <NobodyCam> devananda: do we want one "make ironic i18n compliet bug or per find bug
19:17:26 <NobodyCam> :-p or one bug per find
19:18:14 <romcheg> NobodyCam: only if someone needs Launchpad karma to live :)
19:18:19 <lucasagomes> one bug per find sounds overkill
19:18:26 <NobodyCam> si
19:18:39 <NobodyCam> :)
19:18:48 <NobodyCam> ok to move on then
19:19:22 <NobodyCam> #topic Integration and testing
19:19:22 <NobodyCam> oh.. I've updated the dib walk thru
19:19:30 <NobodyCam> anything on the Devstack side?
19:19:47 <romcheg> Regarding my other action items: I'm still working on tempest and infra. As I mentioned in the #openstack-ironic, I'm trying to catch up on that
19:19:58 <NobodyCam> oh I'm sorry romcheg
19:20:05 <romcheg> NP
19:20:13 <NobodyCam> :)
19:21:16 <romcheg> Even using tempest on my local machine I found several bugs :)
19:21:17 <NobodyCam> anything on testing (or action items) :-p
19:21:24 <NobodyCam> awesome
19:21:26 <NobodyCam> :)
19:22:19 <NobodyCam> did you file bugs for what you've found so far?
19:22:41 <romcheg> I filed one to Ironic and uploaded the fix today
19:22:48 <romcheg> The others were in devstack
19:22:48 <NobodyCam> :)
19:23:13 <romcheg> it looks like nobody reads bugs in devstack so I just uploaded patches
19:23:38 <NobodyCam> lol... awesome romcheg :)
19:24:05 <NobodyCam> go to move on?
19:25:10 <NobodyCam> ok moving on to:
19:25:13 <NobodyCam> topic Python-IronicClient
19:25:20 <NobodyCam> #topic Python-IronicClient
19:25:43 <NobodyCam> awesome work lucas
19:25:48 <NobodyCam> and everyone
19:26:06 <lucasagomes> yea on the client I think all the basic stuffs are already implemented
19:26:07 <NobodyCam> we have a working cli client
19:26:37 <NobodyCam> so that leads me to : Are we ready for nova bindings?
19:26:45 <lucasagomes> we need to add some other things to the client lib, like vendor_passthru (when it's sorted out)
19:26:56 <lucasagomes> NobodyCam, I think so yea
19:27:00 <devananda> vendor_passthru would only be needed for the PXE post-back
19:27:05 <devananda> not the nova driver
19:27:16 <devananda> we'll need to sort the nesting / namespacing of driver options
19:27:23 <devananda> changing that will affect teh noav driver
19:27:35 <devananda> so may as well fix the nesting in ironic first
19:27:45 <lucasagomes> yes, but it's on ironic
19:28:06 <devananda> the option names and API calls to set them will change, no?
19:28:56 <lucasagomes> it's the options that goes in the driver_info, so currently you can add whatever you want there
19:29:07 <NobodyCam> devananda: can we put up the basic framwork for the nova driver?
19:29:14 <lucasagomes> the driver will validate it, but off the top of my head there's no changes on the api or client
19:29:51 <devananda> lucasagomes: right. so the parameter names that the noav driver uses (when it sends the PXE info to ironic) will need to match the ironic pxe driver
19:29:57 <devananda> NobodyCam: yep! I can do that
19:30:07 <devananda> #action devananda to write framework for noav-ironic driver
19:30:12 <NobodyCam> :)
19:30:14 <NobodyCam> awesome
19:30:16 <NobodyCam> ness
19:30:33 <lucasagomes> :), I will work on the bug you filled today as well
19:30:38 * lucasagomes getting the link
19:30:46 <devananda> anyone stood up a dev environment and had success with ironic powering on a VM or doing a deploy yet?
19:30:53 <lucasagomes> #link https://bugs.launchpad.net/ironic/+bug/1236533
19:30:54 <uvirtbot> Launchpad bug 1236533 in ironic "driver options should be namespaced and documented" [Medium,Triaged]
19:30:59 <devananda> *a tripleo devtest environment, using ironic element
19:32:19 <NobodyCam> not yet here.. but much closer
19:32:56 <devananda> k, that's also on my list -- at this point, I think it should work
19:33:04 <devananda> ah! docs for the CLI
19:33:10 <NobodyCam> anything else on the cli / python cliet
19:33:18 <NobodyCam> ahh yes
19:33:20 <lucasagomes> ^ docs missing yea
19:33:21 <devananda> eg, how to patch netsted resources, change power state, etc
19:33:22 <uvirtbot> lucasagomes: Error: "docs" is not a valid command.
19:33:53 <lucasagomes> yea give me one action on that
19:34:01 <lucasagomes> I think it makes sense to me to document it
19:34:07 <NobodyCam> :)
19:34:16 <devananda> #action lucasagomes to add CLI docs to ironic developer doc pages
19:34:51 <devananda> we should also get something up here at some point:
19:34:53 <devananda> #link http://docs.openstack.org/api/api-specs.html
19:35:39 <NobodyCam> our api been changing so fast
19:35:49 <NobodyCam> it would outdate quickly
19:36:26 <lucasagomes> yea I will take a look on the how to contribute link, idk how to add things to that page
19:36:43 <NobodyCam> that leads me to :
19:36:45 <NobodyCam> #topic API discussion
19:37:52 <NobodyCam> there were questions on vendor_passthru?
19:37:56 <lucasagomes> so I think that our new epic discussion on that topic would be the vendor_passthru
19:38:18 <NobodyCam> heheh
19:38:20 <lucasagomes> yuriyz, raised a question last week, whether vendor passthru should return a response body or not
19:38:54 <yuriyz> i agree that not at this moment
19:39:09 <lucasagomes> currently it doesn't because we are doing a async call, and we dont want to have any monitor object returned
19:39:18 <lucasagomes> anyone has any thoughts on that?
19:39:45 <NobodyCam> hummm
19:39:47 <devananda> one challenge with vendor_passthru is it is trying to enable "anything a vendor wants to do", and right now, we dont have vendors telling us what they want
19:39:59 <devananda> our only initial use is pxe driver post-back
19:40:04 <devananda> from the deploy ramdisk
19:40:12 <lucasagomes> so the idea is that, if u want to monitor the state of the node after a vendor_passthru call, you can keep pooling the node-show <id> and look at the states there
19:40:31 <devananda> and that ^ makes sense for task-like requests
19:40:44 <devananda> but not for informatiion requests
19:40:47 <devananda> ahh
19:41:10 <devananda> lucasagomes: any reason why vendor_passthru could not do this
19:41:27 <devananda> return a body for GET (and do a synchronous interaction with conductor)
19:41:47 <devananda> return 202 for POST/PUT/etc and do an async cast to conductor
19:42:13 <lucasagomes> devananda, we can def return a body for GET
19:42:25 <lucasagomes> but how we need some identifier no?
19:42:50 <lucasagomes> s/how//
19:43:03 <devananda> what are you thinking needs to be identified?
19:43:18 <devananda> GET /nodes/{UUID}/vendor_passthru/{some_resource}
19:43:32 <yuriyz> and new method name
19:44:02 <lucasagomes> like you make a call POST /nodes/{UUID}/vendor_passthru/something
19:45:28 <devananda> ah
19:45:42 <lucasagomes> so hmm that is not returning anything
19:45:59 <lucasagomes> so once you do a GET on the same url, it should return what? the status of the previous something call?
19:46:10 <devananda> right
19:46:26 <lucasagomes> so that means that we can only call one something per time
19:46:35 <devananda> so the question seems to be, can a vendor have resources that are distinct from the node, and dont have a 1:1 relationship
19:46:59 <devananda> POST /nodes/{UUID}/vendor_passthru/unicorns
19:47:23 <NobodyCam> *pink Unicorns
19:48:05 <devananda> do that a few times,a nd the node should have a few unicorns. but then, how do you GET those? ... GET /nodes/{UUID}/vendor_passthru/unicorns  -> returns the set of unicorns
19:48:21 <devananda> that doesn't really work :(
19:48:33 <devananda> the POST should be returning the resource identifier :(
19:48:40 <lucasagomes> yea, for that we might need to have POST to return some id
19:48:42 <lucasagomes> yes
19:49:01 <NobodyCam> yep
19:49:09 <yuriyz> or some links
19:49:45 <devananda> is it reasonable to require vendors not to have any resources of their own that do not have a 1:1 node:resource relationship?
19:50:02 <lucasagomes> I think at least for v1 it's reasonable
19:50:04 <NobodyCam> I like single id or single link to status for tranzx
19:50:29 <lucasagomes> because we don't know yet what are their use cases
19:50:36 <NobodyCam> devananda: +1 right now its do what nova BM does
19:50:38 <lucasagomes> so we have to assume something
19:51:09 <devananda> so if we impose that, then I think synch GET, async POST is fine. it's not ideal -- POST is a black hole that will eat your data and never tell you if it fails
19:51:27 <devananda> but that could at elast be improved via the validation call
19:52:00 <devananda> (and there's a note in there that I need to fix the race condition between validatea nd do)
19:52:48 <NobodyCam> ok 8 minutes left
19:52:48 <devananda> well
19:53:00 <devananda> let's d othis for now, and hopefully we'll get manyd iscussions with vendors about this at the summit
19:53:02 <lucasagomes> ok maybe on this http://summit.openstack.org/cfp/details/97 design session
19:53:15 <lucasagomes> we should try to raise some question about the vendor_passthru?
19:53:46 <NobodyCam> lucasagomes: ++
19:53:53 <yuriyz> we need vendor feedback
19:53:53 <lucasagomes> because vendors will be there
19:54:04 <NobodyCam> yes!
19:54:13 <lucasagomes> so that would be a good oportunitty to talk to them directly
19:54:20 <devananda> i can also add that to the release path session: http://summit.openstack.org/cfp/details/139
19:54:33 <lucasagomes> that would be great
19:54:40 <NobodyCam> ok for last 5 min
19:54:50 <NobodyCam> #topic open discussion / Food For Thought
19:55:30 <lucasagomes> how is the coffee driver?
19:55:37 <NobodyCam> i wanted to hank everyone for the awesome progress this last week
19:55:51 <NobodyCam> we where running low on time
19:56:06 <NobodyCam> and I have no reall progress to speak of :-p
19:56:29 <NobodyCam> on the coffee driver I will get back in to that this week
19:56:40 <lucasagomes> :)
19:57:27 <NobodyCam> any thing else
19:57:54 <devananda> not here
19:57:58 <devananda> thanks everyone!
19:58:08 <NobodyCam> great meeting Thank you all
19:58:09 <NobodyCam> !
19:58:13 <lucasagomes> sounds more related to ceilometer, but this thing is pretty cool: http://linux-ha.org/source-doc/assimilation/html/index.html#autoconfiguration
19:58:57 <NobodyCam> #endmeeting