#openstack-meeting: Ironic

Meeting started by NobodyCam at 19:01:02 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting (NobodyCam, 19:01:41)

  1. Greetings, roll-call, and announcements (devananda, 19:02:26)
  2. integration and testing (NobodyCam, 19:03:52)
    1. https://github.com/NoBodyCam/ironic-element (NobodyCam, 19:08:23)
    2. ACTION: enable ironic in experimental pipeline (NobodyCam, 19:21:41)
    3. ACTION: ( romcheg ) enable ironic in experimental pipeline (NobodyCam, 19:21:59)

  3. Nova / neutron (NobodyCam, 19:22:36)
    1. https://blueprints.launchpad.net/ironic/+spec/instance-mapping-by-consistent-hash (devananda, 19:28:59)
    2. https://etherpad.openstack.org/p/IronicWhiteBoard (lucasagomes, 19:30:04)
    3. ACTION: dkehn and devananda to iron out what nova-network-like API bits are needed in ironic/drivers/modules/pxe.py (devananda, 19:39:54)

  4. python-ironicclient (NobodyCam, 19:40:30)
    1. ACTION: lucasagomes look in to adding validate and start deploy methods to ironic Client (NobodyCam, 19:46:11)

  5. API discussion (NobodyCam, 19:46:45)
  6. open discussion (NobodyCam, 19:57:44)
    1. https://review.openstack.org/#/c/57722/ (NobodyCam, 19:58:26)
    2. https://review.openstack.org/#/c/56516/6 (devananda, 20:03:31)
    3. ACTION: devananda to find out project's common plans for sqla-migrate vs alembic, why there are test_migration code in oslo, and whether we should be fixing bugs in sqla-migrate (devananda, 20:09:22)


Meeting ended at 20:12:18 UTC (full logs).

Action items

  1. enable ironic in experimental pipeline
  2. ( romcheg ) enable ironic in experimental pipeline
  3. dkehn and devananda to iron out what nova-network-like API bits are needed in ironic/drivers/modules/pxe.py
  4. lucasagomes look in to adding validate and start deploy methods to ironic Client
  5. devananda to find out project's common plans for sqla-migrate vs alembic, why there are test_migration code in oslo, and whether we should be fixing bugs in sqla-migrate


Action items, by person

  1. devananda
    1. dkehn and devananda to iron out what nova-network-like API bits are needed in ironic/drivers/modules/pxe.py
    2. devananda to find out project's common plans for sqla-migrate vs alembic, why there are test_migration code in oslo, and whether we should be fixing bugs in sqla-migrate
  2. dkehn
    1. dkehn and devananda to iron out what nova-network-like API bits are needed in ironic/drivers/modules/pxe.py
  3. lucasagomes
    1. lucasagomes look in to adding validate and start deploy methods to ironic Client
  4. romcheg
    1. ( romcheg ) enable ironic in experimental pipeline


People present (lines said)

  1. devananda (100)
  2. NobodyCam (72)
  3. romcheg (39)
  4. dkehn (38)
  5. lucasagomes (25)
  6. yuriyz (17)
  7. GheRivero (9)
  8. lifeless (8)
  9. ctracey (5)
  10. openstack (4)
  11. clarkb (3)
  12. wh (3)
  13. shadower (1)


Generated by MeetBot 0.1.4.