19:00:07 <NobodyCam> #startmeeting Ironic
19:00:07 <NobodyCam> #chair devananda
19:00:08 <NobodyCam> Welcome everyone to the Ironic meeting.
19:00:08 <openstack> Meeting started Mon Feb  3 19:00:07 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:12 <openstack> The meeting name has been set to 'ironic'
19:00:13 <openstack> Current chairs: NobodyCam devananda
19:00:19 <matty_dubs> o/
19:00:21 <dkehn> hi
19:00:21 <devananda> hi all!
19:00:22 <NobodyCam> Of course the agenda can be found at:
19:00:22 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:00:26 <k4n0> o/
19:00:29 <k4n0> hi all
19:00:31 <NobodyCam> #topic Greetings, roll-call and announcements
19:00:31 <NobodyCam> Who's here for the Ironic Meeting?
19:00:34 <GheRivero> o/
19:00:40 <NobodyCam> hello all :)
19:00:41 <k4n0> o/
19:00:49 <rloo> me
19:01:07 <yuriyz> o/
19:01:12 <NobodyCam> welcome
19:01:33 <NobodyCam> looks like another short agenda today
19:01:43 <NobodyCam> announcements:
19:01:53 <devananda> hopefully everyone saw my email to the -dev ML on saturday... :)
19:02:03 <NobodyCam> re testing?
19:02:09 <k4n0> devananda:  can you please link to it?
19:02:29 <devananda> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/026081.html
19:02:37 <k4n0> devananda: thanks :)
19:02:43 <devananda> in case not, brief summary -
19:03:15 <devananda> tempest / devstack was enabled for our gate checks last week
19:03:19 <devananda> and promptly broke twice
19:03:32 <devananda> because we're depending on things which we aren't actually using right now
19:03:57 <devananda> i'm workign to fix that, but we also need to start focusing on getting testing of the RIGHT things in place
19:04:31 <devananda> also, a big thanks to the mirantis folks who have been working on our tempest and devstack patches :)
19:04:45 <NobodyCam> :)
19:04:57 <devananda> oh and one more announcement
19:05:24 <devananda> tripleo team is holding their mid-cycle sprint mar 3 - 7, i believe that's been officialy announced now
19:05:42 <devananda> hopefully i'll see several of you there :)
19:05:49 <NobodyCam> yes I believe it is... :)
19:05:59 <NobodyCam> its in sunnyvale CA
19:06:26 <devananda> #link http://lists.openstack.org/pipermail/openstack-dev/2014-January/026040.html
19:06:27 <lucasagomes> I hope I'll be able to make it!
19:06:42 <max_lobur_cell> hi all
19:06:54 <devananda> that's it from me
19:07:13 <devananda> #topic progress to i3
19:07:21 <devananda> #link https://launchpad.net/ironic/+milestone/icehouse-3
19:08:16 <NobodyCam> any updates on https://blueprints.launchpad.net/ironic/+spec/serial-console-access
19:08:40 <NobodyCam> devananda: is that required for graduation?
19:08:49 <devananda> that should be an indication of what we all need to be working on. please target any active work to i3 so we can track it, if it's critical for the icehouse release
19:09:10 <devananda> NobodyCam: AIUI, yes
19:09:24 <devananda> NobodyCam: we should have feature parity with nova "baremetal" driver
19:09:31 <NobodyCam> ack!
19:10:24 <NobodyCam> AIU Sun has been pulled away from ironic??
19:10:34 <NobodyCam> *Sun Jing*
19:11:15 <devananda> NobodyCam: I believe linggao is still working on that
19:11:28 <NobodyCam> ok
19:11:56 <NobodyCam> #action NobodyCam check with linggao on https://blueprints.launchpad.net/ironic/+spec/serial-console-access
19:12:05 <devananda> we will need the db migration stuff, and i haven't seen any activity from romcheg on that
19:12:22 <devananda> also, the neutron integration's initial patch landed
19:12:36 <NobodyCam> woo hoo
19:12:38 <devananda> i have a patch up taht needs review for sending updates to neutron from the PXE driver
19:12:54 <devananda> and I will post a patch soon for triggering that when one conductor takes over from another
19:13:09 <NobodyCam> also lucasagomes has this WIP up:
19:13:13 <NobodyCam> #link https://review.openstack.org/#/c/68457/
19:13:18 <devananda> #link https://review.openstack.org/#/c/70468/2
19:13:33 <devananda> looks like i already have some comments ... heh. will look at after meeting
19:13:40 <lucasagomes> yup that's needed for us
19:14:17 <lucasagomes> I fixed the KeyError problem on the jsonpatch lib as well
19:14:17 <lucasagomes> https://github.com/stefankoegl/python-json-patch/pull/22
19:14:26 <lucasagomes> but it wasn't released yet (merged today)
19:14:44 <k4n0> We at SeaMicro are looking for lots of review comments on https://review.openstack.org/#/c/70719/ & https://review.openstack.org/#/c/70720/ :)
19:14:54 <devananda> lucasagomes: awesome. will we need a version pin change in requiremetns?
19:15:12 <lucasagomes> devananda, yea, once it's released we can do that
19:15:33 <yuriyz> do we need yet breaking node lock manually via api? https://review.openstack.org/#/c/55549/
19:15:57 <lucasagomes> yuriyz, yes
19:16:00 <devananda> k4n0: awesome! I'm not sure why those code reviews didn't update LP -- could you add them manually to the BP's whiteboards?
19:16:11 <k4n0> devananda: will do
19:16:33 <devananda> yuriyz: yea, we will need to support that, however lucasagomes had a very good suggestion late last week
19:16:42 <devananda> yuriyz: and I didn't get around to putting up a WIP, sorry
19:16:56 <yuriyz> ok thanks lucas
19:16:56 <devananda> lucasagomes: do you have time to post that? it may be faster from you as it's mostly API work
19:17:35 <lucasagomes> devananda, you mean coding it? I can do that if yuriyz ok with the idea
19:17:35 <yuriyz> romcheg work with db migration from Nova
19:18:05 <devananda> yuriyz: sorry for the back-and-forth on taht patch. I really want to land /something/ to provide taht functionality, but OTOH, lucasagomes pointed out that the way it would be exposed in teh API is inconsistent
19:18:08 <NobodyCam> lucasagomes: i think it was removing reversation from the patch
19:18:17 <lucasagomes> yuriyz, so yuriz, as the break of the locking envolves a lot more logic than just (un)setting an attribute in the nodes resource
19:18:20 <devananda> lucasagomes: either that or some explanation on the review of what it should be doing
19:18:54 <lucasagomes> devananda, ok, I will talk to yuriyz after meeting then and we can decide
19:19:00 <lucasagomes> yuriyz, is that ok?
19:19:09 <yuriyz> ok
19:20:35 <devananda> k4n0: are you familiar with working with gerrit and jenkins -- openstack's review system in general? it looks like your patches failed pep8 and a lot of unit tests
19:20:49 <k4n0> Yes,
19:21:06 <devananda> k4n0: actually - it looks like all the failures are from python-seamicroclient
19:21:11 <devananda> k4n0: where is that available from?
19:21:30 <k4n0> devananda: Yes, i have fixed that issue, posted a patch to openstack/requiremtns
19:21:38 <devananda> k4n0: ah, great!
19:21:43 <k4n0> devananda: package is available on pypi
19:21:54 <NobodyCam> :) nice
19:22:03 <k4n0> devananda: we will have to wait till the openstack/requirements review goes in
19:22:47 <devananda> k4n0: ack. I'll poke people about that
19:22:51 <k4n0> But we can start getting review comments on these patches so that i can start fixing issues
19:22:56 <devananda> k4n0: do you have a link for that review?
19:23:10 <k4n0> devananda: https://review.openstack.org/#/c/70751/
19:23:20 <devananda> #action devananda to review patches 70719 and 70720
19:23:23 <devananda> k4n0: thanks
19:24:08 <devananda> any other questions on open BPs?
19:24:21 <k4n0> none from me
19:24:28 <devananda> oh, k4n0, also feel free to update teh status of your BPs to "needs code review"
19:24:38 <k4n0> sure
19:25:00 <devananda> ok, bugs -- anyone blocked by any bugs? any particulartly troubling ones we need to discuss?
19:25:29 <devananda> i see about a dozen in-progress targeted to i3, so i assume those are just waiting for reviews/merges
19:25:29 <NobodyCam> #link https://bugs.launchpad.net/ironic
19:25:57 <devananda> and there are a few triaged and unassigned bugs also targeted to i3 -- if anyone's looking for things to do, that's a great start
19:26:00 <matty_dubs> http://www.subway.com/menu/product.aspx?CC=USA&LC=ENG&MenuTypeId=1&MenuId=35&ProductId=9
19:26:08 <matty_dubs> That actually doesn't explain BMT either
19:26:15 <matty_dubs> Oh shoot, wrong window!
19:26:34 <NobodyCam> ummm foood
19:26:38 <devananda> anyone know if imre farkas is around // working on https://bugs.launchpad.net/ironic/+bug/1264596 ?
19:26:42 <lucasagomes> dendrobates, there's the timeout one
19:26:43 <notmyname> and now it's logged forever
19:26:50 <lucasagomes> devananda,*
19:27:37 <matty_dubs> devananda: Last I knew, he was looking at testing Neutron+Ironic, not sure if he's still working on that bug
19:27:39 <NobodyCam> I do not see him on line
19:28:14 <devananda> matty_dubs: can you follow up with him? if not, it should be unassigned so others can work on it
19:28:29 <matty_dubs> devananda: Yes, I will ask him tomorrow AM
19:28:32 <devananda> lucasagomes: do you mean https://bugs.launchpad.net/ironic/+bug/1270986 ?
19:28:36 <devananda> thanks!
19:28:51 <lucasagomes> devananda, yes!
19:28:51 <devananda> #action matty_dubs to follow up with ifarkas re: https://bugs.launchpad.net/ironic/+bug/1264596
19:29:07 <devananda> #link https://bugs.launchpad.net/ironic/+bug/1270986
19:29:11 <lucasagomes> that will based on the work that max_lobur_cell is doing on the power state change
19:29:21 <devananda> right
19:29:53 <devananda> creating a background thread that is trackable and interruptable
19:30:03 <lucasagomes> exactly
19:30:42 <devananda> i'm targeting that bug to i3 as it is, IMO, critical, and we really shouldn't release icehouse without fixing it
19:31:22 <devananda> if we have to bump it past i3 and into the FF area, taht's not ideal, but it's OK
19:31:51 <devananda> this is the one max_lobur_cell is directly trying to fix, i beleive: https://bugs.launchpad.net/ironic/+bug/1259910
19:32:12 <devananda> "race condition when changing node states"
19:32:47 <lucasagomes> yes and there's a review up
19:32:49 <lucasagomes> #link https://review.openstack.org/#/c/69135/
19:32:54 <lucasagomes> I'm going to give it a go tomorrow
19:32:54 <max_lobur_cell> devananda +
19:33:00 <devananda> awesome
19:33:03 <devananda> i'll take a look today
19:33:19 <devananda> anything else on bugs?
19:33:21 <NobodyCam> devananda: is this valid for us? https://bugs.launchpad.net/ironic/+bug/1236623
19:33:27 <max_lobur_cell> great, thanks
19:33:58 <yuriyz> and I restore my patch with dd monitoring/timeouts https://review.openstack.org/#/c/48198/
19:34:03 <devananda> NobodyCam: i think my last patch fixes it
19:34:10 <devananda> NobodyCam: https://review.openstack.org/#/c/70468/2
19:35:09 <devananda> NobodyCam: oh - nvm. different issue. the fix landed a while back
19:36:04 * devananda marks that bug fix-released as it was contained in the i2 release
19:36:25 <NobodyCam> ack
19:37:06 <lucasagomes> yuriyz, did you submit a review for oslo to change the processutils.py?
19:37:54 <yuriyz> I think we needs separate code for this task, w/o changing Oslo
19:38:27 <lucasagomes> ack
19:38:51 <devananda> ok, we've spent a while on bugs - which is great - but let's move on
19:38:58 <devananda> #topic testing
19:39:23 <devananda> i'm really eager to see us get functional testing into devstack/tempest/etc
19:39:28 <devananda> agordeev: are you around?
19:40:02 <k4n0> devananda: Any thoughts on how to add driver specific tests to tempest?
19:40:16 <devananda> #link https://review.openstack.org/#/c/70348/
19:40:32 <devananda> taht ^ is agordeev's WIP to start getting devstack to create the network bridge and soem VMs for testing
19:40:50 <devananda> k4n0: driver-specific tests fall into the 3rd party testing category
19:41:22 <devananda> k4n0: unless you have a way to mock a seamicro hardware device with a VM... :)
19:41:37 <k4n0> devananda: maybe, i will look into that
19:41:59 <devananda> k4n0: but my expectation is taht all the 3rd party drivers will need their own 3rd party test environments, similar to the ongoing discussion within nova and neutron communities
19:42:12 <devananda> k4n0: i posted some initial discussion about this a few weeks ago
19:42:39 <k4n0> devananda: Yes, i read that, we are looking to use tempest to add 3rd part tests which  will run in our env.
19:43:02 <devananda> k4n0: great
19:43:21 <devananda> k4n0: so then, as far as the technical "how-to", i would use ENV vars
19:43:41 <k4n0> devananda: to set the driver right?
19:43:51 <devananda> both to set the driver and to change the test runners
19:44:03 <devananda> right now, our tempest run is just API exercises
19:44:13 <devananda> CRUD stuff. no power/deploy
19:44:34 <k4n0> yes, can we help with the other tests?
19:44:42 <devananda> once we have devstack creating a fake environment out of very small qemu VMs, we'll enroll those with the pxe_ssh driver
19:44:50 <devananda> from taht point on ,the tests should be the same
19:45:07 <k4n0> then only the drivers would change
19:45:10 <devananda> at least for all the driver interfaces except for vendor_passpthru
19:45:14 <devananda> k4n0: right :)
19:45:17 <k4n0> right :)
19:45:24 <devananda> so if you guys want to help write those tests -- awesome!
19:45:53 <k4n0> devananda: we can definitely help, would get in touch tomorrow for details
19:46:01 <devananda> you can see the work that agordeev is doing to spin up thse qemu VMs and enroll them in the devstack patch i linked above
19:46:14 <k4n0> ok, will do
19:46:30 <devananda> you'll probably want a hook there to enroll your seamicro hardware instead. but in principle, the rest should be fairly similar
19:46:43 <devananda> any other questions on testing?
19:46:59 <lucasagomes> I've a note on the devstack+Nova w/ Ironic driver
19:47:14 <devananda> k
19:47:38 <lucasagomes> I put up a guideline on how to setup an environment and deploy a machine using the Nova with the ironic driver + devstack
19:47:45 <lucasagomes> https://etherpad.openstack.org/p/IronicDeployDevstack
19:48:24 <devananda> awesome
19:48:25 * NobodyCam shuold have the DIB walkthru update finished today too
19:48:27 <lucasagomes> it might help the guys changing devstack to incorporate our tests
19:48:46 <lucasagomes> that's it
19:48:59 <k4n0> lucasagomes: thanks for that
19:49:03 <devananda> agordeev: when you're around, please see ^
19:49:05 <NobodyCam> oh I have a nova ironic driver update
19:49:05 <lucasagomes> np
19:49:24 <NobodyCam> it worked. lucasagomes was able to boot a node!
19:49:34 <NobodyCam> :-p
19:49:36 <devananda> hehe :)
19:49:45 <matty_dubs> Woo-hoo!
19:49:46 <yuriyz> cool!
19:49:47 <devananda> ok, 10 minutes left ...
19:49:51 <devananda> #topic open discussion
19:49:58 <mdurnosvistov_> Hi folks! :) What are your thoughts about https://bugs.launchpad.net/ironic/+bug/1256260 :) This chain is very long time without attention ...
19:50:17 <k4n0> any thoughts on multiple vendor passthru muxing ?
19:50:24 <lucasagomes> NobodyCam you and devananda did the mostly work (and hard work) on that driver :) thanks!
19:50:49 <devananda> k4n0: can you clarify?
19:50:58 <NobodyCam> lucasagomes: you got it to work
19:51:12 * NobodyCam looks at ^ bug
19:51:35 <k4n0> So, we are using the SeaMicro vendor passthru, and the PXE deploy interface requires PXE vendor passthru to finish deployment
19:51:57 <lucasagomes> k4n0, I would suggest you from inheriting the new Vendor Interface from the PXE vendor interface, but I don't like this cross-driver dependency
19:52:07 <devananda> mdurnosvistov_: hi! yes - it is a large code-cleanup. I'll try to start looking at some of the patches, but have been prioritizing bug fixes over cleanup in my review time
19:52:36 <NobodyCam> mdurnosvistov_: i too need to review the entire patch set
19:52:44 <k4n0> Yes, but shouldnt the "pass_deploy_info" method be in the PXE deploy interface instead of the PXE vendor passthru?
19:52:47 <devananda> lucasagomes: so that's not quite what i suggest :)
19:53:10 <lifeless> k4n0: no, because pass_deploy_info is pxe specific
19:53:28 <mdurnosvistov_> Great! Thanks!!! :)
19:53:38 <lifeless> k4n0: other deployment methods may have very different ways of organising the deploy (e.g. imagine an Ironic driver that calls another Ironic instance)
19:54:07 <devananda> k4n0: in your driver class, load both interfaces (pxe.vendor_passthru && seamicro.vendor)passthru) then call into either one depending on what the incoming request is
19:54:07 <NobodyCam> mdurnosvistov_: Are all patches linked to that bug?
19:54:09 <lucasagomes> devananda, right, I gotta take a look at ur suggestion
19:54:18 <devananda> lucasagomes: ^
19:54:25 <k4n0> devananda: yes, will do that
19:54:40 <devananda> lifeless: any objections to multiplexing in taht way?
19:54:41 <lucasagomes> devananda, ahh so make the vendor interface to accept a list of different vendor_passthru
19:54:44 * lucasagomes likes that
19:54:58 <devananda> lifeless: iirc, that's what we initially discussed, but it was a while back
19:55:03 <mdurnosvistov_> NobodyCam: yes all
19:55:15 <NobodyCam> :) mdurnosvistov_ TY
19:55:17 <lifeless> devananda: none at all; in fact I would rather suggest that the framework should be able to do do that
19:55:22 <mdurnosvistov_> :)
19:55:36 <devananda> lifeless: ack. pretty sure it can
19:56:16 <lifeless> my expectation of the vendor interfaces is that something outside of ironic (e.g. the deploy ramdisk for pxe) can call the API and supply information back to the relevant conductor driver
19:57:13 <devananda> k4n0: you are using the seamicro power interface but still using the pxe deploy interface, ya?
19:57:32 <k4n0> devananda: yes, PXE for deploy, SeaMicro for power and vendor pass
19:57:52 <k4n0> devananda: power interface works fine functionally.
19:58:13 <devananda> k4n0: right. so you need to instantiate both pxe and seamicro vendor passthru classes in your driver, and call the appropriate one depending on teh API request
19:58:31 <NobodyCam> two minute bell
19:58:32 <k4n0> yes, i will inspect the requested method and make further calls
19:58:34 <devananda> k4n0: let's chat mroe in channel. i can mock it up if that's not clear yet
19:58:44 <k4n0> ok, lets talk in chan
19:58:44 <devananda> cool
19:59:22 <devananda> ok, thanks everyone!
19:59:24 <NobodyCam> great meeting all
19:59:28 <k4n0> thanks all
19:59:31 <NobodyCam> Thank you!
19:59:37 <devananda> #endmeeting