19:00:25 <devananda> #startmeeting ironic
19:00:26 <openstack> Meeting started Mon Feb 17 19:00:25 2014 UTC and is due to finish in 60 minutes.  The chair is devananda. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:30 <linggao> Hi NobodyCam, nice to be back.
19:00:31 <openstack> The meeting name has been set to 'ironic'
19:00:38 <devananda> it's great to see lots of familiar faces :)
19:00:47 <devananda> as usual, our rough agenda is here
19:00:49 <devananda> #link https://wiki.openstack.org/wiki/Meetings/Ironic
19:01:06 <devananda> #topic announcements
19:01:14 <devananda> one brief annoucement
19:01:26 <devananda> i emailed the list this morning but want to call it out
19:01:38 <devananda> ifyou submitted a patch over the weekend and jenkins -1'd it for a py26 failure
19:01:41 <devananda> that's fixed now :)
19:02:02 <devananda> NobodyCam: any other announcements?
19:02:14 <NobodyCam> i'd like to announce that we have start Review jams on mondays and thrusdays
19:02:48 <NobodyCam> s/start/started/
19:02:49 <devananda> ah, right
19:02:59 <devananda> in an effort to get our review queue moving faster...
19:03:00 <linggao> what are jams?
19:03:02 <mrda> so NobodyCam, what's a review jam?
19:03:18 <devananda> as many -core folks as can make it all get online together and focus just on doing code reviews for a few hours
19:03:19 <k4n0> sounds good
19:03:34 <NobodyCam> ya that ^^
19:03:41 <linggao> ah
19:03:45 <devananda> we'll note the time(s) of them on the ML, and if you're in channel you'll probably see a lot of chatter
19:04:00 <mrda> great!
19:04:05 <devananda> and we're stashing notes as we go, follow up cnocerns, etc, here
19:04:07 <devananda> #link https://etherpad.openstack.org/p/IronicReviewDay
19:04:36 <devananda> ok, moving on
19:04:59 <devananda> i'm actually going to skip our regular topics for the moment (they'll get covered by other topics though)
19:05:06 <devananda> #topic Icehouse-3 planning
19:05:16 <NobodyCam> ahh yes
19:05:21 <devananda> I sent a rather lengthy email to the list last week
19:05:32 <devananda> someone want to dig up the link? (I dont have it handy)
19:05:52 <lucasagomes> lemme find it
19:06:03 <devananda> tl;dr - I outlined the various technical deficits between where we are today and what we need to graduate in Icehouse and become an integrated project
19:06:25 <devananda> some of them are well under way...
19:06:33 <devananda> and some of them look likely to prevent our graduation
19:06:40 <lucasagomes> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/026962.html
19:06:43 <devananda> such as docs, the nova driver, and integration tests
19:06:46 <devananda> lucasagomes: thanks
19:07:26 <NobodyCam> we should be seeing some doc reviews shortly (this week I'm hoping)
19:07:50 <mrda> so by nova driver you also mean a 3rd party ci in place?
19:07:50 <devananda> russellb's feedback there is that we need to have the nova driver landed and fully CI'd (devstack + tempest doing functional tests of it)
19:07:53 <devananda> before we can land
19:07:56 <devananda> mrda: no
19:08:13 <devananda> mrda: in this context, third party CI means things like the SeaMicro and HP iLO drivers in Ironic
19:08:22 <devananda> those are not part of the graudation requirement
19:08:38 <mrda> so we're planning on using infra ci all the way except for driver testing, right?
19:08:39 <NobodyCam> for nova driver we will need to start poking people??
19:08:59 <devananda> mrda: we can rely on infra for CI of the SSH and PXE drivers
19:09:20 <devananda> mrda: we can't do either IPMI, or the 3rd party drivers, in infra's CI today -- and that's OK
19:09:34 <devananda> we'll need it eventually (probably by Juno) and we should get a lot of that from tripleo-ci
19:09:35 <lucasagomes> NobodyCam, +1 I haven't seem many reviews on the nova ironic driver patches
19:09:50 <devananda> NobodyCam: yes, start poking people in nova
19:09:57 <NobodyCam> #link https://review.openstack.org/#/c/70348/
19:10:09 <NobodyCam> ^^^^ needed for devstack CI
19:10:10 <devananda> russellb: any one in particular who we should start nagging for feedback on our nova driver patches?
19:10:11 <mrda> I think that's a chicken and egg problem actually.
19:10:35 <mrda> I don't think we'll get the review focus we'd like until there's confidence that the patches will work.
19:11:16 <devananda> russellb: or do we need to wait even on gettign review feedback until we have CI in place?
19:12:02 <devananda> for CI, we need devstack able to create the necessary environment (net bridge, bunch of VMs, SSH key, etc)
19:12:39 <devananda> devstack should accept such a patch before the driver's in Nova. we'll then create an infra job in the experimental pipe to exercise that part of devstack
19:12:56 <devananda> and trigger it only on the nova review that is the tail of our driver patch chain
19:13:01 <devananda> (yea, it's a chain, not just one patch)
19:13:11 <mrda> I think nova driver won't get review until the ci is ready, so I think we need to focus there, FWIW.
19:13:16 <devananda> mrda: I agree
19:13:26 <NobodyCam> mrda: ++
19:13:30 <devananda> which is why i'm bringing it up at the start of our meeting :)
19:13:45 <devananda> cause if we don't get that ASAP, we won't graduate, even if the rest of Ironic is working
19:13:58 <ifarkas> devananda, what type of net bridge is needed for devstack? is there a patch for that?
19:14:00 <devananda> hmmm, where's romcheg ....
19:14:00 <mrda> (was in UT last week and chatted to some Nova cores informally)
19:14:29 <devananda> agordeev2: hi!
19:14:48 <agordeev2> devananda: hi!
19:14:56 <devananda> agordeev2: are you around / still working on the devstack patch for Ironic? see the conversation ^^ ? :)
19:15:17 <devananda> #link https://review.openstack.org/#/c/70348/
19:15:27 <devananda> that ^ is the start of getting devstack to do what we need
19:15:49 <agordeev2> devananda: yes, i do. I'm going to pay more attention to it tomorrow
19:15:57 <devananda> great
19:15:58 <agordeev2> and on the that week too
19:15:58 <NobodyCam> agordeev2: great
19:16:14 * lucasagomes adds that link to his todo list to review later
19:16:24 <devananda> i'm going to start testing / hacking on it this week
19:17:21 <agordeev2> for now only one question. What sort of linux distro is preffered for the infra CI ?
19:17:24 <devananda> if anyone's familiar with devstack or CI already, this'd be a great place to help out right now. it's a critical path item for the next month or so
19:17:49 <NobodyCam> is GheRivero here?
19:17:57 <devananda> clarkb: what distro is tempest run on?
19:17:57 <NobodyCam> GheRivero: ^^^^ ?????
19:18:01 <clarkb> devananda: precise
19:18:08 <devananda> clarkb: thanks
19:18:31 <agordeev2> tripleo-incubator script heavily relies on --persistent virsh option which is not possible on precise.
19:18:50 <devananda> agordeev2: which script?
19:19:09 <devananda> ah, setup-network
19:19:20 <agordeev2> create-node also
19:19:48 <lucasagomes> agordeev2, I usually test things on fedora for e.g to write that pad with the steps to deploy a machine etc... (note I work for rh)
19:20:14 <devananda> agordeev2: infra's tempest nodes are ephemeral (destroyed after one test run)
19:20:38 <devananda> agordeev2: do we need --persistent? if not, it should be easy to patch triplei-incubator to remove that option when run on precise
19:21:17 <NobodyCam> devananda: there was something about in hipchat this mornig ... I did not read all of it
19:21:46 <devananda> lucasagomes: for the CI stuff, any chance you can work on precise so we're all focusing on the same issues (at least for now, until we have some CI, then add fedora support)
19:22:28 <lucasagomes> devananda, yeah sure I can do that
19:22:43 <devananda> lucasagomes: thanks :)
19:23:03 <devananda> any more questions/concerns on CI?
19:23:20 <lucasagomes> concerns: neutron integration
19:23:23 <agordeev2> devananda: yes. What about neutron support?
19:23:29 <devananda> ahh
19:23:51 <devananda> yea, well, we depend on neutron to set the DHCP BOOT option
19:24:13 <devananda> by "we" i mean the PXE driver, which is our reference deploy driver implementation
19:24:34 <devananda> so yea, to do CI with the Nova driver, we need to enable Neutron in those tempest tests
19:24:45 <devananda> and yea, we're kinda tied to Neutron's gate issues ....
19:24:47 <lucasagomes> right, btw lemme ask something... we have this integration with neutron but not with nova network right?
19:24:55 <devananda> lucasagomes: right
19:25:26 <lucasagomes> cause nova network doesn't know how to handle pxe boots?
19:25:47 <devananda> nova-net doesn't haev an API for setting the DHCP BOOT option
19:26:07 <lucasagomes> ah ack... cause I was looking at the code to see if nova bm does have a nova net integration
19:26:17 <lucasagomes> thanks
19:26:22 <devananda> and we dont have a nova-net client linked in to ironic/drivers/modules/pxe
19:26:44 <devananda> now that nova-net is no longer feature frozen, i suppose it might be possible to add it there
19:26:53 <mrda> hmmm, devananda, is it an option to retrofit DHCP BOOT into nova-network?  I'm not sure we want to be tied to neutron.
19:27:01 <devananda> mrda: see ^ :)
19:27:43 <NobodyCam> that going to be really tuff to retofit in a month
19:27:51 <mrda> yup
19:27:52 <lucasagomes> devananda, ahh that's interesting, yea we should keep our eyes on that, cause if someone add an integration to nova bm and nova net we would have to add it to ironic too in order to have pair functionality with nov abm
19:28:04 <devananda> lucasagomes: yep
19:28:35 <devananda> ok, moving on before we run out of time :)
19:28:42 <devananda> #topic feature freeze
19:28:52 <devananda> so, two things
19:29:37 <devananda> 1. lots of projects agreed to stop accepting new code submissions after the 18th. we probably can't follow suit since we have so much to do
19:29:50 <devananda> 2. I3 is supposed to be global featuer freeze, and we need to adhere to that
19:30:03 <devananda> caveat is FFE's - feature freeze exceptions
19:30:18 <linggao> what is the date for I3?
19:30:37 <NobodyCam> do we have ffe for nova driver bits already?
19:30:45 <lucasagomes> linggao, march 6th (I think, lemme search)
19:30:56 <devananda> we haev a lot to do before Icehouse... i'd like to ask that folks prioritize reviews and new code based on what is in the critical path to graduation
19:31:36 <linggao> lucasagomes, thanks
19:31:47 <mrda> I3 is March 6, although string freeze is 2 days earlier
19:32:02 <devananda> mrda: thanks
19:32:07 <mrda> (and string freeze also means feature freeze)
19:32:21 <mrda> so March 4
19:32:25 <devananda> so that week, a lot of us will be at the code sprint in SJC
19:32:26 <linggao> So I'll talk to Sun Jing to make sure we finish the console bp by that date.
19:32:51 <matty_dubs> linggao: Are you folks working on that? I had started to take a look at the console BP as well.
19:32:57 <devananda> the weekend before (Mar 2) I'll go through and block (-2) any large patches that aren't critical to graduation
19:33:06 <matty_dubs> I will stand down if you are doing it. Or I'm happy to help.
19:33:06 <NobodyCam> linggao: before that date... needs to land by the 6th
19:33:16 <lucasagomes> linggao, ack, you guys might want to take a look at https://review.openstack.org/#/c/72998/
19:34:15 <linggao> matty_dubs, yes. Sun Jing is still working on 64100
19:34:32 <linggao> NobodyCam, yes.
19:34:37 <NobodyCam> :)
19:34:37 <devananda> I'll also bump any BP's that aren't implemented by March 2
19:34:37 <matty_dubs> linggao: OK, excellent. I was worried she had been preoccupied. Let me know if I can lend a hand.
19:35:30 <linggao> matty_dubs, thanks.
19:35:33 <NobodyCam> awesome thank you matty_dubs
19:35:38 <NobodyCam> :)
19:35:40 <devananda> linggao, matty_dubs: if you guys can get the console done by then, that's great -- if it's mostly done, I think a FFE would be fine, too
19:35:55 <devananda> NobodyCam: yes, we should file an FFE with Nova for our driver as soon as Nova starts accepting them
19:36:08 <russellb> devananda: just saw your message.  i'm not sure of anyone in particular.  If we think it's going to miss Icehouse, probably best to just put off review while we focus on Icehouse items, honestly
19:36:36 <linggao> devananda, I'll talk to Sun Jing tonight and let you by tomorrow.
19:36:59 <devananda> russellb: that's the largest item // most likely to cause us to miss graduation at this point, so I'm going to focus on it for the next few weeks
19:37:13 <russellb> OK
19:37:25 <russellb> sounds like consensus is to block on CI
19:37:37 <devananda> russellb: if you know that there's no chance of it landing, let me know soon so i don't kill myself trying :)
19:37:50 <russellb> i think CI is the sticking point
19:38:17 <russellb> i definitely don't think you should kill yourself over it
19:38:33 <russellb> but I think CI in place will then get people reviewing it
19:38:48 <devananda> russellb: ack. my concern is the ramifications of ironic not graduating, eg. for tripleo // projects based on nova being able to provision physical machines
19:38:56 <russellb> understood
19:39:03 <devananda> russellb: many of which are counting on functionality in Ironic and likely to start using it even if it doesn't get integrated
19:39:20 <devananda> not that that's a reason for Nova to accept something without CI :)
19:39:25 <russellb> right..
19:40:11 <russellb> but those projects have nova-baremetal in the meantime, in theory
19:40:40 <devananda> which has some significant limitations (no HA, no support for vendors)
19:41:05 <devananda> anyhow, i'll see how much progress we can make on CI in a very short time
19:41:08 <devananda> thanks :)
19:41:45 <devananda> ok, moving on
19:41:50 <devananda> #topic code cleanup
19:42:03 <devananda> there've been several patches by folks doing code cleanup
19:42:27 <devananda> i'd like to know how folks feel about this -- should we review? or postpone in light of upcoming featuer freeze?
19:43:21 <lucasagomes> we need to prioritize the more important patches
19:43:24 <max_lobur> I think if we have time to review - it's better to spent it on critical items
19:43:54 <max_lobur> and cleanup is low priority
19:43:54 <lucasagomes> if it's a _small_ patch fixing some comestic problems it's fine, but larger patches or series might be postponed
19:43:56 <NobodyCam> I feel small cleanup patches are good, but larger ones that remove functionalyity are tuffer
19:44:15 <NobodyCam> lucasagomes: +
19:44:24 <devananda> lucasagomes: ++
19:44:35 <matty_dubs> I thought we talked about this at the last meeting, noting that they should be merged very soon if it's going to happen
19:44:41 <matty_dubs> Or maybe that was your email, devananda?
19:44:50 <matty_dubs> (I don't have a strong opinion either way, though)
19:45:09 <devananda> matty_dubs: yea, we did briefly, but folks are still proposing more
19:45:17 <devananda> matty_dubs: i'm hesitating on -2'ing until there's concensus
19:45:30 <matty_dubs> Ah, okay.
19:45:56 <devananda> example of small fix: https://review.openstack.org/#/c/74114/
19:46:07 <devananda> example of big code cleanup: https://review.openstack.org/#/c/73223/
19:46:16 <NobodyCam> devananda: yea !
19:46:39 <devananda> so, cores, please vote
19:46:44 <devananda> (lets see if i get the syntax right)
19:47:12 <max_lobur> 74114 is follow-up one
19:47:15 <max_lobur> :)
19:47:16 <devananda> #startvote Should we block any further large code cleanups until after Juno opens? (+1 == yes, -1 == no)
19:47:17 <openstack> Begin voting on: Should we block any further large code cleanups until after Juno opens? Valid vote options are , +1, yes, -1, no, .
19:47:18 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:47:21 <NobodyCam> #vote for small comestic clean up patchs only
19:47:22 <openstack> NobodyCam: for small comestic clean up patchs only is not a valid option. Valid options are , +1, yes, -1, no, .
19:47:51 <NobodyCam> #vote +1
19:47:53 <devananda> #vote +1
19:48:05 <max_lobur> #vote +1
19:48:13 <lucasagomes> #vote +1
19:48:28 <devananda> 4/6, two not present
19:48:29 <lucasagomes> but just to make clear, I don't see problem in people proposing new patches
19:48:30 <max_lobur> this means we still tend to merge all what we have till now right?
19:48:46 <lucasagomes> but they will hang in the queue for a while
19:48:55 <max_lobur> at least those ones that we already looked on
19:48:56 <NobodyCam> ya is -2 needed
19:48:58 <devananda> max_lobur: ah, just to be clear, i'll go -2 existing large code refactorings that aren't functional changes
19:48:58 <lucasagomes> new patches fixing costemic problems I mean... and larger ones
19:49:10 <max_lobur> devananda: +
19:49:18 <max_lobur> need to cleanup queue
19:49:20 <NobodyCam> just a novote coment should hold other cores form approving
19:49:27 <max_lobur> so that's appropriate way I think
19:49:36 <max_lobur> or we may ask to abandon change
19:49:51 <max_lobur> so It can be restored later
19:49:59 <devananda> ok. does that change anyone's vote? last chance :)
19:50:03 <max_lobur> that's the same basically :)
19:50:06 <devananda> right
19:50:18 <lucasagomes> heh I gotta think more about -2'ing it tho
19:50:26 <lucasagomes> I mean, I don't see the problem in leaving it on the queue
19:50:34 <lucasagomes> other people might want to review them
19:50:47 <devananda> lucasagomes: the folks who proposed it will continue to spend cycles maintaing it
19:50:58 <NobodyCam> leaving it also means someone new wont re perpsoe it
19:51:03 <max_lobur> if we won't going to merge them nearest time they will stale
19:51:04 <NobodyCam> in a new patch
19:51:10 <devananda> right
19:51:10 <max_lobur> and reviews will stale too
19:51:11 <lucasagomes> right hmm
19:51:22 <devananda> it blocks up the review queue and gives the impression it will be reviweed
19:51:35 <NobodyCam> we /deffered/ status
19:51:42 <max_lobur> let's someone who have time to review doing this on our critical patches :)
19:51:53 <lucasagomes> heh
19:51:56 <lucasagomes> yea makes sense
19:51:58 <lucasagomes> ok agreed
19:52:20 <devananda> alternative is we all go land them now, and start refactoring all the in-flight critical patches to work with the new cleanup state of things
19:52:23 <devananda> ok :)
19:52:25 <devananda> #endvote
19:52:26 <openstack> Voted on "Should we block any further large code cleanups until after Juno opens?" Results are
19:52:27 <openstack> +1 (4): max_lobur, NobodyCam, devananda, lucasagomes
19:52:37 <devananda> thanks guys
19:52:37 <NobodyCam> I will agree to -2 aslong as it comes with a good comemnt to the dev
19:52:43 <devananda> NobodyCam: aboslutely
19:52:46 <NobodyCam> :)
19:52:50 <lucasagomes> NobodyCam, +2
19:52:51 <lucasagomes> :)
19:53:00 <devananda> #action devananda to post to ML regarding large code cleanups prior to -2'ing them
19:53:02 <max_lobur> NobodyCam: fair
19:53:03 <max_lobur> +1
19:53:21 <devananda> ok, ~7 min left
19:53:24 <devananda> #topic Open Discussion
19:53:49 <k4n0> Any reviews on SeaMicro blueprints?
19:54:19 <NobodyCam> lucasagomes: are you going to be able to get the rebased nova driver patches up today or is it too late for you?
19:54:35 <devananda> k4n0: given that it's not critical to icehouse graduation, i wouldn't count on core reviewers having a lot of time for it until Juno opens
19:54:45 <lucasagomes> NobodyCam, I started it today, but I would finish tomorrow
19:54:52 <NobodyCam> :)
19:54:58 <k4n0> devananda: ok
19:54:58 <lucasagomes> NobodyCam, if you need it I can try to finish up
19:55:02 <max_lobur> folks, have you seen https://review.openstack.org/#/c/74063/ comments
19:55:03 <devananda> k4n0: that said, I'll continue to try to look at all teh 3rd party drivers from time to time and give feedback
19:55:14 <NobodyCam> ack : no its holiday here today
19:55:24 <devananda> quick note since I see someone added "Functional/Integration testing of vendor drivers (Tempest?)" to the agenda
19:55:24 <k4n0> devananda: yes, the feedback is more important, they can land whenever time permits
19:56:01 <lucasagomes> NobodyCam, right, tomorrow morning I finish it up :) (and it will be pretty early there in US so it's grand)
19:56:17 <lucasagomes> NobodyCam, thanks
19:56:17 <k4n0> I want to discuss some sort of driver model to extend the chassis object for vendor specific purpose. Any comments?
19:56:18 <devananda> 3rd party CI isn't needed for Icehouse. we'll want to discuss it in depth at the Summit, though
19:56:21 <NobodyCam> lucasagomes: Awesome TY :)
19:56:52 <devananda> k4n0: my guess is that you're looking for a way to drivers to do $thing without needing a node to act on
19:57:06 <devananda> k4n0: eg, discovery, or something
19:57:07 <k4n0> devananda: yes :)
19:57:29 <devananda> k4n0: i'm not sure chassis is the right place for that, but in general, yep, we'll need that. maybe propose something to the summit? :)
19:58:19 <k4n0> devananda: from a vendor's pov, chassis actions can be exposed from the chassis object, right?
19:58:45 <devananda> k4n0: from API perspectiev, yes. but there is also an API end point for drivers
19:59:04 <NobodyCam> - One Minute -
19:59:13 <NobodyCam> can we contine inchannel?
19:59:17 <max_lobur> +
19:59:23 <devananda> k4n0: so eg. discovery may make more sense as POST  /v1/drivers/seamicro/discover {'range': '10.0.0.0/24'}
19:59:29 <devananda> yep
19:59:41 <k4n0> ok ,lets discuss inchan
19:59:42 <NobodyCam> Great meeting Thank you all
19:59:45 <k4n0> thanks
19:59:49 <devananda> cheers, thanks everyone
19:59:50 <max_lobur> thanks Everyone!
19:59:53 <ifarkas> thanks!
19:59:56 <lucasagomes> thanks
19:59:58 <devananda> #endmeeting