19:00:15 <NobodyCam> #startmeeting Ironic
19:00:15 <NobodyCam> #chair devananda
19:00:16 <NobodyCam> Welcome everyone to the Ironic meeting.
19:00:16 <openstack> Meeting started Mon Mar 10 19:00:15 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:19 <openstack> The meeting name has been set to 'ironic'
19:00:20 <openstack> Current chairs: NobodyCam devananda
19:00:29 <NobodyCam> who's here for the Ironic meeting
19:00:33 <matty_dubs> \o
19:00:34 <jroll> \o
19:00:34 <JayF> o/
19:00:35 <max_lobur> o/
19:00:37 <devananda> o/
19:00:37 <linggao> me
19:00:38 <Shrews> o/
19:00:38 <dwalleck> howdy :)
19:00:40 <ifarkas> o/
19:00:45 <lucasagomes> me
19:00:46 <romcheg1> \o
19:00:56 <devananda> hi all!
19:00:59 <NobodyCam> welcome all
19:01:01 <NobodyCam> Of course the agenda can be found at:
19:01:01 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:01:09 <NobodyCam> #topic Greetings, roll-call and announcements
19:01:17 <romcheg1> I was missing you :)
19:01:19 <devananda> it was great to see so many of you last week -- and for the rest, I look forward to seeing you in Atlanta
19:01:21 <NobodyCam> was great to see everyone at the sprint
19:01:31 <NobodyCam> :)
19:01:54 <dwalleck> So I'm tagging along with the other Rackers
19:02:11 <NobodyCam> devananda: would you like to recap some if last week?
19:02:16 <devananda> hopefully we can keep the meeting somewaht short today - i suspect some of us are still recovering from travel
19:02:18 <NobodyCam> new deploy agent?
19:02:19 <devananda> NobodyCam: sure
19:02:30 <NobodyCam> and time change
19:02:41 <devananda> so three things happened last week that I want to mention
19:03:12 <devananda> feature freeze was tuesday, and ttx cut an I3 milestone of Ironic
19:03:50 <devananda> we're following the general releace cycle, which means no more major features should land in tree until Juno opens
19:04:09 <devananda> bug fixes, documentation, and integration work are all good things to work on
19:04:19 <devananda> there's plenty of that to go around :)
19:04:30 <NobodyCam> :)
19:04:42 <devananda> also
19:04:55 <devananda> we talked with the rackspace team a bunch about their driver and deply agent
19:04:59 <GheRivero> o/
19:05:18 <devananda> i sent an email to the list, so i won't recap much here
19:05:34 <devananda> besides to welcome them to the meeting and the project
19:05:52 <devananda> and say that i'm excited to have rackspace finally joining us :)
19:06:00 <jroll> :)
19:06:01 <devananda> lastly
19:06:19 <devananda> adam_g and Shrews made a lot of progress with agordeev's devstack patch
19:06:24 <devananda> and it seems to be quite functional now
19:06:36 <wanyen> Does Nova Ironic driver make to the icehouse?
19:06:42 <lucasagomes> nice!
19:06:49 <NobodyCam> awesome and welcome to the RS folks
19:06:53 <NobodyCam> I woud like to draw attention to the fact that we have pulled the ironic-nova driver into our tree. for those who have not seen it there yet
19:07:09 <NobodyCam> wanyen: ^^
19:07:10 <NobodyCam> no
19:07:20 <lucasagomes> wanyen, the Nova Ironic Driver is now being developed in the Ironic tree
19:07:32 <lucasagomes> wanyen, we are going to push it to nova again on J
19:07:43 <NobodyCam> yes!
19:08:04 <lucasagomes> #link https://review.openstack.org/#/c/78002/
19:08:15 <wanyen> oka,  Thanks!
19:08:15 <NobodyCam> ty lucasagomes :)
19:08:21 <devananda> NobodyCam: thanks for the reminder - and for those who want to know more, I mentioned that in my email t othe dev list as well
19:08:44 <ifarkas> devananda, the guide agordeev created is still relevant or needs to be updated: https://etherpad.openstack.org/p/IronicAndDevstackAgain ?
19:08:47 <devananda> anyone else have announcements / things to share from last week?
19:09:05 <dwalleck> And if anyone needs any help with testing of the Nova Ironic Driver, I'd be more than glad to pitch in <-- tester/CI person
19:09:05 <devananda> ifarkas: i believe taht etherpad is correct. last I saw, adam_g was updating it as he went
19:09:17 <ifarkas> devananda, ok, thanks
19:09:17 <NobodyCam> other then BIG thank you's to HP and YAHOO! for hosting
19:09:18 <devananda> dwalleck: yes! thanks! see that etherpad ^
19:09:28 <matty_dubs> We did set up https://etherpad.openstack.org/p/IronicDocumentationTasks to coordinate work on documentation if that's useful to others
19:09:35 <devananda> dwalleck: please chat with Shrews and adam_g in #openstack-ironic post meeting
19:10:02 <NobodyCam> #link https://etherpad.openstack.org/p/IronicDocumentationTasks
19:10:08 <Shrews> devananda, ifarkas: i question the correctness of that etherpad, atm
19:10:39 <devananda> Shrews: ack ... well, it's an etherpad after all ... i'm sure someone will update it ;)
19:10:48 <Shrews> mainly because 70348 is not referenced anymore for some reason
19:11:14 <devananda> ok, moving on then
19:11:17 <lucasagomes> #link https://review.openstack.org/#/c/70348/
19:11:24 <ifarkas> Shrews, devananda, right. the localrc file still checks out the gerrit branch for nova
19:11:38 <devananda> ifarkas: ah. that's a problem
19:12:01 <devananda> it also needs to set the virt_driver to a different value now taht the driver is in ironic's tree, not nova's
19:12:08 <devananda> let's circle back to that in a bit
19:12:16 <devananda> #topic what got postponed to Juno
19:12:37 <devananda> a few blueprints got bumped last week
19:12:54 * devananda should have the links handy, but doesn't
19:13:04 <devananda> windows / whole-disk image support
19:13:14 <devananda> ipmitool console via shellinaboxd
19:13:22 <devananda> HP iLO driver
19:13:25 <devananda> ceilometer integration
19:13:39 <devananda> </end>
19:13:59 <NobodyCam> devananda: topic question. if people what to continue to work ok blocked (-2'd) patches until J cycle opens can/should they push up new revs or hold off until J is open?
19:14:18 <NobodyCam> s/work ok/work on/
19:14:20 <devananda> NobodyCam: thanks for asking
19:14:35 <devananda> I encourage folks to continue working on features taht didn't make it in
19:14:41 <devananda> and pushing patches up if they want to
19:14:52 <romcheg1> -2 won't get overridden anyway
19:14:56 <devananda> I'll try to look now and then, if I see activity
19:15:00 <lucasagomes> +1
19:15:09 <NobodyCam> :)
19:15:16 <devananda> gerrit will carry the -2 forward onto new patch sets, and I'll remove that as soon as Juno development opens
19:15:33 <devananda> it is in no way a reflection on not wanting the contribution
19:15:42 <NobodyCam> devananda: thank you for the answer :)
19:15:43 <devananda> just a matter of time -- we didn't have enough
19:16:14 <devananda> it looks to me like the whole-disk-image support and ipmitool console support were pretty close
19:16:54 <devananda> so I'm hoping we can keep those alive and land as soon as juno opens
19:17:10 <devananda> any questions about postponed work?
19:17:20 <NobodyCam> when is J opened
19:17:40 <devananda> #link https://wiki.openstack.org/wiki/Icehouse_Release_Schedule
19:17:49 <NobodyCam> :)
19:18:05 <devananda> IMBW, but I believe Juno is opened as soon as RC1 is branched
19:18:13 <devananda> which would be the last week of March
19:18:45 <devananda> we then maintain the RC branch for a few weeks and back-port fixes if an only of necessary
19:18:58 <devananda> before the final reelease is cut ~ april 19th
19:19:29 <devananda> any more questions?
19:19:54 <devananda> #topic working towards RC
19:19:57 <devananda> #link https://launchpad.net/ironic/+milestone/icehouse-rc1
19:20:02 <devananda> very briefly
19:20:26 <devananda> if you find or see a bug taht you think is essential to fix *now*
19:20:42 <devananda> please bring it to the attention of a -core member
19:20:46 <devananda> and we'll target to RC
19:20:52 <devananda> that list is tracked at the link abovce
19:21:27 <devananda> it's also the reference taht the release team has
19:21:28 <NobodyCam> just fwiw: I'm looking a few issues on Bug #1289048
19:21:38 <devananda> and they won't release until everything targeted to RC is marked as fix-committed
19:22:02 <devananda> #topic what to expect in Juno
19:22:29 <devananda> another real quick point here -- besides the bumped BP's, what we do is largely up to all of you
19:22:36 <devananda> so please go propose sessions for the design summit :)
19:22:58 <NobodyCam> devananda: do we have a session on the new deploy agent stuff?
19:23:15 <jroll> NobodyCam: we haven't proposed any, afaik
19:23:16 <NobodyCam> would like to sink my teeth in to that :-p
19:23:18 <devananda> #link http://summit.openstack.org/
19:23:48 <jroll> yeah, we'll put one up this week
19:23:57 <NobodyCam> jroll: awesome :)
19:23:59 <lucasagomes> NobodyCam, :P yeah we def need a section for that
19:24:05 <lucasagomes> jroll, nice
19:24:28 <jroll> it looks like there's no ironic sessions at all right now?
19:24:47 <devananda> unless there are any process questions about the summit or session proposals, i'd like to open the floor for general discussion soon
19:24:59 <devananda> jroll: hmm... lemme check
19:25:15 <NobodyCam> open the gates~ :)
19:25:25 <devananda> jroll: yea, none proposed yet
19:25:30 <devananda> #topic open discussion
19:26:02 <lucasagomes> maybe the guys working on supporting disk image should propouse one, that would be an interesting one
19:26:13 <lucasagomes> or we can propose it ourselfs if needed
19:27:04 <NobodyCam> how summit session for Driver architecture for Chassis object ...
19:27:32 <NobodyCam> seems to me we don't have a good idea of what the chassis is currently doing / needed for
19:28:07 <NobodyCam> gah/ s/how summit/ how about a summit/
19:28:20 <ifarkas> devananda, regarding devstack, to what value does virt_driver need to be set in localrc?
19:28:37 <lucasagomes> ifarkas, http://paste.openstack.org/show/73053/
19:28:38 <devananda> jroll / JayF - by the summit, you guys will probably have the agent cleaned up a lot. I'd definitely encourage you to spend a few minutes presenting the work you've got and then let folks discuss their needs and see how it all fits together
19:28:50 <devananda> I also think we should have a session on CI
19:28:52 <lucasagomes> here's a nova conf file pointing to the nova ironic driver in the ironic tree
19:28:54 <devananda> both devstack and tripleo
19:29:11 <JayF> I was thinking from a focus perspective, we'd want to get the agent+driver to fully working prototype state by the summit.
19:29:23 <devananda> JayF: ++
19:29:26 <JayF> With a focus on having something working with ironic to demo at the summit
19:29:32 <NobodyCam> JayF: ++ :)
19:29:57 <jroll> agreed :)
19:30:22 <JayF> I think once we get the non-OS deps out and switch to testr, we'll be focusing on the features needed for finishing a prototype
19:30:47 <devananda> JayF: expect a lot of interest in collaboration on it
19:30:59 <adam_g> assuming the ironic+devstack patch gets finished up this week, i was planning on starting to put together an etherpad tracking tempest coverage of ironic.  what passes, whats busted, whats missing, etc.
19:31:18 <devananda> adam_g: that is very much needed
19:31:22 <NobodyCam> adam_g: that would great
19:31:49 <ifarkas> lucasagomes, thanks but I asked specifically regarding the localrc because devananda mentioned before that the virt_driver need to be set to something else
19:32:32 <lucasagomes> ifarkas, ah ack :) I think I missread that
19:32:34 <devananda> ifarkas: note that scheduler_host_manager and compute_driver both have a prefix of "ironic." now
19:32:37 <devananda> taht's the change
19:32:53 <devananda> those classes are now in ironic.nova.* instead of nova.*
19:32:57 <adam_g> ifarkas: i saw your comments on the devstack patch, i will be poking closer at it today. i updated it on friday to set drivers accordingly
19:33:40 <ifarkas> adam_g, devananda, cool, thanks
19:33:50 <jroll> devananda, NobodyCam: http://summit.openstack.org/cfp/details/26 :)
19:34:04 <NobodyCam> devananda: I'll prob be poking at https://review.openstack.org/#/c/72969 in the next day or so
19:34:17 <NobodyCam> Add Ironic bits to _undercloud
19:34:38 <devananda> NobodyCam: great
19:35:41 <devananda> I think it's time that I did a massive cleanup of our white board :)
19:35:53 <NobodyCam> lol
19:35:56 <devananda> #action devananda to clean up https://etherpad.openstack.org/p/IronicWhiteBoard
19:36:23 <NobodyCam> can we have a etherpad that lists all our etherpads
19:36:27 <NobodyCam> :-p
19:36:28 <devananda> hehe
19:36:57 <NobodyCam> I have 9 open etherpads
19:37:07 <devananda> https://wiki.openstack.org/wiki/Ironic#Etherpads
19:37:14 <NobodyCam> doh
19:37:34 <devananda> a metapad might be better
19:37:36 <max_lobur> heh
19:37:50 <devananda> we could move that to the top of the white board,a nd just link that one from the wiki and IRC channel
19:37:52 <NobodyCam> I'll add what I have thats not listed
19:38:19 <NobodyCam> this works for me
19:38:24 <lucasagomes> devananda, yeah that will be good
19:38:31 <NobodyCam> was just looking for a place I could point folks to
19:38:34 <devananda> k, will do after meeting
19:38:56 <devananda> I see someone added an item to the agenda to talk about IPMI and gathering metrics fro mother devices
19:39:09 <devananda> I'm not sure what that's about -- there's no link
19:39:37 <devananda> unless it's a reference to ceilometer work that was abandoned early in icehouse?
19:40:37 <NobodyCam> devananda: I assue its "oob" metrics
19:40:51 <NobodyCam> assume even
19:41:13 <NobodyCam> do we know who added that?
19:41:13 <devananda> lucasagomes: looks like you made the edit?
19:41:17 <lucasagomes> ah it was me
19:41:40 <lucasagomes> it's was more to start a brainstorm about whether ironic should collect metrics from other devices
19:41:45 <lucasagomes> and pass it to ceilometer
19:42:03 <devananda> define "other devices"
19:42:26 <lucasagomes> Haomeng was implementing it for nodes in ironic, I think we mentioned that talking to him at some point
19:42:49 <NobodyCam> lucasagomes: i think that might change our mission statment.
19:43:07 <lucasagomes> devananda, any other device that ironic might touch, e.g disk arrays
19:43:16 <lucasagomes> NobodyCam, yeah I see that
19:43:28 <wanyen> e.g., NICs
19:43:58 <devananda> lucasagomes: i dont see ironic doing configuration of non-compute resources (eg, SAN, switch, etc)
19:45:00 <lucasagomes> devananda, ack, but as talked ironic might touch these devices for e.g to update the os image on them
19:45:10 <devananda> I've talked with a few people about whether or not Ironic could provision them -- right
19:45:18 <lucasagomes> cinder manages the storage array, but when it comes to provision a new image to it
19:45:21 <devananda> but ironic's mission ends once the OS is installed
19:45:22 <lucasagomes> cinder talks to ironic which does it
19:45:29 <lucasagomes> and pass the control backs to cinder
19:45:33 <wanyen> Ironic can report status of those devices, e.g., link is up or down
19:46:24 <NobodyCam> wanyen: that might be a good topic for the summit, But see that type of reporting out side of Ironic's current scopr
19:46:26 <devananda> wanyen: i believe lucasagomes is referring to flashing firmware / updating the operating system on a SAN or Switch, not monitoring individual NICs -- which is, IMO, even further from Ironic's mission statement
19:46:57 <devananda> lucasagomes: here's the use case AIUI
19:47:04 <devananda> * user talks to cinder to provision storage
19:47:06 <wanyen> Iwas referring to ceilometer and Ironic integration
19:47:12 <devananda> * user talks to nova to request compute with that storage attached
19:47:19 <linggao> devananda, I have a bp passed to me by sjing. it is firmware update.
19:47:20 <devananda> * nova passes cinder vol info to ironic
19:47:33 <devananda> * ironic attaches remote storage to hardware
19:47:39 <linggao> Have you guys discussed it at the Hong Kong summit?
19:47:41 <devananda> * ironic provisions image on hardware
19:47:42 <NobodyCam> (hi linggao )
19:48:04 <devananda> lucasagomes: so in that ^ I don't see Ironic as ever having touched cinder or the SAN directly
19:48:37 <devananda> linggao: hi! we talked in HKG, but I think it was somewhat premature and no work has been done on firmware update
19:49:04 <lucasagomes> devananda, right, hmm yeah that makes sense
19:49:05 <devananda> linggao: we'll need support for that at some point within the utility agent that JayF and jroll are working on
19:49:36 <linggao> right sjing told me it depends on the utiliy ramdisk
19:49:38 <devananda> linggao: and some common modeling in the REST and driver APIs so that firmware update is possible across many drivers
19:49:42 <jroll> right
19:50:01 <jroll> linggao: our team will be working on that soon, possibly before atlanta
19:50:30 <jroll> linggao: do you have a link to the blueprint?
19:50:32 <devananda> also, for the folks working or interested in that utility ramdisk
19:50:35 <linggao> jroll, I saw utility-ramdisk bp is already in code-review status
19:50:37 <devananda> it's not tied to the ironic release cycle
19:50:44 <devananda> IOW, it's not under feature freeze :)
19:50:49 <jroll> ^
19:51:04 <jroll> linggao: it's in "code review" to become an openstack project
19:51:15 <devananda> jroll: as soon as you guys can finish the clean up, let's get it into gerrit so others can start collaborating with you guys
19:51:28 <jroll> linggao: we should have a demo and most basic features available by atlanta
19:51:44 <devananda> jroll: not that you need any encouragement on taht front ;)
19:51:44 <JayF> https://review.openstack.org/#/c/79088/ we have it -1'd right now pending getting tests working happily
19:51:44 <jroll> devananda: +1
19:51:46 <JayF> but once that is merged we'll be in openstack/gerrit
19:52:00 <NobodyCam> #link https://review.openstack.org/#/c/79088/
19:52:08 <devananda> jroll: did I say that I'd set up the LP stuff for it? or have you guys?
19:52:17 <linggao> jroll, that would be cool (demo)
19:52:33 <jroll> devananda: as for the agent driver, my plan is to put up a patch for ironic to upstream it when juno opens
19:52:39 <jroll> devananda: I'm not sure. JayF?
19:52:40 <NobodyCam> devananda: I recall hearing that
19:52:42 <JayF> devananda: I think you said we'd use the ironic project? Although I'm not opposed to having the agent have it's own.
19:53:02 <JayF> In fact it might make sense to keep it separated, especially if it's not going to be part of FF
19:53:11 <JayF> different review teams, etc
19:53:19 <jroll> +1
19:53:24 <NobodyCam> JayF: ++
19:53:26 <devananda> jroll: please put up a patch for the driver around the time that the agent repo is populated in gerrit
19:53:40 <jroll> devananda: ok, we can do that
19:53:43 <linggao> jroll, here is the bp https://blueprints.launchpad.net/ironic/+spec/firmware-update
19:53:45 <JayF> devananda: If that's the route we want to go, I'd ask either to point me at a document telling me how to setup LP for it, or just do it
19:53:48 <devananda> jroll: i'll promptly -2 it, but i'd still like to have a reference in gerrit :)
19:53:55 <jroll> devananda: yep :)
19:53:58 <devananda> thanks :)
19:54:25 <JayF> jroll: we'll be continuing work on the driver, probably in gh with upstreaming of the patches as they're written, while waiting for juno to open, right?
19:54:26 <devananda> #action devananda to check with infra re: separate LP thing for the agent, and set it up if needed
19:54:39 <jroll> JayF: yes
19:54:55 <linggao> jroll, are you saying your team will work on firmware update or I work on the update using the framework you team is working on?
19:55:04 <jroll> JayF: we'll just be continually updating the gerrit review for our driver until ironic team is ready to look at it
19:55:04 <NobodyCam> at the tone there is 5 minutes left... beep
19:55:08 <devananda> JayF: jroll: even one patch in gerrit with a link to GH would be enough to start -- just a reference point for now
19:55:27 <jroll> devananda: ok
19:55:40 <JayF> linggao: It's absolutely on the list of things we want to do. I don't know if that means you should do it now or if we'll get to it first. :)
19:55:52 <jroll> linggao: if you'd like to work on it, go ahead. If you don't work on it, we will :)
19:56:26 <NobodyCam> I can see the firmware update being tricky
19:56:40 <JayF> You're even welcome to submit a PR in via the github repo while we're waiting to get things fixed for it to merge over
19:56:45 <JayF> #link http://github.com/rackerlabs/teeth-agent
19:56:48 <NobodyCam> ie if the otherboard only have windows based flashing tools
19:57:15 <NobodyCam> s/otherboard/motherboard/
19:57:41 <JayF> NobodyCam: honestly that hadn't even occurred to me. That could be rough. It'll help that we're doing plugable backends for hardware, so we might implement a sensible one for linux for the prototype, but leave room for folks who need that to implement it
19:58:22 <NobodyCam> JayF: ya that makes sense to me
19:58:28 <linggao> right. I know how to do the firmware update for IBM hardware. Have to talk to folks on what is the general way to do it.
19:58:35 <devananda> JayF: also the driver API for firmware updates will need to support other vendor's drivers which may do updates OOB
19:59:04 <devananda> a summit session where folks sketch out how to do firmware udpates on different hardware might be good
19:59:15 <NobodyCam> devananda: ++
19:59:18 <devananda> start getting a picture of where the abstraction points are
19:59:21 <NobodyCam> less then one minute
19:59:22 <devananda> what a common API will look like
19:59:22 <devananda> etc
19:59:25 <linggao> devananda, +1
19:59:33 <lucasagomes> indeed
19:59:44 <lucasagomes> we gotta start looking at promoting some methods in the vendor interface to core
19:59:49 <devananda> lucasagomes: ++
19:59:58 <devananda> lucasagomes: want to toss an email to the list with some ideas on that?
20:00:11 <NobodyCam> lucasagomes: devananda thats a topic for summit track
20:00:12 <lucasagomes> devananda, yeah
20:00:20 <devananda> time's up :)
20:00:23 <devananda> thanks everyone! great meeting
20:00:27 <NobodyCam> thank you
20:00:28 <lucasagomes> I can send something to the list
20:00:33 <ifarkas> thanks
20:00:36 <devananda> #endmeeting