19:00:02 <NobodyCam> #startmeeting Ironic
19:00:02 <NobodyCam> #chair devananda
19:00:02 <NobodyCam> Welcome everyone to the Ironic meeting.
19:00:03 <openstack> Meeting started Mon Mar 24 19:00:02 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:07 <openstack> The meeting name has been set to 'ironic'
19:00:08 <openstack> Current chairs: NobodyCam devananda
19:00:09 <NobodyCam> Of course the agenda can be found at:
19:00:09 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:00:16 <NobodyCam> #topic Greetings, roll-call and announcements
19:00:16 <NobodyCam> Who's here for the Ironic Meeting?
19:00:19 <devananda> hi all!
19:00:20 <adam_g> o/
19:00:21 <JayF> o/
19:00:22 <agordeev2> o/
19:00:24 <jroll> \o
19:00:27 <Shrews> o/
19:00:30 <ifarkas> hello o/
19:00:32 <linggao> \o
19:00:37 <rloo> hi
19:00:37 <dtantsur> \o/
19:00:41 <NobodyCam> welcome all :)
19:00:42 <lucasagomes> hey
19:00:47 <lifeless> o/
19:01:10 <comstud> o/
19:01:11 <NobodyCam> hey lifeless glade to see you
19:01:23 <NobodyCam> and welcome everyone else
19:01:47 <romcheg> o/
19:01:55 <NobodyCam> announcements:
19:02:04 <GheRivero> o/
19:02:27 <mrda_away> o/
19:02:34 <NobodyCam> Ironic is in working in tripleO deploys... at least in testing ... not quite ready for production
19:02:51 <NobodyCam> but we're getting really close
19:02:59 <max_lobur> o/
19:03:14 <lifeless> NobodyCam: well, we can deploy from seed, but we can't deploy Ironic from tripleo
19:03:28 <lifeless> NobodyCam: due to https://bugs.launchpad.net/ironic/+bug/1295503
19:03:29 <uvirtbot> Launchpad bug 1295503 in ironic "ironic nova driver blocks nova-compute startup when ironic isn't available" [Medium,Incomplete]
19:03:32 <NobodyCam> lifeless: that is very true :)
19:03:50 <devananda> let's come back to tripleo integration bits in a bit
19:03:59 <adam_g> is there an etherpad tracking the tripleO integration and issues similar to the one for devstack?
19:04:15 <lucasagomes> yeah that would be nice
19:04:27 <NobodyCam> we'll come back to that ... there was
19:04:36 <devananda> I'd like to discuss the open bug list for icehouse RC1 which should be getting tagged by EOW // early next week
19:04:42 <devananda> #link https://launchpad.net/ironic/+milestone/icehouse-rc1
19:04:45 <NobodyCam> #topic Ironic RC1 milestone
19:05:56 <devananda> I think we're making good progress fixing bugs but reviews are a bit slow still
19:06:24 <NobodyCam> devananda: should we start up the review jams again
19:06:31 <lucasagomes> NobodyCam, yeah
19:06:35 <lucasagomes> also I was away last week
19:06:37 <devananda> I know several folks were gone last week
19:06:49 <comstud> devananda: I posted a partial fix for https://bugs.launchpad.net/ironic/+bug/1289048, which the bug doesn't seem to reflect
19:06:50 <uvirtbot> Launchpad bug 1289048 in ironic "nova virt driver performance issue" [High,Triaged]
19:06:58 <comstud> which merged
19:07:03 <jroll> I can put aside some time for reviews this week
19:07:04 <romcheg> yup, so I guess we need to clean up the queue
19:07:05 <comstud> The rest of it will require API changes, so
19:07:09 <comstud> I don't think that happens for rc1
19:07:12 <jroll> and would be up for a review jam
19:07:30 <devananda> comstud: right. would you mind updating the bug? it may be reasonable to un-target it at this point
19:07:34 <linggao> anyone is working on #1295874	default heartbeat_timeout too low, leads to random test failures?
19:07:48 <comstud> Yeah, I'll update it.. I can't untarget it, of course
19:07:54 <NobodyCam> devananda: should https://bugs.launchpad.net/ironic/+bug/1295503 be on the rc-1 list?
19:07:56 <uvirtbot> Launchpad bug 1295503 in ironic "ironic nova driver blocks nova-compute startup when ironic isn't available" [Medium,Incomplete]
19:08:03 * devananda untargets it
19:09:13 <devananda> NobodyCam: lifeless: AIUI, that is actually "ironic-nova driver blocks nova-compute when keystone is not configured"
19:09:23 <devananda> if ir-api service is offline, the retry code should handle it
19:09:36 <lifeless> devananda: at startup ?
19:10:06 <lifeless> I'll tweak the title, its definitely wrong
19:10:08 <devananda> lifeless: https://bugs.launchpad.net/ironic/+bug/1295870
19:10:10 <uvirtbot> Launchpad bug 1295870 in ironic "ironic.driver does not wrap all icli calls in _retry" [High,Triaged]
19:10:11 <rloo> https://bugs.launchpad.net/ironic/+bug/1285507 can be closed based on the comments in it.
19:10:12 <uvirtbot> Launchpad bug 1285507 in ironic "Improve Ironic Conductor threading & locks" [High,In progress]
19:10:27 <devananda> rloo: ah, right! thanks for pointing that out
19:10:38 <mrda> rloo: agree
19:11:31 <lifeless> devananda: so https://bugs.launchpad.net/ironic/+bug/1295870 is related, but we'd need an arbitrarily long timeout for startup operations.
19:11:32 <uvirtbot> Launchpad bug 1295870 in ironic "ironic.driver does not wrap all icli calls in _retry" [High,Triaged]
19:11:53 <lifeless> devananda: because unlike responses to RPCs, if an error escapes there, startup fails, and nova compute exits
19:12:24 <devananda> lifeless: yea. these are definitely separate-but-related issues
19:12:36 <lifeless> devananda: although it might be ok as long as it stays up long enough for upstart to believe it started
19:12:42 <lifeless> then we can finish the bootstrap
19:12:50 <devananda> lifeless: ack. let's revisit the tripleo startup sequence problem in a bit :)
19:12:53 <lifeless> and upstart will restart it when it does fail
19:12:58 <lifeless> sorry, dog with bone
19:13:03 <lifeless> also C is up now I need to go get her
19:13:13 <NobodyCam> :)
19:13:17 <rloo> dumb question: https://bugs.launchpad.net/ironic/+bug/1291420 doesn't the fix have to go in nova?
19:13:19 <uvirtbot> Launchpad bug 1291420 in ironic "Scheduler not doing exact matching when picking an Ironic Node" [High,Triaged]
19:13:32 <JayF> re: icehouse-rc1 bugs --> https://bugs.launchpad.net/ironic/+bug/1295874 is on the rc-1 list. Is the desired fix just to bump the default heartbeat_timeout or something more involved? If it's a timeout bump I'll gladly take care of it, if it's something more involved the bug might need more details.
19:13:34 <uvirtbot> Launchpad bug 1295874 in ironic "default heartbeat_timeout too low, leads to random test failures" [High,Triaged]
19:13:59 <linggao> davanada, for #1295874 I can take a look at it if it is not taken.
19:14:01 <devananda> JayF: I think that's the only solution we can do now
19:14:10 <NobodyCam> rloo: nova driver and host manager and in our tree atm
19:14:11 <JayF> devananda: I can take care of that today then.
19:14:42 <rloo> NobodyCam: ah, so we'd add the filter in our tree too. thx.
19:14:51 <devananda> linggao: JayF: doesn't matter to me which of you take it :)
19:14:55 <Shrews> devananda: 1295870 isn't targeted. should it be?
19:15:30 <devananda> Shrews: it'd be great to have that fixed, yes
19:15:38 <devananda> just not sure how much work that is. might be a lot
19:15:42 <linggao> ou, JayF I did not see your message.
19:15:57 <linggao> JayF it is yours then.
19:15:59 <JayF> linggao: it's OK, we were both thinking about the same thing :)
19:16:22 <JayF> linggao: ty, was hoping to get a low-hanging-bug for my first direct ironic contribution, and that fits the bill. I'll ping you when it's done for a review if you want.
19:16:42 <linggao> JayF, sure. :)
19:16:44 * devananda looks through untriaged bugs
19:17:10 <NobodyCam> https://bugs.launchpad.net/ironic/+bug/1285806 has a review that needs a look over
19:17:12 <uvirtbot> Launchpad bug 1285806 in ironic "Ironic will poke the node continuously, if it fails to change power state" [Medium,In progress]
19:17:13 <devananda> https://bugs.launchpad.net/ironic/+bug/1280267
19:17:14 <uvirtbot> Launchpad bug 1280267 in ironic "pxelinux config files: absolute paths and symlinks" [Undecided,New]
19:17:34 * NobodyCam looks
19:17:35 <devananda> https://bugs.launchpad.net/ironic/+bug/1292733
19:17:38 <uvirtbot> Launchpad bug 1292733 in ironic "unplugging of instance VIFs fails if no VIFs associated with port" [Undecided,New]
19:17:55 <adam_g> devananda, er, thats invalid
19:17:56 <adam_g> let me update
19:18:01 <devananda> thanks
19:18:39 <NobodyCam> devananda: https://bugs.launchpad.net/ironic/+bug/1280267 should have a map file
19:18:40 <uvirtbot> Launchpad bug 1280267 in ironic "pxelinux config files: absolute paths and symlinks" [Undecided,New]
19:19:25 <adam_g> yeah--thats just deployment detail handled in tripleO / devstack / etc
19:19:33 <devananda> NobodyCam: does that need to be fixed for RC ?
19:19:38 <NobodyCam> https://github.com/openstack/tripleo-image-elements/blob/master/elements/ironic-conductor/install.d/68-ironic-tftp-support#L38-L39
19:19:53 <NobodyCam> ok I added it to the dib element
19:20:15 <NobodyCam> so devstack prob needs to create
19:20:23 <adam_g> NobodyCam, we adjusted to match what tripleO was doing
19:21:05 <adam_g> the deploy-ironic element  explicitly ffetches its token- file from /tftpboot/token-$foo so whoever sets up the tftpd needs to take that into account
19:21:12 <NobodyCam> adam_g: ya so you'll have a map file if you build with DIB
19:21:31 <adam_g> NobodyCam, yup, we just laid down a similar map with devstack
19:22:11 <adam_g> tho we were hitting problems fetching the token file /w tftpd, not the kernel or ramdisk, so i'm not sure about that bug
19:22:28 <NobodyCam> so is this 1280267 a valid bug?
19:22:59 <NobodyCam> ya maybe some  more testing needed
19:23:19 <adam_g> yeah
19:23:27 <adam_g> we can discuss later
19:23:42 <NobodyCam> devananda: I would not tag that for RC just yet
19:23:47 <devananda> k, untagging
19:24:09 <devananda> or not taggign :)
19:24:14 <NobodyCam> :)
19:24:16 <devananda> also sounds like you guys aren't sure it's even a bug
19:24:22 <NobodyCam> ya
19:24:32 <NobodyCam> thats almost tftp config
19:24:43 <devananda> adam_g: can you update // mark incomplete ?
19:24:53 <adam_g> devananda, yeah
19:24:58 <devananda> ty
19:25:00 <NobodyCam> :)
19:25:06 <devananda> so we've still got a decent list of bugs to fix
19:25:25 <devananda> let's plan on meeting 8am PST a couple days this week
19:25:32 <devananda> to plough through them
19:25:33 <NobodyCam> when is the new review jam?
19:25:46 <devananda> ideally, i'd like https://launchpad.net/ironic/+milestone/icehouse-rc1 all green by friday
19:26:01 <NobodyCam> :) I will afk tomorrow from 8:15 pst to about 10 ish
19:26:02 <devananda> *friday morning GMT
19:26:23 <devananda> lucasagomes, romcheg1 - can you guys make 1500 GMT tmw?
19:26:39 <romcheg1> devananda: I think I can
19:26:56 <jroll> devananda: would non-cores be helpful at these jams?
19:27:00 <devananda> jroll: yes
19:27:01 <lucasagomes> yeah I think it's fine for me as well
19:27:12 <lucasagomes> jroll, definitely
19:27:14 <jroll> devananda: cool, I'll do my best to make it
19:27:26 <devananda> jroll: we need a minimum of cores present, other folks are very helpful too, as long as we can all stay focused on landing code :)
19:27:37 <jroll> meaning I may be closer to 8:15 PST for some of them :)
19:27:42 <jroll> sure :)
19:27:46 <lifeless> devananda: I can reproduce the 'nvoa delete' does nothing issue btw
19:28:03 <lifeless> devananda: I haven't captured any traces yes (the default logging level appears fairly useless)
19:28:04 <devananda> jroll: start times have not been exact in the past ;)
19:28:09 <jroll> heh
19:28:21 <devananda> lifeless: :(
19:28:21 <NobodyCam> I will have to leave the jam at 8:15
19:28:22 <devananda> lifeless: bug # ?
19:28:34 <devananda> NobodyCam: we'll probably have one wednesday morning too :)
19:28:46 <lifeless> devananda: I'll file one
19:28:56 <NobodyCam> :) that I can make :)
19:29:02 <devananda> lifeless: thanks much
19:29:15 <NobodyCam> should we bump the topic to the next one?
19:29:16 <devananda> ok - let's move on
19:29:18 <devananda> heh
19:29:18 <devananda> yes
19:29:22 <NobodyCam> #topic Ongoing integration & testing work
19:30:23 <adam_g> oh, so we've got an initial non-voting devstack gate check running, which gets us as far as failing tests on half the runs (issues when running on rackspace cloud still being worked out)
19:30:47 <NobodyCam> again TripleO integration going well, Lifeless jumped in later last week and got things on track for tripleO
19:31:29 <NobodyCam> anyone have anything on devstack?
19:31:34 <devananda> adam_g: the implication from your statement is that it succeeds on half the runs
19:31:35 <adam_g> i've started brainstorming and putting together some functional testing for tempest - https://etherpad.openstack.org/p/IronicCI, but we'll likely be blocked on some broader tempest discussions that likely wont happen till post-release / summit
19:31:49 <devananda> adam_g: if that's the case, we can ask infra to target it to just the working cloud
19:31:51 <NobodyCam> dtantsur: you hit a firewall issue this morning with fedora?
19:32:03 <dtantsur> NobodyCam, yes, and a lot more :)
19:32:12 <dtantsur> firewall issue was with port udp:69
19:32:19 <devananda> adam_g: that is, if it looks like the issue with xen will be impractical to solve
19:32:53 <adam_g> devananda, yeah--i think the xen issue can probably be worked around, another patch up for review now to help out with that. will ping infra about it later
19:32:55 <NobodyCam> dtantsur: was that from a fresh install?
19:33:02 <dtantsur> I'm still keeping updating https://etherpad.openstack.org/p/jjWcLDThTK; will work on patch for firewall setting
19:33:03 <devananda> adam_g: ah, graet
19:33:18 <NobodyCam> dtantsur: awesome Thank You :)
19:33:25 <dtantsur> NobodyCam, yes. I'm constantly reverting my devstack to clear VM snapshot, the last time was today
19:33:39 <devananda> dtantsur: i know that fedora/RH support is important to some folks, but again, I want to point out that IMO, it shouldn't be a priority for us right now
19:33:45 <adam_g> what is our CI roadmap for the rest of the cycle? is it a top priority still?  i'm not sure what we can accomplish right now other than the non-voting check /w failing tempest tests
19:33:57 <devananda> dtantsur: simply because devstack isn't yet functional(ly tested) on those platforms anyway
19:34:11 <devananda> dtantsur: so there's no way to ensure that, once you implement it, it doesn't get silently broken upstream again
19:34:33 <NobodyCam> devananda: is 12.04 (same as gate jobs) our supported Distro?
19:34:38 <dtantsur> devananda, I understand, but I hope we're uncovering some braoder issue (e.g. with firewall)
19:34:39 <ifarkas> devananda, same applies to centos?
19:34:46 <dtantsur> * broader
19:34:55 <devananda> adam_g: goal is to get asymmetric tests running ASAP in general, not tied to the Icehouse release cycle
19:35:03 <devananda> ifarkas: yes
19:35:22 <devananda> dtantsur: it sounds like you are -- and I'm sure the folks wokring on broader support for devstack appreciate it :)
19:35:33 <jroll> adam_g: has dwalleck been chatting with y'all about testing at all?
19:36:05 <devananda> dtantsur: as do I, fwiw, just not as much of a priority for me until there's upstream support for testing it
19:36:06 <adam_g> jroll, yup, he's been working on getting a testable environment up himself
19:36:32 <jroll> adam_g: awesome, he should be a big help in the near future
19:36:36 <devananda> NobodyCam: 12.04 is what openstack CI tests on today. therefor it's what counts for devstack testing
19:37:09 <NobodyCam> devananda: ack :)
19:37:09 <devananda> for those that might not have it, the context for why devstack/tempest is important even though we're not graduating in Icehouse
19:37:15 <adam_g> devananda, right--just seems such testing taking place in tempest is not going to be an ASAP thing
19:37:27 <devananda> is that the community will need us to have sufficient integration tests
19:37:31 <devananda> in the gate
19:37:37 <adam_g> there are some broader issues that need resolving in tempest WRT non-default compute drivers
19:37:37 <devananda> for "long enough" to build confidence
19:37:39 <dtantsur> devananda, my current purpose is to collect and triage as many issues with Fedora as it is possible :) not trying to shift overall focus at any rate
19:37:58 <devananda> adam_g: indeed there are ... do you know if there's a session at the summit yet proposed for that?
19:38:19 <devananda> adam_g: i spoke with clarkb ~1mo ago, and I think he might have been planning to propose something?
19:38:22 <adam_g> in the shorter term (pre-summit), i propose we lean on old devstack exercises to at least give ironic developers confidence, with tempest testing following later
19:38:30 <devananda> adam_g: ++
19:38:42 <devananda> adam_g: and it sounds like you can spin that up pretty easily
19:38:46 <devananda> sdague: any objection to ^ ?
19:38:50 <adam_g> devananda, i need to touch base with #openstack-qa and find that out. i wont be at the summit to drive that, but i know its a broader topic, esp. WRT defcore
19:39:00 <clarkb> devananda: I think sdague is driving it
19:39:32 <sdague> devananda: what am I objecting to? :)
19:39:34 <lifeless> adam_g: hmmm, defcore is a future issue for Ironic, as its not yet integrasted
19:39:53 <devananda> sdague: :)
19:40:09 <adam_g> sdague, we're just discussing where/how testing of a driver like ironic fits in tempest, in terms of defining and testing supported features
19:40:11 <sdague> so, honestly, I wouldn't really bother with exercises, if you can get a simple scenario test instead
19:40:22 <devananda> sdague: us leveraging devstack exercises in the short-term, while issues around tempest && nova-driver-differences get sorted out
19:40:22 <sdague> it's fine to punt on API right now
19:40:40 <sdague> but we basically don't run exercises many places, so they are fragile
19:40:48 <sdague> and prone to breaking
19:41:12 <sdague> just have a custom ironic job that skips the API tests for now
19:41:27 <adam_g> okay ill take an action for that ^
19:41:43 <adam_g> i have a WIP scenario test, just need a good way to run it without the API/scenarios that i know will break
19:41:45 <adam_g> *fail
19:41:47 <devananda> #action adam_g to implement a simple tempest scenario test, skipping the API part for now
19:41:50 <NobodyCam> adam_g: action ?
19:41:55 <NobodyCam> lol devananda beet me to it
19:42:25 <sdague> I also wonder if eventually we really want to hit ironic through nova api, or just hit the ironic api directly
19:42:34 <devananda> sdague: need to hit it through nova
19:42:37 <devananda> two reasons
19:42:53 <devananda> we need to test the nova.virt.ironic driver -- taht's an explicit requirement of our graduation
19:43:34 <devananda> and we'd essentially have to rewrite all taht driver code
19:43:37 <NobodyCam> oh that reminds me...
19:43:38 <devananda> if we wanted to test without nova
19:43:40 <devananda> which is silly
19:43:45 <sdague> yeh, fair
19:44:09 <devananda> we just can't implement the full set of libvirt functionality
19:44:32 <devananda> hence the need to discuss what driver functionality can/should be tested && how to designate that in the test suite
19:44:48 <devananda> sdague: we'll also probably run into timeout issues
19:44:56 <devananda> eg, PXE bootign nested virt is SLOOOWWWW :(
19:45:07 <adam_g> devananda, the timeouts are all configurable, should be okay there
19:45:09 <sdague> so the way to handle that is get the logic in lib/tempest to set the right enabled things based on virt driver
19:45:23 <devananda> ahh
19:45:51 <devananda> I'm sure we'll talk moer at the summit about all this
19:46:00 <devananda> adam_g: I'm sad you won't make it
19:46:14 <NobodyCam> 15 minutes left.. can we bump topic?
19:46:15 <adam_g> devananda, me too. first time since diablo
19:46:32 <devananda> yep. let's move on. severa things in the open discussion list
19:46:35 <JayF> We still have agent architechture, and 15m will not be a lot of time for that.
19:46:40 <devananda> #topic Open Discussion
19:46:42 <lifeless> adam_g: can't make it ?
19:46:58 <devananda> JayF: the full depth of agent arch will not fit into a 1hr meeting anyway :p
19:46:59 <NobodyCam> open floor...
19:47:09 <adam_g> lifeless, unfortunately, no
19:47:12 <lifeless> tripleo bootstrapping
19:47:18 <lifeless> I'd like to get this unblocked
19:47:27 <lifeless> since an ironic seed with nova-bm undercloud doesn't make a lot of sense
19:47:39 <devananda> but I'd really like to bring this up and find out who's got what interests: ironic as a CMDB // the agent running without ironic at all.
19:47:46 <jroll> ^
19:47:55 <NobodyCam> I like to throw out there that we need to figure out how to run the nova driver tests... they are already out of date
19:48:16 <jroll> devananda: that's coming from vkozhukalov afaik
19:48:22 <lucasagomes> NobodyCam, yeah :/ I don't think we want to enable that in our tree tho
19:48:22 <JayF> I have an explicit interest in making sure the scope of the agent remains Ironic, as to avoid creating every agent possible/an agent framework rather than an Ironic Python Agent.
19:48:25 <devananda> lifeless: I agree. but IIRC, the initial plan was to get ironic into undercloud and then figure out how to get it into seed. a lot may have changed tho
19:48:31 <lucasagomes> due the nova dependencies that would need to be installed anda ll
19:48:33 <devananda> lifeless: so i'm ++ if there's a way to get it landed in both at once
19:48:54 <vkozhukalov> cmdb is just a use case, nothing more, it is not critical
19:49:06 <NobodyCam> lucasagomes: we need something I, have landed patches that I know broke the current tests
19:49:07 <agordeev2> jroll: devananda: i'm also interested in new python agent
19:49:13 <devananda> JayF: i have a very strong interest -- and, practically speaking, a requirement -- to keep IPA <-> ir-cond bindigns very tight
19:49:14 <lifeless> devananda: so, seed works and undercloud fails, today, with my patchsets to incubator/images/templates.
19:49:17 <jroll> agordeev2: I know :)
19:49:25 <jroll> devananda: +1
19:49:29 <lifeless> devananda: the only reason undercloud fails is the bug I pointed you at about nova-compute startup.
19:49:35 <jroll> vkozhukalov: are you ok with a non-pluggable heartbeat, then?
19:49:45 <JayF> As a first note; the agent has been fully integrated into Openstack now.
19:49:48 <JayF> #link http://git.openstack.org/cgit/openstack/ironic-python-agent/
19:50:05 <devananda> lucasagomes, NobodyCam - I think we can enable the noav.virt.ironic unit tets in our tree IFF we somehow clone the nova repo and make some symlinks
19:50:06 <agordeev2> JayF: great!
19:50:07 <lucasagomes> NobodyCam, yeah... maybe updating the nova review with the new code and fixing the bugs?
19:50:18 <devananda> lucasagomes: it's not pretty. perhaps someone with more unit test knowledge than I has a better way
19:50:25 <JayF> Which means if you want to contribute, please follow standard workflow, bugtracker/blueprints are shared with Ironic.
19:50:38 <devananda> JayF: woot woot
19:50:53 <lucasagomes> devananda, yeah
19:51:00 <lucasagomes> worth trying :)
19:51:05 <devananda> lifeless: right. so there's the related but wont fix it bug. But really what I see as the issue is
19:51:11 <JayF> The team here will continue to have a laser-focus to get a working prototype by the summit. Do one thing before we try to do all the things :)
19:51:16 <lucasagomes> JayF, good stuff
19:51:19 <NobodyCam> clarkb: you happen to know know we could test a nova driver thats in the ironic repo?
19:51:29 <devananda> lifeless: you're starting n-cpu + nova.virt.ironic before creating the requried accounts in keystone
19:51:46 <vkozhukalov> jroll: i prefer everything in agent  implemented in a pluggable manner
19:51:49 <devananda> lifeless: so even if ir-api/ir-cond were running, it wouldn't matter
19:51:52 <lifeless> devananda: right, which we do for every other service, and only nova-compute w/Ironic driver has an issue
19:52:21 <jroll> vkozhukalov: heartbeat will always go to ironic. I see no reason to put in the effort to make this pluggable.
19:52:30 <devananda> lifeless: interesting. nova expects the hypervisor to provide some info during init
19:52:43 <jroll> vkozhukalov: we are not building an agent framework, we are building an agent specifically for ironic
19:52:59 <devananda> lifeless: there are several code paths later on in n-cpu's run that aren't goign to be exercized if those things are not initialized
19:53:14 <lifeless> devananda: so I'm not suggesting that we don't run them, just defer it
19:53:24 <lifeless> devananda: rather than failing so fast upstart detects it
19:53:29 <devananda> lifeless: cause n-cpu to block until it becomes available?
19:53:36 <lifeless> devananda: for instance yes
19:53:44 <lifeless> just poll every 5 seconds say
19:53:56 <devananda> lifeless: so taht will render a huge back-log if any other nova service attempts to send RPC messages to n-cpu
19:53:58 <lifeless> cluster init will proceed asynchronously
19:54:21 <lifeless> devananda: yes, so you'd want to log a WARNING
19:54:41 <lifeless> 'Cannot connect to Ironic <...>' or something
19:54:59 <devananda> vkozhukalov: ironic agent should not be designed in a way that does not assume it will talk to ironic
19:55:06 <NobodyCam> five (5) minute WARNING
19:55:06 <devananda> vkozhukalov: which seems to be waht you are proposing
19:55:19 <adam_g> doesn't nova currently do the same /w DB and MQ connections at startup?
19:55:30 <lifeless> adam_g: not meaningfully
19:56:33 <vkozhukalov> jroll: devananda: ok, let's start from tight version, not pluggable
19:56:49 <devananda> another POV on this issue is that, from nova's perspective, the configured hypervisor is unavailable
19:57:00 <devananda> thus nova-compute can't perform its job
19:57:21 <lucasagomes> so the etherpad u guys are using to track the agent decisions is the https://etherpad.openstack.org/p/282Ocf7oXR?
19:57:32 <lucasagomes> https://etherpad.openstack.org/p/282Ocf7oXR
19:57:53 <jroll> lucasagomes: discussion started here: https://etherpad.openstack.org/p/IronicPythonAgent
19:58:04 <NobodyCam> #link https://etherpad.openstack.org/p/282Ocf7oXR
19:58:08 <JayF> An etherpad doesn't seem to be an awesome interface for the discussion to happen and decisions be reached though, honestly
19:58:10 <lucasagomes> ack cheers jroll
19:58:12 <jroll> the etherpad you linked is something I made as a draft of the new wiki page
19:58:15 <devananda> time's almost up -- lifeless, let's continue in a bit. I want to solve this, just not sure how
19:58:18 <lifeless> devananda: I don't expect n-c to perform its job
19:58:20 <NobodyCam> #link https://etherpad.openstack.org/p/IronicPythonAgent
19:58:24 <lifeless> devananda: just to not bail and exit
19:58:30 <jroll> and is my attempt at a cleaned up version of the named etherpad
19:58:39 <devananda> jroll: vkozhukalov: who added all the mentions of a CMDB to https://etherpad.openstack.org/p/IronicPythonAgent ?
19:58:45 <jroll> not I
19:58:59 <JayF> devananda: I believe those were there in the initial etherpad, which was put together by vkozhukalov iirc
19:59:04 <jroll> I believe that was vkozhukalov but not 100% sure
19:59:04 <NobodyCam> *BEEP* One minute *BEEP*
19:59:09 <lucasagomes> JayF, heh indeed, but it's good to have some documentation somewhere
19:59:09 <vkozhukalov> devananda: i added
19:59:16 <NobodyCam> can we continue in channel?
19:59:19 <jroll> ^
19:59:24 <JayF> I think we should take jroll's proposed wiki page, make it the wiki page, and put arch discussions in there/in a blueprint
19:59:25 <devananda> vkozhukalov: ack. let's talk :)
19:59:46 <devananda> thanks everyone! let's continue in channel - we've got a few good discussions going now
19:59:47 <JayF> The etherpad is not a well organized or well attributed way to figure out what is good
19:59:54 <NobodyCam> thank you all for a great meeting
20:00:04 <ifarkas> thanks
20:00:05 <devananda> #endmeeting