19:02:11 <devananda> #startmeeting ironic
19:02:11 <lucasagomes> me (half afk)
19:02:12 <openstack> Meeting started Mon Jun 30 19:02:11 2014 UTC and is due to finish in 60 minutes.  The chair is devananda. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:13 <JayF> o/
19:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:15 <openstack> The meeting name has been set to 'ironic'
19:02:18 <aweeks> \o
19:02:19 <devananda> #chair NobodyCam
19:02:19 <openstack> Current chairs: NobodyCam devananda
19:02:34 <devananda> Hi all! As usual, the agenda can be found here:
19:02:36 <devananda> #link https://wiki.openstack.org/wiki/Meetings/Ironic
19:02:46 <devananda> #topic announcements
19:03:11 <devananda> I hope at this point everyone knows about the mid cycle in Portland (Beaverton)
19:03:22 <devananda> and has seen my email(s) to the list, signed up on EventBrite if you're coming, and so on
19:03:58 <NobodyCam> note there is a nova and ironic signup! <- just fyi
19:04:09 <linggao> \o
19:04:11 * romcheg sets a reminder to ask for invitation
19:04:18 <devananda> right - there are two events (nova and ironic) whic hare co-located but separate events
19:04:26 <devananda> please sign up for the one that you'll be primarily attending
19:04:35 <devananda> no need to sign up for both
19:04:51 <devananda> mikal and I are coordinating with the site regarding headcount
19:05:15 <devananda> in other news, the ironic driver spec for Nova was approved last week
19:05:17 <devananda> #link https://github.com/openstack/nova-specs/blob/master/specs/juno/add-ironic-driver.rst
19:05:24 <adam_g`> \o/
19:05:27 <devananda> so I have begun proposing our driver code to Nova
19:05:28 <NobodyCam> Awesome
19:05:28 <mrda> \o/
19:05:29 <JoshNang> woo!
19:05:42 <devananda> which means -- please do not make any changes to it unless absolutely necessary (or you're working with me)
19:05:57 <lucasagomes> o/
19:06:09 <adam_g`> devananda, review # for the nova merge?
19:06:13 <devananda> #notice please do not propose or approve changes to nova code in the ironic tree, unless coordinating with devananda
19:06:34 <romcheg> \o/
19:06:43 <comstud> yay
19:06:43 <devananda> #link https://review.openstack.org/#/c/103164/
19:06:50 <adam_g`> devananda, FYI https://review.openstack.org/103227 is a driver patch that fixes a pretty critical issue with rebuild, ill ping you about it later
19:06:51 <devananda> adam_g`: that's the starting point
19:06:53 <devananda> there are 3 patches so far
19:06:59 <devananda> adam_g`: ack, thanks
19:07:07 <mrda> devananda: just FYI I'm working on caching auth credentials, will catch you after the meeting about it.
19:07:19 <devananda> mrda: awesome.
19:07:28 <wanyen> Deva, UEFI boot needs changes in Nova virt driver
19:07:28 <devananda> there's also a patch from lucasagomes to add doc strings and fix a few minor issues
19:08:11 <devananda> wanyen: ack. let's circle back to that in a minute. I will also want to talk about spec reviews
19:08:51 <devananda> any questions regarding the mid cycle or the nova driver, before we move on to release cycle progress?
19:09:31 <devananda> ok
19:09:41 <devananda> #topic release cycle status
19:09:52 <devananda> so, we're about half way through Juno at this point
19:09:56 <devananda> (omg, right?!)
19:10:05 <NobodyCam> :-p
19:10:30 * romcheg feels like a student just before their exams
19:10:33 <devananda> last friday, we had a discussion about our spec review list, which is quite long
19:10:40 <devananda> and about the goals we set out at the summit
19:11:00 <devananda> and I said I would follow up with an email -- I've got it drafted
19:11:12 <devananda> but want to give folks a chance to review before I send it
19:11:31 <devananda> there are two points to it
19:11:44 <devananda> first - the list of priorities we had from the summit -- I've cleaned it up and added color
19:11:47 <devananda> #link https://docs.google.com/spreadsheets/d/1Hxyfy60hN_Fit0b-plsPzK6yW3ePQC5IfwuzJwltlbo
19:12:26 <devananda> second - I've adapted Nova's timeline to fit our team a bit, and drafted it here
19:12:30 <devananda> #link https://etherpad.openstack.org/p/3sxKH2po1o
19:12:42 <devananda> and want to invite feedback on that timeline before we commit to it
19:13:15 <comstud> my 'clean up rpc object code' is probably more yellow than green
19:13:23 <devananda> comstud: ack :(
19:13:35 <comstud> i mean, it's true..a lot of progress has been made, but there's a lot more to do I think
19:13:50 <matty_dubs> devananda: Are you gone for 2 weeks, or just two Thursdays?
19:13:54 <comstud> I want to say it's less than 50% done... but I'll get on it here
19:13:56 <comstud> :-/
19:14:04 <devananda> these are related because I'm suggesting that we focus *this week* on landing specs for everything not crossed off that spreadsheet
19:14:09 <comstud> Need to finish up a couple things with Node and then do Port
19:14:45 <devananda> matty_dubs: I'm gone for two weeks
19:14:47 <lucasagomes> comstud, probably chassis and port might be mostly copy&paste from nodes?
19:14:56 <comstud> well
19:15:01 <comstud> it's not really copy/paste work
19:15:19 <comstud> but it's also not very difficult
19:15:22 <devananda> matty_dubs: unless you fly to Nevada, I'll be unreachable from about 8/19 until 9/2
19:15:27 <comstud> nor will it take much time
19:15:41 <lucasagomes> I see, ack
19:15:55 <comstud> technically there's a bug associated with this, I think
19:15:55 <rloo> devananda: for the timeline, what are the numbers in parentheses?
19:15:59 <comstud> vs a spec
19:16:01 <comstud> :)
19:16:07 <devananda> rloo: weeks until feature freeze
19:16:29 <devananda> comstud: so the spreasheet is just goals - some have specs or bugs associated
19:16:46 <matty_dubs> What is the prognosis for Juno graduation looking like?
19:16:55 <rloo> devananda: thx.
19:17:07 <devananda> matty_dubs: that's largely pinned on the nova driver at this point
19:17:36 <devananda> matty_dubs: we're ahead of the curve for nearly everythign that the TC considers for graduation, though we do need to work on horizon and ceilometer integration
19:17:42 <matty_dubs> If that is merged, do we think the other requirements (I see four yellows) are likely to go through too?
19:17:46 <matty_dubs> Ah, that's good news
19:17:53 <JayF> devananda: wasn't there a determination at the summit that we did not need any ceilometer integration?
19:18:14 <devananda> JayF: the determiniation was taht Ironic needs to support emitting events in a pluggable way
19:18:22 <mrda> So I think horizon could be difficult, since the propsed solution uses Tuskar, and that's not out of incubation yet either.
19:18:24 <devananda> JayF: which fits with the TC req's around projects
19:18:31 <devananda> it wasn't decided whether ceilometer wants (all or some or none) of those
19:18:56 <JayF> devananda: so would aweeks' statsd integration spec need to instead work with whatever pluggable method will be implemented for ceilometer?
19:19:03 <devananda> mrda: i need to follow up with jcoufal on that. I've communicated our req that it be usable without tuskar to him
19:19:13 <mrda> ok
19:19:26 <devananda> JayF: instead of requiring statsd, itshould be pluggable so that it could use statsd or ceilometer or ...
19:19:43 <devananda> JayF: however. we may be talking about different things
19:20:03 <devananda> JayF: let's talk more on that later
19:20:14 <wanyen> Deva and JayF : there  is an ceilometer notification desgin spec for ironic hw sensors
19:20:15 <aweeks> devananda: JayF I'm still working on finding a reasonable API that covers the metrics models for ceilometer and statsd at the same time
19:20:28 <devananda> any questions/concerns on the timeline?
19:21:21 <lucasagomes> wanyen, yeah the ceilometer spec is already merged
19:21:33 <NobodyCam> just under a month for spec freeze
19:21:44 <lucasagomes> (in ceilometer I mean)
19:21:52 <devananda> main points to call out on the timeline:
19:22:05 <devananda> july 24 - no new specs after this point
19:22:14 <NobodyCam> devananda: this spce? https://review.openstack.org/#/c/102435/
19:22:18 <NobodyCam> spec even
19:22:29 <lucasagomes> devananda, no specs for juno/*
19:22:34 <lucasagomes> or k/* would be allowed?
19:23:46 <devananda> aug 14 - we all do one big push to land any remaining specs and set direction for the last ~3 weeks of Juno dev
19:24:14 <devananda> Sep 4 - feature freeze. focus on integration and documentation and bug fixes
19:24:17 <boris-42> hi all*
19:24:19 * mrda hopes specs will be all sorted out before then
19:24:36 <devananda> oh, and this wendesday - spec review day :)
19:24:57 <devananda> lucasagomes: so Nova has been debating whether to block or allow k/* proposals during that window
19:25:19 <devananda> lucasagomes: the question being, even if the team isn't reviewing them, shoudl we encourage developers to spend their time writing specs or workign on bugs/integration/docs/etc
19:25:42 <jroll> IMO, just need to make it very clear that specs probably will not be reviewed
19:25:47 <jroll> no sense in blocking work
19:25:56 <devananda> I think clearly communicating that between Sep 4 and Sep 25 we aren't going to look at the specs repo at all will be enough
19:26:21 <lucasagomes> devananda, right... Yeah lets see the output of that discussion
19:26:55 <devananda> going to give a few more minuets for questions/comments before moving on ...
19:27:39 <NobodyCam> jroll: I tend to agree with you. but under the same token I think thinks can go stale just sitting wating for review
19:28:20 <devananda> ok, thanks all. let's move on
19:28:21 <jroll> NobodyCam: code, sure. specs, I doubt it
19:28:23 <NobodyCam> so ++ to lucasagomes comment of waiting
19:28:30 <rloo> i don't understand the timeline after k is open for spec proposals but i'll ask in Sept.
19:28:37 <wanyen> deva:  for uefi and node property discovery, we have generic and iLO specs.  I hope reviewers can review both specs.
19:28:39 <devananda> #topic sub team status reports
19:29:05 <devananda> adam_g: hi! any news on tempest testing last week?
19:29:11 <devananda> NobodyCam: hi! any news on tripleo testing last week?
19:29:45 <adam_g> nothing major, got a bunch of patches up for review and have been filing related bugs @ https://bugs.launchpad.net/tempest/+bugs?field.tag=ironic-tempest
19:30:03 <NobodyCam> the undercloud-ironic job is now running, I have nnot check the fail / success rate yet
19:30:22 <NobodyCam> but on reviews I have seen it seems to be passing
19:30:30 <mrda> thanks for that link adam_g, I thik I'm tickling a neutron-tempest bug right now
19:30:39 <NobodyCam> so we'll prob make a move to make it voting soon
19:30:47 <adam_g> mrda, specific to ironic, or ?
19:30:56 <matty_dubs> win 9
19:31:00 <devananda> adam_g: might you have time to add the tripleo-undercloud-ironic job to http://no-carrier.net/~adam/openstack/ironic_gate_status.html
19:31:11 <adam_g> devananda, sure
19:31:13 <devananda> adam_g: or set up a second page for that job?
19:31:14 <devananda> thanks!
19:31:25 <devananda> NobodyCam: that'll help you track it's succes ^
19:31:28 <adam_g> devananda, http://goodsquishy.com/downloads/tripleo-jobs.html is what i use to track those
19:32:08 <devananda> adam_g: so we swapped ironic-seed-precise for ironic-undercloud-precsie last week
19:32:15 <mrda> adam_g: well, my patch isn't passing dsvm-virtual-ironic and its unrelated.  romcheg thinks it might be neutron related.  I'll ping you after
19:32:17 <devananda> the former shouldn't be runing any longer, at least in ironic's pipe
19:32:40 <adam_g> dendrobates, okay, ill add the tripleo jobs to the ironic page regardless
19:32:45 <adam_g> er devananda ^
19:33:05 <Shrews> adam_g: devananda: it has been suggested that our scenario tests should really just be using the existing compute tests. so we may need to revisit our tempest testing strategy
19:33:15 <NobodyCam> adam_g: devananda Thank you
19:33:28 <NobodyCam> oh we are failing now
19:33:50 <devananda> Shrews, adam_g: it seems to me like a meeting with the QA team might be really helpful
19:34:01 <NobodyCam> #link http://goodsquishy.com/downloads/tripleo-jobs.html
19:34:02 <adam_g> Shrews, theres lots of issues with doing that, but im hoping that fixing the bugs ive been filing will let us at least  run  all the tests from *-tempest-dsvm-ironic against ironic+nova
19:34:14 <devananda> to sort out the differences we've run into, both in terms of ironic's uniqueness and each team's understanding/expectation of tests
19:34:33 <adam_g> devananda, +1 there still seems to be confusion on both sides
19:34:34 <Shrews> devananda: just relaying what sdague just suggested, but yes, a meeting may be helpful
19:35:03 <devananda> would either of you like to organize it? :-)
19:35:11 <jroll> NobodyCam: ironic py26/py27/check-tempest-dsvm-virtual-ironic are failing, seemingly latest glance client release
19:35:23 <Shrews> NobodyCam: py26/py27 jobs are all failing now
19:35:26 <jroll> (probably tripleo too)
19:35:26 <adam_g> devananda, sure
19:35:28 <devananda> jroll: huh?
19:35:32 <Shrews> due to what jroll just said
19:35:37 <jroll> devananda: e.g. http://logs.openstack.org/44/86744/20/check/gate-ironic-python26/27cd699/console.html
19:35:41 <NobodyCam> yes all look read
19:35:46 <NobodyCam> red even
19:35:52 <devananda> wow, that's great
19:35:53 <jroll> devananda: Shrews just caught this in the last hour
19:35:56 <jroll> yep!
19:35:59 <lucasagomes> :(
19:36:13 <devananda> I'll follow up on our gate status after the meeting
19:36:44 <devananda> #action adam_g to arrange meeting between adam, shrews, devananda and QA team
19:36:59 <devananda> moving on ...
19:37:02 <GheRivero> I can take a look to the glance client wrapper (was my code, so I know it)
19:37:17 <devananda> I think dtantsur is on PTO, so probably no updateon bugs this week
19:37:23 <devananda> or on fedora support
19:37:29 <Shrews> GheRivero: thanks!
19:37:36 <devananda> unless anyone else has news on those
19:37:59 <devananda> jroll: hi! what's the status of IPA driver? ready for the world to play with it yet? :)
19:38:13 <jroll> hey :) getting there
19:38:26 <jroll> still working a bit on splitting up the patches
19:38:36 <jroll> and at the same time have been working on getting devstack up and running
19:38:47 <jroll> so I can add IPA support to devstack, and eventually tempest
19:39:17 <devananda> awesome
19:39:43 <jroll> no major updates this week, though
19:39:52 <devananda> k, thanks
19:40:01 <devananda> GheRivero: hi! any updates on oslo?
19:40:15 <GheRivero> no news
19:40:51 <NobodyCam> no noews os good news
19:41:04 * NobodyCam cannot type this morning
19:41:05 <devananda> GheRivero: i'm eagerly awaiting the oslo.db fixes, fwiw
19:41:16 * devananda would like to land https://review.openstack.org/#/c/42159/ once it is fixed upstream
19:41:31 <GheRivero> devananda: me too. I'll take a look to them after the glance issues
19:41:47 <devananda> romcheg: hi! any updates on the nova db -> ironic db migration tool?
19:42:00 <romcheg> Hi everyone again !
19:42:08 <romcheg> Yes, there are some updates
19:42:24 <NobodyCam> wow 42159 we on 100000+ now
19:42:34 <romcheg> So I published a flavor update tool in the form it's expected to be released
19:42:58 <romcheg> I made a few tweaks on data migration tool and published them too
19:43:35 <romcheg> I faced some problems, one of them was that we cannot tell the architecture of a specific node exactly
19:43:43 <devananda> romcheg: links?
19:43:56 <NobodyCam> romcheg: is there a list of all the migration patches?
19:43:59 <romcheg> devananda: they are in the whiteboard
19:44:04 <NobodyCam> :)
19:44:09 <devananda> romcheg: re: arch, I think we can assume from the conf setting of the nova compute host it was assigned to
19:44:29 <romcheg> #link https://review.openstack.org/#/c/101920/
19:44:37 <romcheg> #link https://review.openstack.org/#/c/102563/
19:44:55 <romcheg> devananda: We cannot assume that because that option tells us allowed architectures
19:45:20 <romcheg> I discussed it with NobodyCam and we agreed that just adding a command line option for that should be better
19:45:37 <romcheg> A cloud administrator knows that better than we can guess
19:45:45 <devananda> romcheg: ack
19:46:05 <romcheg> devananda: Does that approach seem to work for you?
19:46:24 <devananda> romcheg: seems fine so far. I'll review those ^ soon
19:46:53 <devananda> romcheg: any concerns about the migration tool at this point?
19:46:55 <devananda> *other
19:47:20 <romcheg> devananda: There is one concern I was about to ask
19:47:40 <romcheg> We need to make Ironic to take ownership on the nodes
19:48:30 <romcheg> So after the data was migrated we do not need to bind nodes to conductors and generate PXE stuff from the migration script
19:48:47 <romcheg> It's not hard to do but doesn't seem to be right
19:49:09 <romcheg> And also the spec mentiones taking ownership on nodes by Ironic conductors
19:49:19 <devananda> romcheg: indeed. I was chatting a bit with lifeless las week about it -- the conductor take over work needs t obe finished
19:49:38 <romcheg> I will take a look at grenade testing this week
19:49:45 <devananda> that's on the spreadsheet, fwiw, like 17
19:49:48 <NobodyCam> romcheg: we may wan to to do move the images from the nova-bm tftp dir to ironics
19:50:03 <devananda> NobodyCam, romcheg: let's circle back on that after the meeting
19:50:10 <romcheg> ok
19:50:13 <NobodyCam> ack
19:50:15 <romcheg> let's not waste time now
19:50:32 <devananda> #topic specs for all-object-changes
19:50:55 <NobodyCam> ahh this is what I added?
19:51:02 <devananda> NobodyCam: hi! I see you and boris-42 want to talk about osprofiler -- can you summarize briefly?
19:51:10 <boris-42> dwalleck yep
19:51:13 <boris-42> devananda yep
19:51:16 <devananda> we have 9 minutes left and I'd like a little time for open discussion too :)
19:51:22 <NobodyCam> boris-42: go..
19:51:23 <boris-42> devananda it will be enough
19:51:32 <boris-42> dwalleck I don't want to write for this spec
19:51:38 <boris-42> dwalleck sorry*
19:51:44 <boris-42> devananda I don't want to write for this spec
19:51:57 <boris-42> dwalleck cause I need to make 2 patches (one in project, one in client)
19:52:02 <boris-42> devananda ^
19:52:08 <boris-42> devananda to enable profiler
19:52:15 <boris-42> devananda they are really simple
19:52:18 * dwalleck needs to change his nick :)
19:52:23 <boris-42> dwalleck yep
19:52:46 <boris-42> devananda in python we are adding just 2 special Headers
19:52:52 <NobodyCam> i was lookig to discuss how we would handle all project changes
19:52:54 <jroll> boris-42: isn't writing the ironic spec just a matter of `cp` and `sed`?
19:52:56 <boris-42> dwalleck in project we are adding wsgi middlewaer
19:53:07 <NobodyCam> will we require a spec
19:53:07 <boris-42> jroll it is not
19:53:25 <boris-42> jroll you need to make this in 100500 projects
19:53:25 <NobodyCam> or is there a global spec we can ref for blueprints
19:53:30 <boris-42> jroll get everywhere approves
19:53:38 <boris-42> jroll and formats are a bit different in different projects
19:53:42 <NobodyCam> I still feel we need blueprints for changes like this
19:53:44 <jroll> sounds like an infra/tc question
19:53:47 <boris-42> jroll so it's useless spending of my time
19:53:52 <jroll> I'd still like to see a spec for this, personally
19:53:58 <jroll> but I totally understand that
19:54:00 <boris-42> jroll and I am not secretary to do that crap
19:54:01 <devananda> boris-42: so rather than talka bout profiler itself (which I'd be happy to do, but not right now) it sounds like the question is
19:54:02 <boris-42> =)
19:54:17 <devananda> boris-42: can you propose small changes which are being accepted across many openstack projects without a spec?
19:54:24 <boris-42> devananda yep
19:54:27 <boris-42> devananda and about profiler
19:54:37 <devananda> boris-42: my answer, at least for now, is: it depends :)
19:54:45 <devananda> boris-42: you're welcome to propose the code and find out :)
19:54:56 <boris-42> devananda so about profiler
19:55:01 <boris-42> devananda it doesn't add overhead
19:55:13 <boris-42> devananda even if it is turned on
19:55:14 <devananda> boris-42: let's not talk about the specifics of profiler right now
19:55:20 <boris-42> devananda lol=)
19:55:24 <NobodyCam> lets loop back to the details of the change
19:55:28 <NobodyCam> :)
19:55:38 <boris-42> NobodyCam I mean
19:55:44 <boris-42> it's just 1 header
19:55:47 <devananda> #topic Open Discussion
19:55:48 <boris-42> 2 actually*
19:55:54 <boris-42> and 1 wsgi middleware
19:55:57 <NobodyCam> my question was more ... how will we handle this type of change request
19:56:10 <boris-42> NobodyCam heh just don't use specs
19:56:14 <jroll> NobodyCam: I think it depends on the change
19:56:15 <devananda> boris-42: in this case, if it's that simple, please propose the code and let's discuss there
19:56:30 <boris-42> devananda going to make osprofiler v 0.2.0
19:56:33 <devananda> boris-42: if other projects are adopting the change, I am likely to follow suit with Ironic
19:56:34 <boris-42> devananda for first
19:56:42 <boris-42> devananda cause there is some conflict in oslo.messaging
19:56:55 <boris-42> devananda they don't want one peace of code
19:56:58 <boris-42> piece*
19:57:06 <boris-42> devananda so I am going to move it to osprofiler
19:57:14 <boris-42> devananda and then I'll publish patches
19:57:20 <boris-42> devananda probably tomorrow
19:58:17 <NobodyCam> While not on the spec team I have been making a big effort to review spec over hte last several days
19:58:25 <NobodyCam> hope others will join me
19:58:27 <devananda> NobodyCam: thank you!
19:58:54 <wanyen> wanyen: who is on spec team?
19:58:58 <NobodyCam> :) (*BLUSH*)
19:59:24 <NobodyCam> one moinunte beep *BEEP*
19:59:25 <linggao> devananda, why did native IPMI driver is move to K*?
19:59:25 <jroll> NobodyCam: +1 :)
19:59:38 <devananda> wanyen: https://review.openstack.org/#/admin/groups/352,members
19:59:41 <linggao> We are activaly setting up the CI
19:59:52 <wanyen> deva: thnaks!
20:00:31 <NobodyCam> thats time
20:00:41 <mrda> thanks!
20:00:45 <devananda> linggao: i think that line meant "make it the default" -- I'll edit the sheet
20:00:51 <romcheg> Thanks everyone
20:00:52 <devananda> thanks everyone!
20:00:57 <NobodyCam> thank you all
20:00:57 <devananda> #endmeeting