19:01:48 <NobodyCam> #startmeeting Ironic
19:01:48 <NobodyCam> #chair devananda
19:01:49 <openstack> Meeting started Mon Aug 18 19:01:48 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:50 <NobodyCam> Welcome everyone to the Ironic meeting.
19:01:53 <openstack> The meeting name has been set to 'ironic'
19:01:54 <openstack> Current chairs: NobodyCam devananda
19:01:58 <NobodyCam> Of course the agenda can be found at:
19:01:58 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:02:06 <NobodyCam> #topic Greetings, roll-call and announcements
19:02:07 <NobodyCam> Roll-call: Who's here for the Ironic Meeting?
19:02:09 <mrda> o/
19:02:18 <rloo> me
19:02:19 <lucasagomes> :)
19:02:31 <GheRivero> o/
19:02:34 <harshada_kakad> o/
19:02:36 <NobodyCam> \o/ howdy ya all
19:02:48 <NobodyCam> announcements:
19:02:49 <NobodyCam> Devananda is off burning thing in the desert.
19:02:54 <comstud> o/
19:03:10 <NobodyCam> things even :-p
19:03:20 <comstud> men
19:03:36 <NobodyCam> adam_g is also out for the day
19:03:58 <lucasagomes> dtantsur is on PTO as well
19:04:22 <lucasagomes> today*
19:04:26 <NobodyCam> looks like we may even have a light agenda ..
19:04:44 <jroll> \o (was grabbing food, sorry)
19:04:52 <NobodyCam> any announcements for anyone out there ?
19:04:57 <NobodyCam> np jroll
19:05:05 <NobodyCam> we assigned everything to you
19:05:17 <jroll> good
19:05:34 <NobodyCam> :)
19:05:44 <NobodyCam> ok then lets jump into things:
19:05:46 <NobodyCam> #topic Release cycle progress report
19:05:53 <NobodyCam> lucasagomes: thats you today?
19:06:00 <linggao> o/
19:06:03 <lucasagomes> right so, while deva is off I will be assuming the release cycle progress
19:06:14 <lucasagomes> feature freeze will happen in less than 3 weeks from now (September 4)
19:06:18 <lucasagomes> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
19:06:26 <lucasagomes> we had our feature proposal freeze last Thursday
19:06:35 <lucasagomes> so no more specs will be approved, and they need to be resubmitted once Kilo opens
19:06:48 <lucasagomes> also it's important to note that in Kilo we will change slightly our spec process
19:07:03 <lucasagomes> mostly to be able to give people a faster feedback and let them know whether the feature that they are proposing belongs in Ironic or not
19:07:09 <lucasagomes> #link http://lists.openstack.org/pipermail/openstack-dev/2014-August/041960.html
19:07:15 <lucasagomes> ^ for more information about the spec process changes
19:07:19 <jroll> note: JayF -2'd all outstanding specs already
19:07:35 <lucasagomes> nice, thanks for that
19:07:42 <lucasagomes> so J3...
19:07:46 <lucasagomes> #link https://launchpad.net/ironic/+milestone/juno-3
19:07:50 <NobodyCam> yes thank you jroll jayf
19:08:01 <lucasagomes> we really need to spend time reviewing code for the already approved specs
19:08:07 <lucasagomes> we have 14 specs tagged to land in J3
19:08:11 <lucasagomes> that's a lot
19:08:15 <lucasagomes> and from this 14 only 3 is already marked as implemented
19:08:26 <lucasagomes> I know some of the specs are just waiting for code reviews in Ironic and/or changes in other related project like tempest and/or devstack
19:08:33 <lucasagomes> but we also have some specs approved which has no code proposed yet
19:08:33 <NobodyCam> lucasagomes: are we going to have a review jam tomorrow morning?
19:08:46 <lucasagomes> NobodyCam, yup, yeah we should
19:08:49 <NobodyCam> :)
19:08:50 <rloo> First bp is done I believe.
19:09:07 <rloo> lucasagomes: are you going to go through the bps?
19:09:12 <lucasagomes> rloo, ah right, I will mark it as implemented later then
19:09:19 <jroll> +1 review jam
19:09:26 <lucasagomes> rloo, tomorrow or today u mean?
19:09:36 <NobodyCam> #action review jam tomorrow morning!
19:09:46 <rloo> lucasagomes:  right now.
19:09:52 <lucasagomes> rloo, today I'm just doing an overview of the situation
19:10:01 <rloo> lucasagomes:  ok.
19:10:08 <lucasagomes> so
19:10:24 <lucasagomes> so if you own one spec and you didn't put any code up yet, please do!
19:10:27 <lucasagomes> ASAP
19:10:35 <lucasagomes> and if you don't think you'll have time to finish your spec before September 4, please lemme know
19:10:39 <mrda> so tomorrow is quite subjective, just sayin'
19:10:57 <jroll> lucasagomes: I think in that review jam, we should also assess the specs without code
19:10:59 <jroll> mrda: tuesday :P
19:11:06 <lucasagomes> jroll, yup
19:11:08 <rloo> time on tuesday?
19:11:20 <mrda> jroll: oh you mean today
19:11:23 <jroll> 7am pacific or later is fine with me
19:11:25 <jroll> mrda :P
19:11:29 <lucasagomes> so for next week I to bring some numbers about how many of the blueprints was completed or blocked on the week before and more details about specific specs that might need a special attention
19:11:45 <jroll> mrda: tomorrow utc :P
19:11:45 <NobodyCam> lucasagomes: awesome
19:11:52 <lucasagomes> and that's it for now, ah, folks who has a spec approved and not completed yet I might ping you this week (and the next weeks as well) to know about the progress of it
19:11:53 <lucasagomes> :)
19:11:58 <lucasagomes> ahhh
19:12:08 <NobodyCam> I'd vote for 8am pst just to have time for coffee
19:12:08 <wanyen> fyi- uefi boot  code has been sumitted and need code review
19:12:09 <lucasagomes> folks working in the nova driver, tempest, nova migration and grenade should continue on that because that's very important for our graduation!!
19:12:18 <jroll> NobodyCam: fine with that
19:12:20 <lucasagomes> NobodyCam, lets talk about the time after the meeting or opendiscussion
19:12:27 <NobodyCam> ++
19:12:31 <lucasagomes> cause I've a important call I will check the hours here
19:12:35 <jroll> wanyen: we're aware and it will get reviewed :)
19:12:47 <wanyen> jroll, tx
19:12:54 <lucasagomes> but that's it for me, I will be probably nagging people about their bps status for the next days :)
19:13:01 <NobodyCam> great report lucasagomes TY
19:13:06 <rloo> wanyen: maybe you could update the BP status for uefi. it shows as 'Started'.
19:13:16 <NobodyCam> +1 for nagging
19:13:35 <jroll> rloo, wanyen, that should be automatically updated if the BP is mentioned correctly in the commit message
19:13:36 <NobodyCam> comments / question for lucasagomes
19:13:42 <lucasagomes> wanyen, awesome! I will mark it as need code review
19:13:49 <wanyen> rloo, ok.  I will try.  Sometime Ihave problemto update bp' status
19:14:02 <jroll> comments: lucasagomes is awesome. that is all
19:14:06 <rloo> wanyen: ask for help later ;)
19:14:13 <NobodyCam> lol :)
19:14:29 <NobodyCam> ok then lets jump into subteams :)
19:14:30 <lucasagomes> u all are awesome :)
19:14:36 <NobodyCam> #topic SubTeam: integration & testing work
19:14:36 <NobodyCam> adam_g is out for the day:
19:14:40 <NobodyCam> per his request I am relaying his most pressing review: https://review.openstack.org/#/c/112402
19:14:46 <wanyen> lucasagomes, tx
19:15:08 <NobodyCam> he also has Ironic migration script needs review: https://review.openstack.org/#/c/112402
19:15:21 <jroll> NobodyCam: should we be pinging nova people for reviews on that migration script, too?
19:15:26 <jroll> (also, those are the same links)
19:15:33 <mrda> jroll: +1
19:15:55 <NobodyCam> jroll: adam_g seem to think so so I would say yes!
19:16:14 <jroll> heh, ok
19:16:18 <jroll> agree
19:16:23 <NobodyCam> adam added his links to the agenda please find them there
19:16:52 <NobodyCam> any questions/ comments on integration & testing
19:17:33 <NobodyCam> ok moving on...
19:17:35 <NobodyCam> #topic SubTeam: Bug team
19:17:44 <lucasagomes> so dmitry is on PTO
19:17:54 <lucasagomes> but
19:18:00 <lucasagomes> he has a nice bug dashboard here
19:18:02 <lucasagomes> #link http://ironic-bugs.divius.net/
19:18:13 <lucasagomes> stats: Open: 134. 8 new, 37 in progress, 0 critical, 16 high and 5 incomplete
19:18:17 <NobodyCam> anyone to report for dtantsur
19:18:22 <NobodyCam> lol awesome lucasagomes
19:18:35 <lucasagomes> it's on the dashboard, just c&p
19:18:38 <lucasagomes> heh
19:18:40 <NobodyCam> :)
19:18:45 <jroll> lol
19:18:46 <jroll> good report!
19:18:58 <jroll> is someone triaging while he is out?
19:19:07 <lucasagomes> jroll, he will be back tomorrow
19:19:08 <NobodyCam> any questons/comments on bugs?
19:19:10 <jroll> ha, ok
19:19:18 <NobodyCam> oh no that I know
19:19:26 <NobodyCam> how long is he out?
19:19:33 <jroll> til tomorrow apparently
19:19:33 <lucasagomes> only today afaik
19:19:38 <NobodyCam> :)
19:19:45 <NobodyCam> I think we're ok then
19:20:12 <NobodyCam> we're mak'n good time today :)
19:20:14 <NobodyCam> #topic SubTeam: Ironic Python Agent
19:20:15 <NobodyCam> jroll
19:20:30 <jroll> hi!
19:20:35 <NobodyCam> :-p
19:20:37 <NobodyCam> :)
19:20:39 <jroll> as always, tracking progress here: https://etherpad.openstack.org/p/ipa-todos
19:20:48 <jroll> still working on getting CI out there
19:20:53 <jroll> devstack changes and docs have landed
19:21:13 <jroll> there's some more changes on that etherpad that need to land for ironic check jobs and IPA gate jobs
19:21:38 <lucasagomes> o/
19:21:45 <lifeless> o/
19:21:52 <jroll> I'd like to land more docs for J3 as well
19:21:53 * lucasagomes needs to poke someone to review the ipxe devstack changes too
19:22:09 <NobodyCam> jroll: morning lifeless :)
19:22:11 <jroll> oh I can take a look at that, too, lucas
19:22:17 <jroll> heya lifeless
19:22:39 <lucasagomes> jroll, nice docs are imporant... we also have J4 for docs
19:22:41 <lucasagomes> and bug fixes
19:22:52 <jroll> oh, I'd also like to revive the DIB patch for IPA too
19:23:08 <jroll> that NobodyCam
19:23:10 <jroll> started
19:23:21 <NobodyCam> jroll: lets chat about that after the meeting
19:23:24 <jroll> ^^
19:23:30 <jroll> might need help from lifeless or someone
19:23:34 <lifeless> sure
19:23:48 <lifeless> I have a fragmented morning but I'm sure we can hook up
19:23:57 <jroll> yep, no rush
19:24:08 <jroll> ok, any comments/questions for me?
19:24:25 <NobodyCam> :>
19:24:42 <NobodyCam> very good report Ty jroll
19:25:01 <NobodyCam> #topic SubTeam: Oslo
19:25:02 <NobodyCam> Ghe
19:25:16 <NobodyCam> you here GheRivero
19:25:20 <GheRivero> nothing to add :)
19:25:28 <NobodyCam> :) love it
19:25:30 <NobodyCam> TY
19:25:46 <jroll> don't forget Nova driver status (mrda) :)
19:25:57 <NobodyCam> question/comments for GheRivero
19:26:02 <NobodyCam> jroll: I wont
19:26:05 * mrda waits patiently
19:26:11 <NobodyCam> :-p
19:26:14 <jroll> ok, just noticed we're out of order :P
19:26:21 <NobodyCam> we dping really good on time
19:26:29 <lucasagomes> GheRivero, 1 q
19:26:37 <lucasagomes> the problem with migration tests running on gate
19:26:46 <lucasagomes> it's fixed already? any updates on that?
19:27:34 <GheRivero> I was looking on that but got stuck with other issue. First thing tomorrow morning :)
19:27:53 <lucasagomes> ack
19:27:57 <lucasagomes> thanks Ghe
19:28:34 <NobodyCam> :)
19:28:43 <NobodyCam> any other Q/C?
19:29:06 <NobodyCam> moving on.
19:29:07 <NobodyCam> #topic SubTeam: Nova Driver status
19:29:08 <NobodyCam> mrda thats you
19:29:14 <mrda> \o/
19:29:49 <mrda> So it's been a battle of git rebasing this past week, but I learnt a valuable lesson - you must start with the last patch in the chain :)
19:30:02 <NobodyCam> :-p
19:30:26 <mrda> So there's a 5 patch series, 1 and 2 will be ok with Nova
19:30:34 <mrda> there's some +2'ing already
19:30:41 <lucasagomes> o/
19:30:44 <mrda> 3, 4, 5 need more work and I'm continuing on that
19:31:13 <NobodyCam> awesome :)
19:31:15 <mrda> I know jroll has a couple of perfomance related reviews he'd like looked at in Ironic that I he would like tacked on the end as review 6
19:31:26 <mrda> so help jroll out if you can
19:31:44 <jroll> ^^
19:32:03 * lucasagomes gotta review the cache stuff
19:32:04 <NobodyCam> mrda: if those land in ironic are you ok with adding to the patch train
19:32:05 <mrda> besides that, all ok.  I'll scream loudly if I need ironic core assistance on fixes in the ironic tree before reposting them back into nova
19:32:06 <jroll> https://review.openstack.org/108545 and https://review.openstack.org/113036
19:32:19 <jroll> mrda: ++ for screaming
19:32:24 <lucasagomes> mrda, ++ any time
19:32:31 <mrda> NobodyCam: Yes, those 2 performance ones (108545 + 113036 I thik)
19:32:48 <rloo> and nothing gets into nova until the entire chain is approved?
19:32:54 <NobodyCam> mrda: :) (poking folks with sharp sticks works too)
19:33:06 <mrda> oh, and I need someone to represent us at the Nova team meeting in meeting-alt at http://www.timeanddate.com/worldclock/fixedtime.html?iso=20140821T140000
19:33:14 <jroll> my firewall blocks sharp sticks :)
19:33:17 <mrda> (just in case they have questions)
19:33:42 <mrda> (I'm not going to do late nights and early mornings in the same week :)
19:33:48 <jroll> mrda: I can if nobody else wants to, lucasagomes might also be a good candidate for that based on the time
19:33:53 <NobodyCam> lucasagomes: where you planning on attending that?
19:33:55 <mrda> lucasagomes: does that work for you?
19:34:13 <jroll> (lucas might know more about that than myself)
19:34:17 <lucasagomes> so I wasn't planning, I have to check my calendar here
19:34:24 <lucasagomes> can I give you the answer later?
19:34:36 <NobodyCam> sure..Ty lucasagomes
19:34:38 <lucasagomes> there's some internal meetings I have, so I want to make sure it won't collide
19:34:47 <mrda> sure, it's not a big deal, just in case nova wants to discuss about the ironic patch series
19:34:53 <lucasagomes> or if I can rearrange it somehow
19:35:00 <lucasagomes> right
19:35:03 <mrda> anyone have any questions about the driver landing in nova?
19:35:05 <lucasagomes> I will check that out
19:35:19 <mrda> lucasagomes: thnx
19:35:20 <jroll> lucasagomes: feel free to poke me if you can't do it
19:35:29 <NobodyCam> #link http://www.timeanddate.com/worldclock/fixedtime.html?iso=20140821T140000 <- nova meeting
19:35:30 <lucasagomes> jroll, mrda np, will do
19:36:26 <mrda> I'm done unless there's q's
19:36:42 <NobodyCam> I skipped over tempest Ci, as dtantsur was out, I should ask if there are any questions on that tpoic
19:36:54 <NobodyCam> topic even
19:37:35 <NobodyCam> if not. then we can mosy over to :
19:37:36 <NobodyCam> #topic Food for Thought / Open Discussion
19:38:01 <NobodyCam> any questions?
19:38:05 <NobodyCam> comments?
19:38:11 <NobodyCam> screams?
19:38:56 <jroll> yeah, I have a thing!
19:39:06 <jroll> I started the horizon work today https://review.openstack.org/115050
19:39:15 <NobodyCam> oh I saw that in channel
19:39:37 <lucasagomes> ah nice!
19:39:42 <jroll> that's mostly autogenerated code, but I'm going to continue working on it... if anyone wants to play with it or help or whatever please let me know :)
19:39:51 <NobodyCam> #link https://review.openstack.org/115050
19:40:09 <jroll> I might post that to the mailing list just so nobody duplicates that work
19:40:22 <rloo> it would be good to have an item in the meeting to review outstanding stuff to get to graduation.
19:40:22 <jroll> and see if there's any new mockups
19:40:24 <NobodyCam> that would be great jroll
19:40:31 <jroll> rloo: +1
19:41:12 <NobodyCam> #action NobodyCm add outstanding stuff for graduation item to agenda
19:42:12 <NobodyCam> that it? folk want 20 minutes back?
19:42:30 <jroll> oh come on, there has to be something to argue about ;)
19:42:31 <lucasagomes> NobodyCam, jroll rloo as for the time of the review jam tomorrow... I'm busy from 14:00~15:30 UTC tomorrow
19:42:39 <mrda> I can go back to sleep! \o/
19:42:48 <lucasagomes> can we do it after that? of you guys can start and I join later
19:43:06 * jroll converts the time real quick
19:43:14 <jroll> that's 7-8:30 pacific, yeah?
19:43:24 <NobodyCam> jroll: thats 9 am pst?
19:43:27 <jroll> I can do either way, let's just start at 8:30
19:43:31 <jroll> uhh
19:43:34 <jroll> is it?
19:43:35 <NobodyCam> give you a few minutes inbetween?
19:43:51 <jroll> oh you're saying start at 9am
19:43:52 <jroll> sounds good
19:43:57 <NobodyCam> si
19:44:24 <NobodyCam> review jam tomorrow 9am pst ?
19:44:30 <jroll> wfm :)
19:44:34 <rloo> works for me.
19:44:36 <NobodyCam> +1 here
19:44:39 <lucasagomes> :) aight
19:44:46 <NobodyCam> sounds good.
19:45:13 <rloo> uhh, 15:30 utc is 9:30 pst.
19:45:19 <rloo> so you want to start at 15 UTC?
19:45:27 <jroll> I don't think it is?
19:45:30 <jroll> we may be in pdt
19:45:42 <jroll> idk, it's currently 1945 utc / 1245 pacific
19:45:50 <jroll> afaik
19:45:57 <NobodyCam> lol
19:46:13 <NobodyCam> I think we are officaly in pdt
19:46:35 <NobodyCam> ok then shall we take 14 minutes and go grab some lunch?
19:46:51 <lucasagomes> I think so if nobody has anything else
19:46:53 <rloo> +1 NobodyCam
19:46:56 <lucasagomes> (it's late here :P)
19:47:00 <jroll> I've got nothing
19:47:01 <wanyen> what timeis ther review jam, *:30 pdt?
19:47:02 <lucasagomes> mrda, will be happy as well I bet
19:47:19 <NobodyCam> wanyen: 9 am tomorrow
19:47:20 <wanyen> review jam 8:30 pdt?
19:47:36 <wanyen> ok. ty, nNobodyCam
19:47:53 <NobodyCam> Thank you everyone
19:47:57 <NobodyCam> #endmeeting