19:01:26 <NobodyCam> #startmeeting Ironic
19:01:26 <jroll> \o
19:01:26 <NobodyCam> #chair devananda
19:01:27 <NobodyCam> Welcome everyone to the Ironic meeting.
19:01:27 <openstack> Meeting started Mon Aug 25 19:01:26 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:27 <dtantsur> o/
19:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:30 <openstack> The meeting name has been set to 'ironic'
19:01:30 <GheRivero> o/
19:01:30 <JayF> o/
19:01:31 <openstack> Current chairs: NobodyCam devananda
19:01:32 <lucasagomes> :)
19:01:43 <NobodyCam> Of course the agenda can be found at:
19:01:44 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:01:50 <NobodyCam> #topic Greetings, roll-call and announcements
19:01:51 <NobodyCam> Roll-call: Who's here for the Ironic Meeting?
19:01:57 * jroll is
19:01:57 <mrda> o/
19:02:00 <adam_g> \o/
19:02:00 <lucasagomes> me
19:02:02 <GheRivero> o/
19:02:02 * Shrews too
19:02:05 <wanyen> hi
19:02:09 <rloo> me
19:02:13 <dtantsur> \o/
19:02:21 <NobodyCam> welcome all :)
19:02:30 <NobodyCam> announcements:
19:02:32 <NobodyCam> Devananda is still off burning thing in the desert.
19:02:39 <NobodyCam> as you may know our gate was again broken last week :(
19:02:48 <Shrews> :(
19:03:04 <NobodyCam> rloo: are we borken again with the doc thing or is that a red harring?
19:03:14 <lucasagomes> :/ it's fixed now, but there's some inconsistencies with docs and py26 afaict
19:03:26 <NobodyCam> :/
19:03:28 <mrda> :(
19:03:29 <rloo> I don't know how broken we are, but the doc thing seems to be broken a bit.
19:03:43 <NobodyCam> uggh
19:03:44 <Shrews> rloo: i'll try to help you track down the doc thing after the meeting
19:03:57 <NobodyCam> we'll need to check on htat after the meeting
19:03:58 <rloo> the py26 is out of our control it appears. I updated our etherpad. you can recheck if py26 fails
19:04:03 <NobodyCam> Ty Shrews :_
19:04:06 <rloo> Shrews: thx.
19:04:14 <adam_g> are there bugs for either issues?
19:04:22 <linggao> o/
19:04:29 <Shrews> https://bugs.launchpad.net/ironic/+bug/1361295
19:04:30 <uvirtbot> Launchpad bug 1361295 in ironic "gate-ironic-docs failed due to TypeError from sphinx" [High,New]
19:04:30 <rloo> yes, there are bugs. see etherpad.
19:04:42 <adam_g> thanks
19:04:43 <NobodyCam> :)
19:04:45 <lucasagomes> the doc thing would be good to check with ceilometer as well, they use the same docs as we do
19:04:55 <lucasagomes> sphinx with the wsme extension
19:05:05 <NobodyCam> oh good poing lucasagomes :)
19:05:16 <NobodyCam> point even
19:05:18 * adam_g wonders if PYTHONHASHSEED strikes again
19:05:31 <NobodyCam> no that landed this weekend
19:05:35 <NobodyCam> I saw it :-p
19:05:36 <adam_g> in tempest
19:05:39 <NobodyCam> oh
19:05:43 <adam_g> i mean, in ironic for the docs
19:06:02 <NobodyCam> adam_g: can you maybe help rloo and Shrews with that?
19:06:20 <adam_g> tox -evenv -- python setup.py build_sphinx
19:06:20 <adam_g> sure
19:06:25 <NobodyCam> :)
19:06:29 <adam_g> ill throw up a patch now just to see if that eliminates the issue after a number of rechecks
19:06:43 <NobodyCam> awesome TY rloo Shrews ^^^^
19:06:56 <NobodyCam> any other announcements?
19:06:58 <rloo> thx adam_g; I am crossing my fingers.
19:06:59 <NobodyCam> lol :)
19:07:05 <lucasagomes> hah
19:07:23 <NobodyCam> if not we'll jump right in to it
19:07:53 <NobodyCam> #topic Release cycle progress report
19:07:56 <NobodyCam> Lucas that you
19:08:00 <NobodyCam> ?
19:08:00 <lucasagomes> alright
19:08:03 <lucasagomes> #link https://launchpad.net/ironic/+milestone/juno-3
19:08:09 <lucasagomes> yeah I think it's me :)
19:08:15 <lucasagomes> stats: 7 Implemented, 5 Needs Code Review, 2 Started (no code upstream yet)
19:08:26 <lucasagomes> we have ~2 weeks until our feature freeze (Sep 4)
19:08:31 <lucasagomes> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
19:08:37 <lucasagomes> compared with last week we have 4 more blueprints implemeted this week :)
19:08:42 <lucasagomes> which is great!
19:08:53 <NobodyCam> woo hoo
19:08:59 <lucasagomes> two approved specs still have no code upstream yet :(
19:09:10 <lucasagomes> one is the Drac Managment Interface, and I'm helping with this one
19:09:14 <NobodyCam> lucasagomes: anyone we can poke on those?
19:09:14 <lucasagomes> I'm planning to put the code upstream tomorrow!
19:09:21 <lucasagomes> NobodyCam, yup, will update about it
19:09:32 <NobodyCam> :)
19:09:40 <lucasagomes> the other one is the Power Driver for SNMP
19:09:52 <lucasagomes> I sent an email to the author last thursday, and the tl;dr is
19:10:09 <lucasagomes> the driver is written and in use on their site but they need more time to refine and improve unit testing, also, he have not been through the company procedures for external code release yet
19:10:15 <lucasagomes> so I hope they can sort out the tests and the company thing, but there's some good chances that it's not going to make it :(
19:10:25 <jroll> agree, I'd be shocked if that got in
19:10:40 <lucasagomes> all other bps seems to be in good shape, and have the code upstream
19:10:49 <lucasagomes> I think we are doing great job, the review jam last week was pretty good and I would like
19:10:49 <NobodyCam> lucasagomes: are they requesting a ffe yet?
19:10:58 <lucasagomes> to do it again this week, if people agree with it (we can talk about time/day at the open-discussion)
19:11:01 <lucasagomes> NobodyCam, not yet
19:11:11 <NobodyCam> lucasagomes: +1 from me on jam
19:11:23 <lucasagomes> NobodyCam, he said he will try to put the code up asap, but you know how things are inside companies
19:11:26 <lucasagomes> it may take a while
19:11:32 <NobodyCam> and I'll try and make the whole thing this time too
19:11:34 <jroll> NobodyCam: I think that's not worth it for an ffe?
19:11:40 <jroll> +1 on a jam tomorrow
19:11:47 <lucasagomes> yeah that's a low priority bp
19:11:47 <jroll> (or whenever)
19:12:07 <NobodyCam> jroll: I agree was just checking to see if they  had asked for one
19:12:08 <lucasagomes> so we well see when time comes, if there's no code until the last day, we may just block it until K
19:12:18 <lucasagomes> and that's pretty much it about the updates
19:12:19 <jroll> +1
19:12:23 <lucasagomes> let's keep with the reviews :)
19:12:34 <NobodyCam> great update lucasagomes thank you
19:12:56 <NobodyCam> any questions / comments for lucasagomes ?
19:13:25 <NobodyCam> ok then moving on :)
19:13:28 <NobodyCam> #topic SubTeam: integration & testing work
19:13:29 <NobodyCam> adam_g
19:13:32 <NobodyCam> thats you?
19:13:46 <wanyen> ilo drivers are having doc issue.  Will the revew jam reivew  code that have doc issue?
19:13:56 <adam_g> heya
19:14:03 <jroll> wanyen: yes, that's a known bug
19:14:04 <adam_g> so we're in the final stretch for our CI/QA goals for this cycle
19:14:12 <jroll> wanyen: we're looking into it, no worries
19:14:21 <NobodyCam> wanyen: lets tough on that in open discussion
19:14:23 <wanyen> jroll. ty
19:14:39 <adam_g> we should hopefully be wrapping up our tempest and grenade work this week
19:14:40 <NobodyCam> adam_g: w00t :)
19:14:46 <mrda> yay
19:14:48 <lucasagomes> niiiice
19:14:50 <adam_g> and have a new grenade job popping up in our pipeline hopefully before FF
19:15:13 <adam_g> #link https://review.openstack.org/#/q/topic:ironic_tempest,n,z
19:15:13 <NobodyCam> sweet
19:15:16 <adam_g> (2 patches left to merge there)
19:15:23 <dtantsur> great!
19:15:30 <adam_g> #link https://review.openstack.org/#/q/topic:ironic_grenade,n,z
19:15:33 <adam_g> (a few more there)
19:15:53 <NobodyCam> adam_g: do you need ny help pingging folks on getting the two patches reviewed, or are you doing good there?
19:15:56 <adam_g> confident we should be wrapping this up this week and getting the infra changes put in place to turn the job on
19:16:08 <adam_g> NobodyCam, i think we are okay now that everyone from qa is back from conference travel
19:16:13 <jroll> adam_g: are you pushing to get this in this week as well? https://review.openstack.org/#/c/112134
19:16:34 <adam_g> jroll, yeah, thanks for reminding. looks like it needs a rebase
19:16:38 <jroll> (I'm relying on that for getting IPA jobs in)
19:16:40 <jroll> yeah
19:16:51 <jroll> adam_g: if you're fine with it, I can help babysit that one
19:16:51 <adam_g> jroll, is the IPA stuff ready and blocked?
19:17:15 <jroll> adam_g: devstack-gate patch has 1 +2, then I can land infra/config changes that depend on 112134
19:17:56 <NobodyCam> :)
19:17:56 <adam_g> jroll, okay, ill rebase it now and check with shrews after meeting about some minor concerns about coordinating the merge /w other things. i think we're okay, but want to check (dont want to risk gate breakage again)
19:17:58 <jroll> I have some other work up after that; specifically IPA repo gate jobs, that stuff needs some more love before I can land it though
19:18:15 <jroll> adam_g: cool, just making sure it's on your radar :)
19:18:34 <jroll> thanks
19:18:56 <NobodyCam> any other q/c?
19:19:26 <adam_g> thats all from me
19:19:34 <NobodyCam> awesome Ty adam_g :)
19:19:47 <NobodyCam> moving on downhte road
19:19:49 <NobodyCam> #topic SubTeam: Bug team
19:19:53 <NobodyCam> dtantsur thats you?
19:19:55 <dtantsur> o/
19:20:08 <NobodyCam> \o/
19:20:16 <dtantsur> people like numbers, so here are some numbers: Open: 136 (+3). 8 new (0), 41 in progress (+6), 0 critical, 16 high (+1) and 5 incomplete (-3)
19:20:56 <dtantsur> amount of bugs is not decreasing. also, I forgot to ping people who promised me to help with triaging smth nova-related
19:21:02 <NobodyCam> dtantsur: we should add a catagory for broke our gate
19:21:11 <dtantsur> heh
19:21:32 <dtantsur> if we create a tag in launchpad
19:21:35 <dtantsur> :)
19:21:38 <NobodyCam> hehehe
19:21:40 <dtantsur> and one more thing from me:
19:22:00 <dtantsur> #link https://etherpad.openstack.org/p/IIe0cnnJ5L possible candidates for Juno 3
19:22:12 <lucasagomes> ah nice
19:22:14 <dtantsur> these are my ideas, what could also be prioritized
19:22:22 <dtantsur> feel free to add/delete/edit
19:22:40 <jroll> cool
19:22:50 <dtantsur> #link http://ironic-bugs.divius.net/ shows which bugs still have 'New' status
19:22:51 <NobodyCam> please cross out do not just delete :)
19:23:00 <dtantsur> (some are cached, so don't be surprised)
19:23:29 <dtantsur> that's all I wanted to tell you
19:23:40 <NobodyCam> great Thank you dtantsur :)
19:23:58 <NobodyCam> questions / comments for dtantsur
19:24:00 <NobodyCam> ?
19:24:25 <jroll> just one thing
19:24:28 <NobodyCam> if not we'll move on too:
19:24:31 <NobodyCam> #topic SubTeam: Ironic Python Agent
19:24:33 <NobodyCam> jroll go
19:24:37 <NobodyCam> "-p
19:24:39 <jroll> I'd like to go over those bugs in the review jam
19:24:46 <jroll> and target as needed
19:24:48 <jroll> :)
19:24:56 <NobodyCam> jroll: the one's on hte etherpad?
19:24:56 <jroll> so, IPA
19:24:56 <dtantsur> jroll, right, I posted today for everyone to prepare :)
19:25:00 <jroll> NobodyCam: indeed
19:25:11 <jroll> on the IPA front... not much new
19:25:17 <jroll> still working on CI
19:25:27 <jroll> #link https://etherpad.openstack.org/p/ipa-todos
19:25:30 <JayF> jroll: should-we-release  questions? should they be brought up here or wait?
19:25:38 <jroll> ^ reviews are mentioned there
19:25:55 <jroll> JayF: yeah, we should, I'll let you talk about that :)
19:26:01 <lucasagomes> JayF, I think it's related so +1
19:26:20 <JayF> just generally wondering what folks think about how IPA should be released
19:26:22 <rameshg87> jroll, NobodyCam, i have one point to bring
19:26:24 <NobodyCam> yea ipa questions go _here_
19:26:31 <JayF> initially the idea was releases would be cut like with clietns
19:26:37 <NobodyCam> rameshg87: for IPA?
19:26:39 <JayF> but there's rarely a good natural place to cut an agent release
19:26:43 <rameshg87> jroll, NobodyCam, the ilo-virtualmedia-ipa driver requires a change in ipa : https://review.openstack.org/#/c/115275/
19:26:48 <JayF> aside from release time with ironic
19:26:55 <dtantsur> I didn't think of it
19:26:58 <JayF> so I wonder if we should tag a stable branch for a juno agent, and do a 'release'
19:27:03 <jroll> rameshg87: it's on my radar, last time I looked it was WIP :)
19:27:03 <dtantsur> sorry, posted earlier
19:27:14 <JayF> *I* would never use that, but wanted to check with folks who have other usaeg patterns
19:27:21 <rameshg87> jroll, thanks, its fully functional code which you can review now
19:27:47 <dtantsur> I wanted to say (and I barely manage my keyboard already) that distro folks may need some "know good version for J/K/..."
19:28:07 <jroll> dtantsur: well, I highly disagree there should be deb/rpm/etc
19:28:13 <jroll> but imbw
19:28:18 <rloo> jroll: would it hurt to do that? ie, if it is useful for folks and only a minor inconvenience for you to do it, why not?
19:28:22 <dtantsur> jroll, what do you propose for them?
19:28:27 <JayF> Well, if the distro did something like build a deploy ramdisk and make that rpm/deb installable, that would be OK
19:28:51 <JayF> but I don't think I would personally ever condone being able to apt-get install ironic-python-agent and have ipa installed, as a python module, in the distro directories
19:28:55 <jroll> yeah, I guess it could be used in a ramdisk build
19:28:59 <jroll> but agree with JayF
19:29:07 <NobodyCam> JayF: vs packaging up the scripts to build the image?
19:29:12 <JayF> if someone is doing a ramdisk build, having a release cut and in pypi would be useful
19:29:25 <JayF> NobodyCam: What other distro packages fit that pattern?
19:29:34 <JayF> NobodyCam: install a binary package to build an image for something?
19:29:46 <JayF> I just can't think of any, so it leads me to think folks may just do that one their own... I know I would
19:29:46 <NobodyCam> any src package
19:30:27 <NobodyCam> ironic-ipa-source-rpm
19:30:39 <NobodyCam> s/-rpm/.rpm/
19:30:41 <dtantsur> I think it should not be RPM/Deb but we still need some "know good version for J" somewhere, I guess
19:30:57 <jroll> agree
19:31:01 <jroll> we should tag a release
19:31:03 <jroll> put on pypi
19:31:20 <NobodyCam> jroll want an action item for that?
19:31:21 <dtantsur> jroll, ++
19:31:24 <lucasagomes> sounds good
19:31:33 <jroll> we should probably hit the mailing list too, to see what others think
19:31:35 <jroll> NobodyCam: sure
19:31:46 <jroll> NobodyCam: although the actual tagging is a long way out
19:32:21 <NobodyCam> #action IPA looking into how to cut a know good version for J
19:32:34 <NobodyCam> that work ^^
19:32:40 <jroll> sure
19:33:10 <NobodyCam> great update. any q/c for the IPA team
19:33:48 <NobodyCam> okay moving on to:
19:33:50 <NobodyCam> #topic SubTeam: Oslo
19:33:51 <NobodyCam> Ghe
19:33:54 <NobodyCam> is that you?
19:33:58 <NobodyCam> are you here?
19:34:00 * jroll will be back in 5 or so
19:34:07 <NobodyCam> ack TY jroll
19:34:12 <GheRivero> here but nothing to report
19:34:32 <NobodyCam> :) woo hoo.. .no news is good news
19:34:33 <NobodyCam> :)
19:34:38 <dtantsur> :)
19:34:39 <NobodyCam> Thank you GheRivero
19:34:59 <NobodyCam> questions / comments for GheRivero ?
19:35:30 <NobodyCam> nope... moving on to:
19:35:31 <NobodyCam> #topic SubTeam: Nova Driver status
19:35:31 <NobodyCam> mrda thats you
19:35:38 <mrda> hey
19:35:45 <mrda> So a number of changes to the driver were required in the last week , both internal and external, which have all been applied.  I've also been fixing up various
19:35:47 <mrda> Nova check failures.
19:35:55 <mrda> Hopefully there will be less churn this coming week.
19:36:06 <mrda> But I have struck a git issue yesterday.  During fixing a rebase conflict I accidentilly squashed a change by 'committing' when I should have 'continued'.  So now I need to replay the sequence of patches on top of the pre-conflict patch to fix the dependencies.
19:36:26 <NobodyCam> mrda: i have a patch up that I was going to bring up in Open Discussion but prob should bring up here
19:36:31 <mrda> sure
19:36:45 <NobodyCam> https://review.openstack.org/#/c/116316
19:36:55 <NobodyCam> #link https://review.openstack.org/#/c/116316
19:37:02 * mrda looks
19:37:21 <lucasagomes> NobodyCam, we need it as part of graduation?
19:37:22 <NobodyCam> I am not sure that is the correct place for that review?
19:37:30 <NobodyCam> lucasagomes: I think so
19:37:38 <lucasagomes> NobodyCam, I think we could just put that on nova directly no?
19:37:44 <lucasagomes> like at the end of the chain or something
19:37:57 <mrda> It probably could be added to the end of the chain
19:38:06 <NobodyCam> lucasagomes: thats why I pointed it out to mrda
19:38:06 <rloo> why at the end of the chain? our chain doesn't touch that file?
19:38:10 <mrda> because it would be dependent on everything else being in
19:38:21 <NobodyCam> mrda: and nova bm being out
19:38:27 <rloo> so it can be a separate patch that depends on the chain, but not part of the chain?
19:38:36 <mrda> rloo: I think so
19:38:42 <rloo> ie, I don't want that patch to cause the rest of the chain not to be approved/merged.
19:38:44 <lucasagomes> rloo, I don't think the driver has anything to do with that change, that's more about proxying nova bm commands to ironic
19:39:06 <NobodyCam> ya I would not include it with the driver patches
19:39:20 <mrda> correct, but we don't want the nova proxy to land until we have a ironic driver in nova, right?
19:39:22 <NobodyCam> nova bm should be removed before it lands
19:39:30 <rloo> lucasagomes: right, so it shouldn't be put 'at the end of the chain'. it isn't part of that chain, but it needs that chain as a dependency.
19:39:55 <rloo> NobodyCam: fwiw, there are other patches that are -2
19:40:01 <lucasagomes> rloo, right... well it should merge after the driver is merged, but in a different topic
19:40:02 <rloo> d cuz they are nova changes.
19:40:03 <mrda> NobodyCam: I'm not sure nova bm is going to be removed for a cycle
19:40:04 <lucasagomes> afaict
19:40:40 <mrda> ie nova bm will exist for a while in tree even afer ironic lands
19:40:43 <NobodyCam> mrda: we will need to figure out how and when that needs to land
19:40:56 <rloo> NobodyCam: we should discuss that proxy patch. if you make the change to baremetal_nodes, and BM is removed at some point, will we still need to proxy those nova bm commands?
19:40:57 <mrda> of whether it is switchable?
19:41:13 <NobodyCam> I wouldnn't want to remove the nova bm commands untill nova bm is actually removed
19:41:13 <mrda> s/of/or/
19:41:37 <mrda> NobodyCam: right, which might be anotgher cycle
19:41:53 <NobodyCam> we could add a switch and let operators set it
19:42:04 <mrda> +1
19:42:10 <NobodyCam> but I think we have time on that patch to work it out
19:42:30 <mrda> I agree
19:42:50 <mrda> So hopefully no more actual changes to the driver :)
19:42:54 <NobodyCam> mrda: do you need any help poking folks for reviews on hte nova patches?
19:43:06 <jroll> NobodyCam: I'm curious if that's going to get blocked by "feature freeze" that has already happened in nova
19:43:12 <lucasagomes> mrda, +1 /me fingers crossed!
19:43:22 <mrda> So I hope to resolve the rebase issue today, then it'll be back to bugging Nova.  That should be fine.  I'll holler if I need help.
19:43:32 <NobodyCam> jroll: nova team requested it... we have it, so I'm not sure
19:43:40 <jroll> NobodyCam: hm, ok :)
19:43:45 <mrda> The hardest part is fixing my squashed patch :-S
19:43:49 <NobodyCam> lucasagomes: are you in nova meeting this week?
19:44:06 <lucasagomes> NobodyCam, oh, I forgot that, when is it? yeah I can go this week
19:44:10 <mrda> I can attend Nova this week.  6:30am is a fine timeslot for me
19:44:19 <NobodyCam> lol :(
19:44:22 <jroll> "fine"
19:44:24 <jroll> :P
19:44:34 <lucasagomes> mrda, heh not that fine, if needed I can join there for u
19:44:38 <NobodyCam> might be worth askin about how we want ot handle that patch
19:44:40 <mrda> It's better than 2:30am or whatever
19:44:45 <mrda> it was last week
19:45:14 <NobodyCam> :/
19:45:22 <mrda> lucasagomes: I'll be there, but you are also welcome to join, of course :)
19:45:39 <lucasagomes> ack... I will put on my calendar
19:45:41 <NobodyCam> awesome Thank you lucasagomes and mrda :)
19:46:16 <NobodyCam> any other questions / comments on nova driver stuff?
19:46:47 <NobodyCam> Thank you for the great report mrda :)
19:46:53 <mrda> thanks :)
19:47:03 <NobodyCam> ok we added this one last week:
19:47:05 <NobodyCam> #topic Outstanding items for graduation
19:47:27 <NobodyCam> I had the proxy patch listed here but we talked about it already
19:47:30 <NobodyCam> so
19:47:40 <NobodyCam> #link https://docs.google.com/spreadsheets/d/1Hxyfy60hN_Fit0b-plsPzK6yW3ePQC5IfwuzJwltlbo/edit?usp=sharing
19:48:01 <NobodyCam> any one have ANY concerns or comments?
19:48:07 <NobodyCam> questions too :)
19:48:09 <rloo> how's the DB migration stuff?
19:48:33 <rloo> and the horizon panel, is that going well?
19:48:45 <rloo> do we need the onductor take-over for graduation?
19:48:53 * jroll checks on horizon
19:49:10 <NobodyCam> take over I don't believe so
19:49:23 <NobodyCam> has romcheg been on line?
19:49:24 <JoshNang> for horizon, aweeks has been hammering away on it. i don't think there's anything submitted yet, but i'll give him a hand this week and have some patches by next meeting
19:49:28 <lucasagomes> the horizon is not part of graduation is it?
19:49:36 <jroll> lucasagomes: it is
19:49:39 <mrda> lucasagomes: no
19:49:43 <lucasagomes> :O
19:49:47 <jroll> wait
19:49:50 <lucasagomes> hah... well I don't think it is
19:49:56 <jroll> oh, right, we have to have some things proposed
19:49:58 <jroll> but not landed
19:50:00 <jroll> chicken/egg thing
19:50:01 <JoshNang> ^
19:50:11 <mrda> So horizon won't take patches from non graduated projects
19:50:12 <jroll> I think it's more of a "good faith effort toward it"
19:50:14 <mrda> correct
19:50:26 <mrda> so it can merge soon afterwards
19:50:36 <JoshNang> so we'll show some good faith work this week
19:50:36 <rloo> maybe someone could update that and add a comment about chicken/egg, proposed but ok if not landed?
19:50:47 <jroll> sure
19:50:49 * jroll does it
19:50:53 <mrda> rloo: On whiteboard?
19:51:01 <NobodyCam> Ty jroll :)
19:51:03 <rloo> mrda: on that google doc link
19:51:11 <rloo> mrda: https://docs.google.com/spreadsheets/d/1Hxyfy60hN_Fit0b-plsPzK6yW3ePQC5IfwuzJwltlbo/edit#gid=1357128775
19:51:11 <wanyen> who is working on ironic horizon?  UEFI boot mode might need changes to horizon work
19:51:29 <JoshNang> wanyen: aweeks and i
19:51:44 <mrda> rloo: thnx
19:51:58 <wanyen> does horizon allow a user to specify which boot mode to deploy?
19:52:15 <NobodyCam> anyone need help with ANYTHING for graduation readyness?
19:52:17 <jroll> wanyen: it won't land in juno, so don't worry about it yet
19:52:34 <jroll> wanyen: (anything with horizon at all)
19:52:48 <wanyen> jroll, when is horizon work targeted toland?
19:53:03 <jroll> wanyen: kilo, assuming ironic graduates in juno
19:53:15 <wanyen> jroll, I see.  tx
19:53:34 <NobodyCam> jroll: horizon will not accept our patches until we graduate no?
19:53:41 <aweeks> jroll: I assume you're referring to the horizon patches (such as they are)?
19:53:45 <NobodyCam> at least thats what I thought
19:53:54 <mrda> That's my understanding
19:54:25 <NobodyCam> any thing else on graduation?
19:54:31 <jroll> NobodyCam: right, so horizon work will land the cycle after we graduate, yes?
19:54:40 <jroll> (which hopefully will mean kilo)
19:54:42 <NobodyCam> thats what I thought
19:55:12 <clarkb> the nova bm to ironic job upgrade is in
19:55:22 <NobodyCam> ok with our last 5 minutes
19:55:26 <clarkb> so you can start running it as experimental
19:55:27 <NobodyCam> awesome TY clarkb
19:55:41 <jroll> nice, thanks clarkb
19:55:56 <NobodyCam> clarkb: 'check experimental' to run it
19:56:18 <NobodyCam> ok with our last four minutes:
19:56:19 <NobodyCam> #topic Food for Thought / Open Discussion
19:56:22 <clarkb> yup against grenade devstack and devstack gate iirc
19:56:33 <clarkb> maybe ironic too
19:56:35 <NobodyCam> awesome TY clarkb
19:56:40 <lucasagomes> nicee
19:56:43 <mrda> thanks clarkb!
19:57:09 <NobodyCam> #action test nova bm -> ironic upgrade with 'check experimental'
19:57:39 <NobodyCam> any Food for Thought?
19:57:49 <jroll> I thought I had something... lost it
19:58:15 <NobodyCam> just to toss it out there: https://bugs.launchpad.net/ironic/+bug/1325942
19:58:19 <uvirtbot> Launchpad bug 1325942 in ironic "Ironic should support IPv6" [Wishlist,Confirmed]
19:58:36 <NobodyCam> two minutes
19:58:37 <jroll> NobodyCam: :(
19:58:38 <lucasagomes> hah
19:58:47 <rloo> NobodyCam: kilo
19:58:50 <jroll> we should start puting together things we want to do in paris, soon
19:58:51 <NobodyCam> yep
19:58:58 <NobodyCam> jroll: ++
19:59:14 <lucasagomes> yup +1
19:59:17 <JayF> FWIW; the decom talk from myself and JoshNang was accepted for the Summit
19:59:21 <JoshNang> \o/
19:59:26 <NobodyCam> nice :)
19:59:27 <jroll> we've confirmed from our team that at a minimum, JayF, JoshNang, and I will be there
19:59:37 <dtantsur> jealous :)
19:59:40 <lucasagomes> ah nice!
19:59:47 <JayF> what jroll is saying is his talk was accepted too :)
19:59:51 <jroll> heh
19:59:53 <jroll> :P
19:59:56 <JayF> just apparently learned how to be modest today
19:59:57 <NobodyCam> nice :)
20:00:06 <NobodyCam> and thats time
20:00:12 <NobodyCam> great meeting everyone
20:00:13 <lucasagomes> congrats :)
20:00:14 <jroll> thanks everybody!
20:00:15 <NobodyCam> thank you
20:00:15 <dtantsur> thanks!
20:00:28 <NobodyCam> #endmeeting