19:01:44 <NobodyCam> #startmeeting Ironic
19:01:44 <jroll> lol
19:01:44 <NobodyCam> #chair devananda
19:01:45 <openstack> Meeting started Mon Sep  8 19:01:44 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:46 <NobodyCam> Welcome everyone to the Ironic meeting.
19:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:50 <openstack> The meeting name has been set to 'ironic'
19:01:51 <openstack> Current chairs: NobodyCam devananda
19:02:00 <NobodyCam> Of course the agenda can be found at:
19:02:00 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:02:12 <NobodyCam> #topic Greetings, roll-call and announcements
19:02:33 <NobodyCam> mrda: would you like to do the BIG announcement
19:02:39 <mrda> Sure!
19:02:59 <mrda> So it appears that 4 hours ago the last patch for the ironic driver to land in Nova merged successfully!
19:03:08 <mrda> Wooohooo!
19:03:09 <devananda> \o/
19:03:10 <mrda> \o/
19:03:10 <NobodyCam> :) w00t
19:03:13 <lucasagomes> w00t
19:03:17 <lucasagomes> mrda, now we are waiting ur patch in Ironic to remove the driver from our tree :)
19:03:19 <dtantsur> \o/ \o/ \o/
19:03:23 * adam_g does a dance
19:03:24 <NobodyCam> everyone "AWESOME JOB"!!!!!!
19:03:25 <devananda> many many thanks to everyone - especially mrda - who worked on that
19:03:39 <mrda> lucasagomes: If you would like, I would be pleased to post that patch today :)
19:03:47 <lucasagomes> mrda, +1 all urs
19:03:48 <dtantsur> mrda, yes please
19:03:49 <jroll> NobodyCam: the quotes there makes it sound like sarcasm :P
19:03:56 <devananda> mrda: I've tossed up a patch to devstack to switch - https://review.openstack.org/119844
19:04:01 <dtantsur> we'll be figting for the right to approve it
19:04:09 <NobodyCam> it not!!!! it hounest truth!
19:04:09 <devananda> mrda: we should ensure that passes and merges before removing the code from ironic
19:04:13 <lucasagomes> jroll, lol indeed haha
19:04:21 <mrda> cool, I'll let the channel know once the patch is up for review
19:04:30 * mrda needs to wake up
19:04:51 <NobodyCam> and ofc Welcome back Devananda
19:04:56 <mrda> yay!
19:04:58 <lucasagomes> :) wb
19:05:00 <dtantsur> o/
19:05:07 <linggao> o/
19:05:14 <rloo> who's back? :-)
19:05:15 <devananda> I swear, I'm not that dusty any more ...
19:05:22 <Shrews> was he gone?
19:05:28 <NobodyCam> lol
19:05:31 <lucasagomes> :D
19:05:36 <devananda> Shrews: I'm thrilled that you didn't notice my absense :)
19:05:56 <Shrews> i did notice we were much more productive. maybe coincidence  :P
19:05:59 <devananda> in fact, from everyone i've spoken with and what i've seen, ya'll did fantastic things while I was gone!
19:06:08 <devananda> Shrews: I was thinking the same thing
19:06:20 * devananda wonders if he should take more vacations
19:06:32 <mrda> It's amazing the focus we get at the end of cycles :)
19:06:32 <dtantsur> heh
19:06:38 <JayF> I suspect a correlation with time-since-midcycle
19:06:44 <JayF> moreso than devananda being gone :)
19:06:45 <romcheg1> devananda: We did notice! Meetings were very short :-P
19:06:47 <NobodyCam> #info nova Driver has landed!
19:07:04 <NobodyCam> lol ... I run a tight meeting
19:07:27 <lucasagomes> heh well the last meeting was holiday in US
19:07:29 <devananda> NobodyCam: carry on :)
19:07:36 <NobodyCam> lucasagomes: still up for hte Release cycle progress report?
19:07:55 <lucasagomes> NobodyCam, I think it's devananda, well I can can grab some numbers if needed
19:08:14 <lucasagomes> J3 was tagged already :) and we have 1 bp in the FFE
19:08:19 <NobodyCam> #topic Release cycle progress report
19:08:30 <lucasagomes> which should land till Friday :)
19:08:53 <lucasagomes> #link https://launchpad.net/ironic/+milestone/juno-rc1
19:09:07 <NobodyCam> :)
19:09:13 <lucasagomes> we got 15 bugs open for rc1 right now
19:09:18 <dtantsur> do you have links for remaining patches?
19:09:25 <lucasagomes> dtantsur, will grab it
19:09:42 <lucasagomes> #link https://review.openstack.org/#/c/116561/
19:09:59 <lucasagomes> #link https://review.openstack.org/#/c/118578/
19:10:08 <rloo> so the patches for the BP have to land by Fri or they're out, right? What's the date for RC1?
19:10:30 <devananda> another huge thanks to everyone who worked on reviewing features in Juno3 and making it Ironic's most feature-full milestone ever!
19:10:38 <lucasagomes> rloo, yup, afaict yes
19:10:42 <devananda> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
19:10:43 <devananda> rloo: ^
19:10:44 <NobodyCam> :)
19:11:09 <devananda> RC1 should be tagged around 9/25
19:11:18 <lucasagomes> so yeah that's pretty much it, let's prioritize that blueprint and work on the bugs!
19:11:32 <NobodyCam> great Thank you lucasagomes :)
19:11:49 <NobodyCam> did I see adam_g ?
19:11:56 <adam_g> hi!
19:11:58 <NobodyCam> #topic SubTeam: integration & testing work
19:12:02 <NobodyCam> that you :)
19:12:05 <NobodyCam> hehehe
19:12:12 <adam_g> so just about all of our tempest and grenade work has landed
19:12:24 <adam_g> im working with infra folks today on getting it all enabled in our gate in one way or another
19:12:54 <adam_g> thanks to anyone who helped with the effort
19:12:56 <NobodyCam> awesome
19:13:02 <devananda> adam_g: status on grenade tests? full tempest parallel testing of nova+ironic?
19:13:07 <adam_g> expect to see a non-voting grenade job pop up this week
19:13:17 <devananda> those two things are likely to come up tomorrow in the TC graduation review
19:13:36 <adam_g> tempest should now pass in parallel (with concurrency=2) against ironic now
19:13:43 <adam_g> (with the proper flags set in tempest.conf via devstack)
19:13:53 <Shrews> and with lucasagomes latest patch
19:14:00 <adam_g> Shrews, link?
19:14:04 <Shrews> he found a parallel testing bug
19:14:07 <Shrews> lucasagomes?
19:14:07 <lucasagomes> adam_g, w00t
19:14:11 <lucasagomes> oh lemme get the link
19:14:16 <lucasagomes> but that's unittests
19:14:20 <devananda> adam_g: ooh! great! can we get a job running for that and drop the current tempest job(s) ?
19:14:29 <lucasagomes> #link https://review.openstack.org/#/c/119746/
19:14:31 <adam_g> https://review.openstack.org/#/c/118700/ adds a parallel tempest job that will be experimental until its proven stable
19:14:38 * lucasagomes recheck that after the fix to the sample config
19:14:43 <devananda> adam_g: why not -nv?
19:14:58 <adam_g> devananda, oh, good call
19:15:07 <NobodyCam> +1 for non voting
19:15:40 <adam_g> the grenade work is functional, just pending some infra patches that set the environment correctly for it to pass
19:15:58 <adam_g> https://review.openstack.org/#/c/111859/ should hopefully be approved soon
19:15:58 <devananda> adam_g: "grenade work" - you mean the nova->ironic migration, yes?
19:16:15 <devananda> awesome
19:16:24 <adam_g> grenade work - sideways migration within the juno release from a nova-bm -> ironic
19:16:28 <devananda> adam_g: fwiw, we'll need to look at ironic->ironic grenade testing in Kilo
19:16:41 <adam_g> we're the first project to actually setup this type of sideways migration testing
19:16:44 <devananda> but that should be fairly straight forward
19:16:49 <devananda> much easier than this was :)
19:17:05 <NobodyCam> :-p
19:17:07 <adam_g> yeah, we're setup nicely for that
19:17:31 <NobodyCam> any more quetions / comments for adam_g
19:17:45 <devananda> nope - CI stuff all sounds great to me
19:17:48 <adam_g> also
19:18:03 <adam_g> jroll is working on getting IPA testing rolling in the gate, it looks like he's fairly close
19:18:20 <jroll> yeah
19:18:25 <devananda> jroll: link to info on that if you want me to mention it tomorrow
19:18:35 <devananda> *have a ... ?
19:18:41 <jroll> well, getting there. ran into this thing with preserve ephemeral now
19:18:41 <NobodyCam> oh thats a great segway:
19:18:44 <NobodyCam> #topic SubTeam: Ironic Python Agent
19:18:51 <jroll> devananda: I need to update the ipa-todos pad
19:18:54 <jroll> will do that asap
19:19:04 <devananda> jroll: cool
19:19:15 <devananda> NobodyCam: let's post a few infos first
19:19:22 <JayF> jroll: you probably want to mention https://review.openstack.org/#/c/119869/1 now?
19:19:26 <NobodyCam> #topic SubTeam: integration & testing work
19:19:56 <devananda> #info parallel tempest job has been proposed to infra, will be non-voting until proven stable
19:20:25 <devananda> #info nova_bm -> ironic grenade job is passing, has one +2, waiting for approvals to merge it
19:20:54 <devananda> #info grenade work is also pending some add'l infra patches to set up the env for it correctly
19:20:58 <devananda> NobodyCam: done. thanks :)
19:21:02 <NobodyCam> :)
19:21:09 <romcheg1> I have a question
19:21:10 <NobodyCam> Thank you
19:21:13 <NobodyCam> shoot
19:21:33 <romcheg1> #link https://review.openstack.org/#/c/112575/ It's a flavor migration tool
19:21:40 <romcheg1> Do we still need it?
19:21:56 <romcheg1> A few folks told their concern
19:22:25 <devananda> adam_g: is the grenade test using that?
19:22:28 <NobodyCam> romcheg1: as far a i thought we do still need it
19:22:32 <lucasagomes> last time I reviewed I agreed with adam_g comment there
19:22:58 <Shrews> yeah, i think just documenting is likely better
19:22:59 <NobodyCam> s/far a/far as/
19:23:35 <adam_g> dendrobates, no, grenade is not using that
19:23:44 <adam_g> devananda, ^
19:23:56 <devananda> adam_g: ah, i see. it's doing it directly: https://review.openstack.org/#/c/111859/25/within-juno/upgrade-ironic
19:23:59 <NobodyCam> I kinda like the script vs just documenting how to do it?
19:24:04 <adam_g> adding a script to do that direclty in DB seems like overkill to me, IMO'
19:24:12 <devananda> in function nova_bm_update_flavor()
19:24:28 <devananda> NobodyCam: it's 10 lines of bash
19:24:39 <adam_g> its a single API call vs requiring database access
19:25:32 <devananda> let's punt on this until nova approves and is ready to proceed with deprecation of the nova_bm schema
19:25:34 * NobodyCam only has one flavor so not a issue for him, but others may have many more flavors?
19:25:39 <adam_g> the node migration is more complex and requires migration of database columns to driver info, mapping ports to nodes, etc.  the updating flavor specs is entirely supported by the API.
19:25:53 <devananda> that spec hasn't been approved by Nova yet, so they may say "we dont care how you update flavor" or they may want a script
19:25:55 <NobodyCam> but at 10 lines they can create them selfs
19:26:16 <devananda> NobodyCam: exactly -- a production env could have many more baremetal flavors than our tempest env does
19:26:36 <devananda> NobodyCam: but it would be possible to loop on them in bash ... so maybe 12 lines :)
19:26:49 <NobodyCam> :)
19:27:03 <devananda> anyhow, let's punt on it until Kilo
19:27:05 <NobodyCam> should we move on to ipa?
19:27:10 <devananda> yep
19:27:21 <NobodyCam> #topic SubTeam: Ironic Python Agent
19:27:28 <NobodyCam> jroll: I think thats you
19:27:40 <jroll> hey
19:27:53 <jroll> so first off, we broke the agent driver when we landed ipa/ilo
19:28:03 <jroll> here's a fix, with some tests: https://review.openstack.org/#/c/119869/
19:28:17 <jroll> need that merged quickly, please :)
19:28:19 <lucasagomes> :(
19:28:41 <jroll> besides that, we've been working on getting CI running:
19:28:46 <jroll> simple devstack-gate change: https://review.openstack.org/#/c/119473/
19:29:08 <jroll> this devstack change is approved but going through a million rechecks: https://review.openstack.org/#/c/114408/
19:29:29 <jroll> then the big one for infra config, depends on adam_g's refactor: https://review.openstack.org/#/c/112693/
19:29:42 <jroll> and that will give us jobs on IPA and ironic with tempest and the agent driver
19:29:45 <jroll> *however*
19:30:02 <NobodyCam> #link https://review.openstack.org/#/c/112693
19:30:09 <jroll> turns out we landed 'rebuild --preserve-ephemeral' changes since I started looking at this stuff
19:30:16 <jroll> IPA doesn't support ephemeral volumes, so this fails :(
19:30:52 <jroll> I'd like to find a way to work around this; supporting ephemeral partitions in IPA might be a somewhat large effort
19:31:01 <JayF> jroll: for https://review.openstack.org/#/c/112693 I'd strongly suggest making even the IPA jobs nonvoting to start... and vote on all of them simultaneously... lest we suffer internally the same asymmetric gating problems that ironic does with nova right now
19:31:12 <jroll> JayF: yep, need to change that
19:31:18 <devananda> #info devstack, devstack-gate, and infra-config changes are in flight to enable tempest jobs using the agent driver
19:31:26 <NobodyCam> jroll: is it blantly clear that IPA only supports whole-disk-imgaes, for someone new was just starting to look at itonic
19:31:36 <devananda> #info however, IPA doesn't support ephemeral volumes, and is now failing the rebuild-preserve-ephemeral test
19:32:01 <jroll> NobodyCam: I should check the docs; not sure
19:32:12 * jroll waits for someone to say "what docs?"
19:32:24 * NobodyCam thinks about adding a #action
19:32:25 <jroll> I think the big effort for IPA for the rest of juno should be docs
19:32:34 <JoshNang> +1
19:32:41 <jroll> NobodyCam: go for it
19:32:58 <jroll> (side note, I noticed another meeting review action items at the beginning, we should do that)
19:33:09 <devananda> jroll: ++
19:33:20 <NobodyCam> #action Ipa to review docs for end of Juno / start of Kilo cycles
19:33:26 <jroll> I've always wondered where the #action black hole is :P
19:33:33 <devananda> jroll: differences, such as "IPA only supports whole disk images", really need to be communicated clearly in said docs, too
19:33:49 <devananda> jroll: I'll link after the meeting
19:34:13 <NobodyCam> other questions/ comments for IPA / jroll
19:34:20 <devananda> all the hash-actions show up in the minutes
19:34:29 <jroll> devananda: indeed, it's on our todo list to clearly document pxe / agent differences
19:34:57 <NobodyCam> jroll: can you #link the ipa-todolist here
19:35:08 <jroll> #link https://etherpad.openstack.org/p/ipa-todos
19:35:12 <NobodyCam> Ty
19:35:25 <NobodyCam> go to move on?
19:35:32 <NobodyCam> s/go/good/?
19:35:40 <JayF> Another thing re: IPA worth noting
19:35:55 <JayF> Is that we still do not have DIB elements for IPA
19:36:16 <JayF> which was indicated as a potential requirement for running jobs regularly, because of the lower requirements for ram per vm
19:36:31 <JayF> I know NobodyCam and jroll were looking at this... assuming that effort died?
19:36:46 <NobodyCam> I will pick that back up
19:36:52 <jroll> thanks, NobodyCam
19:36:57 <devananda> #action NobodyCam to resume work on DIB element for IPA
19:36:58 <devananda> :)
19:37:03 <NobodyCam> lol
19:37:05 <NobodyCam> :)
19:37:16 <JayF> I'll help however much I can :) Just let me know if you get stuck or have a problem... although last time I offered this the only thing I learned was that I don't know much about DIB :)
19:37:29 <jroll> JayF: use the source, luke
19:37:34 <NobodyCam> lol
19:37:35 <greghaynes> If you need any DIB help feel free to poke me
19:37:41 <lucasagomes> hah
19:37:54 <NobodyCam> #action nobodyca to poke greghaynes
19:38:00 <greghaynes> splendid
19:38:12 <NobodyCam> gah wanted a space between # and action
19:38:18 <NobodyCam> :(
19:38:19 <NobodyCam> :)
19:38:26 <jroll> lol
19:38:29 <NobodyCam> good to move on :)
19:38:56 <NobodyCam> #topic SubTeam: Bug team
19:39:10 <NobodyCam> dtantsur: I thnink thats you?
19:39:13 <dtantsur> o/
19:39:16 <NobodyCam> think even
19:39:19 <dtantsur> Open: 133 (+2). 9 new (-2), 44 in progress (+4), 0 critical, 14 high (-1) and 4 incomplete (0); juno-rc1: 15
19:39:28 <dtantsur> and I'll be retargetting driver bugs to Nova starting from tomorrow
19:39:42 <NobodyCam> sweet :)
19:39:45 <dtantsur> currently 15 targeted to rc, which looks doable
19:39:56 <dtantsur> we may even add more, I hope
19:40:39 <dtantsur> that's all from me now
19:40:48 <NobodyCam> awesome, so at this point any driver bug SHOULD be filed with nova?
19:40:59 <dtantsur> IMO yes
19:41:02 <jroll> woo
19:41:06 <devananda> NobodyCam: I would say so, yes
19:41:10 <jroll> offload all the work!
19:41:11 <dtantsur> provided we're dropping the code
19:41:21 <rloo> is there a way to tag the ironic bugs with nova? I suspect we'll want to know about those.
19:41:21 <NobodyCam> #info any driver bug SHOULD be filed with nova
19:41:31 <dtantsur> jroll, that's revenge for them retargetting nova-bm bugs :D
19:41:38 <jroll> lol
19:41:39 <devananda> #undo
19:41:40 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x326afd0>
19:41:50 <devananda> #info any bug in the nova ironic driver should be filed with nova
19:42:04 <devananda> NobodyCam: clarified ^ to differentiate bugs in _our_ drivers
19:42:10 <NobodyCam> oh undo I didn't even know that was there
19:42:16 <rloo> I mean, tag the nova bugs related to the ironic driver
19:42:20 <lucasagomes> :O there's an undo command!
19:42:22 <NobodyCam> devananda: ack TY
19:42:26 <dtantsur> I like repr()s: <ircmeeting.items.Info object at 0x326afd0>
19:42:29 <dtantsur> :)
19:42:37 <devananda> rloo: yes -- we should maintain trackign in both projects
19:42:47 * jroll is going to #undo all action items pointed at him
19:42:53 <mrda> lol
19:42:57 <lucasagomes> hah
19:42:57 <NobodyCam> thank you dtantsur :)
19:43:04 <NobodyCam> anythig else for dtantsur ?
19:43:17 <dtantsur> do they have official tag for us?
19:43:26 <devananda> rloo: one could also subscribe to that tag in noav
19:43:28 <dtantsur> by they I mean 'nova'
19:43:28 <devananda> dtantsur: not yet afaik
19:43:40 <dtantsur> would be nice to have for both us and them
19:43:46 <devananda> #action devananda to follow up with mikal to create official bug tag in nova
19:43:55 <NobodyCam> :)
19:44:16 <NobodyCam> I guess no GheRivero_pto
19:44:17 <dtantsur> yeah and please communicate back to me :)
19:44:28 <devananda> dtantsur: ack
19:44:43 <lucasagomes> NobodyCam, I think we agreed last meeting to remove the oslo things from the meeting until K opens
19:44:51 * NobodyCam skips oslo and nova
19:45:01 <devananda> lucasagomes: I dont think we should completely remoev oslo from the agenda
19:45:10 <devananda> because they're still coming out with releases and making some changes, AIUI
19:45:30 <lucasagomes> right
19:45:37 <NobodyCam> devananda: would you like a topic change?
19:45:42 <lucasagomes> yeah it was mentioned on the last meeting we can talk about it later on whether remove it or not
19:45:57 <lucasagomes> but I'm grand leaving it there and just saying "no updates" if there's nothing to say
19:46:11 <devananda> eg, oslo messaging, config, and rootwrap are all currently tagged with "alpha" status
19:46:18 <devananda> so those should be updated prior to Juno release
19:46:28 <NobodyCam> #topic SubTeam: Oslo
19:46:49 <dhellmann> devananda: we're aiming for final releases around 18 sept
19:46:49 <devananda> NobodyCam: no need. w/o GheRivero_pto here to report on it, I dont have anything to add (aside from lets not take it off the agenda)
19:47:05 <devananda> dhellmann: hi there! thanks, that's good to know
19:47:08 <NobodyCam> #info GheRivero on pto no update this meeting
19:47:23 <NobodyCam> :)
19:47:49 <NobodyCam> #topic Outstanding items for graduation
19:47:59 <NobodyCam> devananda: you want this one?
19:48:02 <devananda> sure
19:48:17 <devananda> so I started writing up notes this morning, basically what the TC may want to look at
19:48:20 <devananda> #link https://etherpad.openstack.org/p/IronicGraduationDiscussion
19:48:31 <dhellmann> devananda: http://lists.openstack.org/pipermail/openstack-dev/2014-September/045375.html
19:48:37 <devananda> adam_g: in particular, your input on the QA/CI section would be much appreciated
19:48:48 <adam_g> devananda, ack
19:49:33 <NobodyCam> devananda: what time is the TC / gradution meeting tomorrow?
19:49:37 <devananda> dhellmann: the unknown oslo.db is a bit concerning since we migrated to depend on that
19:49:49 <devananda> NobodyCam: same time as usual: 2000 UTC
19:49:55 <jroll> devananda: want me to add IPA testing stuff to that?
19:49:59 <dhellmann> devananda: I expect 1.0, but didn't catch viktors in time to say so for certain
19:50:21 <devananda> dhellmann: ack. I'm assuming that ya'll will still have something for that timeframe :)
19:50:23 <JayF> I mean, oslo.db migration for Nova got an FFE... hard to imagine it wouldn't be considered ready for Juno
19:50:29 <devananda> right
19:50:31 <NobodyCam> should we (ironic) join the meeting in force ?  would it help / hurt?
19:50:43 <devananda> jroll: no thanks. I'll mention it, but dont expect it to be a graduation-relevant item
19:51:00 <devananda> NobodyCam: not necessary, but anyone is welcome to join
19:51:10 <NobodyCam> :)
19:51:12 <dhellmann> there will be a release of oslo.db, it's just not clear we'll call it 1.0 vs. say 0.5
19:51:30 <devananda> dhellmann: sounds good
19:51:53 <jroll> devananda: ok :)
19:51:56 <devananda> NobodyCam: that's all from me on the graduation front, unless fo,ks have more questions
19:52:09 <NobodyCam> :) thank you devananda :)
19:52:18 <NobodyCam> I'll be at the TC meeting tomorrow
19:52:27 <lucasagomes> so tomorrow is the big day!
19:52:32 <NobodyCam> ok that leaves us 8 minutes for :
19:52:34 <NobodyCam> #topic Food for Thought / Open Discussion
19:52:46 <NobodyCam> lucasagomes: you had a question on the agenda
19:52:47 <wanyen> I  have one thing about ilo driver dib element
19:52:55 <lucasagomes> I added the item to discuss whether we should remove the sample.conf or not
19:52:56 <NobodyCam> Should we remove ironic.conf.sample ?
19:53:10 <jroll> devananda: "TBD: are Nova's notifications sufficient? should Ironic emit notifications for node creation/deletion?" <- yes, so much yes
19:53:11 <NobodyCam> wanyen: sure
19:53:12 <lucasagomes> we discussed a bit on channel, but there's no final decision yet AFAIK
19:53:13 <JayF> wanyen: which diskimage are you wanting to build?
19:53:30 <wanyen> ilo driver still has one dib change to be reviewed https://review.openstack.org/#/c/114124/
19:53:49 <JayF> wanyen: how does the ISO get built for IPA?
19:53:54 <wanyen> This is the change to retreive token fromvfloppy
19:54:02 <devananda> jroll: i'd like to understand the use case for that
19:54:28 <lucasagomes> jroll, resource tracker?
19:54:32 <NobodyCam> wanyen: with out looking at the code behind that patch will it also create the config floppy
19:54:36 <jroll> devananda: "node failed decommissioning" (nova has thrown away the instance by this point)
19:54:50 <wanyen> JayF, we have a script to build iso image from ramdisk & kernel,  Should we give you that script?
19:55:03 <JayF> devananda: I will echo jroll's request for notifications from Ironic directly
19:55:03 <jroll> devananda: more generally, ironic errors/activities that nova doesn't know about
19:55:22 <JayF> wanyen: I'd love for someone to be able to build an IPA ISO out of the imagebuild/ dir in IPA
19:55:42 <wanyen> waht is the best way to get dib reviewers to review ilo dib changes?
19:55:47 <JayF> wanyen: And unless, generally, other people can use IPA as ISO the ilo-ipa driver isn't very useful (unless Ironic does the conversation at some point?)
19:55:57 <devananda> jroll: ah. good point. so it's not about resource creation/deletion, but about state changes that are done either autonomously w/in ironic, or directy at an admin request
19:56:01 <lucasagomes> wanyen, #tripleo channel?
19:56:02 <JayF> wanyen: And for any DIB elements relating to IPA, I have a strong preference to having them landed *in* the IPA repo
19:56:02 <NobodyCam> wanyen: ping folks in #tripleo
19:56:13 <jroll> devananda: indeed
19:56:20 * devananda updates 'pad
19:56:29 <wanyen> JayF, okay.  We will work with you to get the iso script into IPA dir
19:56:30 <jroll> wanyen: greghaynes is one of the reviewers :)
19:56:43 <JayF> devananda: it can be about create/delete as well. For instance, we'd probably consider it an "alert" if Ironic sent out a notify about an instance creation, but didn't have an instance_uuid set
19:56:53 <wanyen> alos, when the documentation due date?
19:57:01 <NobodyCam> as to lucasagomes's question: I like the saple conf but can see that things may be easier with out id
19:57:05 <wanyen> s/eh/sehn is
19:57:06 <NobodyCam> s/id/it/
19:57:13 <wanyen> s /when/when is
19:57:48 <JayF> I am +1 to removing the sample conf from the check/gate job, and +1 to removing it from the git repo entirely
19:58:05 <wanyen> greghaynes, we also like to create a dib element to build iso image
19:58:09 <NobodyCam> fyi: 2 miinutes
19:58:10 <JayF> I can't imagine there being value in us leaving somethign that can happily break our gate without us doing anything when it's already damn hard to get something merged
19:58:13 <rloo> if we don't have the .sample, when people deploy, where will they get a sample .conf to start with?
19:58:27 <lucasagomes> rloo, they can generate it
19:58:30 <greghaynes> wanyen: sounds fun
19:58:35 <NobodyCam> lucasagomes: ++
19:58:39 <dtantsur> re .sample, I'd prefer to have it but now I realize why it should go
19:58:40 <rloo> can you generate it w/o setting up a dev environment?
19:58:46 <lucasagomes> JayF, that's a good point, yeah it breaks w/o we do anything
19:59:00 <lucasagomes> rloo, I don't think so :/
19:59:13 <JayF> I also checked with -infra and we can't have them autocommit it every time
19:59:17 <rloo> so we're asking users of openstack, to set up a dev environment, so they can generate the .sample?
19:59:20 <JayF> they can open a merge req in gerrit, but not a full-merge
19:59:23 <Shrews> sample config makes me feel like this, fwiw: https://www.youtube.com/watch?v=Raf5JdFecPQ
19:59:29 <NobodyCam> maybe we could make the sample a doc vs a file in the repo?
19:59:51 <NobodyCam> about to run out of time
19:59:58 <jroll> anyone that needs to configure ironic should be capable of running 'pip install' and a shell script to generate the config
20:00:01 <JoshNang> i think having it proposed and merging it every so often (and before milestones) would be an easy way to keep it in git?
20:00:08 <NobodyCam> beep
20:00:14 <NobodyCam> thats time
20:00:31 <devananda> rloo: that's what Nova does today
20:00:34 <NobodyCam> can we move back to #ironic
20:00:36 <lucasagomes> aight thanks everyone
20:00:40 <dtantsur> thanks!
20:00:42 <devananda> thanks everyone!
20:00:44 <NobodyCam> thank you all!!!!1
20:00:45 <jroll> thanks :)
20:00:46 <mrda> \o/
20:00:54 <NobodyCam> #endmeeting