19:00:05 <devananda> #startmeeting Ironic
19:00:06 <harshada_kakad> o/
19:00:06 <openstack> Meeting started Mon Oct 6 19:00:05 2014 UTC and is due to finish in 60 minutes. The chair is devananda. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:09 <openstack> The meeting name has been set to 'ironic'
19:00:13 <NobodyCam> o/
19:00:20 <devananda> as usual, our agenda is on the wiki
19:00:22 <devananda> #link https://wiki.openstack.org/wiki/Meetings/Ironic
19:00:33 <devananda> #topic announcements
19:00:47 <devananda> probably something everyone is aware of, but we tagged RC1 last week :)
19:01:02 <NobodyCam> :) w00 h00
19:01:03 <devananda> cheers for all the work fixing bugs lately, folks!
19:01:08 <lucasagomes> great!
19:01:37 <devananda> so, until the final release is tagged on Oct 16th, please test it
19:02:03 <linggao> o/
19:02:14 <devananda> and if you find bugs that are still release critical, please tag them in LP with "juno-rc-potential"
19:02:32 <devananda> after Oct 16th, the tag will become "juno-backport-potential"
19:03:17 <devananda> also, Kilo is now open for specs
19:03:27 <devananda> I posted a few changes to the spec template and its unit tests last week
19:03:52 <NobodyCam> :) and the reviews are already underway. very good job to all :)
19:04:02 <devananda> that's the only release announcement from me. I'll save the discussions of summit for the next topics
19:04:24 <devananda> NobodyCam, lucasagomes: any other annoncements?
19:04:37 <NobodyCam> you covered what I had
19:04:43 <NobodyCam> :)
19:04:46 <lucasagomes> yeah I think we are good
19:04:52 <lucasagomes> can't think about anything else
19:04:55 <devananda> #topic Juno status
19:05:03 <devananda> actually I think I just covered this section ... moving on ...
19:05:07 <devananda> #topic Kilo planning
19:05:20 <devananda> ok! Kilo! so, specs are open :)
19:05:37 <devananda> let's talk a bit about the summit as we now have more details on the scheduling
19:05:56 <NobodyCam> would love more eyes on https://review.openstack.org/#/c/126019/
19:06:02 <devananda> we've got 4 design slots on wed. morning and 1 on thurs. afternoon
19:06:03 <lucasagomes> someone has a link handy to the scheduling?
19:06:14 <adam_g> http://kilodesignsummit.sched.org/
19:06:18 <devananda> #link http://kilodesignsummit.sched.org/
19:06:21 <lucasagomes> cheers
19:06:25 <devananda> #link http://openstacksummitnovember2014paris.sched.org/event/722245d15f368a720d95c9a9bbb77100#.VDLALHWx15Q
19:06:51 <devananda> and
19:06:52 <devananda> #link http://openstacksummitnovember2014paris.sched.org/event/10c3a654c250f60b9efc7f18cd7d2cb8#.VDLoSHWx15Q
19:07:07 <lucasagomes> ouch yeah it conflicts with JayF talks :/
19:07:09 <devananda> I've asked the organizers to bump JayF's talk so it won't conflict with our sessions
19:07:23 <devananda> the reschedule tentatively looks good, but not confirmed yet
19:08:24 <devananda> we also have a slot in the Operator track on Monday, which isn't shown yet on the schedule
19:08:50 <devananda> and a half-day meetup Friday afternoon (again, not shown yet)
19:08:53 <devananda> so
19:09:15 <devananda> I'd like to organize our discussions around that
19:09:35 <devananda> getting operator input Monday, cross project and conference things Tuesday, then most of our sessions on Wednesday
19:09:43 <devananda> and specifically for those things we need to build concensus on
19:09:52 <devananda> like exposing hardware capabilities
19:10:00 <rloo> what is Friday's 'contributors' meetup meant for?
19:10:25 <devananda> rloo: unconference space specifically scheduled for Ironic. we get a room for 3.5hr
19:10:40 <rloo> devananda: thx. a free-for-all then (just joking)
19:10:41 <devananda> we also (like all projects) have a "pod" where we can have unscheduled things
19:10:43 <jroll> read: we all argue about things :)
19:10:54 <devananda> we could just sit together and hack on code
19:11:12 <devananda> or have tea :)
19:11:23 <wanyen> deva, what ironic related topics/event onTuesday afternoon?
19:11:26 <rloo> and croissants
19:11:29 <lucasagomes> sounds like a sample of a mid-cycle :)
19:11:56 <devananda> wanyen: tuesday there is a talk by jroll in the main conference track (I linked it above)
19:12:02 <devananda> wanyen: our design sessions are on wednesday
19:12:24 <wanyen> okay. Ihave a brownbag talk on Tuesday afternoon as well
19:12:34 <jroll> wanyen: have a link?
19:12:46 <wanyen> I nned to find it. hold on
19:13:00 <devananda> any questions / thoughts / comments on the summit -- let's start discussing it
19:13:08 <rloo> devananda: will there be details later wrt what the tues cross-project workshops are?
19:13:21 <devananda> fwiw, for the next two meetings, I expect this to take up a decent chunk of our time
19:13:54 <devananda> rloo: eventually yes. but those might not be set until just a week before the summit
19:14:27 <NobodyCam> should we add a voting coloum to the spread sheet as to what items we want for out sessions?
19:14:32 <devananda> oh, as a reminder, here's a link to our planning doc
19:14:32 <wanyen> jroll: I don't have a link. it's ILo driver talk at 2:30 pm on Tuesday
19:14:33 <devananda> #link https://docs.google.com/spreadsheets/d/1XBKdeDeGfaRYaThjIIoYRwe_zPensECnxsKUuqdoVmQ/edit#gid=0
19:14:36 <lucasagomes> right, so we have 4 slots and lot of items in the spreedsheet
19:14:38 <NobodyCam> #link https://docs.google.com/spreadsheets/d/1XBKdeDeGfaRYaThjIIoYRwe_zPensECnxsKUuqdoVmQ/edit#gid=0
19:14:44 <lucasagomes> we should start voting on them maybe?
19:14:53 <devananda> lucasagomes: 5 slots. 4 are wed. 1 is thurs. (the split is odd...)
19:15:00 <lucasagomes> oh yeah my bad 5
19:15:03 <devananda> I might have forgotten to say that
19:15:28 <NobodyCam> so vote for your top 8 and we'll take the top 5
19:15:30 <NobodyCam> ???
19:15:47 <devananda> vote by adding your name in the "interested" section
19:15:53 <devananda> and keep adding ideas, too
19:15:58 <lucasagomes> right
19:15:59 <wanyen> I plan to enter a few items to the spreadsheet
19:16:04 <lucasagomes> maybe we should merge some of the talks too
19:16:16 <lucasagomes> we did it last summit, if we think that it's small or the topic are related
19:16:33 <NobodyCam> wanyen: please do soon as we are asking folks to vote on items
19:16:37 <devananda> we don't need to settle the schedule until Oct 27, though I'd like to finish it by Oct 25
19:16:54 <JayF> heh, if putting your name in interested is voting
19:16:56 <JayF> then I need to unvote
19:16:58 <wanyen> when will we start vote on the topics?
19:17:20 <jroll> now?
19:17:34 <rloo> dumb question. what is the purpose of the 'design' sessions? I don't recall much design stuff from previous summits.
19:17:37 <NobodyCam> yea there are already names in the interested col
19:17:51 <devananda> rloo: right. well. we should be designing things in those meetings
19:17:55 <wanyen> I will enter my topics tonight
19:18:17 <devananda> for example, at the midcycle we discusssed how we might expose hardware / driver capabilities or properties in a generic way
19:18:29 <devananda> such that Nova flavors could be used to just-in-time reconfigure hardware
19:18:31 <rloo> so we vote on things/features that we know we need/want in ironic, and we discuss the design of those features at the summit?
19:18:38 <devananda> JayF and I have some similar thoughts on this
19:19:00 <devananda> but I dont think it's been widely discussed
19:19:08 <devananda> so the summit might be a good time to discuss that large of a change
19:19:09 <lucasagomes> rloo, that's how I see it yes... tho time is always a problem
19:19:22 * JayF cares more about specific hardware configuration not ending up as a "public" API in Ironic
19:19:25 <NobodyCam> JIT hardware reconfigure
19:19:28 <devananda> whereas. I wouldn't want everyone to spend time discussing the changes for a single driver there
19:19:31 <rloo> it seems to me that the spec process is a good way to get the design down.
19:19:57 <devananda> rloo: I agree - it is usually enough, but sometimes, not
19:20:13 <devananda> rloo: hardware discovery is another one. we've had a LOT of specs for that and no real agreement yet
19:20:24 <rloo> devananda: so we should focus on those features that we think would benefit from people being there.
19:20:35 <rloo> face-to-face, with tomatoes or whatever.
19:20:39 <devananda> exactly
19:20:50 <rloo> gotcha ;)
19:21:16 <devananda> and things which may not require quite as wide an audience could then get scheduled for unconference / hackathon / BoF time
19:22:12 <wanyen> link for the openstack brownbag techtalk schedule http://openstack.prov12n.com/vbrownbag-techtalk-schedule-at-openstack-summit-paris-2/
19:22:27 <NobodyCam> #link http://openstack.prov12n.com/vbrownbag-techtalk-schedule-at-openstack-summit-paris-2
19:22:35 * lucasagomes googles BoF
19:22:47 <devananda> birds-of-a-feather
19:23:03 * dtantsur still does not understand :(
19:23:17 <devananda> BoF = informal after hours have pizza and beer together and talk about something
19:23:27 <devananda> dtantsur: what can I help clarify?
19:23:35 <dtantsur> you just did :)
19:23:42 <devananda> :)
19:23:56 <rloo> and/or on Friday's contributor meetup.
19:24:18 <devananda> oh, also, I'd like to ask everyone - how many folks want to (and what's a good night to) have an Ironic team dinner?
19:24:31 <lucasagomes> +1
19:24:38 <wanyen> +1
19:24:40 <rloo> +1
19:24:41 <devananda> and would folks prefer a proper dinner or an open birds-of-a-feather session?
19:24:56 <rloo> devananda: define them both?
19:25:10 <lucasagomes> both will end up on discussions no?
19:25:17 <devananda> dinner = ironic ATC's get an invite to a restaurant
19:25:22 <NobodyCam> dinner with friends, who may happen to chat about worky things too
19:25:28 <lucasagomes> BoF sounds better to me, informal and we get to talk
19:25:38 <devananda> BoF = we order lots of take-out food to be delivered to the conference hall after-hours and sit around chatting with whoever shows up
19:25:53 <jroll> I'm fine with either, but we should definitely get together
19:26:04 <lucasagomes> +1 jroll
19:26:06 <dtantsur> both sound nice :)
19:26:28 <NobodyCam> if pressed to vote I'd vote informal
19:26:38 <NobodyCam> but am okay with either
19:26:58 <devananda> I've heard two votes for informal, none for formal
19:27:00 * dtantsur has a modification to BoF variant with setting under the Eiffel Tower, but not sure about whether
19:27:08 <dtantsur> * sitting
19:27:12 <devananda> dtantsur: heh. I hear it rains a lot in early November
19:27:38 <devananda> giving it another minute before we move on ...
19:27:42 <rloo> as long ad takeout food is good ;)
19:27:45 <rloo> ad -> as
19:27:50 <lucasagomes> it will be cold too
19:27:50 <dtantsur> rloo ++
19:28:05 <rloo> informal at a restaurant?
19:28:10 <devananda> lucasagomes: yea. cold and rainy.
19:28:26 <lucasagomes> plus loads of people around the tower
19:28:31 <devananda> rloo: that's a party. there are already lots of those planned ;)
19:28:58 <rloo> informal at a restaurant without LOUD music ;)
19:29:12 <devananda> ok, I'll start scheduling a BoF, probably later in the week as Mon-Wed I will probably be busy
19:29:29 <NobodyCam> devananda: ++
19:29:32 <devananda> can't wait to see all of you :)
19:29:41 <rloo> that probably means Thur, cuz Fri evening might not be good.
19:29:41 <devananda> #topic sub team reports
19:29:53 <devananda> adam_g: hi! any news on the CI front?
19:30:07 <adam_g> so im still trying to get our grenade job functional again after fallout from some devstack changes
19:30:16 <adam_g> fixed one issue, but another has slipped through
19:30:42 <adam_g> also going through the parallel failures that are still occurring and trying to do a quick triage of each to see what failures are real and which are transient
19:31:02 <devananda> adam_g: the grenade job will move to stable/juno once that branch is cut, so we just need trunk working for another two weeks, right?
19:31:33 <adam_g> i'd like to propose we get our stuff voting in other projects (namely devstack, tempest, grenade) before we make them voting on ironic. increasing # of running jobs increases the risk of breaking changes merging elsewhere
19:31:35 <devananda> adam_g: actually, nm. juno-rc is tagged on everythign already
19:31:57 <devananda> adam_g: yea, those three ++
19:32:38 <adam_g> are there any issues that would prevent that from happening now that we are fully graduated?
19:33:10 <devananda> adam_g: for devstack/tempest/grenade, none that I know of
19:33:28 <devananda> adam_g: for nova, I *think* it's fine to start voting there too, now, since kilo is open
19:33:50 <devananda> adam_g: nova may or may not want the grenade job to vote on stable/juno -- that's up to them. I think it should, and I think they'll want it to
19:34:03 <devananda> but that's not spelled out in the gov guidelines
19:34:29 <devananda> sdague: if you're around, have a minute to answer test/voting questions?
19:34:51 <adam_g> okay, i'd still like to give the parallel tempest job and grenade a bit to stabilize and find bugs, but the current check-tempest-dsvm-ironic-pxe_ssh has proveb to be stable and should be good to vote
19:35:24 <devananda> adam_g: sounds good
19:35:26 <devananda> dtantsur: how are our bug stats looking?
19:35:40 <dtantsur> pretty well
19:35:42 <dtantsur> Open: 89 (-5). 4 new (+1), 21 in progress (-5), 0 critical, 9 high (-3) and 4 incomplete (0)
19:36:00 <dtantsur> added one about ceilometer fields naming
19:36:00 <devananda> nice
19:36:10 <NobodyCam> great numbers :)
19:36:11 <dtantsur> I'd ask someone to have a look at it
19:36:16 <lucasagomes> :)
19:36:16 <devananda> #link https://bugs.launchpad.net/ironic/+bug/1377157
19:36:24 <uvirtbot> Launchpad bug 1377157 in ceilometer "ipmi sensor naming in ceilometer is not consumer friendly" [Undecided,In progress]
19:36:42 <devananda> ceilometer team seems to agree that it's a bug in their meter naming and, i think, is working on a fix for Juno
19:37:11 <dtantsur> so we can confirm it?
19:37:16 <NobodyCam> devananda: Juno? is there a review?
19:37:30 <lucasagomes> yeah, we may want to mark that as invalid/won't fix for Ironic
19:37:35 <devananda> lucasagomes: ++
19:37:53 <dtantsur> ah, so we can't fix it?
19:37:57 * dtantsur is confused
19:38:18 <devananda> though, also, Jim Mankovich is going to be proposing some changes to Irnoic during Kilo to improve sensor data handling for non-ipmi drivers
19:38:27 <lucasagomes> dtantsur, the bug is not in Ironic, it's the way the data is consumed/transformed in ceilo
19:38:51 <dtantsur> ah I see. won't fix then?
19:38:52 <lucasagomes> NobodyCam, https://review.openstack.org/#/c/126397/
19:39:22 <lucasagomes> dtantsur, +1 for me
19:39:25 <devananda> k, i'll update teh bug in Ironic
19:39:38 <dtantsur> thanks
19:39:39 <devananda> I dont have any other bugs to discuss -- anyone else?
19:39:48 <NobodyCam> ahh ok that was put up today
19:40:01 <dtantsur> also https://bugs.launchpad.net/ironic/+bug/1239481 <-- long-standing, people say it's serious, I don't understand as well :(
19:40:04 <uvirtbot> Launchpad bug 1239481 in neutron "nova baremetal requires manual neutron setup for metadata access" [Undecided,Confirmed]
19:40:17 <wanyen> deva, so for the hw sensor that Jim is proposing should I enter it inthe spreadsheet?
19:40:22 <jroll> does that affect ironic?
19:40:43 <devananda> wanyen: sure, but I suspect it's a fairly simple change and won't need summit discussion time
19:40:52 <wanyen> Yes. It will have someimpact as we want to be able to emit sensors to other destination
19:41:17 <devananda> jroll: you and wanyen / jim should chat about statsd integration
19:41:36 <JayF> that is proposed by aweeks
19:41:38 <JayF> not by jroll
19:41:38 <devananda> dtantsur: that bug is very old. are we sure it's still a problem for Ironic?
19:41:46 <JayF> re: statsd integration
19:41:46 <wanyen> we want to emit data to monasca
19:41:55 <dtantsur> devananda, I am not definitely
19:41:56 <devananda> JayF: ah, right. I keep tagging him for everything ... sorry :p
19:42:18 <JayF> devananda: that's explicitly why I corrected it :P we have a whole group of people here
19:42:38 <lucasagomes> dtantsur, hmm I don't know much about it too... but sounds like something that nova would do when creating the instance, and ports in neutron etc...
19:42:47 <lucasagomes> idk if we can do something in our end to fix that
19:43:22 <devananda> dtantsur: ah, ok. yes, that definitely affects Ironic
19:43:36 <devananda> dtantsur: it will be problematic for any Ironic deployment larger than a single L2 domain
19:44:09 <dtantsur> devananda, mind confirming/triaging please?
19:44:20 <devananda> dtantsur: confirmed. not sure of priority since I'm actually not sure the fix lies within Ironic at all
19:44:34 <devananda> I suspect the fix is "use a neutron plugin that supports your HW switch"
19:44:39 <devananda> but need to dig in more
19:44:56 <dtantsur> well, we need to have some priority IIRC
19:44:58 <devananda> #action devananda to follow up on https://bugs.launchpad.net/ironic/+bug/1239481
19:44:59 <uvirtbot> Launchpad bug 1239481 in neutron "nova baremetal requires manual neutron setup for metadata access" [Undecided,Confirmed]
19:45:05 <dtantsur> cool thanks
19:45:06 <devananda> moving on so we dont run out of time
19:45:10 <dtantsur> that's all :)
19:45:21 <devananda> GheRivero: hi!
19:45:38 <devananda> GheRivero: if you'd like to continue being our oslo liaison - I think taht's great. thanks!
19:46:23 <NobodyCam> +1 vote for GheRivero
19:46:28 <NobodyCam> :-p
19:46:38 <devananda> anyone else want to work with oslo team on osloification of things?
19:47:01 <devananda> ok :)
19:47:04 <rloo> devananda: ? you mean if GheRivero doesn't?
19:47:17 <devananda> drivers! wow, we're running out of time too
19:47:34 <devananda> jroll: wanyen: linggao: hi! any news from the driver side of things?
19:47:46 <jroll> I have nothing afaik :)
19:47:55 <linggao> Hi devananda, nothing new from here.
19:48:23 <devananda> great
19:48:25 <lucasagomes> does that include rpc objects?
19:48:32 <devananda> I know ya'll are working on CI for each of your respective drivers
19:48:33 <lucasagomes> of so I'd like to help to oslofy it
19:48:33 <wanyen> we are doing internal review for the doc. Are there any quideline for vendor driver in terms of what to submit and what to put on the ilo driver wiki?
19:48:40 <lucasagomes> if so*
19:48:50 <devananda> I was pinged by stackalytics folks re: https://wiki.openstack.org/wiki/DriverLog yesterday
19:48:59 <wanyen> I meant docment quideline for vendor drivers
19:49:00 <devananda> so I've posted some initial bits to get that going for Ironic
19:49:37 <jroll> devananda: neat
19:50:11 <devananda> #link https://review.openstack.org/#/c/126369
19:50:20 <NobodyCam> 10 minutes to go before the bell
19:50:22 <devananda> anything wrong there, feel free to tell me or post on top of
19:50:57 <devananda> wanyen: anything a user of the driver would need to know -- like config options, how the environment must be set up (esp. how it is different from other drivers)
19:51:18 <devananda> lucasagomes: you mentioned adding DRAC to the drivers section of the meeting -- I did
19:51:24 <devananda> lucasagomes: but I'm not sure whothe point of contact for that is
19:52:06 <wanyen> deva, tx
19:52:11 <lucasagomes> did I? well ifarkas would be a good point of contact but he's busy
19:52:23 <jroll> devananda: if I make a comment on that review, mind adding some more IPA maintainers?
19:52:25 <lucasagomes> so maybe myself as I have access to a DRAC and can test stuff
19:52:38 <devananda> lucasagomes: ack, thanks
19:52:44 <devananda> jroll: dont' mind at all
19:52:50 <jroll> thanks
19:52:59 <devananda> moving on then
19:53:02 <devananda> #topic open discussion
19:53:18 <lucasagomes> #link https://review.openstack.org/#/c/99426
19:53:25 <lucasagomes> thanks NobodyCam for adding that ^
19:54:21 <NobodyCam> just a open question should test ass items in to the ironic.conf. <- in ref to : https://review.openstack.org/#/c/125361/2/ironic/tests/db/base.py
19:54:46 <NobodyCam> s/ass/add/
19:54:48 <NobodyCam> :-p
19:55:08 <jroll> NobodyCam: nooooo
19:55:14 <lucasagomes> so folks, r you guys happy to remove things like local_gb, memory_mb etc... and have a generic name where we can add suffixes for the values to determine the unit size?
19:55:21 <jroll> ironic.conf.sample should be a good starting point for production use
19:55:24 <jroll> NobodyCam: ^
19:55:32 <devananda> NobodyCam: that's very odd looking to me
19:55:40 <lucasagomes> (ofc we need to leave those options to be backward for cycle at least)
19:55:52 <devananda> lucasagomes: yep. backwards compat ++
19:55:59 <jroll> NobodyCam: there's probably a way to do that
19:56:07 <dtantsur> lucasagomes ++
19:56:16 <NobodyCam> ack just wanted to point that out
19:56:27 <jroll> lucasagomes: I'd like to see the nova driver impact but generally +1
19:56:38 <devananda> lucasagomes: it may be worth noting that our API doesn't expose -any- means to indicate to a user that certain "properties"fields are expected / compatible / deprecated / removed
19:57:15 <lucasagomes> jroll, not much, well... these values comes from the flavor so we just need to change the way we create the json patch in nova (as far as I see it)
19:57:22 <devananda> lucasagomes: something like num_cpu and ram_gb aren't actually used by Ironic today (though they could be in some esoteric hardware) werehas local_gb *is* used
19:57:34 <jroll> lucasagomes: right, the driver would tack on the unit string, yes?
19:57:40 <lucasagomes> devananda, oh yeah, indeed. We can add a doc, and a LOG if those options are used
19:57:40 <devananda> lucasagomes: if we change that, anyone who is not using Nova will be affected and unaware of it
19:57:49 <devananda> jroll: right
19:58:01 <lucasagomes> jroll, yup...
19:58:30 <jroll> I'm still a bit confused why we don't just assume MB everywhere :/
19:58:36 <lucasagomes> also flavors are opinionated about the unit sizes right now (just like we are), so it would patch with memory=512MB for e.g
19:58:41 <lucasagomes> and we convert it in ironic
19:58:44 <devananda> NobodyCam: I think your question is, should CONF options be defined in the unit tests, not how taht relates to our sample config file
19:58:56 <devananda> jroll: because Nova
19:59:14 <jroll> devananda: convert it in the driver
19:59:18 <devananda> jroll: ++
19:59:20 <jroll> either way we're messing with it
19:59:29 <jroll> like... don't see the use case for accepting gb
19:59:30 <devananda> oh
19:59:30 <devananda> so
19:59:33 <lucasagomes> jroll, that was my 2nd attempt of fixing the unit inconsistency (1st was everything GB), but got some push backs... so maybe having it very flexible is good
19:59:39 <NobodyCam> devananda: yes .. much better wording
19:59:43 <NobodyCam> one minute
19:59:46 <devananda> the reason is, we don't SET it from the nova driver, Nova reads it from Ironic
20:00:03 <NobodyCam> beep
20:00:03 <jroll> devananda: ...through the driver interface
20:00:10 <devananda> and we need Nova to understand when it reads "512" from Ironic what that means in terms of its flavors
20:00:20 <devananda> anyhow, lets continue that in channel
20:00:22 <devananda> thanks all!
20:00:25 <dtantsur> thanks
20:00:25 <lucasagomes> cheers
20:00:26 <jroll> thanks
20:00:27 <NobodyCam> great meeting
20:00:30 <devananda> #endmeeting