19:00:24 <NobodyCam> #startmeeting Ironic
19:00:24 <NobodyCam> #chair devananda
19:00:25 <NobodyCam> Welcome everyone to the Ironic meeting.
19:00:25 <openstack> Meeting started Mon Oct 27 19:00:24 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:28 <openstack> The meeting name has been set to 'ironic'
19:00:29 <openstack> Current chairs: NobodyCam devananda
19:00:33 <NobodyCam> who's here
19:00:36 <Shrews> o/
19:00:37 <jroll> \o
19:00:41 <naohirot> Hello all, I'm from Fujitsu. I joined today to learn how the meeting is proceeding. Because I added a new topic, iRMC driver, for the next meeting.
19:00:41 <JoshNang> o/
19:00:42 <yjiang5> hi
19:00:46 <Nisha_> hi
19:01:03 <NobodyCam> hi all, devananda will be a few minutes late this morning
19:01:23 <NobodyCam> Of course the agenda can be found at:
19:01:23 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:01:32 <NobodyCam> #topic Greetings, roll-call and announcements
19:01:53 <NobodyCam> one week until we get to see each other f2f
19:02:11 <jroll> woohoo!
19:02:14 <GheRivero> o/
19:02:15 <devananda> sorry I'm late
19:02:20 <rloo> o/
19:02:27 <NobodyCam> anyone have any announcements of such
19:02:32 <NobodyCam> Welcome devananda :)
19:02:36 <NobodyCam> your nit late
19:02:43 <NobodyCam> not even
19:02:48 <devananda> no announcements here
19:03:08 <devananda> aside from the obvious "omg the conference is next week" general chaos :)
19:03:28 <NobodyCam> awesome.. okay at teh last meeting we decided to keep this meeting focused on summit topics
19:03:41 <NobodyCam> so I am bypassing the normal adgenda
19:03:55 <mjturek> o/
19:04:16 <devananda> we're so organized today, look, I even updated the wiki page to say that!
19:04:25 <NobodyCam> :)
19:04:28 <NobodyCam> heheheh
19:04:43 <jgrimm> o/ late
19:04:45 <devananda> so, in case anyone hasn't seen it, I did post the discussed summit sessions to the official places
19:04:48 <devananda> #link http://kilodesignsummit.sched.org/overview/type/ironic
19:05:03 <NobodyCam> #topic "K" summit planning
19:05:11 <devananda> #link http://kilodesignsummit.sched.org/overview/type/ironic
19:05:22 <devananda> if folks want to discuss those, think there really needs to be changes to the main track agenda, now's the time to speak up
19:05:33 <devananda> I'll give a few minutes for everyone to review
19:05:59 <rloo> it doesn't show the operators' one. That's on Monday, right?
19:06:14 <devananda> rloo: correct. in a different track
19:06:26 <devananda> that link only lists the official "ironic" design track
19:06:34 <devananda> not our sessions in other tracks, sessions of initerst to us, etc
19:06:34 <NobodyCam> rloo: this will: http://kilodesignsummit.sched.org/?s=ironic
19:06:57 <devananda> ah, good link NobodyCam
19:07:05 <rloo> thx NobodyCam. Now I know who devananda is ;)
19:07:14 <NobodyCam> lol
19:07:21 <devananda> there are also some slots in other tracks that don't explicitly say "ironic" which are probably very interesting to some of you
19:07:42 <devananda> nova scheduler discussions, in-project functional testing, docs, etc ...
19:07:56 <devananda> I'm happy to discuss those now, provide links to the ones I know, if that would be helpful to folks?
19:08:05 <NobodyCam> cross project dependices?
19:08:19 <devananda> well 0- not just yet. let's give a few more minutes for everyoneto review the main ironic sessions
19:08:29 <rloo> would it be worth putting links in an etherpad or somewhere accessible when I'm at the summit?
19:08:53 <devananda> rloo: I have found etherpads to be terrible references at a conference
19:09:02 <devananda> they requrie a laptop; accessing them from my phone is bad
19:09:09 <devananda> rloo: so I'd propose we sue https://docs.google.com/spreadsheets/d/1XBKdeDeGfaRYaThjIIoYRwe_zPensECnxsKUuqdoVmQ/edit#gid=101783491 for that
19:09:10 <NobodyCam> I keep getting kicked from them at the conf
19:09:10 <rloo> devananda: ok. that's fine. I'll probably just follow the other ironic folks around anyway :)
19:09:12 <devananda> tab 3
19:09:24 <mtreinish> devananda: I'm not sure how flexible your sched is but there's overlap between your functional test session, nova's, and a similar qa session
19:09:32 <devananda> google spreadsheet is easy to cache
19:09:51 <devananda> mtreinish: indeed there is, thanks for pointing it out
19:10:23 <mtreinish> I also need to bug mikal about it again when he's awake
19:10:27 <devananda> mtreinish: my goal for the ironic session is to discuss hwo we want to implement it
19:10:45 <devananda> whereas I imagine the qa session is broader and will inform what we talk about
19:11:08 <devananda> however, time overlap with Nova is going to be tricky -- I'll need to see if mikal can reschedule his so that some of us can attend
19:11:48 <mtreinish> devananda: yeah the qa is going to be more about how do we migrate from having everything functional black box be in tempest to more spread out in the projects
19:11:57 <mtreinish> and what that means for tempest policy moving forward
19:12:58 <devananda> functional testing of nova.virt.ironic and where that lives is going to be important as well, which is what mikal and I should figure out
19:13:09 <devananda> mtreinish: when is the qa session?
19:13:30 <mtreinish> devananda: the same time as the ironic and nova functional testing ones :)
19:13:46 <mtreinish> http://kilodesignsummit.sched.org/event/9dbde26cced67b54d24176b746d3027e#.VE6ZZ3_tljE
19:13:54 <devananda> oh haha
19:13:56 <devananda> that's terrible
19:14:12 <devananda> i didn't realize the TIME was the same too
19:14:50 <rloo> why isn't the QA one in the cross-project track?
19:14:50 <devananda> mtreinish: you can't bump that to thurs afternoon?
19:15:07 <mtreinish> rloo: there is also a proposed cross project session for functional testing
19:15:20 <mtreinish> rloo: this is more about the specifics of how we change tempest
19:15:28 <devananda> er, i mean wed. afternoon
19:15:38 <mtreinish> devananda: yeah I can move it around a bit
19:15:48 <mtreinish> I just wanted to connect with you and mikal before I do that
19:16:03 <devananda> mtreinish: ironic slots are wed. morning
19:16:28 <mtreinish> ok, well that makes avoiding that conflict easy :)
19:16:45 <devananda> indeed
19:16:58 <devananda> that said, it also means there's no point in us talking about how irnoic will implement it on wed. morning
19:17:32 <NobodyCam> that would free up a slot for something else?
19:17:35 <devananda> NobodyCam: yes
19:18:04 <devananda> NobodyCam: the other angle on that session was going to be how we make Ironic more stand-alone (and thereby how we could test it in such a configuragion)
19:18:15 <devananda> is it worth still having a session to go over that work?
19:18:49 <jroll> devananda: I would love to test ironic standalone
19:19:04 <mtreinish> devananda: well the qa track discussion should be somewhat independent
19:19:16 <mtreinish> because it's more about the tempest policy around removing tests
19:19:25 <jroll> devananda: and/or talk about how we want to do functional testing
19:19:29 <mtreinish> and the criteria for new tests
19:19:31 <jroll> I think it's worth a slot
19:19:55 <NobodyCam> devananda: yes i think so. if we have extra time we ca pick a secondary topic too
19:20:08 <mtreinish> what you guys want to have for your in-tree testing should be fairly ironic specific
19:20:27 <NobodyCam> but I think that will be a largish topic on it own
19:20:49 <devananda> mtreinish: more related to tempest-lib, then?
19:22:16 <devananda> jroll, NobodyCam: cool. taht's my sense as well. I'll update the session title to clarify it
19:22:29 <NobodyCam> :) +1
19:22:45 <mtreinish> devananda: yeah, I imagine the tempest-lib session will decide some of your internal implementation choices
19:22:59 <mtreinish> I'm really hoping the cross project functional testing topic get's picked up
19:23:31 <mtreinish> so we can decide on common framework stuff there and leave the tempest-lib conversation for more the implementation details in tempest->tempest-lib
19:24:48 <devananda> mtreinish: ++
19:25:08 <devananda> are there other conflicts anyone's noticed?
19:27:49 <devananda> (I'll take no answer to mean "no")
19:28:13 <NobodyCam> :)
19:28:19 <devananda> #topic summit extra-curricular activities
19:28:36 <jroll> this is the best part :P
19:28:47 <devananda> I had raised the idea of a team dinner or BoF session a while back
19:28:53 <devananda> before concrete schedules were known
19:29:36 <NobodyCam> Shrews: wants us to drink because he's not going to be there
19:30:17 <devananda> I'm going to be unfortunately busy thurs night with the TC dinner
19:30:20 <jroll> I'd prefer monday or tuesday for a team thing, personally
19:30:21 <JayF> I'd love a team dinner, and for selfish personal reasons would like it to be any day but Wednesday :)
19:30:32 <aweeks> heh
19:30:38 <NobodyCam> dinner may be tuff with all the partys
19:30:41 <devananda> wed. many of us are going to be busy
19:30:42 <jroll> wednesday is the core reviewer party thing
19:30:48 <devananda> jroll: right
19:31:15 <devananda> monday or tuesday would probably be best. I can skip out on some of my obligations those nights
19:31:15 <NobodyCam> mon , tue, and wed are tuff
19:31:21 <NobodyCam> :)
19:31:33 <yjiang5> JayF: Feel so hungry when hearing the dinner discussion.
19:31:44 <NobodyCam> would breakfest work?
19:31:59 <devananda> I'd also be thrilled if ya'll get together w/o me
19:32:10 <devananda> NobodyCam: breakfast may be the best option, schedule wise
19:32:28 <devananda> how about tuesday morning?
19:32:37 <NobodyCam> I could do that
19:32:52 <JayF> Assuming they have breakfast that doesn't consist of a bagutte and/or croissant
19:32:54 <JayF> lol
19:33:17 <jroll> tuesday morning is fine for me
19:33:17 <devananda> can I get a quick count of folks who could make a tuesday 8am breakfast?
19:33:29 <jroll> assuming Shrews doesn't make me drink at breakfast
19:33:35 <jroll> \o
19:33:39 <JoshNang> o/
19:33:40 <JayF> \o
19:33:50 * NobodyCam has been wanting creps for well over a month now
19:34:02 <devananda> #vote should we have a tuesday morning 8am breakfast?
19:34:04 <rloo> maybe (I like to sleep in)
19:34:05 <NobodyCam> o/
19:34:10 <dtantsur> rloo ++
19:34:13 <devananda> hmm. that didn't work
19:34:19 <wanyen> maybe
19:34:23 <jroll> sleeping is overrated :P
19:34:40 <devananda> #startvote should we have a tuesday morning 8am breakfast?
19:34:41 <openstack> Begin voting on: should we have a tuesday morning 8am breakfast? Valid vote options are Yes, No.
19:34:43 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:34:48 <jroll> #vote Yes
19:34:49 <devananda> there we go
19:34:49 <NobodyCam> Yes
19:34:50 <JayF> #vote Yes
19:34:56 <JoshNang> #vote Yes
19:34:57 <NobodyCam> #vote Yes
19:34:57 <devananda> #vote Yes
19:34:58 * JayF hands NobodyCam a #vote
19:35:03 <NobodyCam> lol
19:35:09 <NobodyCam> ty JayF
19:35:33 <devananda> if you would prefer to have a team dinner, vote "no"
19:35:39 <devananda> and I will do a seaprate vote for that
19:35:51 <NobodyCam> we could do both
19:35:55 <JayF> I think we should attempt to have a team dinner, even if folks can't be there
19:36:03 <rloo> #vote No
19:36:10 <dtantsur> #vote No
19:36:37 <devananda> (giving it another 30 seconds)
19:36:54 <wanyen> prefer dinner
19:37:04 <NobodyCam> wanyen: vote no then please
19:37:12 <wanyen> vote No
19:37:37 <devananda> wanyen: you need to use a # mark, like "#vote no"
19:37:50 <wanyen> #vote No
19:37:55 <NobodyCam> :)
19:37:58 <devananda> #endvote
19:37:59 <openstack> Voted on "should we have a tuesday morning 8am breakfast?" Results are
19:38:28 <devananda> ...
19:38:29 <NobodyCam> drum roll
19:38:41 <jroll> must be a heavy db query
19:38:52 <rloo> too many votes... takes longer...
19:38:57 <NobodyCam> lol
19:39:00 <devananda> dramatic pause
19:39:02 <JayF> IRC is tcp, right?
19:39:03 <NobodyCam> hehehhe
19:39:03 <jroll> or maybe rabbit died
19:39:11 * devananda wonders if the bot died
19:39:14 <JayF> Does the robot have a stuck lock?
19:39:35 * devananda counts by hand
19:39:48 <devananda> yes: 5 no: 3
19:39:49 <NobodyCam> luv's tech
19:40:08 <NobodyCam> I would be ok with having both B and D
19:40:10 <devananda> #startvote should we have a Monday evening gathering instead?
19:40:11 <openstack> Begin voting on: should we have a Monday evening gathering instead? Valid vote options are Yes, No.
19:40:12 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:40:13 <JayF> devananda: tht matches my log count
19:40:22 <devananda> JayF: thanks
19:40:24 <JayF> #vote yes
19:40:30 <rloo> #vote yes
19:40:33 <jroll> "instead is a weird word"
19:40:37 * JayF clarifies; he thinks we should have both
19:40:38 <wanyen> #vote yes
19:40:41 <jroll> err.
19:40:46 <jroll> "instead" is a weird word.
19:40:49 <jroll> #vote yes
19:41:02 <devananda> #vote no
19:41:05 <NobodyCam> #vote yes
19:41:19 <rameshg87> #vote yes
19:41:21 <rameshg87> :)
19:41:22 <NobodyCam> though I may not be ableto make it. but will try
19:41:25 <JoshNang> #vote yes
19:41:29 <dtantsur> #vote Yes
19:41:49 <jroll> what else is happening monday night?
19:42:03 <devananda> jroll: there's a booth crawl 5 - 7 or something like that
19:42:11 <jroll> meh :)
19:42:15 <devananda> and some companies have their internal/private get togethers at taht time
19:42:19 <NobodyCam> and hp employee party?
19:42:30 <NobodyCam> ++
19:42:33 <devananda> and at 8pm Mirantis is throwing the underground party
19:42:38 <devananda> http://openstacksummitnovember2014paris.sched.org/event/5c3f044471d857d8cff5de124f838040
19:42:40 <jroll> cool
19:43:15 <wanyen> Can we have dinner on other night?
19:43:29 <devananda> wanyen: only other option for me is friday
19:43:38 <rloo> breakfast might be the best option
19:43:39 <devananda> #endvote
19:43:41 <openstack> Voted on "should we have a Monday evening gathering instead?" Results are
19:43:41 <wanyen> I see
19:43:56 <devananda> bot apparently does not want to tally our votes
19:44:08 <NobodyCam> lol it wants us to have both
19:44:18 <devananda> votes for monday dinner: yes 8, no 1
19:44:25 <devananda> that's a clear winner over breakfast
19:45:06 <devananda> (and I was the only objection)
19:45:09 <devananda> so monday night dinner it is
19:45:15 <devananda> #agreed monday night team dinner in paris
19:45:57 <jroll> fwiw, I'll be going to breakfast tuesday morning and folks are welcome to join me :P
19:46:06 <NobodyCam> jroll: ++
19:46:29 <rloo> are folks going to bail out of dinner if devananda doesn't show?
19:46:48 <JayF> My only concern with devananda not showing
19:46:55 <JayF> is that we might not go to a place I can eat :)
19:46:58 <JayF> hah
19:47:10 <devananda> I'd like to be there :)
19:47:10 <jroll> I'm living on baguettes the entire time
19:47:18 <jroll> and so excited to do so
19:47:19 <devananda> jroll: poison!
19:47:20 <rloo> pain au chocolat :D
19:47:22 <jroll> :D
19:47:38 <devananda> do ya'll want to do something more formal (like, reserve it in advance)
19:47:49 <devananda> or just gather somewhere, wander off, and see what you find?
19:48:04 <JayF> I think that's prudent, especially if you and I are both going to be there and need dietary considerations
19:48:08 <NobodyCam> i'd be up for the see what you find option
19:48:24 <rloo> I think JayF should suggest something
19:49:03 <JayF> rloo: I think someone who can read french should suggest something.... and tell me their rates for being my personal guide all week :P
19:49:13 <devananda> JayF: ++
19:49:19 <NobodyCam> lol
19:49:26 <rloo> I think liver and onions might be gluten free
19:49:35 <jroll> http://glutenfreemom.com/travel_gluten_free/paris/
19:49:38 <JayF> rloo: gravy starts with a roux
19:49:39 <lucasagomes> omg the meeting started already? :( damn DST
19:49:49 * lucasagomes will read the logs
19:49:56 <devananda> lucasagomes: hi there! we assigned you everything :)
19:50:09 <lucasagomes> devananda, hah oh noes
19:50:18 <NobodyCam> lo
19:50:19 <NobodyCam> lol
19:50:32 <jroll> people keep talking about DST, did it change in europe or?
19:50:40 <lucasagomes> yeah, it did yesterday
19:50:43 <jroll> aha
19:50:44 <lucasagomes> but I forgot
19:50:48 <jroll> it changes next week here I think
19:50:48 <devananda> jroll: yes. US time is crazypants
19:50:55 <jroll> time zones are crazypants
19:50:56 <dtantsur> lucasagomes, lol
19:50:57 <jroll> I hate them
19:51:00 <jroll> utc all the things
19:51:04 <devananda> ++
19:51:09 <devananda> jroll: tshirt that
19:51:11 <jroll> (including people)
19:51:12 <JayF> People in US get to escape DST
19:51:13 <jroll> ha
19:51:20 <JayF> because US switches while we're gone, and Paris already switched
19:51:22 <lucasagomes> and it's holiday here so, I wasn't paying much attention to time
19:51:26 <JayF> so we just get slightly asymetric jet lag
19:51:30 <jroll> jet lag will hit harder than DST :P
19:51:43 <devananda> it seems like we're done with that particular discussion
19:51:50 <jroll> indeed
19:51:54 <lucasagomes> yup move on
19:52:04 <devananda> let's follow up with details of when/where via email (directly to folks, not on ML)
19:52:11 <devananda> #topic open discussion
19:52:19 <naohirot> devananda: May I interrupt a little bit? I'd like to have some advice.
19:52:40 <naohirot> I'm preparing the blueprint for iRMC driver. Is there anything else I should do by the next meeting?
19:52:41 <JayF> I'll be putting in the beginnings of a spec for node/hardware capabilities -> https://blueprints.launchpad.net/ironic/+spec/exposing-hardware-capabilities this afternoon, and anyone who wants to help expand on it or work on the implementation is very welcome to
19:52:43 <NobodyCam> I have a general question, how do we handle say blue prints assigned to someone who is not responding
19:53:02 <JayF> other than getting the idea through hand helping reivew, I don't think I'll have time to give hardware capabilities the TLC it will need
19:53:15 <jroll> naohirot: do you know our spec process?
19:53:25 <JayF> so anyone who wants to spend some time on that particular topic, please LMK. I'll make sure the spec is linked into the channel before I leave work today
19:53:32 <lucasagomes> naohirot, submit a spec, and also next week I believe we won't have a meeting because of the summit
19:53:34 <naohirot> a little bit, I'm learning.
19:53:38 <jroll> naohirot: we don't really need to talk about blueprints in meetings, we just get the spec approved and start coding :)
19:53:58 <lucasagomes> naohirot, https://github.com/openstack/ironic-specs/blob/master/README.rst
19:54:01 <naohirot> I know the next meeting is Nov. 17th
19:54:13 <jroll> right
19:54:17 <devananda> NobodyCam: we email them. if someone else wants to work on it and author is non responsive, propose a new BP, or ask me to unassign it
19:54:38 <jroll> naohirot: once you have the spec up for review, we'll start looking at it... feel free to drop a link in #openstack-ironic as well :)
19:54:45 <naohirot> Unfortunately I cannot go to Paris.
19:54:46 <NobodyCam> devananda: this is in ref to cinder stuff
19:55:00 <NobodyCam> this = my question
19:55:04 <naohirot> jroll: Okay
19:55:24 <naohirot> I hope that the summit goes well.
19:55:32 <jroll> :)
19:55:35 <devananda> NobodyCam: I'd ping other cinder cores then, since that's a cinder issue
19:55:54 <devananda> oh, minor announcement - I may not make the Nov 17th meeting
19:56:28 <devananda> NobodyCam or lucasagomes - will either of you be able to lead that one?
19:56:37 <devananda> I will probably be on a plane at that time
19:56:37 <lucasagomes> devananda, yup, no problem for me
19:56:44 <devananda> lucasagomes: great, thanks
19:56:51 <NobodyCam> devananda: https://blueprints.launchpad.net/ironic/+spec/cinder-integration
19:57:17 * lucasagomes adds to the calendar
19:57:29 <NobodyCam> devananda: we got ya covered
19:57:37 <devananda> JayF: if you're proposing a spec that you dont have time to implement, please indicate that lclearly in the "asignee" portion
19:57:57 <devananda> we shouldn't approve the spec until someone steps up to work on tjhe code, IMO, but I can be convinced otherwise
19:58:00 <JayF> devananda: absolutely will; this is w/r/t what we talked about last week
19:58:14 <devananda> JayF: yup. and cheers for working on the spec.
19:58:15 <JayF> devananda: and agree with you about finding someone to shepherd it before approval
19:59:12 <wanyen> NobodyCam,  iLO driver team plan to look into cinder integration in L release
19:59:31 <lucasagomes> oh that's nice, boot from volumes?
19:59:41 <devananda> NobodyCam: fwiw, https://wiki.openstack.org/wiki/Ironic/blueprints/cinder-integration
19:59:49 <wanyen> yes
19:59:50 <devananda> looks like hemna wrote that up about a year ago
19:59:59 <NobodyCam> devananda: thats the soec I was reffering to
20:00:07 <devananda> wanyen: are you working with Walter Boring on that?
20:00:29 <devananda> oops, we're out of time!
20:00:35 <NobodyCam> :)
20:00:39 <NobodyCam> great meeting all
20:00:44 <wanyen> Devananda, not lately.  We had a few meetings about that a while back.
20:00:49 <naohirot> thanks
20:00:50 <devananda> thanks all -- can't wait to see you in Paris next week!
20:00:56 <devananda> #endmeeting