19:00:13 <NobodyCam> #startmeeting Ironic
19:00:13 <NobodyCam> #chair devananda
19:00:13 <NobodyCam> Welcome everyone to the Ironic meeting.
19:00:13 <openstack> Meeting started Mon Nov 17 19:00:13 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:16 <openstack> The meeting name has been set to 'ironic'
19:00:17 <dtantsur> o/
19:00:18 <openstack> Current chairs: NobodyCam devananda
19:00:19 <mrda> o/
19:00:20 <lucasagomes> o/
19:00:22 <JoshNang> o/
19:00:23 <pensu> o/
19:00:23 <yuriyz> o/
19:00:24 <romcheg> o/
19:00:24 <NobodyCam> Of course the agenda can be found at:
19:00:25 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:00:25 <naohirot> o/
19:00:25 <yjiang5> o/
19:00:27 <vdrok> o/
19:00:30 <ChuckC> o/
19:00:34 <NobodyCam> wow big meeting today
19:00:41 <rloo> hi
19:00:48 <NobodyCam> great to see everyone at the summit :)
19:00:57 <NobodyCam> #topic Greetings, roll-call and announcements
19:00:58 <NobodyCam> Roll-call: Who's here for the Ironic Meeting?
19:01:02 <zyluo> o/
19:01:04 <NobodyCam> oh think we just did that one
19:01:09 <JayF> o/
19:01:11 <Shrews> o/
19:01:24 <NobodyCam> announcements:
19:01:24 <NobodyCam> Devananda may be lurking, but I expect he's still traveling.
19:01:40 <harshada_kakad> o/
19:02:01 <adam_g> o/
19:02:01 <NobodyCam> ok we chatted about a new format for the meetings, While its not official I was going to try and hold to the new format
19:02:21 <jroll> \o
19:02:28 <NobodyCam> basicly more talk about specs/reviews and a little less status
19:03:07 <jroll> all +1 here
19:03:13 <lucasagomes> sounds good
19:03:13 <GheRivero> +1
19:03:15 <dtantsur> +1
19:03:18 <pensu> +1
19:03:19 <NobodyCam> I hope every one made it back with out any summit sickness
19:03:26 <jroll> NobodyCam: should we do 5 minutes for updates since we don't have that stuff set up yet? (and it's been weeks)
19:03:37 <NobodyCam> jroll: yep comming up next
19:03:41 <JayF> NobodyCam: You know better than to hope that; hah
19:03:45 <jroll> :)
19:04:11 <NobodyCam> :)
19:04:41 <NobodyCam> ok lets jump in to the old format stuff:
19:04:45 <NobodyCam> #topic SubTeam: status report (deprecated)
19:04:45 <NobodyCam> In an effort to speed the meeting along and promote the new format lets have a
19:04:48 <NobodyCam> cattle call for status updates
19:04:51 <NobodyCam> #topic SubTeam:
19:04:53 <JayF> IPA has updates
19:04:53 <NobodyCam> adam_g: testing
19:04:56 <NobodyCam> dtantsur: bugs
19:04:58 <NobodyCam> Ghe: oslo
19:05:01 <NobodyCam> jroll: IPA
19:05:03 <NobodyCam> Drivers: wanyen, linggao, lucas
19:05:03 <dtantsur> Open: 97 (+9). 3 new, 26 in progress (+5), 0 critical, 10 high (+1) and 4 incomplete /end
19:05:06 <NobodyCam> (sorry of the large paste)
19:05:19 <NobodyCam> dtantsur: +9 :(
19:05:22 <dtantsur> oh, sorry wrong copy-paste
19:05:23 <dtantsur> Open: 100 (+12). 6 new (+3), 29 in progress (+8), 0 critical, 10 high (+1) and 3 incomplete (-1)
19:05:26 <JayF> The agent_ssh tempest jobs are *passing* when using a prebuilt, binary agent (how they run for ironic). Please treat these jobs as voting now.
19:05:31 <lucasagomes> + 12
19:05:40 <NobodyCam> ieek that worse... can we go back to the other one :-p
19:05:45 <wanyen> working on design specs and currently under internalreview
19:06:01 <JayF> I have https://review.openstack.org/#/c/134438/ up to have the agent_ssh-src job fixed, so IPA can then gate on tempest tests, at which point I'll start making the agent_ssh jobs voting as appropriate
19:06:02 <adam_g> I've been spending my AM looking into https://bugs.launchpad.net/openstack-ci/+bug/1393099  hoping to get some patches up to collect more debug info to get to the bottom of it
19:06:07 <uvirtbot> Launchpad bug 1393099 in openstack-ci "test_baremetal_server_ops fails with timeout waiting for provision_state to change" [Undecided,Incomplete]
19:06:17 <lucasagomes> JayF, w00t
19:06:21 <NobodyCam> wayen awesome
19:06:41 <lucasagomes> JayF, are we waiting like a week or so before making it voting?
19:06:43 <NobodyCam> #link https://review.openstack.org/#/c/134438
19:06:56 <JayF> lucasagomes: the agent_ssh job (non-src) has already got quite a bit of good history of passing
19:07:03 <jroll> agent_ssh jobs have been passing for a week or two on ironic changes
19:07:09 <GheRivero> oslo: New libraries out of incubation are on its way: log, context, utils
19:07:09 <NobodyCam> adam_g: thats a odd one
19:07:10 <JayF> lucasagomes: the agent_ssh-src job will run on IPA only, and it's a situation where if it passes once I wouldn't expect it to fail
19:07:12 <GheRivero> oslo: syncing oslo blocked at: config (lucasagomes, solved) and new policy (romcheg)
19:07:18 <jroll> adam_g: got a quick link to your ironic job stats?
19:07:30 <adam_g> #link http://no-carrier.net/~adam/openstack/ironic_gate_status.html
19:07:35 * JayF emphasizes to cores: Please do not approve any changes with tempest agent_ssh failing for a valid reason
19:07:37 <jroll> thanks
19:07:41 <romcheg> GheRivero: Yup, I updated policy patch a few days ago
19:07:51 <dtantsur> JayF, ack
19:07:52 <lucasagomes> JayF, jroll great! yeah we may want to have it voting soonish then
19:08:00 <GheRivero> romcheg: I'm looking at it
19:08:01 <lucasagomes> probably it can be proposed already
19:08:03 <jroll> agent_ssh is on adam's gate status thing
19:08:06 <jroll> and lgtm
19:08:08 <NobodyCam> JayF: I've seen it fail with a rst file change
19:08:09 <GheRivero> romcheg: thx for it
19:08:26 <JayF> lucasagomes: NobodyCam: I am not going to make agent_ssh job voting until IPA itself can gate on it (what the -src tests are for)
19:08:34 <JayF> lucasagomes: NobodyCam: So I hope we can flip that switch this week
19:08:53 <NobodyCam> JayF: :)
19:09:02 <dtantsur> small announcement: ironic-discoverd is now on stackforge, more news coming next week, I hope https://github.com/stackforge/ironic-discoverd
19:09:10 <jroll> \o/
19:09:12 <JayF> dtantsur: I have a question about that
19:09:13 <lucasagomes> nice :)
19:09:17 <jroll> #link https://github.com/stackforge/ironic-discoverd
19:09:17 <mrda> yay!
19:09:19 <NobodyCam> yes great work dtantsur :)
19:09:25 <JayF> dtantsur: ironic-python-agent was put into openstack/ and was immediately made part of the baremetal program
19:09:28 <JoshNang> dtantsur: wooo!
19:09:31 <pensu> Nice :)
19:09:37 <JayF> dtantsur: any reason we haven't taken that aggressive approach with discoverd?
19:09:57 <dtantsur> JayF, we'll consider it later this cycle, that's what we agreed on with devananda
19:10:00 <JayF> dtantsur: was looking under programs.yaml, and don't see any stackforge/ projects officially associated with a program
19:10:07 <JayF> dtantsur: aha, wonderful then :D
19:10:18 <NobodyCam> JayF: we are going to start, is that not what came out of the summit?
19:10:50 <JayF> NobodyCam: I was just asking if not doing all the things was an explict decision or a missed step
19:11:03 <NobodyCam> ahh :)
19:11:06 <JayF> explicit decision is what dtantsur answered with which is fine by me
19:11:18 <NobodyCam> :)
19:11:42 <JayF> just I remember from doing teeth-agent -> ironic-python-agent was something that not many folks knew all the steps up. Was going to offer help if needed P
19:11:44 <JayF> :P
19:12:07 <dtantsur> JayF, thanks, I'll ping you, if we'll be moving on :)
19:12:49 <NobodyCam> ok are there any thoughts on sending status info / updates to the ML before the meeting? and just have a small section where we can discuss any items of consern to folks?
19:13:00 <GheRivero> small announcement: The liaison program has been extended to other projects: QA, Doc, API (lucasagomes), Stable, Vulnerability More info at: https://wiki.openstack.org/wiki/CrossProjectLiaisons
19:13:17 <jroll> NobodyCam: I think we should do it; I think we should make the etherpad today, mail the list that it exists
19:13:26 <NobodyCam> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
19:13:31 <jroll> appoint someone to send out current status report every friday/monday
19:13:46 <jroll> #link https://etherpad.openstack.org/p/ironic-status-report
19:13:46 <JayF> Has anyone laid claim to Vulnerability liason for Ironic?
19:13:48 <jroll> is my proposal
19:13:57 <GheRivero> NobodyCam: There are many subprojects. I prefer an etherpad than a mail report per status
19:14:19 <lucasagomes> jroll, +1 for the etherpad
19:14:21 <jroll> JayF: I spoke to devananda about taking it on, he gave me some reading material, we didn't make it official
19:14:25 <JayF> Aggreggate status to etherpad, email status to list periodically seems like a decent pattern
19:14:47 <JayF> because *nobody* non-Ironic is going to view our etherpads, but our status reports are likely of interest to a wider audience
19:14:50 <JayF> just my $0.02
19:14:58 <jroll> yeah
19:14:59 <jroll> +1
19:15:00 <NobodyCam> jroll: JayF: I'm good with etherpad.
19:15:24 <NobodyCam> (yet another etherpad)
19:15:26 <NobodyCam> lol
19:15:26 <jroll> do we want to have a separate section for IPA or just put it under drivers
19:15:29 <jroll> ?
19:15:45 <NobodyCam> jroll: you really fix in to both?
19:15:50 <dtantsur> white not use existing whiteboard?
19:15:53 <lucasagomes> NobodyCam, jroll JayF we can even use the whiteboard no?
19:15:56 * mrda is waiting for the therpad to load
19:16:00 <lucasagomes> dtantsur, +1
19:16:03 <jroll> could take up lots of space
19:16:06 <jroll> I don't care either way
19:16:13 <jroll> use whiteboard or ref from whiteboard
19:16:17 <rloo> is the whiteboard/etherpad going to contain a history of status', or just the previous week's?
19:16:29 <rloo> I don't what the whiteboard to get cluttered with history of status'.
19:16:30 <mrda> ref from whiteboard +1
19:16:38 <jroll> IMO, should contain just current status
19:16:43 <jroll> current status gets emailed weekly
19:16:45 <NobodyCam> I tend to use the whiteboard for quick status stuff.
19:16:49 <jroll> mailing list archive for old statuses
19:17:01 <JayF> ++
19:17:03 <lucasagomes> sounds good
19:17:08 <NobodyCam> ++
19:17:14 <mrda> +1
19:17:18 <GheRivero> +1
19:17:19 <rloo> if current status only, I'm ok with whiteboard ;)
19:17:25 <dtantsur> +1
19:17:41 <NobodyCam> do we want a offical vote?
19:17:49 <NobodyCam> or hold off untill next week
19:17:59 <rloo> vote on what?
19:18:06 <JayF> sounds like it already passed by acclimation?
19:18:14 <jroll> NobodyCam: let's do this, anyone disagree with this proposal?
19:18:15 * deva__ lurks from his phone
19:18:16 <NobodyCam> using ehterpad/whiteboard
19:18:18 <lucasagomes> yeah seems that we have agreed with it already
19:18:24 <NobodyCam> hey deva__ :)
19:18:28 <NobodyCam> ack.
19:18:37 <jroll> NobodyCam: let's also email what we decide to the list for folks to disagree
19:18:56 <jroll> (I can do that)
19:19:02 <rloo> I don't think deciding on etherpad vs whiteboard requires a vote/email discussion?
19:19:03 <NobodyCam> jroll: you going to handle that?
19:19:04 <dtantsur> yeah, we decided to use ML more
19:19:18 <jroll> rloo: I mean the whole thing in general
19:19:25 <dtantsur> rloo, just communicate so that someone can say nooooooooooooooo
19:19:43 <jroll> while we're on the whiteboard topic, can we delete old gate issues please?
19:19:47 <rloo> no to what? having status' sent in email once/week and not discussing much in meetings?
19:19:58 <deva__> jroll: please do
19:20:17 <NobodyCam> jroll: I would say please lease anything less then a week old?
19:20:19 <jroll> done
19:20:23 <NobodyCam> hehehe
19:20:27 <lucasagomes> I put an email up to discuss the meeting format, people can say no there
19:20:35 <dtantsur> rloo, ^^^
19:20:49 <rloo> so we're talking about a vote to change the meeting format?
19:20:51 <lucasagomes> so far people only +1'ed
19:20:57 <deva__> we also agreed in Paris to start having alternating meeting times, iirc
19:21:05 <mrda> \o/
19:21:09 <NobodyCam> deva__: thats next on my list
19:21:10 <mrda> :)
19:21:16 <NobodyCam> #topic Post Summit Discussion
19:21:22 <NobodyCam> do we want to chat about splitting / alternating the meeting for those folks in
19:21:25 <NobodyCam> out lying time zones.
19:21:33 <deva__> NobodyCam: oh, sorry :)
19:21:37 <NobodyCam> hehehehe
19:21:43 <rloo> NobodyCam: did we have closure on what we just discussed?
19:22:29 <NobodyCam> rloo: I took it as whiteboard for current status, and jroll would be mailing the list for everything else
19:22:34 * NobodyCam *ducks*
19:22:43 <jroll> ogod
19:22:43 <NobodyCam> :-p
19:22:54 <jroll> I mean, I'm pretty good at copy/paste
19:22:56 <rloo> and 'everything else' = = ?
19:23:11 <rloo> am I the only one that seems confused?
19:23:19 <jroll> meaning email the status report weekly
19:23:28 <pensu> rloo: me too, I thought we were going with etherpad!
19:23:34 <rloo> jroll: ah, ok thx.
19:23:39 <lucasagomes> rloo, no I'm a bit confused now... seems we are discussing the etherpad thing still
19:23:39 * NobodyCam backs up
19:23:47 <rloo> ha ha
19:24:00 <jroll> sigh
19:24:04 <NobodyCam> hehehe
19:24:12 <jroll> I have since made the correct categories on the whiteboard and on https://etherpad.openstack.org/p/ironic-status-report
19:24:21 <jroll> so whichever gets the first status update wins
19:24:49 <NobodyCam> so I left off with current status reports going on the whiteboard
19:24:58 <rloo> I thought people wanted to use the whiteboard, not a different etherpad
19:25:01 <dtantsur> ++
19:25:03 <jroll> that's fine with me
19:25:34 <NobodyCam> then each week a copy/paste email would capture the "history" in the mailling list
19:25:51 <wanyen> link to the whiteboard pls
19:25:52 <NobodyCam> have I missed the boat?
19:25:54 <jroll> yes
19:25:59 <jroll> wanyen: https://etherpad.openstack.org/p/IronicWhiteBoard
19:26:00 <lucasagomes> #link https://etherpad.openstack.org/p/IronicWhiteBoard
19:26:06 <NobodyCam> #link https://etherpad.openstack.org/p/IronicWhiteBoard
19:26:09 <NobodyCam> :)
19:26:10 <wanyen> tx
19:26:25 <rloo> here's my understanding then:
19:26:37 <rloo> people put status in whiteboard by XXX hours before weekly meeting
19:26:56 <rloo> Someone sends email at/when weekly with status stuff and clears whiteboard status section
19:27:12 <mrda> rloo: sounds good!
19:27:24 <rloo> repeat weekly
19:27:33 <jroll> agree
19:27:35 <dtantsur> yeah
19:27:37 <lucasagomes> +1
19:27:39 <rloo> jroll to send email about our new process wrt status
19:27:41 <dtantsur> now to define XXX :)
19:27:43 <NobodyCam> yep
19:27:43 <jroll> I say don't clear whiteboard section tbh
19:27:51 <jroll> dtantsur: EOB friday?
19:27:52 <mrda> if it were in it's own etherpad, this process could be automated...
19:28:05 <jroll> I can also send the weekly mail
19:28:06 <dtantsur> jroll, define EOB :)
19:28:14 <rloo> what does EOB mean?
19:28:17 <devananda> on my laptop now so i can actually say things
19:28:20 <jroll> dtantsur: I'm in the last time zone to go EOB
19:28:22 <mrda> End of Beer
19:28:23 <jroll> so EOB for you
19:28:26 <jroll> is fine
19:28:30 <jroll> because that's before EOB for me
19:28:33 <dtantsur> heh ok
19:28:35 <NobodyCam> at the summit we talked about locking the agenda 48 hours before the meeting, not sure thats valid for status
19:28:38 <jroll> until we get a hawaiin
19:28:41 <jroll> hawaiian?
19:28:59 <jroll> NobodyCam: I think that's fine for status
19:29:01 <dtantsur> yeah, locking bug report at Fri may make it incorrect on Mon
19:29:03 * Shrews volunteers to move to Hawaii... for the team
19:29:05 <rloo> i'd prefer some time before the weekly meeting, since who knows if they will always be on mondays
19:29:15 <jroll> then people can come up with questions/issues/etc based on that info
19:29:20 <JayF> How about status report gets sent as soon as meeting is over
19:29:26 <jroll> the point is to not talk about status on monday
19:29:30 <JayF> so if there's anything sticky in the status, it can be brought up in the meeting
19:29:39 <JayF> if not, the info is dissemenated after meeting
19:29:39 <jroll> so it's irrelevant if there is inaccuracies in between
19:29:47 <devananda> JayF: ++
19:29:49 <dtantsur> JayF, if report is made on Fri but sent on Mon, it's stale
19:30:01 <jroll> it will be made immediately before sending
19:30:05 <jroll> whenever we decide that is
19:30:08 <NobodyCam> for status I've actually say somethig like 4 four hours before the meeting to give folks time to look them over
19:30:16 <devananda> status tracked in etherpad, we look at it around the meeting time and only discuss if something looks *wrong*
19:30:19 <devananda> then send it after meeting
19:30:23 <devananda> that sounds good to me
19:30:32 <jroll> fine with me
19:30:34 <dtantsur> then I +1 to forming it 4 hours in advance
19:30:38 <lucasagomes> yeah sounds reasonable
19:30:46 <jroll> and email after meeting?
19:30:50 <NobodyCam> ++
19:30:52 <dtantsur> jroll, yes
19:30:52 <jroll> ok
19:30:52 <lucasagomes> yeah
19:30:55 * jroll makes notes
19:31:18 <NobodyCam> (thnak you for taking notes on this jroll)
19:31:34 <rloo> and whiteboard or non-whiteboard etherpad? (sorry, I have a very short-term memory)
19:31:45 <jroll> whiteboard is fine
19:31:47 <lucasagomes> whiteboard +1
19:31:47 <dtantsur> whiteboard IIRC
19:31:57 <NobodyCam> I'm ok with whiteboard
19:31:58 <devananda> #agreed status reporting to move to an etherpad, updated before meeting. discuss only things which we disagree on. summary gets emailed after meeting
19:32:02 * lucasagomes have too many etherpads open already
19:32:20 <NobodyCam> lucasagomes: +++1
19:32:36 <NobodyCam> ok good to move on?
19:32:44 <rloo> yes
19:32:45 <jroll> +1
19:32:48 <lucasagomes> please
19:33:01 <NobodyCam> do we want to chat about splitting / alternating the meeting for those folks in
19:33:04 <NobodyCam> out lying time zones.
19:33:15 <jroll> yes
19:33:29 <mrda> I have a link: http://www.timeanddate.com/worldclock/meetingtime.html?iso=20141125&p1=5&p2=224&p3=78&p4=179&p5=367&p6=33
19:33:34 <rloo> I think we should, the question is what is the other meeting time?
19:33:36 <jroll> genius, mdra
19:33:44 <NobodyCam> has anyone looked for a free meeting slot?
19:33:47 <mrda> (prepared beforehand :)
19:34:04 <jroll> so, our chairs are both west coast US, usually
19:34:24 <jroll> shall we make one very early and one very late for west coast folks?
19:34:32 <jroll> where "very" is somewhat reasonable
19:34:39 <devananda> i'm fine with lucas chairing an EU-timezone'd meeting, but that doesn't help mrda much
19:34:46 <mrda> I think something only a few hours later would be fine
19:35:06 <mrda> It would hurt our eastern european friends
19:35:10 <devananda> mrda: oh, right. later is better for you, not earlier
19:35:14 <rloo> is the current time up for grabs too? or are we looking to keep this one, add a second one?
19:35:25 <devananda> rloo: add second one, alternate weeks
19:35:36 <devananda> many other projects have adopted that as they grew
19:35:45 * jroll proposes 0000 and 1500
19:35:53 <jroll> 1900 is pretty late for europeans
19:35:55 <rloo> this time doesn't seem to work for either EU (very well) or Australia (bad).
19:36:20 * lucasagomes is looking at the times
19:36:23 <jroll> maybe s/1500/1700/, dunno
19:36:53 <dtantsur> 1500 better then 1700 for me personally :)
19:36:54 <mrda> I can live with one week at 1900 (but in non-summer it's 0430)
19:36:54 <yuriyz> jroll, +1
19:37:18 <jroll> is anyone east coast US?
19:37:24 <jroll> or central time?
19:37:31 <rloo> east coast Canada ;)
19:37:41 <devananda> remember, we'll still only have one meeting per week. so everyone is (probably) going to miss a meeting now and then
19:37:44 <Shrews> jroll: i'm east coast
19:37:49 <jroll> Shrews: rloo: is 0000 too late for you? (7pm)
19:37:54 <mrda> Alternate weeks, 2300 works fine is 2300 for Dublin and 0100 for Kiev
19:38:01 <mrda> though
19:38:12 <Shrews> jroll: honestly, if 15 or 17:00 are proposed, i'd attend those
19:38:14 <rloo> i'm happy attending a meeting once every two weeks
19:38:34 <jroll> ok, then I stand by my proposal and brace for wet cats and other strange objects to be thrown
19:38:41 <lucasagomes> maybe let's put an email to ML to decide it
19:38:48 <lucasagomes> since it's going to affect folks that can't be in this meeting
19:38:49 <rloo> we should have a time that makes folks happy outside of North America
19:38:52 <NobodyCam> 1700 not that far from 1900
19:38:55 <lucasagomes> I think it's fairest to decide on the ML
19:39:05 <jroll> lucasagomes: yes, we should do that regardless but need a couple good proposals first
19:39:13 <devananda> actually, I'd rather not punt that to the ML - it's not a matter of making it perfect for everyone, cause that can't happen
19:39:17 <rloo> I agree with lucas, but in the email maybe suggest some times just to get things heated up, err rolling
19:39:35 <rloo> but lucasagomes is right, folks who might have a say may be sleeping now
19:39:44 <mrda> The current 1900 is hard, but doable.  1700 is a killer :)
19:39:52 <Shrews> don't we have to consider what times are _available_ for the #-meeting channel(s)?
19:39:52 <rloo> at least ask haomeng?
19:40:11 <devananda> Shrews: yup. i was just getting that info
19:40:20 <dtantsur> seems like we can have one US+AU meeting and one EU+Asia
19:40:23 <devananda> it's not obviously listed, but it is available here: https://wiki.openstack.org/wiki/Meetings
19:40:23 <lucasagomes> Shrews, yeah also that, we should take a look at what is available for the openstack meetings
19:40:27 <jroll> yes, we should ask haomeng
19:40:31 <NobodyCam> lucasagomes: are you planning on chairing the "OTHER" meeting?
19:40:37 <lucasagomes> NobodyCam, yup I can do that
19:40:44 <jroll> there's three meeting rooms by now, I'd be surprised if many slots were full
19:40:46 <lucasagomes> (if folks agree with it ofc)
19:40:59 <NobodyCam> csn we ask the chair to get a consences for it and come back with a perposal
19:41:04 <devananda> four, actually
19:41:06 <rloo> 4 meeting rooms
19:41:08 <jroll> wow
19:41:24 <rloo> hey, could always add a 5th room ;)
19:41:27 <NobodyCam> (sorry lucasagomes :-p)
19:41:31 <lucasagomes> NobodyCam, it's all good :)
19:41:56 <lucasagomes> I would like to see who is willing to participate in an alternate meeting
19:42:04 <lucasagomes> and make the best time for the majority
19:42:05 <NobodyCam> but I agree that the folks that care may not be at this meeting
19:42:30 <wanyen> I will ask one iLO driver teammember fromIndia to attend teh alternative meeting time
19:42:39 <JayF> ++ to the idea we have to float this at the ML first, explicitly to catch people who can't/won't attend here
19:42:59 <NobodyCam> lucasagomes: can I give you a action item to see what time folks would like
19:43:02 <devananda> besides haomeng, what other cores or ATCs are active outside of US/EU timezones?
19:43:13 <lucasagomes> NobodyCam, sure, I can put out an email about it
19:43:20 <wanyen> India
19:43:23 <devananda> ah - wanyen, thanks! what is the UTF offset there?
19:43:29 <devananda> * UTC
19:43:36 <rloo> besides mrda too?
19:43:40 <wanyen> I don't know
19:43:44 <zyluo> 15 17 sounds good for PRC
19:43:45 <lucasagomes> there's also some people in japan takada
19:43:48 <lucasagomes> and haomeng
19:43:50 <rloo> yuiko?
19:43:54 <devananda> rloo: mrda is here to represent himself :)
19:43:54 <lucasagomes> rloo, yeah
19:43:58 <naohirot> devananda: Hi, I'm in Japan
19:44:05 <lucasagomes> naohirot, is in japan too
19:44:11 <lucasagomes> oh yeah :)
19:44:14 <devananda> naohirot: hi! thanks for speaking up :)
19:44:18 <mrda> Japan, Australia and China line us nicely
19:44:19 <rloo> (oh yeah, hi mrda)
19:44:21 <naohirot> lucasagomes: :-)
19:44:22 <NobodyCam> hi naohirot :)
19:44:34 <harshada_kakad> india
19:45:23 <devananda> http://www.timeanddate.com/worldclock/meetingtime.html?iso=20141125&p1=5&p2=224&p3=78&p4=179&p5=367&p6=33&p7=44&p8=248
19:45:24 <rloo> there doesn't seem to be much 'daytime' overlap between dublin and eg beijing
19:45:27 <devananda> I added mumbai and tokyo
19:45:46 <jroll> rloo: agree
19:45:47 <zyluo> please add china also
19:46:08 <rloo> isn't beijing in china?
19:46:10 <jroll> that's why I think 1500-1700 and 0000-0200 are ok
19:46:38 <jroll> UE/EU and US/Others, respectively
19:46:38 <devananda> 17:00 and 5:00 UTC
19:46:45 <zyluo> rloo, oh didn't see that.
19:46:57 <NobodyCam> lol just fyi less then 15 minutes left
19:46:57 <jroll> devananda: who would chair 0500?
19:46:59 <devananda> 5 UTC is just the tail end of being attendable by crazy US west coast people (9PM for us)
19:47:11 <jroll> oh, right, crazy people :)
19:47:23 <devananda> but catches everyone else at good daytime hours
19:47:34 <wanyen> what is west coast time for 5:00 UTC?
19:47:38 <devananda> 9PM
19:47:50 <wanyen> that should works for Inida folks
19:47:52 <dtantsur> 17:00 UTC sounds nice
19:48:12 <rloo> how does 17 utc work for Beijing/Tokyo?
19:48:18 <lucasagomes> dtantsur, +1
19:48:24 <jroll> rloo: 1am/2am
19:48:35 <rloo> jroll: aren't they sleeping then?
19:48:41 <zyluo> rloo, better than the current meeting time
19:48:42 <jroll> beijing/yokyo would be on the 5am UTC meeting
19:48:47 <mrda> 17utc == 1am beijing and 3:30 for adelaide
19:48:49 <jroll> tokyo*
19:48:49 <dtantsur> though it's go-home time, so will have to leave either earlier or later, but that's not a concern
19:48:50 <devananda> rloo: 5:00 UTC is 1pm beijing 2pm tokyo
19:49:00 <jroll> oh wow
19:49:02 <jroll> I can't read
19:49:04 <jroll> sorry
19:49:28 <lucasagomes> what about 9 utc?
19:49:40 <rloo> devananda: yes, 5 UTC looks good. I didn't see how 17 UTC would work.
19:49:45 <mrda> is there great dissention from leaving this timeslot ewhere it is, and adding 0500UTC ?
19:50:02 <devananda> lucasagomes: 9 UTC is too late for anyone in US
19:50:25 <devananda> mrda: so 0500 and 1900 ?
19:50:26 <dtantsur> rloo, 17 UTC works for EU and Asia, no?
19:50:28 <lucasagomes> devananda, I see, 5 utc is quite early for me
19:50:37 <lucasagomes> but ok
19:50:55 <mrda> 5 and 19 is doable for me - I'd make both.
19:51:13 <mrda> (even though 19 is early)
19:51:22 <rloo> dtantsur: 17 UTC = 5pm dublin, 1am beijing, 2am tokyo...
19:51:44 <Shrews> i would miss the 5, but rather attend the 19
19:51:54 <Shrews> so i'd become a European  :)  which is fine
19:51:58 <dtantsur> Shrews, +1
19:52:04 <yuriyz> +1
19:52:19 <dtantsur> rloo, 19 is even worse for them
19:52:34 <devananda> 1900 is the current meeting time, fwiw
19:52:53 <rloo> dtantsur: I'm not even sure what is going on now ;)
19:52:59 <dtantsur> heh
19:52:59 <lucasagomes> hah yeah... I think people are talking in different tzs here
19:53:03 <lucasagomes> let's decide it in UTC please
19:53:07 <jroll> ^
19:53:09 <Shrews> oh, i mixed up the proposed times. either way
19:53:12 <NobodyCam> lucasagomes: ++
19:53:18 <jroll> 7 minute warning
19:53:24 <devananda> ok
19:53:38 <devananda> I'll email two options to the list
19:53:49 <jroll> thank you!
19:53:51 <devananda> it sounds like there's general agreement on "this is a good thing"
19:53:53 <NobodyCam> devananda: awesome Thank you
19:54:11 <lucasagomes> yeah I think it's good, I'm very interested to know who are willing to participate and all
19:54:26 <NobodyCam> devananda: want a action?
19:54:32 <devananda> #action devananda to propose two (specific) time slot combinations to the ML
19:54:35 <NobodyCam> :)
19:54:41 <devananda> let's move on ...
19:54:51 <NobodyCam> #topic spec / review discussion: The new state machine
19:54:52 <NobodyCam> #link https://review.openstack.org/#/c/133828
19:55:25 <NobodyCam> I saw several questions last week in channel about this
19:56:02 <yjiang5> I'm one of them :) I just thought we push too much into the provision state, which will be used by provision tools like nova.
19:56:05 <NobodyCam> the main one concern was are we over loading provision state, (how) will this impact Nova?
19:56:36 <NobodyCam> can we tackel that in 4 minutes
19:56:58 <dtantsur> I honestly think that we had enough discussion on the summit :-/
19:56:59 <jroll> I kind of doubt it
19:57:00 <NobodyCam> also there are open discussion itiems on the agenda
19:57:05 <jroll> we did discuss this point at the summit, no?
19:57:20 * jroll currently has a bad memory
19:57:24 <lucasagomes> seems so... and I don't know how much it would affect nova
19:57:36 <devananda> jroll: i do not recall it, no
19:57:37 <yjiang5> jroll: sorry, I didn't attend the summit, and I didn't say this was discussed in the spec.
19:57:39 <lucasagomes> cause states like ENROLL, INIT, DISCOVERING not won't see it
19:58:02 <jroll> ok, sorry
19:58:05 <lucasagomes> nova won't*
19:58:26 <devananda> yjiang5: IIUC, you're suggesting we represent the new states with a different interface
19:58:31 <devananda> not provision_state
19:58:46 <dtantsur> the only change to nova should be using AVAILABLE instead of NOSTATE, right?
19:58:52 <devananda> dtantsur: nope
19:58:54 <yjiang5> devananda: : yes, something like that.
19:59:08 <NobodyCam> one minute
19:59:09 <dtantsur> yjiang5, that what's the provision_state of node under discovery?
19:59:13 <devananda> dtantsur: nova will also need to learn what the other states are, and what to "do" with them
19:59:22 <devananda> is a node in "zapping" available for scheduling new instances on?
19:59:31 <JoshNang> i'd hope not!
19:59:33 <dtantsur> devananda, no, it's not
19:59:34 <devananda> right
19:59:40 <devananda> that was a rhetorical question
19:59:41 <NobodyCam> is a node in zapping billiable
19:59:52 <dtantsur> select node from nodes where state=AVAILABLE :)
19:59:54 <devananda> i mean, we have to make the Nova driver understand this
20:00:06 <devananda> and we need to consider backwards compat // upgrade paths
20:00:11 <NobodyCam> thats our time
20:00:12 <lucasagomes> IIRC available is the state where nova look at to schedule things on it
20:00:13 <devananda> and third party tools
20:00:16 <yjiang5> devananda: yes, and the 'undertand' may means "don't need care".
20:00:23 <devananda> yjiang5: right
20:00:27 <lucasagomes> yeah backwards compat will be a problem we need to discuss it further
20:00:31 <lucasagomes> in the channel :)
20:00:33 <devananda> ok - let's continue this on the spec or ML
20:00:37 <lucasagomes> meeting's over
20:00:39 <ChuckC> sorry to interrupt, but i have a quick plea for attention on http://lists.openstack.org/pipermail/openstack-dev/2014-November/050329.html
20:00:42 <devananda> yjiang5: thanks for bringing up the concern
20:00:43 <lucasagomes> devananda, spec +1
20:00:49 <harshada_kakad> #limk https://review.openstack.org/#/c/132628/
20:00:51 <yjiang5> devananda: :)
20:01:04 <NobodyCam> ChuckC: lets take a look in channel
20:01:07 <harshada_kakad> i would like to review someone
20:01:26 <NobodyCam> #link https://review.openstack.org/#/c/132628
20:01:29 <NobodyCam> thank you all
20:01:30 <sdake> is this meeting about to end, or just getting started?
20:01:38 <NobodyCam> ending
20:01:41 <sdake> thanks
20:01:53 <NobodyCam> #endmeeting