#openstack-meeting-3: ironic

Meeting started by devananda at 17:02:09 UTC (full logs).

Meeting summary

  1. announcements (devananda, 17:02:23)
    1. https://wiki.openstack.org/wiki/NeutronKiloProjectPlan (naohirot, 17:05:06)
    2. As we are now alternating weekly times, next week's meeting is at 0500 UTC Tuesday (or 2100 PST Monday) (devananda, 17:06:17)
    3. https://wiki.openstack.org/wiki/Kilo_Release_Schedule (devananda, 17:07:50)

  2. subteam status (devananda, 17:08:24)
    1. https://etherpad.openstack.org/p/IronicWhiteBoard (devananda, 17:08:51)

  3. changes to the 'maintenance mode' API (devananda, 17:13:45)
    1. https://review.openstack.org/#/c/136934/ (devananda, 17:14:09)
    2. AGREED: keep both endpoints for now, plan to drop the old one (if/)when we have a v2 API (devananda, 17:23:56)

  4. discovery is blocked on the state machine (devananda, 17:24:10)
    1. question deferred until later in the agenda (devananda, 17:27:16)
    2. arbitrary driver compositing is a good goal, but not there today (and unlikely for this cycle, given other work) (devananda, 17:33:06)
    3. adding an IntrospectionInterface increases the number of entries in the driver namespace, but it's a good thing regardless (devananda, 17:33:58)
    4. AGREED: add new IntrospectionInterface (devananda, 17:34:12)

  5. adding PUT support for API resources (devananda, 17:34:51)
    1. https://review.openstack.org/#/c/130228/ (vdrok, 17:35:17)
    2. https://tools.ietf.org/html/rfc6902 <-- JSON PATCH rfc (victor_lowther, 17:39:17)
    3. https://github.com/stefankoegl/python-json-patch (lucasagomes, 17:39:51)
    4. https://github.com/stefankoegl/python-json-patch/blob/master/doc/commandline.rst (jroll, 17:42:57)
    5. no agreement on whether we should or shouldn't have PUT, but also, no clear need for it. deferring any further discussion (devananda, 17:53:23)

  6. new state machine (devananda, 17:53:38)
    1. http://upload.wikimedia.org/wikipedia/commons/thumb/c/cf/Finite_state_machine_example_with_comments.svg/244px-Finite_state_machine_example_with_comments.svg.png (lucasagomes, 17:58:41)
    2. http://en.wikipedia.org/wiki/Finite-state_machine#Concepts_and_terminology (lucasagomes, 17:59:27)


Meeting ended at 18:00:49 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. devananda (101)
  2. lucasagomes (61)
  3. jroll (57)
  4. victor_lowther (37)
  5. NobodyCam (28)
  6. rloo (27)
  7. dtantsur (15)
  8. vdrok (11)
  9. naohirot (9)
  10. Nisha (6)
  11. openstack (5)
  12. Shrews (5)
  13. yuriyz (4)
  14. zyluo_ (2)
  15. ChuckC (2)


Generated by MeetBot 0.1.4.