17:02:32 <NobodyCam> #startmeeting Ironic
17:02:32 <openstack> Meeting started Mon Mar 23 17:02:32 2015 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:32 <NobodyCam> #chair devananda
17:02:32 <NobodyCam> Welcome everyone to the Ironic meeting.
17:02:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:36 <openstack> The meeting name has been set to 'ironic'
17:02:37 <jroll> \o
17:02:37 <openstack> Current chairs: NobodyCam devananda
17:02:43 <NobodyCam> Of course the agenda can be found at:
17:02:43 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
17:02:47 <dtantsur> o/
17:02:49 <jlvillal> \o/
17:02:51 <clif_h> p/
17:02:53 <stendulker> o/
17:02:54 <clif_h> o/
17:02:59 <TheJulia> o/
17:03:04 <NobodyCam> #topic Greetings, roll-call and announcements
17:03:04 <rloo> hi
17:03:04 <NobodyCam> Roll-call: Who's here for the Ironic Meeting?
17:03:06 <NobodyCam> lol
17:03:09 <krotscheck> \o/
17:03:10 <JoshNang> o/
17:03:11 <Shrews> ohai
17:03:18 <jlvillal> o/
17:03:18 <NobodyCam> hey all :)
17:03:19 <BadCub> heya
17:03:22 <JayF> p/
17:03:29 * krotscheck is a turing machine.
17:03:38 <rloo> q/
17:03:49 <NobodyCam> :)
17:04:03 <JayF> win 38
17:04:07 <JayF> sorry
17:04:08 <NobodyCam> ok looks like we have a full agenda today
17:04:12 <NobodyCam> #topic announcements:
17:04:14 <NobodyCam> as Devananda posted he is in Grenoble. , I hope he's having fun :)
17:04:20 <jroll> JayF: wow, ditching the meeting already
17:04:40 <NobodyCam> Feature freeze in effect
17:04:45 <NobodyCam> #link https://wiki.openstack.org/wiki/FeatureFreeze
17:05:00 <rloo> NobodyCam: also string freeze and dependency freeze
17:05:13 <rloo> https://wiki.openstack.org/wiki/StringFreeze
17:05:20 <rloo> https://wiki.openstack.org/wiki/DepFreeze
17:05:21 * krotscheck read that as string cheese.
17:05:25 <NobodyCam> rloo: yes:
17:05:36 <NobodyCam> #link //wiki.openstack.org/wiki/StringFreeze
17:05:41 <NobodyCam> #link //wiki.openstack.org/wiki/DepFreeze
17:05:47 <jroll> krotscheck: mmm, now I want string cheese
17:05:51 <jroll> NobodyCam: http
17:05:51 <NobodyCam> Thank you rloo
17:05:54 <NobodyCam> :-p
17:06:14 <NobodyCam> ok for my announcement
17:06:47 <rloo> on IRC last week, devananda mentioned that even with string freeze, it was ok to approve string changes 1-2 days after kilo-3. Anyone know if it is too late now?
17:06:49 <NobodyCam> I wanted to thank EVERYONE for the awesome effort last week landing everything for K-3
17:06:58 <NobodyCam> Thank you one and all
17:07:06 <rloo> +100 NobodyCam
17:07:19 <jroll> rloo: probably a question for the i18n team
17:07:21 * BadCub seconds that! everyone was totally awesome :-)
17:07:29 <rloo> jroll: ack
17:07:51 <NobodyCam> thats it for me and announcements anyone else have any?
17:08:37 <rloo> NobodyCam: what about specs for L*?
17:08:38 <NobodyCam> if not we'll move on to:
17:08:48 <NobodyCam> oh
17:08:57 <rloo> NobodyCam: I mean, are we going to announce when/if specs are open for L*?
17:09:11 <NobodyCam> rloo: as in they are not open yet or bumped spec from K
17:09:29 <jroll> when do they open, is the quesiton
17:09:31 <NobodyCam> rloo: I do not think they are open... are they?
17:09:36 <rloo> NobodyCam: yeah. I don't even remember the process for specs-approved-in-K. what do they do?
17:09:48 <rloo> NobodyCam: I don't know if they are open. That's what I'm asking.
17:10:09 <rloo> NobodyCam: maybe make it an action item for that-person-in-grenoble-right-now?
17:10:13 <NobodyCam> I don't think we have opened L spec yet.
17:10:19 <dtantsur> I guess we ask the authors to move a spec to L directory
17:10:27 <dtantsur> (and rereview it quickly)
17:10:30 <NobodyCam> I will see what I can do to track down the date for that
17:10:30 <jroll> maybe let's bump this to open discussion? we talked about it some last week. can push devananda to send an email tomorrow
17:10:36 <rloo> BadCub: do you remember? I saw some IRC chatter about it.
17:10:43 <BadCub> there was some discussion last week
17:10:52 <NobodyCam> jroll: ++
17:10:56 <BadCub> devananda: was saying we need to move specs to L folder
17:11:43 <rloo> NobodyCam: would you take an action item to track down the details and send email to the mail list about it?
17:11:51 <NobodyCam> #action Nobodycam find out when specs for L open
17:11:57 <NobodyCam> :)
17:12:02 <rloo> thx NobodyCam!
17:12:15 <NobodyCam> anything else for #topic SubTeam: status report (deprecated)
17:12:23 <NobodyCam> gah
17:12:33 <BadCub> NobodyCam: if you want, I can take that action and follow-up with devananda
17:12:48 <NobodyCam> thank you BadCub
17:13:02 <NobodyCam> #undo
17:13:02 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9228750>
17:13:14 <NobodyCam> #action badcub find out when specs for L open
17:13:36 <NobodyCam> ok anything else for announcements?>
17:14:07 <rloo> there is an etherpad wrt summit.
17:14:26 <rloo> but i don't have the link.
17:14:31 <jlvillal> https://etherpad.openstack.org/p/ironic-liberty-priorities
17:14:39 <jlvillal> https://etherpad.openstack.org/p/liberty-ironic-design-summit-ideas
17:14:41 <NobodyCam> #link https://etherpad.openstack.org/p/liberty-ironic-design-summit-ideas
17:14:56 <NobodyCam> #link https://etherpad.openstack.org/p/ironic-liberty-priorities
17:15:04 <rloo> thx
17:15:18 <NobodyCam> ok moving on.
17:15:20 <NobodyCam> #topic SubTeam: status report (deprecated)
17:15:21 <NobodyCam> Whiteboard wiped out, no posted status
17:15:35 <adam_g> I've been working on testing the API microversioning within tempest and as part of the ironicclient functional test suite. patches here, comments welcome: https://review.openstack.org/#/c/166386/ https://review.openstack.org/#/c/165665/
17:16:16 <NobodyCam> adam_g: you have a line item for that later on down the lisr
17:16:18 <NobodyCam> list even
17:16:21 <jroll> I don't think there's any big news for IPA
17:16:26 <adam_g> NobodyCam, oh!
17:16:29 <jroll> JoshNang: did the IPA cleaning patch ever land?
17:16:36 <JoshNang> jroll: it did!
17:16:39 <jroll> sweet.
17:16:42 <JoshNang> like, 40 hours after approval
17:16:51 <NobodyCam> :( ugggh
17:17:03 <rloo> JoshNang: did it make it in k-3?
17:17:30 <JoshNang> rloo: it's in IPA, i don't think we have a k-3 release
17:17:47 <rloo> JoshNang: oh, right! (phew)
17:17:49 <JoshNang> cleaning made it for k-3 in ironic, waiting on the nova patches for rc1
17:18:20 <NobodyCam> JoshNang: I have not look at those this morning are they still on track?
17:18:28 <NobodyCam> (the nova patches)
17:18:39 <BadCub> so far no activity on those (nova) patches
17:18:48 <JoshNang> NobodyCam: i have to push up a fix for a variable name after the meeting
17:18:57 <NobodyCam> ack :)
17:18:59 <JoshNang> but yeah, no attention yet. i'll ping in channel
17:19:08 <NobodyCam> awesome thank you :)
17:19:25 <NobodyCam> dtantsur: do you haev a bug status?
17:19:40 <dtantsur> Open: 148. 7 new, 34 in progress, 1 critical, 14 high and 12 incomplete
17:19:47 <dtantsur> no diff today - lost previous version
17:20:12 <NobodyCam> ya fungi is looking into what happened to our WhiteBoard
17:20:14 <rloo> Open: 145 (+12)
17:20:14 <rloo> 10 new (+7), 33 in progress (+1), 0 critical, 16 high (-1) and 10 incomplete (+2)
17:20:15 <rloo> previous week was
17:21:10 <NobodyCam> we'll be talking detail about some of those in the next section
17:21:23 <NobodyCam> thank you rloo
17:21:54 <NobodyCam> anything from driver status updates?
17:22:36 <jroll> nothing notable for IPA off the top of my head
17:22:40 <jroll> except cleaning support!!
17:22:47 <NobodyCam> :) w00 hoo
17:23:35 <BadCub> I will be hunting down drivers that are not listed on https://wiki.openstack.org/wiki/Ironic/Drivers and asking folks to update
17:23:47 <NobodyCam> ok then I expect the next section will take a bit so we'll move on to
17:23:55 <NobodyCam> BadCub: awesome.
17:24:00 <NobodyCam> thank you
17:24:07 <NobodyCam> #topic RC1 status check.
17:24:09 <NobodyCam> Goal is April 9 to cut rc-1. - https://launchpad.net/ironic/+milestone/kilo-rc1
17:24:32 <NobodyCam> looks like 11 bugs tagged for rc-1 most in progress
17:24:46 <NobodyCam> we have four currently unassigned, anyone
17:24:47 <NobodyCam> looking for something to do, volunteers?
17:24:55 <NobodyCam> #link https://launchpad.net/ironic/+milestone/kilo-rc1
17:26:06 <NobodyCam> two High and Two medium need eyes according to the status link
17:26:23 <jroll> I know deva and adam_g were hacking on https://bugs.launchpad.net/bugs/1433727
17:26:24 <openstack> Launchpad bug 1433727 in Ironic "partial upgrade not possible, 'reason': u'Unknown argument: "configdrive" (HTTP 400)'" [High,Confirmed]
17:26:56 <jroll> also I've never seen this one to be a huge problem: https://bugs.launchpad.net/ironic/+bug/1308680
17:26:56 <openstack> Launchpad bug 1308680 in Ironic "RPC receivers may starve periodic tasks" [Medium,Triaged]
17:27:16 <NobodyCam> adam_g: can we tag you as assignee?
17:27:24 <adam_g> NobodyCam, sure
17:27:55 <jroll> on 1308680, last real comment is "but the real fix for this problem should come from oslo, making periodic tasks to run in parallel."
17:28:04 <jroll> which makes me think that we can't fix this in rc1
17:28:17 <jroll> unless we want to re-use dtantsur's hack for conductor-level tasks
17:28:38 <dtantsur> yeah, Oslo is _very_ slow...
17:28:45 <dtantsur> up to now my spec got 1x +1
17:28:51 <NobodyCam> jroll: want to comment on the bug, may be should be untagged?
17:28:51 <jroll> -.-
17:29:00 <rloo> i think we should bump that to L*
17:29:05 <jroll> sure, I'll let deva decide if he wants to untag it
17:30:09 <jroll> commented.
17:30:34 <NobodyCam> okay three more. we'll loop back to see if we can get any volunteers
17:30:47 <jroll> (two more if we untag that)
17:30:49 <NobodyCam> should we see if we can get a quick status update on the assigned bugs:
17:31:01 <BadCub> I will follow up with devananda on https://bugs.launchpad.net/ironic/+bug/1308680 as well
17:31:02 <openstack> Launchpad bug 1308680 in Ironic "RPC receivers may starve periodic tasks" [Medium,Triaged]
17:31:12 <adam_g> re: bug #1433727, we need to decide how we want to handle the case where a kilo nova is trying to attach a config drive to a juno ironic node. should we error the instance build or let it continue with noop'ing the config drive (like we would have done with a juno nov)
17:31:13 <openstack> bug 1433727 in Ironic "partial upgrade not possible, 'reason': u'Unknown argument: "configdrive" (HTTP 400)'" [High,Confirmed] https://launchpad.net/bugs/1433727 - Assigned to Adam Gandelman (gandelman-a)
17:31:16 <adam_g> *nova
17:32:01 <adam_g> would love lucas's thoughts there, but looks like he's away
17:32:04 <NobodyCam> adam_g: I would say no-op
17:32:13 <jroll> adam_g: I tend to think we should error the build
17:32:14 <NobodyCam> but others need to weigh in on that
17:32:18 <NobodyCam> lol
17:32:20 <NobodyCam> see
17:32:22 <jroll> idk
17:32:25 * dtantsur summons Lucas
17:32:33 <rloo> error on build
17:32:41 <jroll> woot
17:32:41 <lucasagomes> sorry forgot the meeting :(
17:32:41 <rloo> does the user expect a config drive or not?
17:32:43 <NobodyCam> hi lucasagomes
17:32:46 <jroll> great work dtantsur
17:32:51 <dtantsur> :D
17:32:51 * lucasagomes was busy on other stuff
17:32:52 <JayF> Can we not fix the nova driver to error earlier?
17:32:58 <lucasagomes> what's up about the configdrive? I don't have the logs
17:33:03 <adam_g> .:adam_g:. re: bug #1433727, we need to decide how we want to handle the case where a kilo nova is trying to attach a config drive to a juno ironic node. should we error the instance build or let it continue with noop'ing the config drive (like we would have done with a juno nov)
17:33:04 <openstack> bug 1433727 in Ironic "partial upgrade not possible, 'reason': u'Unknown argument: "configdrive" (HTTP 400)'" [High,Confirmed] https://launchpad.net/bugs/1433727 - Assigned to Adam Gandelman (gandelman-a)
17:33:04 <JayF> i.e. to not even have a build to fail, but to prevent the build from starting
17:33:29 <jroll> JayF: +1, that's what I meant, I sohuld have been more clear
17:33:41 <adam_g> rloo, IIRC nova can be configured to do a config drive by default,e ven if the user doesn't explicitly specify one at spawn
17:33:51 <adam_g> rloo, so you end up with *all* instances failing in that case
17:33:59 <rloo> adam_g: :-(
17:34:06 <JayF> I think it's important to fail earlier or to succeed without configdrive, i.e. if we can't keep Nova from accepting the build, we should proceed building w/o configdrive
17:34:28 <NobodyCam> JayF: that was my thought too
17:34:35 <jroll> adam_g: oh, that's right :|
17:35:37 <NobodyCam> we didn't fully support config drives in juno so a operator should be expecting it be there
17:35:49 <NobodyCam> s/should/shouldn't/
17:36:15 <jroll> but what about the user.
17:36:23 <lucasagomes> in juno, even if nova asked for a configdrive we would just ignore in the ironic driver
17:36:26 <lucasagomes> because it wasn't supported
17:36:37 <lucasagomes> maybe we should do the same if we see the ironic version doesn't support it
17:36:42 <lucasagomes> just log a warning or something
17:36:55 <adam_g> this gets to a later meeting point re upgrades and client--we need to define how upgrade story and figure out what we support in terms of ordering component upgrades
17:37:13 <jroll> I guess ignoring the configdrive would be fine
17:37:34 <NobodyCam> jroll: only for folks in juno land
17:37:47 <NobodyCam> which didn't have support for it anyway
17:37:48 <jroll> right
17:37:50 <NobodyCam> :)
17:37:55 <lucasagomes> yeah, well while we don't have it, maybe checking fo TypeError?
17:38:04 <jroll> NobodyCam: but the user doesn't know what version of ironic is being used :)
17:38:04 <lucasagomes> I mean if we try to pass a parameter that doesn't exist on the api
17:38:06 <adam_g> i think it'd be okay to ignore it under the assumption operators will eventually be upgrading ironic from juno->kilo very soon, and we ignore it only to allow things to continue working during the upgrade
17:38:17 <jroll> adam_g: +1
17:38:33 <lucasagomes> adam_g, +1
17:38:34 <adam_g> that could be release noted
17:38:44 <NobodyCam> i do like lucasagomes idea of logging something about it
17:38:52 <adam_g> NobodyCam, definitely
17:38:55 <NobodyCam> adam_g: oh ya!
17:39:27 <NobodyCam> okay going to skip the detailed bug drill down for sake of time
17:40:01 <NobodyCam> please keep reviewing https://launchpad.net/ironic/+milestone/kilo-rc1 for status of rc-1 tagged bugged
17:40:10 <NobodyCam> bugs even
17:40:51 <BadCub> should we be adding these bugs to the review day pad since we have other rc-1 stuffs listed?
17:41:10 <NobodyCam> BadCub: ya that'd prob be a good thing
17:41:19 <BadCub> will do
17:41:25 <NobodyCam> Thak you
17:41:29 <NobodyCam> #topic issues needing discussion for RC1
17:41:42 <NobodyCam> mrda-away: are you really away
17:42:13 <jroll> probably :P
17:42:19 <NobodyCam> so moving to adam_g
17:42:31 <NobodyCam> python-ironicclient sending version header by default
17:42:33 <rloo> NobodyCam: well, I think it needs discussion.
17:42:38 <rloo> NobodyCam: I mean, what mrda brought up.
17:42:48 <jroll> +1
17:42:55 <rloo> lucasagomes: I think you are familiar with the issue?
17:42:56 <NobodyCam> ok
17:43:09 <NobodyCam> HTTP error code changed by logical names patch -- https://etherpad.openstack.org/p/ironic-microversion-handling
17:43:17 <NobodyCam> #link https://etherpad.openstack.org/p/ironic-microversion-handling
17:43:22 <lucasagomes> rloo, well I put some thoughts on the review
17:43:40 * lucasagomes trying to remember
17:43:53 <adam_g> so the issue here is another upgrade snag but in the other direction, juno nova with a kilo ironic: if a juno nova is using a client /w https://review.openstack.org/#/c/165559/ merged, it will send the 1.6 header to the Ironic server during boot and get node states that it does not understand
17:44:03 <rloo> I haven't read it and won't be able to in 60 secs. All I see is deva's "I think 1B should continue to raise a 400 Bad Request" at the bottom ;)
17:44:53 <lucasagomes> yeah, basically if we someone tries to GET a node by it's logical name and it's not supported
17:44:58 <lucasagomes> in Juno it would return 400
17:45:09 <lucasagomes> but in Kilo the etherpad suggest returning 406
17:45:13 <lucasagomes> which is not backward compat
17:45:23 <lucasagomes> I think the idea of the microversioning was make it look like it was before
17:45:25 <rloo> lucasagomes: and what's the rationale for returning 406?
17:45:35 <lucasagomes> so the suggestion is to keep retuning 400
17:45:55 <NobodyCam> lucasagomes: wht was the objection to returning 400
17:45:55 <lucasagomes> 406 not acceptable, other bits of the microversioning are using it
17:45:55 * rloo wonders when to bring up issues in meetings vs in eg mail list
17:46:09 <lucasagomes> when something that is not supported on the old version is requested
17:46:24 <lucasagomes> but I think that for this case, we should not return 406 and just keep it as it was before
17:46:48 <Shrews> yeah, i thought we agreed 400 must be returned to not break the API
17:46:49 <lucasagomes> otherwise we break backward compatibility and the microversioning makes little sense to prevent that
17:47:39 <NobodyCam> Shrews: oh we did?
17:47:52 <rloo> I agree with lucasagomes (w/o thinking about it too much). At the very least, we can change it later (in L) if we think it should be 406. But it would be more difficult to change from 406 to 400 if we determine later that it should be 400.
17:48:04 <Shrews> NobodyCam: i might just be remembering a quick conversation (not an "official" agreement)
17:48:20 <NobodyCam> Shrews: ack++++
17:48:36 <lucasagomes> the comment is here https://review.openstack.org/#/c/163730/4/ironic/api/controllers/v1/utils.py
17:48:38 <rloo> but if feature X was in version 1.9 and someone used version 1.8, what should they get? 406?
17:48:47 <NobodyCam> but here I think we are agree to continue to return 400?
17:48:48 <lucasagomes> #link https://review.openstack.org/#/c/163730/4/ironic/api/controllers/v1/utils.py
17:48:53 <jroll> +1 on 400
17:49:05 <dtantsur> what if we always return 400 instead of 406?
17:49:09 <Shrews> also, see deva's comment on March 18
17:49:31 <jroll> rloo: the difference here is, name replaces uuid in the url... it's not a new endpoint or field
17:49:49 <Shrews> and deva's experiment: http://paste.openstack.org/show/193128/
17:49:53 <lucasagomes> yeah, it's a paramater and not a new endpoint
17:50:11 <dtantsur> actually it might be the same for provision state: now some states return 406 :)
17:50:29 <lucasagomes> dtantsur, but that's fine because those states weren't supported in old versions
17:50:36 <lucasagomes> oh depends
17:50:37 <lucasagomes> hmmm
17:50:45 <rloo> it isn't clear to me when to use 400 vs 406.
17:50:49 <jroll> dtantsur: node_set_provision_state 'notastate' also returns 406
17:50:54 <jroll> iirc
17:50:58 <dtantsur> lucasagomes, names neither :) but the error code is different
17:51:00 <lucasagomes> yeah maybe it should be 400, because if you input an not valid state in an old version you should get a 400
17:51:00 <dtantsur> oh
17:51:03 <lucasagomes> dtantsur, +1
17:51:06 <rloo> wrt the states, before, one only expected X number of states. We've added new states that they are not aware of.
17:51:07 <jlvillal> 9 minutes
17:51:29 <NobodyCam> thank you jlvillal
17:51:54 <rloo> so I think we agree on 400 in this case, but it isn't clear (to me) when to use 406?
17:52:12 <lucasagomes> rloo, right, so old versions should return 400 (BadRequest) becasue that's what old versions would do
17:52:20 <lucasagomes> as for endpoints that didn't exist before we should return 404
17:52:33 <lucasagomes> I don't see much use for 406, but I need to investigate more
17:52:46 <NobodyCam> lucasagomes: want a action item for htat?
17:52:52 <lucasagomes> NobodyCam, could be
17:53:34 <NobodyCam> #action to investigate returning 406
17:53:42 <NobodyCam> #undo
17:53:42 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x926c410>
17:53:49 <NobodyCam> #action lucasagomes to investigate returning 406
17:53:56 <NobodyCam> thank you lucasagomes
17:53:58 <NobodyCam> ok
17:54:01 <NobodyCam> quickly
17:54:11 <NobodyCam> python-ironicclient sending version header by default -- https://review.openstack.org/#/c/165559/
17:54:20 <NobodyCam> #link https://review.openstack.org/#/c/165559
17:54:34 <NobodyCam> kinda along the same lines (kinda)
17:54:41 * jroll doubts this will be quick :x
17:54:43 <NobodyCam> adam_g: thats you and devananda ?
17:54:49 <adam_g> ya. the problem here is we realy have no way of controlling python-ironicclient used by stable/juno nova
17:54:50 <NobodyCam> 6 minutes
17:55:27 <adam_g> the shortest and easiest solution i can think of is to patch nova stable/juno to specify a 1.0 header
17:55:47 <NobodyCam> adam_g: right now its acting like 1.1?
17:55:51 <jroll> adam_g: how sure / when can we be sure that people pick up that change?
17:56:12 <rloo> adam_g: so should this patch be dependent on a nova-stable/juno patch?
17:56:24 <adam_g> NobodyCam, its not specifying any header so yeah, it gets downgraded AIUI
17:56:30 <adam_g> jroll, we can't
17:56:38 <rloo> it isn't only nova that this will break though; it is all those hundreds of deployments out there ;)
17:56:50 <jroll> adam_g: so we break anyone that updates the client but not ironic
17:57:00 <adam_g> rloo, yeah, or at least blocked ntil we have a plan on how to handle it
17:57:08 <adam_g> jroll, yup
17:57:20 <jroll> fun.
17:57:23 <lucasagomes> ouch
17:57:25 <adam_g> jroll, which is the case if 165559 lands now
17:57:35 <jroll> right
17:57:53 <jroll> I guess patching nova-juno seems fine to me
17:58:15 <adam_g> so this coupled with the config drive thing begs the question: do we support partial upgrades (ie, upgrade nova without upgrading ironic or the other way around)
17:58:30 <rloo> i thought we already had this discussion in one of our previous meetings. where people wanted the client to default to the latest version and I wanted none or minimum. but the rationale was that anyone that upgrades the client should only upgrade after seeing what changes were in the client. so they should know that it will/could break.
17:59:03 <jroll> adam_g: yeah, we need to support partial upgrades IMO. the question to me is nova first, ironic first, or both
17:59:07 <NobodyCam> * two minutes * stendulker see my comment in ironic channel
17:59:29 <rloo> jroll, adam_g: what can/do we support now.
17:59:36 <NobodyCam> jroll: ya I think we have to do our best to support them
17:59:44 <adam_g> jroll, with those two bugs open we can't do either right now
17:59:54 <jroll> adam_g: right :|
18:00:01 <rloo> oh. so no partial upgrade at all.
18:00:01 <lucasagomes> :/
18:00:15 <NobodyCam> ok folks can we take this back to our channel? we are out of time
18:00:25 <lucasagomes> yea
18:00:28 <jroll> yeah, thanks for running NobodyCam
18:00:29 <lucasagomes> let's do it
18:00:36 <NobodyCam> thank you all grat meeting
18:00:36 <lucasagomes> sorry for not being here b4
18:00:43 <NobodyCam> not at all
18:00:44 <lucasagomes> thanks NobodyCam for covering deva
18:00:54 <NobodyCam> see ya all back in our channel
18:01:03 <NobodyCam> #endmeeting