17:00:14 <NobodyCam> #startmeeting Ironic
17:00:14 <NobodyCam> #chair devananda
17:00:14 <NobodyCam> Welcome everyone to the Ironic meeting.
17:00:14 <NobodyCam> Of course the agenda can be found at:
17:00:14 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
17:00:14 <openstack> Meeting started Mon Aug 31 17:00:14 2015 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:17 <openstack> The meeting name has been set to 'ironic'
17:00:19 <openstack> Current chairs: NobodyCam devananda
17:00:24 <jlvillal> o/
17:00:25 <NobodyCam> #topic Greetings, roll-call and announcements
17:00:29 <gabriel-bezerra> o/
17:00:32 <NobodyCam> Roll-call: Who's here for the Ironic Meeting?
17:00:32 <vdrok_> o/
17:00:40 <yuriyz> o/
17:00:47 <lucasagomes> o/
17:00:55 <NobodyCam> morning all
17:00:55 <Nisha> o/
17:00:59 <stendulker> o/
17:00:59 <cdearborn> o/
17:01:06 <NobodyCam> giving folks a couple of minutes to join
17:01:08 <JoshNang> o/
17:01:24 <rloo> o/
17:01:30 <TheJulia> o/
17:01:43 <rloo> (why/what is the chair thingy for, since devananda isn't here?)
17:01:50 <JayF> o/
17:01:51 <NobodyCam> welcome all to the Ironic meeting
17:02:06 <NobodyCam> hey JayF glad you could make it
17:02:17 <NobodyCam> as I am for all here :)
17:02:25 <lucasagomes> rloo, probably c&p
17:02:26 <lucasagomes> :-)
17:02:27 <jroll> \o
17:02:27 <NobodyCam> #topic announcements:
17:02:33 <NobodyCam> Devananda out burning things until Sept. 8th, Hope he's having fun!
17:02:44 <NobodyCam> devananda: is out at burning man
17:03:04 <NobodyCam> so I do not expect we'll see him for a few weeks
17:03:57 <NobodyCam> ahh yes. we did cut a new release 4.0.0 last week
17:04:03 <lucasagomes> o/
17:04:11 <NobodyCam> rloo: I see you have a item on the agenda
17:04:16 <rloo> devananda left notes about 4.0.0 in the etherpad
17:04:22 <natorious> o/
17:04:37 <rloo> there are a few outstanding issues related to 4.0.0
17:04:48 <lucasagomes> #link https://launchpad.net/ironic/liberty/4.0.0
17:04:48 <NobodyCam> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:05:44 <rloo> jroll: hopefully you'll shepherd the 4.0.0 release now that you're back and its your baby :-)
17:06:24 <rloo> that's all I wanted to mention wrt 4.0.0
17:06:36 <jroll> rloo: I think I could do that :)
17:06:40 <trown> o/
17:06:44 <NobodyCam> looks like two reviews outstanding according to hte whiteboard notes
17:06:44 <rloo> thx jroll
17:06:45 <jroll> holy cow, 91 bugs fixed?!
17:06:52 <jroll> <3
17:07:03 <lucasagomes> well done everybody
17:07:04 <rloo> jroll: what's wrong, we didn't do enough? :)
17:07:17 <NobodyCam> great job everyone!
17:07:35 <jroll> :)
17:08:01 <jroll> seriously, awesome work
17:08:04 <NobodyCam> jroll: your going to stay in touch with doug on the 4.1.0 as soon as we can land the patches
17:08:14 <jroll> NobodyCam: yep
17:08:18 <NobodyCam> #link https://review.openstack.org/#/c/216758/1
17:08:34 <jroll> ok, I'll own that
17:08:35 <NobodyCam> #link https://review.openstack.org/#/c/209251/
17:08:55 <NobodyCam> #link https://review.openstack.org/216843
17:08:58 <jroll> the release notes work is on my todo list
17:09:07 <NobodyCam> sorry first one was alreaady landed
17:09:22 <jroll> on 209251, we don't need to land that before 4.0.1, right?
17:09:22 <NobodyCam> jroll: awesome Thank you !
17:09:28 <jroll> because docs are published from master
17:10:04 <NobodyCam> jroll: that is listed by devananda in the section on the whiteboard
17:10:10 <jroll> right
17:10:12 <rloo> jroll: I think we do want to land it if we can, so that the doc corresponds to the release
17:10:15 <jroll> I just think it's weird, but anyway :)
17:10:18 <jroll> ok
17:10:25 <NobodyCam> :)
17:10:40 <rloo> NobodyCam: I might have added it to the whiteboard, but it was based on devananda saying we didn't have doc on enroll for the release
17:10:57 <NobodyCam> ahh ok
17:11:03 <lucasagomes> :-/
17:11:22 <NobodyCam> rloo: you also have a dates around 4.1.0 item
17:11:39 <NobodyCam> would as soon as the patches land work as an answer?
17:12:09 <rloo> NobodyCam: the patches mentioned above landing, is for 4.0.1
17:12:15 <jroll> rloo++
17:12:20 <rloo> NobodyCam: 4.1.0 is the ironic release corresponding to liberty release
17:12:24 <jroll> and 4.1.0 around openstack-RC-time
17:12:33 <rloo> NobodyCam: I sent email about this: http://lists.openstack.org/pipermail/openstack-dev/2015-August/073100.html
17:12:41 <lucasagomes> yeah sounds good, the idea of the new release model is to not relying on specific dates AFAIUI
17:12:44 <jroll> 4.1.0 will become stable/liberty
17:12:49 <rloo> Am mentioning it here cuz I think it is important
17:13:28 <NobodyCam> ahh mixed uo 4.0.1 and 4.1.0 :(
17:13:38 <rloo> 4.1.0 will have to be cut w/i some date range.
17:14:10 <NobodyCam> deva's got this note: Let's plan on cuting a 4.1.0 release around Liberty RC1, so this can become our stable/liberty branch
17:14:15 <rloo> I'm guessing jroll, devananda, or we will determine the actual date as we get closer to the end of Sept.
17:14:35 <lucasagomes> aight, I think we are a bit out of topic no?
17:14:38 <NobodyCam> jroll: have you started thinking of a date?
17:14:39 <lucasagomes> for announcements at least
17:14:56 <NobodyCam> lucasagomes: its actualy a line item
17:14:59 <rloo> lucasagomes: that was my other announcement, I mean mention of 4.1.0 and the dates
17:15:00 <jroll> NobodyCam: nothing hard, I think around the time the rest of openstack cuts RC
17:15:12 <lucasagomes> aight
17:15:36 <rloo> please note, especially core reviewers, the 'freeze' on requirements after this week.
17:15:38 <NobodyCam> rloo: ya we have time to firm up the date as we get closer to end of month
17:16:15 <rloo> according to Thierry (in the email thread), no new requirements or requirements bumps after this week. (except for exceptions)
17:16:27 <NobodyCam> any other Announcements?
17:17:13 <NobodyCam> lets move on to subteam status reports
17:17:20 <NobodyCam> #topic subteam status reports
17:17:50 <wanyen> freze for requirement means spec freeze?
17:17:59 <jroll> no, requirements.txt
17:18:03 <jroll> libraries etc
17:18:05 <jroll> wanyen: ^
17:18:11 <wanyen> I see.
17:18:33 <rloo> jroll: I'm not sure how that affects ironic-lib. we should discuss later.
17:18:52 <lucasagomes> rloo, oh good point
17:18:56 <jroll> rloo: great question, later sounds good
17:19:03 <NobodyCam> :)
17:19:07 <jroll> I suspect we can get exceptions there
17:19:15 <gabriel-bezerra> anything related to driver requirements in this requirements freeze?
17:19:52 <rloo> gabriel-bezerra: if the driver requirements are packages that go in requirements.txt, then they are affected.
17:20:02 <jroll> (which they typically aren't)
17:20:05 <rloo> gabriel-bezerra: but we don't tend to put driver requirements in requirements.txt.
17:20:15 <jlvillal> jroll: rloo: maybe add ironic-lib as a requirement now with no version?
17:20:18 <lucasagomes> yeah I think driver-requirements is not part of the global requirements for openstack
17:20:22 <NobodyCam> lets swing back to that in Open dis
17:20:23 <lucasagomes> so it's fine
17:20:25 <jroll> jlvillal: +1
17:20:26 <jroll> NobodyCam: +1
17:20:32 <gabriel-bezerra> oh, ok
17:20:36 <gabriel-bezerra> thank you
17:20:48 <NobodyCam> dtabrsur is out on pto this week I think
17:20:49 <rloo> jroll: guess you don't know what the status is yet, of the neutron/ironic work?
17:21:06 <lucasagomes> NobodyCam, I think it's just today, he went to prague to get his visa to japan
17:21:07 <jroll> rloo: patches are up, failing CI, people are working on it and also manually testing
17:21:11 <NobodyCam> dtantsur even
17:21:16 <NobodyCam> ahh
17:21:27 <rloo> jroll: ok thx (sounds similar to last week)
17:21:28 <lucasagomes> which was approved and all so o/ he will be there!
17:21:29 <NobodyCam> so th e bug numbers are uptodate :)
17:21:37 <jroll> rloo: indeed
17:22:11 <NobodyCam> jlvillal: any updates other then your line item?
17:22:25 <jlvillal> NobodyCam: No.  Just would like to get feedback on: https://bugs.launchpad.net/nova/+bug/1405131
17:22:26 <openstack> Launchpad bug 1405131 in OpenStack Compute (nova) "Ports cannot be mapped to networks" [Low,In progress] - Assigned to Mark Goddard (mgoddard)
17:22:38 <jlvillal> How important is it?
17:22:58 <jlvillal> Do we want to push for this in Liberty?  Assuming it won't be considered a feature.
17:23:14 <rloo> NobodyCam: just checked, the bug stats are old. give me a few minutes...
17:23:16 <jroll> jlvillal: it will be considered a feature :)
17:23:27 <jlvillal> And if yes, who would want to work on it.  Need someone with good knowledge of Nova, we think.
17:23:31 <jroll> jlvillal: we have to build a feature to fix that bug, it's going to touch the networking guts
17:23:42 <NobodyCam> jlvillal: we can get there in a few
17:23:54 <NobodyCam> there is a line item for that
17:23:55 <jlvillal> jroll: In that case it would have to be for Mitaka.
17:23:58 <jroll> jlvillal: all this neutron integration work kind of lays the groundwork for us to be able to deal with that
17:24:00 <jroll> yep
17:24:05 <jlvillal> NobodyCam: Oh, sorry. I jumped the gun.
17:24:07 <jroll> it's going to be pretty tough, too
17:24:10 <jroll> heh
17:24:17 <wanyen> This will hlep to solve ports with unconnected calbe.
17:24:24 <NobodyCam> NP its a light agenda, just trying to get all the updates in
17:24:27 * jlvillal reads his name and just goes!
17:24:31 <wanyen> s/cable/cable
17:24:46 <NobodyCam> TheJulia: any thing for bifrost you want to share
17:25:06 <TheJulia> Nope, just what is on the board
17:25:06 <NobodyCam> new debain bugs?
17:25:15 <TheJulia> dib issues :(
17:25:33 <TheJulia> Hopefully this is the last of them for now.
17:25:57 <rloo> NobodyCam: the bug stats have been updated, current as of a few minutes ago.
17:25:58 <NobodyCam> #link https://review.openstack.org/#/c/218879
17:25:59 * trown apologizes
17:26:15 <TheJulia> trown: no need to apologize, it happens :)
17:26:22 <rloo> jlvillal: maybe in the future, you can put any issues in the subteam report instead of in the meeting agenda.
17:26:34 * lucasagomes adds that review to his todo
17:27:08 <NobodyCam> krotscheck: betherly: any updates on the web client?
17:27:24 <krotscheck> betherly's on bank holiday
17:27:25 <jlvillal> rloo: Okay. we can do that. We just wanted to make sure it got discussed. Thanks.
17:27:48 <NobodyCam> and its our only item for todays meeting :-p
17:27:51 <rloo> jlvillal: wrt testing. do we think we'll have functional testing by 4.1.0? do you need help?
17:28:03 <krotscheck> There was too much bikeshedding on the CORS patch, to the point where things were not advancing.
17:28:09 <krotscheck> Deva took that over.
17:28:27 <NobodyCam> krotscheck: do you have a link? can we help
17:29:07 <krotscheck> NobodyCam: The current iteration is here - https://review.openstack.org/#/c/199769/ - the original was proposed in may before summit, so this patch has been blocked from merging for 4 months now.
17:29:08 <jlvillal> rloo: I doubt by 4.1.0, especially without help.
17:29:21 <NobodyCam> #link https://review.openstack.org/#/c/199769/
17:29:31 <jroll> krotscheck: so I looked at that this weekend, there are real concerns there that some people are ok with and some people are not. those are the types of patches that need to be brought up on the mailing list or the meeting so we can make a solid decision
17:29:34 <rloo> jlvillal: too bad but that's life.
17:29:46 <jlvillal> Yeah :(
17:30:06 <lucasagomes> indeed
17:30:07 <jroll> krotscheck: "this part of sample config will get nuked next time it's generated" is a pretty legit concern IMO
17:30:16 <NobodyCam> jroll: do you happen to have the pepermill link for htat?
17:30:24 <krotscheck> jroll: I welcome any patches to oslo_middleware that fixes this issue.
17:30:32 <jroll> NobodyCam: what
17:30:43 <NobodyCam> (mail archive)
17:30:44 <jroll> pepermill?
17:30:49 <jroll> it wasn't mailed about.
17:30:51 <krotscheck> But, frankly, I have burned out on the land-in-oslo-then-wait-for-land-in-requirements-then-wait-for-yet-another-bikeshed-argument churn.
17:31:19 <NobodyCam> ahh I miss read "brought up on the mailing list or..."
17:31:30 <jroll> krotscheck: such is openstack, we've all been there, I feel your pain. try building a feature that crosses nova, ironic, and neutron
17:31:33 * NobodyCam puts on his *uggh* glasses
17:31:42 <krotscheck> jroll: I am. What do you think CORS is?
17:32:00 <jroll> krotscheck: I mean dependencies between those. you get the idea.
17:32:10 <jroll> we all want this to happen
17:32:20 <krotscheck> It would be nice if I wasn't the only one pushing code and dealing with the frustration.
17:32:27 <jroll> when there's a deadlock on something like that it needs to be brought to the meeting or mailing list
17:32:29 <krotscheck> Because if I'm the only one pushing this, it feels like I'm the only one who cares.
17:32:35 <krotscheck> And, well, if I'm the only one who cares, why bother?
17:32:50 <rloo> krotscheck: seems like devananda cares. he sez so.
17:32:51 <jroll> it's almost as if we're busy reviewing and building other features.
17:33:08 <krotscheck> rloo: I might point out that he only got involved in the patch after I dropped it.
17:33:09 <jroll> just because I care about it doesn't mean it's my top priority
17:33:12 <NobodyCam> krotscheck: reach out to us.. we DO care!
17:33:36 <rloo> NobodyCam: we should make sure it isn't just lip service.
17:33:43 <NobodyCam> any Driver team updates or questions / concerns?
17:33:44 <rloo> NobodyCam: clearly krotscheck is frustrated.
17:33:50 <krotscheck> jroll: Don't you think there's something wrong, if the only way something becomes high priority is when the developer gets so frustrated they drop it?
17:34:02 <jroll> krotscheck: the thing is, I haven't heard about this patch being blocked until last week
17:34:06 * lucasagomes adds the CORS patch to his todo and to the spreadsheet
17:34:23 * krotscheck shrugs.
17:34:27 <NobodyCam> krotscheck: adding to our whiteboard will help get folks attention
17:34:30 <gabriel-bezerra> CORS = cross origin resource sharing?
17:34:41 <krotscheck> My kid's due in 3 days. I can't do this anymore.
17:34:47 <NobodyCam> rloo: yes!
17:34:53 <NobodyCam> krotscheck: congratz!
17:35:01 <jroll> krotscheck: I'm not trying to be a jerk about it, but if there's a problem, you need to make noise, everybody is too busy to see everything happening :/
17:35:10 <krotscheck> Deva's in the desert. He's not involved either.
17:35:11 <rloo> krotscheck: is there more than this one patch? devananda se he's taking over that one.
17:35:12 <krotscheck> And that's the extend of my update.
17:35:12 <krotscheck> jroll: I did!
17:35:22 * krotscheck tags out.
17:35:47 <jroll> krotscheck: not until last week, best I can tell
17:35:56 <jroll> and if I missed it, I apologizwe
17:36:03 <NobodyCam> krotscheck: can you list the reviews i the webclient section of the white board and we'll see if we can find time to review them!
17:36:12 <lucasagomes> yeah well we are humans and we miss stuff...
17:36:31 <lucasagomes> it's on my todo list, I will review it tomorrow
17:36:51 <jroll> I may miss gerrit things, I may miss IRC scrollback, but I won't miss mailing list posts or meeting logs.
17:36:53 <krotscheck> NobodyCam: https://review.openstack.org/#/q/status:open+is:watched+-owner:self+-(label:Code-Review%253D1%252Cuser%253Dself+OR+label:Code-Review%253D2%252Cuser%253Dself)+label:Verified%253D1,n,z
17:36:57 <jroll> that's where problems need to go
17:37:53 <NobodyCam> not sure owner:sef works there
17:38:11 <rloo> jroll: +1. I think we should try to use the mailing list more often. Although having said that, krotscheck may have sent email in the past and maybe didn't want to do so again. not sure.
17:38:13 <gabriel-bezerra> NobodyCam: may driver updates start now?
17:38:19 <NobodyCam> yes!
17:38:21 <krotscheck> oops, wrong link.
17:38:22 <krotscheck> just a sec.
17:38:36 <NobodyCam> krotscheck: add to whiteboard in webclient section
17:38:47 <NobodyCam> gabriel-bezerra: go
17:38:54 <gabriel-bezerra> We've published the kilo version of our driver https://github.com/HewlettPackard/ironic-driver-oneview
17:39:13 <gabriel-bezerra> I wonder if we can list that in ironic's wiki
17:39:39 <jroll> NobodyCam: fwiw this is the primary patch for ironic/CORS stuff https://review.openstack.org/#/c/199769/
17:39:44 <NobodyCam> gabriel-bezerra: wiki are world editable doc require reviews
17:39:57 <gabriel-bezerra> That's a kind of beta release
17:40:13 <rloo> gabriel-bezerra: that is 3rd party, right? we have a 3rd party wiki somewhere.
17:40:17 <lucasagomes> gabriel-bezerra, I don't see why not, maybe we should have a topic in the wiki about 3rd party drivers
17:40:23 <lucasagomes> there are some out there we can link
17:40:31 * lucasagomes the xcat one comes to mind
17:40:52 <NobodyCam> #link https://wiki.openstack.org/wiki/Ironic/Drivers
17:41:08 <NobodyCam> bottum of ^^^^
17:41:13 <NobodyCam> bottom even
17:41:31 <gabriel-bezerra> 3rd party means it is not in the tree?
17:41:39 <rloo> I'm a bit confused. gabriel-bezerra, did you want to add a link to HP code?
17:41:39 <NobodyCam> yes
17:41:46 <gabriel-bezerra> in ironic repository
17:42:10 <gabriel-bezerra> rloo: we did that together with HP
17:42:13 <wanyen> ilo driver is in-tree
17:42:20 <NobodyCam> now I am also confused
17:42:23 <lucasagomes> wanyen, yes
17:42:37 <rloo> gabriel-bezerra: i will rephrase. did you want to add a link to code that is not reviewed/maintained by ironic community?
17:43:11 <jroll> it looks to me like this is a version of oneview driver compatible with kilo ironic, out of tree
17:43:16 <gabriel-bezerra> rloo: that's why it is called 3rd party, isn't it?
17:43:19 <jroll> where as liberty ironic has oneview in tree
17:43:21 <gabriel-bezerra> yes, jroll
17:43:25 <gabriel-bezerra> right that
17:43:28 <jroll> ok.
17:43:38 <jroll> I don't have a problem with linking that in the wiki
17:43:43 <lucasagomes> me neither
17:43:52 <lucasagomes> I think the more content in the wiki the better
17:43:52 <jroll> also reminder that we have 15 minutes left and are still on subteam
17:43:59 <rloo> do we have doc in ironic, on oneview driver (that is in our tree)?
17:44:04 <NobodyCam> just make sure its clearly noted as KILO
17:44:05 <lucasagomes> just make it clear that the driver is out of the tree and compatible with the kilo version etc etc etc
17:44:11 <NobodyCam> yes
17:44:13 <gabriel-bezerra> so the bottom of the page, together with iLO, is the place?
17:44:15 <NobodyCam> ned to move on
17:44:27 <gabriel-bezerra> OK
17:44:27 <jroll> gabriel-bezerra: find with me, feel free to ping for review after you edit
17:44:31 <rloo> i disagree with the above -- we can discuss outside of meeting
17:45:04 <gabriel-bezerra> jroll: thank you.
17:45:24 <wanyen> I am confused why ilo drivers are not  inthe maintable but listed as 3rd-party drivers
17:45:49 <wanyen> I meant ilo drivers are not listed inthe main tables
17:45:49 <jroll> let's take this out of the meeting
17:45:55 <NobodyCam> Can we move on and swing back if there is time?
17:45:58 <jroll> yes
17:46:00 <rloo> NobodyCam: move on please
17:46:01 <NobodyCam> jroll: ++
17:46:01 <lucasagomes> wanyen, maybe it's just outdated, it's actually on both
17:46:04 <NobodyCam> #topic nova bug 1405131
17:46:06 <lucasagomes> ++
17:46:07 <openstack> bug 1405131 in OpenStack Compute (nova) "Ports cannot be mapped to networks" [Low,In progress] https://launchpad.net/bugs/1405131 - Assigned to Mark Goddard (mgoddard)
17:46:09 <NobodyCam> jlvillal: thats you
17:46:13 <jroll> ok so we already discussed this right?
17:46:16 <jlvillal> Yes
17:46:20 <jroll> \o/
17:46:36 <wanyen> pxe-ilo driver, iscsi-ilo and agent-ilo drivers are not int he table
17:46:42 <NobodyCam> jlvillal: you good skipping then?
17:46:47 <jlvillal> Yes,
17:46:49 <jlvillal> Thanks
17:46:57 <NobodyCam> #topic Open Discussion
17:47:00 <linggao> Hi folks, I would like to propose a design session topic for the coming OpenStack summit for ironic. where is a good place to propose?
17:47:23 <jroll> linggao: I don't believe topic submission has opened up yet, we'll be sure to send an email when it does
17:47:40 <jroll> (and if I find it has, I'll be sure to send an email today)
17:47:53 <NobodyCam> yea and we don't yet have a pad for the group yet
17:48:11 <NobodyCam> rloo: you had a question about next week: Next Monday, Sept. 7, is a holiday (Labor Day) in the United States and Canada. Will there be a meeting?
17:48:22 <rloo> NobodyCam: yup. that's my question :)
17:48:27 <linggao> I remember there used to be a place to propse session for all projects.
17:48:34 <NobodyCam> wil folks be around next week?
17:48:47 <rloo> nope, not here next Monday
17:48:49 <jroll> NobodyCam: I won't be here monday unless there's a reason to be
17:48:55 <jroll> linggao: right, it is not up yet
17:48:56 <jroll> afaik
17:49:01 <BadCub> I will not be here next Monday
17:49:02 <rloo> linggao: there WILL be a place. Please WAIT
17:49:07 <NobodyCam> yea I have not seen a email for it yet
17:49:11 <jroll> krotscheck: +2 on the CORS patch, I'm happy with the separate file thing deva did
17:49:13 <trown> jroll: it is my understanding that https://review.openstack.org/#/c/213749/ is the only thing we needed to do IPA release
17:49:25 <lucasagomes> well I will be around
17:49:28 <jroll> trown: and then just tag it, right?
17:49:31 <trown> jroll: I think all that is required now is to tag it
17:49:50 <lucasagomes> NobodyCam, rloo maybe send an email to the ML to see who's going to be here? or vote now?
17:49:57 <lucasagomes> doesn't seems much people will be around
17:50:05 <NobodyCam> I can be around to run a meet if we have folks around to attended it
17:50:10 <rloo> lucasagomes: i think we should just vote now. most folks that can attend this meeting should be here today.
17:50:19 <lucasagomes> ack
17:50:20 <jlvillal> US Holiday on Monday.
17:50:21 <jroll> trown: ok, so... if it is release:independent in governance deva will need to tag it (my keys aren't signed by release people), if it's release:managed I can ask them to do a release
17:50:34 * jlvillal realizes he repeats information :(
17:50:43 <lucasagomes> rloo, let's do it. I think NobodyCam has to start it cause he's chair
17:50:44 <jroll> lucasagomes: NobodyCam rloo let's just say we're having a meeting, lucasagomes is running it, whoever wants to show can show
17:50:56 <NobodyCam> I'll be here
17:50:58 <lucasagomes> could be as well
17:50:59 <jroll> I think anyone can start a meeting no? is there ACLs on that?
17:51:00 <NobodyCam> next monday
17:51:12 <rloo> only a few folks can chair the meeting i think
17:51:12 <NobodyCam> yea anyone can start a meeting
17:51:18 * lucasagomes AFAIK anyone can start it
17:51:20 <JayF> jroll: I think my ket is signed by release people
17:51:22 <JayF> jroll: *key
17:51:23 <rloo> oh, didn't know that.
17:51:29 <JayF> jroll: if I otherwise have what authority is needed
17:51:37 <jroll> JayF: orly, cool, lemme see about this stuff
17:51:38 <lucasagomes> rloo, I think once you start you can set people to be the chair
17:51:47 <NobodyCam> yes!!!
17:52:03 <rloo> ok, enjoy the meeting next week then.
17:52:09 <NobodyCam> :)
17:52:21 <jroll> trown: JayF: release:independent indeed, I'm not sure how this will work without deva but I can poke doug today and try to find out
17:52:40 <rloo> 8 minutes left.
17:52:49 <rloo> do we want to discuss ironic-lib/requirements?
17:52:54 <lucasagomes> rloo, ++
17:52:55 <jroll> yeah
17:52:59 <lucasagomes> I like jlvillal idea
17:52:59 <jroll> did we release that yet?
17:53:06 <trown> jroll, cool thanks
17:53:07 <NobodyCam> Ty rloo was just typing that
17:53:10 <jroll> lucasagomes: I do too
17:53:10 <lucasagomes> to just put it in the g-r without a version
17:53:14 <jroll> but we'll need a release to do that
17:53:21 <lucasagomes> since we know that we are going to release already
17:53:22 <rloo> I think we should release ironic-lib as is
17:53:23 <lucasagomes> it seems fine
17:53:31 <rloo> once released, add to g-r
17:53:37 <jroll> ++
17:53:41 <jlvillal> +1
17:53:42 <lucasagomes> right
17:53:50 <lucasagomes> there's anything else that needs merge there?
17:53:58 <lucasagomes> other we can sort that out today and tomorrow
17:54:05 <rloo> i am trying to recall what we decided about ironic-lib before but i don't remember. something about wanting tests for it before releasing but i don' tknow that it matters.
17:54:08 <lucasagomes> and then release (so we don't release anything broken)
17:54:15 <jroll> if folks are fine with current master (8622f45e1585bc77cd78a621a4db13865515a155) I can get that released today
17:54:25 <jroll> or tomorrow or whenever
17:54:30 <rloo> lucasagomes: we should just release. we can release something else tomorrow or whenever.
17:54:35 <rloo> lets get the ball rolling.
17:54:36 <jroll> nothing is using it yet, anyway
17:54:43 <jroll> so if it's broken it doesn't break anything
17:54:48 <jlvillal> Agree with just release.
17:55:10 <jroll> gonna merge https://review.openstack.org/#/c/216966/
17:55:17 <rloo> i'm still not sure what it means after this week, if we don't cap the version on ironic-lib in g-r.
17:55:27 <jroll> and go from there
17:55:27 <rloo> but we can think about it this week :-)
17:55:36 <jroll> rloo: it means we'll be using any new release of ironic-lib
17:55:47 <jlvillal> rloo: Seems like many requirements are not capped. Usually they seem to have >=
17:55:53 <jroll> I'm not sure if there's a library freeze though?
17:55:55 <jroll> we'll find out
17:56:02 <rloo> jroll: which could break 4.1.0 in the future :-(
17:56:05 <jroll> this just gets requirements freeze off the table at least
17:56:11 <lucasagomes> jroll, I don't think so... like code in the library?
17:56:20 <jroll> rloo: they cap requirements when they cut stable/liberty
17:56:27 <jlvillal> Ah
17:56:39 <jroll> lucasagomes: like openstack/library releases
17:56:41 <rloo> jroll: good, i think that's what I wanted to know.
17:56:49 <jroll> I know there's an oslo freeze, dunno about other libs
17:56:58 <rloo> jroll: wrt 216966, go for it.
17:56:59 <lucasagomes> oh right, yeah not sure either
17:57:01 <lucasagomes> I assume not
17:57:05 <jroll> rloo: already done :)
17:57:06 <NobodyCam> four minutes
17:57:13 <NobodyCam> gah three minutes
17:57:16 <lucasagomes> but well, worth investigate ask dhellmann
17:57:20 <jroll> so once that lands I'll propose... 0.1.0? opinions?
17:57:20 <rloo> NobodyCam: please put action item for jroll to release ironic-lib today
17:57:39 <jroll> and the associated g-r stuff
17:57:46 <NobodyCam> #action jroll to cut ironic-lib release today
17:57:55 <wanyen> what's the process of updating  https://wiki.openstack.org/wiki/Ironic/Drivers?  Like to update ilo drivers in the table
17:58:03 <rloo> thx jroll. welcome back!
17:58:06 <jroll> wanyen: press the edit button.
17:58:11 <NobodyCam> wanyen: click edit
17:58:15 <jroll> rloo: ha, thanks :)
17:58:17 <wanyen> ok.  everone canupdate it.
17:58:22 <NobodyCam> yes
17:58:27 <NobodyCam> its a wiki
17:58:28 <wanyen> evereryone can edit it.
17:58:41 <jroll> yep
17:58:42 <lucasagomes> wanyen, yup
17:58:48 <wanyen> thanks
17:59:02 <jlvillal> wanyen: Just login :)
17:59:04 <NobodyCam> last minute
17:59:24 <NobodyCam> Thank you all for another great meeting :)
17:59:34 <rloo> wanyen: I could be wrong, but I think it was one of your folks that added that link and those wikis for ilo driver
17:59:45 <gabriel-bezerra> thank you
17:59:51 <lucasagomes> cheers
17:59:55 <jlvillal> ciao!
18:00:03 <Madasi> o/
18:00:04 <jroll> thanks everyone, see y'all later
18:00:09 <NobodyCam> thank you all
18:00:12 <wanyen> rloo: I will check with ilo team but I like ilo drivers to be in themaintables
18:00:14 <NobodyCam> #endmeeting